Jump to content
GTAForums does NOT endorse or allow any kind of GTA Online modding, mod menus, tools or account selling/hacking. Do NOT post them here or advertise them, as per the forum rules.

Random Disconnections Both in GTA 5 and Online


Beauclerc

Recommended Posts

Hey fellas.

I reported this issue to R* many times but they are very lazy to post me for help. So I thought you might help.

While I'm playing GTA 5 or Online, "Disconnected from XBOX" bar pops up and I return to single player if I'm playing online. This problem occurs at random time. I don't have this issue in any other games(Halo 4, RDR, GRFS ect. all fine)

I will list the solutions I tried. And I'm looking for another fixes.

 

-Port Forwarding

-Enabling DMZ

-Enabling uPnP

-Clearing System Cache

-Clearing Game Data

-Reinstalling the Game

-Redownloading the Gamer Profile

-Resetting the Modem

-Updating the Modem/Router

-Disabling Firewalls

-Unplugging - Replugging the Modem

-Renewing DNS Settings

-Wired Connection

 

The first time I had this issue was 2nd of August. I never had it before then.

 

R* said it's because of my internet speed.

Download Speed: 8.02 Mbps
Upload Speed: 0,81 Mbps
Ping: 66 ms to 450 miles away(Nis, Serbia)

 

However, my internet speed was much worse before 5 months and I was able to play without any problems.

 

NAT is Moderate but I don't think this is the source of the issue. I play other games with no problems, as I said.

 

Thank you and looking forward for some fixes.

Link to comment
Share on other sites

Have you tried bypassing the router (Modem directly connected to Xbox)-- if this is possible with your setup.

 

Also-- what DNS settings did you use when you say your "Renewing DNS Settings"

 

Have you noticed any difference if you try hosting a game vs you joining a game another person is hosting.

 

Of the games listed-- are you still playing them? What I mean is-- yes they worked previously but are you still playing them currently and are they still working ok?-- I only bring this up since you say that GTA V worked ok several months ago.

 

About the only other thing I would try would be using a different set of ethernet cables (just to eliminate your current ones as being suspect)

 
7744.png

"I want to design a video game where you take care of all the people shot in all the

other video games.... It's called Busy Hospital II" -- Demetri Martin

RIP BDP

Link to comment
Share on other sites

Have you tried bypassing the router (Modem directly connected to Xbox)-- if this is possible with your setup.

 

Also-- what DNS settings did you use when you say your "Renewing DNS Settings"

 

Have you noticed any difference if you try hosting a game vs you joining a game another person is hosting.

 

Of the games listed-- are you still playing them? What I mean is-- yes they worked previously but are you still playing them currently and are they still working ok?-- I only bring this up since you say that GTA V worked ok several months ago.

 

About the only other thing I would try would be using a different set of ethernet cables (just to eliminate your current ones as being suspect)

Hello, first of all, thank you for your effort.

 

I actually use a Router/Modem combo. Could you explain me that bypassing the router thing?

 

I use DNS settings that my ISP suggested me.

 

No, I haven't noticed any difference while playing with others. I could join my friends and other people, play with them. But at a random time, I get "Disconnected from XBOX" thing, going back to SP.

 

Yes I play with those games currently. I played RDR MP 3 hours a few days ago, didn't even get any disconnecting errors.

 

I connect wireless to internet actually. I tried wired connection and it didn't really change anything.

 

By the way, I also bought a new modem, the issue kept happening.

Edited by Agent Lynx
Link to comment
Share on other sites

Since you have a modem/router combo... You can't bypass your router... Mine are seperate and when i had issues with gta 4, i ran an ethernet from modem to my ps3.... Very fast/reliable connection.

 

For DNS.. Get on YouTube and look up how to change your DNS on your console to google's dns servers (do this onbthe console as it should overide your routers DNS settings)... This may help.

 

Are the port forwards still in place on your router? Which ports did you forward.

 

Would like to help more but posting from my phone.

 

Moving this to gtao help section

 
7744.png

"I want to design a video game where you take care of all the people shot in all the

other video games.... It's called Busy Hospital II" -- Demetri Martin

RIP BDP

Link to comment
Share on other sites

It may have to do with that DDOS attack that happened this past sunday, both PSN and MS THINGY got attacked, as well as some online PC games. I havnt played online since friday, and just tried to play HOME on my EU account (since im not installing the 1.16 patch until after im ready to do the stock market online (gotta have 10-15 $million bucks to put into it per character, and im doing all the side missions right now) and lost connection twice. So it just may be the network you are on. Not sure tho.... :facedesk:

Link to comment
Share on other sites

trippy bongos

dude,I know how you feel because I have the same f*ckin annoying problem.I get disconnected from XBOX Live at random times and I sent them a ticket but they sent me the same copy-paste answer.Even they don't know how to solve this problem ,this is stupid I know,this is obviously the most stupid thing in the game because I can't play. it started just a month ago,I don't have it in any other games

Edited by trippy bongos
Link to comment
Share on other sites

Since you have a modem/router combo... You can't bypass your router... Mine are seperate and when i had issues with gta 4, i ran an ethernet from modem to my ps3.... Very fast/reliable connection.

For DNS.. Get on YouTube and look up how to change your DNS on your console to google's dns servers (do this onbthe console as it should overide your routers DNS settings)... This may help.

Are the port forwards still in place on your router? Which ports did you forward.

Would like to help more but posting from my phone.

Moving this to gtao help section

Okay. I will try Google DNS.

Ports Forwarded:

88, 3074, 53, 80, 1863 all TCP and UDP.

It may have to do with that DDOS attack that happened this past sunday, both PSN and MS THINGY got attacked, as well as some online PC games. I havnt played online since friday, and just tried to play HOME on my EU account (since im not installing the 1.16 patch until after im ready to do the stock market online (gotta have 10-15 $million bucks to put into it per character, and im doing all the side missions right now) and lost connection twice. So it just may be the network you are on. Not sure tho.... :facedesk:

Thank you for tip. But I'm having this problem for a really long time, like almost 1 month.

 

dude,I know how you feel because I have the same f*ckin annoying problem.I get disconnected from XBOX Live at random times and I sent them a ticket but they sent me the same copy-paste answer.Even they don't know how to solve this problem ,this is stupid I know,this is obviously the most stupid thing in the game because I can't play. it started just a month ago,I don't have it in any other games

The game definitely has a lot of issues. It is very annoying indeed.

Link to comment
Share on other sites

I'm pretty much out of ideas for you-- as long as you are certain that the ports are being forwarded to the correct IP address (of your console)-- and that your console has a static IP address or the IP address is being assigned to a console to a sprecific one by the router.

 
7744.png

"I want to design a video game where you take care of all the people shot in all the

other video games.... It's called Busy Hospital II" -- Demetri Martin

RIP BDP

Link to comment
Share on other sites

  • 2 weeks later...

its cause they f*cked up the code, been happening to me since the release of the 1.13 version patch, 1.16 made it a little better, but it still happens. it has nothing to do with your internet. i have 30meg up/down fiber that ive monitored very closely and it never wavers and i still have this problem. I have 2 ps3's and ive even formatted one ps3 and then even put a SSD in both of them and formated it for each one and it still happens. ive been playing since release and it never happened before patch 1.13 except when their cloud servers were actually offline for everyone. they dont have an answer cause they dont have a clue. some of it seems to be due to cheaters/modders kicking people but some of it is just poorly written netcode.

Link to comment
Share on other sites

Wow i came here to post the exact same problem. I thought that I was the only one going through this. I've been playing the game since launch and have had a freeze every now and then, nothing serious but NEVER had a problem with connection until 1.16. I've put in a ridiculous amount of effort to try and fix this problem (pretty much all the same steps OP has already stated) but no luck.Haven't played gta online in a few days due to this, just loaded it up to see if that maintenance on the 10th did anything and no luck I got this msg about 2 minutes in my garage 2a6mu55.png

 

That's the first time I've seen this one usually it's just an "unknown network error" then followed up with a disconnection to xbox live. All I'm able to do is play in an invite only lobby and even then it sometimes happens.

 

My download speed is 10.95 Mbps

Upload speed is 10.97 Mbps

Ping is 18ms

 

After reading the suggestions in the post I've kind of lost hope in finding a solution to this problem haha really hoping 1.17 will allow us to actually play the game again.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.