Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTA Online

      1. The Diamond Casino Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews & Posses

      1. Recruitment
      2. Events
    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA 6

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
      5. GTA IV Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA SA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA VC Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA III Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. News

    2. Forum Support

    3. Site Suggestions

fastman92

fastman92 limit adjuster

Recommended Posts

_onyx_
14 hours ago, fastman92 said:

You can probably add a new police car if you add a new map level:

1. Edit data/map.zon, add another level.

2. Edit LEVEL LIMITS, set new level.

2. Use a loader of model special features. Edit its configuration, add an entry like this:

new_police_car copcarla

 

This is mainly used to tell the game, which cop ped model IDs to request.

its not work, added transport will not spawn during a chase

ee3f186e893eeb5174b3062531038aca.jpg
393446ff371d1ca68cab8db669014224.jpg

Edited by _onyx_

Share this post


Link to post
Share on other sites
DragonMarking

Hi, is the San Andreas 2.00 Cleo apk out yet?

Share this post


Link to post
Share on other sites
kr0n0s800
On 2/16/2020 at 8:42 AM, fastman92 said:

Paintjobs: lo he verificado. No veo ningun problema Muestra una captura de pantalla si crees que hay un problema.

El problema ocurre al habilitar "Make paintjobs work for any ID" junto a "Enable model special feature loader" y "Apply ID limit patch" utilizo la versión 5.1

On 2/15/2020 at 3:33 PM, Leinad said:

¿Habilitaste "Enable model special feature loader" y "Apply ID limit patch"? Porque si es así, yo estoy teniendo ese mismo problema, pero teniéndolos en 0, los paintjobs si funcionan.

 

Edited by kr0n0s800

Share this post


Link to post
Share on other sites
pimann

I know that the mobile GTA VC does not support DFF larger than 300-400kb while the PC version of that game supports that.

Does the FLA remove that limit? If no, can you add this feature?

GTA 3 and SA for mobile support 1-2 mb DFF of cars/weapons/peds but when I port that to VC mobile it crashes.

Share this post


Link to post
Share on other sites
pete9516
On 2/20/2020 at 2:29 AM, Leinad said:

@fastman92 How to add police cars, cop bikes, taxi cars, etc. whit this new FLA version? enanbling [LEVEL LIMITS]?

You can also try out this mod:

https://www.gtagarage.com/mods/show.php?id=25866

It isn't quite what you're looking for, but it actually does the job. If you are a little bit experienced in cleo scripting you can tweak some things

  • Like 1

Share this post


Link to post
Share on other sites
delaflorida

How do I open big size IMG files, such as 2.0GB with this tool? is there any tool where I can open 2gb img size?

Share this post


Link to post
Share on other sites
Grinch_
2 hours ago, delaflorida said:

How do I open big size IMG files, such as 2.0GB with this tool? is there any tool where I can open 2gb img size?

Use IMG Factory or fastman92 img console

  • Like 1

Share this post


Link to post
Share on other sites
delaflorida
1 hour ago, Grinch_ said:

Okay I did it to export some files from a GTA IV converted map but I cant do anything  with the files, I cant open the .txd or the .dff, do you know the reason?

Share this post


Link to post
Share on other sites
Saretto28
On 18/2/2020 at 16:27, Nesthor said:

Qualcuno ha notato che se installano nuove mappature nel gioco, appaiono ma perdono le collisioni, se ho un edificio a due piani non posso arrampicarmi, perché le scale non hanno collisioni, attraverso i muri, faccio cadere il tuo fieno 

 

È questo un problema che ha a che fare con il FLA? o con la V 2.0 di GTA 

I noticed this problem right now as well I had tried to install a map but without collisions :(

Share this post


Link to post
Share on other sites
fastman92
1 hour ago, Saretto28 said:

I noticed this problem right now as well I had tried to install a map but without collisions :(

Oggi ho provato ad aggiungere su GTA SA per Android, ma il mio gioco non funzionava.

Volevo a risolvere un problema e mi ha preso un giorno intero.

 

Ho aggiunto il DFF model nel IMG archivio gta3.img e file di texture , poi ho provato a creare una macchina nel gioco.

Il gioco apparentemente non ha caricato il model ID di file.

 

Il soluzione:

rimuova il file "models\MINFO.BIN", che include il cache dei ID per models.

 

Per collisione consiglierei rimuovere il file simile: "CINFO.bin"

 

  

On 2/22/2020 at 1:58 AM, kr0n0s800 said:

El problema ocurre al habilitar "Make paintjobs work for any ID" junto a "Enable model special feature loader" y "Apply ID limit patch" utilizo la versión 5.1

 

Let me think about it later.

 

-----------------------------

I have added a new vehicle to GTA San Andreas for Android for the first time:

b0d9511335028933.jpg 

Edited by fastman92
  • Like 4

Share this post


Link to post
Share on other sites
Nesthor

Today I tried to add a new car on Android, I did the following use mame irizar

 

1. Enable the option to increase vehicle IDEs and enable audio loader

 

0126ef1335028732.jpg

 

2. Edit the handling by adding a line , use the bus base, since it is a bus that I intend to install, it looked like this:

 

4e2c8c1335028735.jpg

 

3. Edit the cargrp by adding to the group of workers And some others:

 

5b01051335028737.jpg

 

4. Edit carcols Adding color lines:

 

06f90f1335028727.jpg

 

5. Edit the Audioloader by adding the same lines as those on the bus, just change the name to irizar

 

76ef341335028739.jpg

 

6. Then I Add in the vehicles.ide a new line whit ID 699 Using the same lines as the bus:

 

90b55d1335028725.jpg

 

7. Add the file irizar.dff to gta3.img

 

a2ef9f1335029115.jpg

 

8. The game starts, but I can't spawned the new vehicle because it doesn't appear in the Cleo vehiclespawn, how can I use it?

 

1058691335028730.jpg

 

Is the procedure correct?

Share this post


Link to post
Share on other sites
fastman92
5 minutes ago, Nesthor said:

Today I tried to add a new car on Android, I did the following use mame irizar

Is the procedure correct?

Read the tutorial:

 

HANDLING.CFG LIMITS are not available for GTA SA on Android, so you must not add any handling.cfg entries.

Car spawner is made for vehicle IDs between 400 and 611. It doesn't read more IDs automatically.

You may have to edit it or use a simple script like this:

 

You need to add textures as well. There's a texture cache in GTA SA for Android.

// This file was decompiled By-Krishna95
{$CLEO .csa}

//-------------MAIN---------------  
{$CLEO .csi}

0000: NOP


//        00BC: show_text_highpriority GXT 'LANDSTK' time 5000 flag 2

[email protected] = 612

0247: load_model [email protected]
038B: load_requested_models                                           

04C4: get_offset_from_char_in_world_coords $PLAYER_ACTOR offset 0.0 4.0 0.0 store_to [email protected] [email protected] [email protected]

     /*
while true
wait 0
00BC: show_text_highpriority GXT 'LANDSTK' time 5000 flag 2
end
*/

00A5: create_car [email protected] at [email protected] [email protected] [email protected] store_to [email protected]        

0172: get_char_heading $PLAYER_ACTOR store_to [email protected]
0175: set_car_heading [email protected] to [email protected]  

/// 00AB: put_car [email protected] at [email protected] [email protected] [email protected]

// v07D5: set_car [email protected] velocity_in_direction_XYZ [email protected] [email protected] [email protected] rotation_velocitiesXYZ 0.0 0.0 0.0

01C3: mark_car_as_no_longer_needed [email protected]
0249: mark_model_as_no_longer_needed [email protected]

004E: terminate_this_script

 

You must use my script definitions to compile this script: https://gtaforums.com/topic/943982-fastman92-script-command-definitions/

Edited by fastman92
  • Like 2

Share this post


Link to post
Share on other sites
Nesthor
4 hours ago, fastman92 said:

Read the tutorial:

Thanks, I am reading it to see what can be done.

 

On the other hand, this error is already driving me crazy, I can't solve it by editing any possible value in the ini, and I don't read any modified original IPLs, if I have added a mapping The game does not start, this is the log:

 

Launch time: 24-2-2020 0:41:08 (UTC)
Launched during the day.

Solution platform: ANDROID_ARM32
Game detected: GTA SA 2.00
Game uses dynamic image base? Yes
Game preferred image base: 0x0
Game current image base: 0xD1C9E000

Delayed processing of limits? Yes

Package name: com.rockstargames.gtasa
Root base directory: /storage/emulated/0
Root directory: /storage/emulated/0/Android/data/com.rockstargames.gtasa/files/
Initial directory: /
INI filename: fastman92limitAdjuster_GTASA.ini

Global exception handler has been registered.
---------------------------------------------
---------------------------------------------
Modified limit of IPL:inst, buildings to: 50000
---------------------------------------------
Modified limit of IPL: entity index array to: 100
---------------------------------------------
Streaming memory available limit set to 1073741824 bytes (1024 MB)
---------------------------------------------
---------------------------------------------
Trying to load CLEO: /data/app/com.rockstargames.gtasa-7enfuMfwZQYNmQtc9cPRRg==/lib/arm/libcleo.so
CLEO loaded
Number of memory changes made: 15
---------------------------------------------

Game has crashed, here's a crash log:
Current process ID: 21797
Current thread ID: 21860
Exception address: 0x0000001C (module not found)
Exception signal: 11 (SIGSEGV)
Exception code: 0x1 (SEGV_MAPERR)

General registers:
R0 : 0x00000005 (5)
R1 : 0xC81FF000 (-937431040)
R2 : 0x000000F6 (246)
R3 : 0xC823D408 (-937176056)
R4 : 0x00000000 (0)
R5 : 0xC823D3F8 (-937176072)
R6 : 0xD264C280 (-765148544)
R7 : 0xCD49F6E0 (-850790688)
R8 : 0xD264C264 (-765148572)
R9 : 0xD264C260 (-765148576)
R10: 0xD25BBCB8 (-765739848)
R11: 0xD25BBCB8 (-765739848)
R12: 0xD230C658 (-768555432)
SP : 0xCD49F6B0 (-850790736)
LR : 0xD210479D (-770685027)
PC : 0xD2104722 (-770685150) ["libGTASA.so"+0x466722]
PSR : 0x00070030 (458800)

 

No matter what mapping I installed, no matter how small, the game does not start, at first I thought it was because I added IPL New to GTA.dat, so I removed them and tried only with a modified IPL (SFs.ipl), but it continues to fail

Share this post


Link to post
Share on other sites
fastman92
3 minutes ago, Nesthor said:

Thanks, I am reading it to see what can be done.

 

On the other hand, this error is already driving me crazy, I can't solve it by editing any possible value in the ini, and I don't read any modified original IPLs, if I have added a mapping The game does not start, this is the log:

 

Launch time: 24-2-2020 0:41:08 (UTC)
Launched during the day.

Solution platform: ANDROID_ARM32
Game detected: GTA SA 2.00
Game uses dynamic image base? Yes
Game preferred image base: 0x0
Game current image base: 0xD1C9E000

Delayed processing of limits? Yes

Package name: com.rockstargames.gtasa
Root base directory: /storage/emulated/0
Root directory: /storage/emulated/0/Android/data/com.rockstargames.gtasa/files/
Initial directory: /
INI filename: fastman92limitAdjuster_GTASA.ini

Global exception handler has been registered.
---------------------------------------------
---------------------------------------------
Modified limit of IPL:inst, buildings to: 50000
---------------------------------------------
Modified limit of IPL: entity index array to: 100
---------------------------------------------
Streaming memory available limit set to 1073741824 bytes (1024 MB)
---------------------------------------------
---------------------------------------------
Trying to load CLEO: /data/app/com.rockstargames.gtasa-7enfuMfwZQYNmQtc9cPRRg==/lib/arm/libcleo.so
CLEO loaded
Number of memory changes made: 15
---------------------------------------------

Game has crashed, here's a crash log:
Current process ID: 21797
Current thread ID: 21860
Exception address: 0x0000001C (module not found)
Exception signal: 11 (SIGSEGV)
Exception code: 0x1 (SEGV_MAPERR)

General registers:
R0 : 0x00000005 (5)
R1 : 0xC81FF000 (-937431040)
R2 : 0x000000F6 (246)
R3 : 0xC823D408 (-937176056)
R4 : 0x00000000 (0)
R5 : 0xC823D3F8 (-937176072)
R6 : 0xD264C280 (-765148544)
R7 : 0xCD49F6E0 (-850790688)
R8 : 0xD264C264 (-765148572)
R9 : 0xD264C260 (-765148576)
R10: 0xD25BBCB8 (-765739848)
R11: 0xD25BBCB8 (-765739848)
R12: 0xD230C658 (-768555432)
SP : 0xCD49F6B0 (-850790736)
LR : 0xD210479D (-770685027)
PC : 0xD2104722 (-770685150) ["libGTASA.so"+0x466722]
PSR : 0x00070030 (458800)

 

No matter what mapping I installed, no matter how small, the game does not start, at first I thought it was because I added IPL New to GTA.dat, so I removed them and tried only with a modified IPL (SFs.ipl), but it continues to fail

Remove CINFO.BIN and test again.

  • Like 1

Share this post


Link to post
Share on other sites
Nesthor
1 hour ago, fastman92 said:

Remove CINFO.BIN and test again.

ready, I start the game, however, with the V2.0 of the apk it only supports a maximum of 4 lines of IPL, with the V 1.08 it supports 10

 

Edit: support 10, 

 

00cee31335056049.jpg

 

These are the ipl with mappings that I have installed regards

Edited by Nesthor
Add information

Share this post


Link to post
Share on other sites
Liam Sheberstov

There is a bug with the quad bike I found when I was adding cars, when I set the number of bike lines to 60 the quad bike starts to glitch like the image shown below. To verify this I tried the limit adjuster 5.1 in the clean GTA SA. When I set it to something around 20 the quad bike will just function as normal, but when increase it to around 60 the quad bike will glitch.

 

Notice the handle disappears when CJ gets on and CJ can not move after getting off:

DO8LV7G.jpg?1

VBXHns5.jpg?1

The modified part of the INI:

J1Ws3lg.png

  • Like 5

Share this post


Link to post
Share on other sites
RiyanArtz

@fastman92 Hello:) anyone can create this Cleo shadow for All obj? d This will give a shadow effect on the trees, at home, in all of the GTA objects: "we really need it: "to fix GTA Sa Android graphics that are too ugly when compared to we really need it: "to fix GTA Sa Android graphics that are too ugly when compared to GTA graphics on PC I hope you have make it, 

Share this post


Link to post
Share on other sites
fastman92
1 hour ago, Liam Sheberstov said:

There is a bug with the quad bike I found when I was adding cars, when I set the number of bike lines to 60 the quad bike starts to glitch like the image shown below. To verify this I tried the limit adjuster 5.1 in the clean GTA SA. When I set it to something around 20 the quad bike will just function as normal, but when increase it to around 60 the quad bike will glitch.

 

Notice the handle disappears when CJ gets on and CJ can not move after getting off:

DO8LV7G.jpg?1

VBXHns5.jpg?1

The modified part of the INI:

J1Ws3lg.png

I've never seen it.

If you still think there's a problem, we can make a TeamViewer session, where you'll show me the problem and I can check what could be a reason of this.

Edited by fastman92

Share this post


Link to post
Share on other sites
Leinad
Spoiler
10 hours ago, Liam Sheberstov said:

There is a bug with the quad bike I found when I was adding cars, when I set the number of bike lines to 60 the quad bike starts to glitch like the image shown below. To verify this I tried the limit adjuster 5.1 in the clean GTA SA. When I set it to something around 20 the quad bike will just function as normal, but when increase it to around 60 the quad bike will glitch.

 

Notice the handle disappears when CJ gets on and CJ can not move after getting off:

DO8LV7G.jpg?1

VBXHns5.jpg?1

The modified part of the INI:

J1Ws3lg.png

 

I got the same bug using the old .ini v 5.0 config with last fastman92limitajudter.asi v 5.1

Share this post


Link to post
Share on other sites
pete9516
15 hours ago, Liam Sheberstov said:

There is a bug with the quad bike I found when I was adding cars, when I set the number of bike lines to 60 the quad bike starts to glitch like the image shown below. To verify this I tried the limit adjuster 5.1 in the clean GTA SA. When I set it to something around 20 the quad bike will just function as normal, but when increase it to around 60 the quad bike will glitch.

 

Notice the handle disappears when CJ gets on and CJ can not move after getting off:

DO8LV7G.jpg?1

VBXHns5.jpg?1

The modified part of the INI:

J1Ws3lg.png

Same here. But for me it doesn't even work if i set the number of actual lines in handling.cfg

Share this post


Link to post
Share on other sites
fastman92
On 2/25/2020 at 12:06 AM, pete9516 said:

Same here. But for me it doesn't even work if i set the number of actual lines in handling.cfg

Thank you both for telling me about the problem.

I have configured the handling.cfg limits in the way that you've shown me and I see there's a problem.

I will be working to solve it.

 

---------------------

Fixed.

Edited by fastman92
  • Like 4

Share this post


Link to post
Share on other sites
EldarGangsta

Hello. I loading the safe but when it's completed i hear pixel music. My safe then is broken. 

Share this post


Link to post
Share on other sites
fastman92

Discord server for my projects

discord-512.png

If you have an interest in any of my projects or game modding, there's a Discord server available, where you can discuss things related to the FLA and similar.
Send me a private message, if you would like to join and from there I'll tell you what to do next.

  • Like 4

Share this post


Link to post
Share on other sites
istap9
17 minutes ago, fastman92 said:

Discord server for my projects

discord-512.png

If you have an interest in any of my projects or game modding, there's a Discord server available, where you can discuss things related to the FLA and similar.
Send me a private message, if you would like to join and from there I'll tell you what to do next.

Sure man post the link.

  • Like 1

Share this post


Link to post
Share on other sites
Tirta RB

How do you add weapons to GTA SA Mobile v 2.0 ???

Share this post


Link to post
Share on other sites
fastman92
14 hours ago, Tirta RB said:

How do you add weapons to GTA SA Mobile v 2.0 ???

You don't.

You can't do this.

Use GTA SA 1. US compact/HOODLUM for computer if you want to add weapons.

Edited by fastman92
  • Like 1

Share this post


Link to post
Share on other sites
Nesthor

To add new dff objects just increase these limits? 

 

24a7aa1335608419.jpg

 

I want to make a road mod, where I put different signs and other objects 

Share this post


Link to post
Share on other sites
M®.D

Can someone give me v1.08 version with fastman's limit adjuster.

  • Like 1

Share this post


Link to post
Share on other sites
Mutfurry

Hello. Is it possible to add more anim weapons? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 2 Users Currently Viewing
    0 members, 1 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.