Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (85,714 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Sign in to follow this  
eugene89

Which patch do I need for modding GTA IV?

Recommended Posts

eugene89

Okay, so I had gta iv on my pc for quite t=some time, and finally I've got the courage to mod it. Currently, I'm at a halt. The current patch I have installed is 1.0.3.0 + crack. I've seen alot of mods require different ones, so which is most used or recommended - and how do I install it?

 

p.s - my pc is low-mid range

Edited by maurice96

Share this post


Link to post
Share on other sites
kaow

Okay, so I had gta iv on my pc for quite t=some time, and finally I've got the courage to mod it. Currently, I'm at a halt. The current patch I have installed is 1.0.3.0 + crack. I've seen alot of mods require different ones, so which is most used or recommended - and how do I install it?

 

p.s - my pc is low-mid range

1.0.4.0 or 1.0.7.0.

1.0.4.0 is recommended. How to install it? Well.. just like you did 1.0.3.0? I don't support pirating, I have steam version myself and you should too, but obviously if not you'll need a crack for the patch.

Share this post


Link to post
Share on other sites
eugene89

 

Okay, so I had gta iv on my pc for quite t=some time, and finally I've got the courage to mod it. Currently, I'm at a halt. The current patch I have installed is 1.0.3.0 + crack. I've seen alot of mods require different ones, so which is most used or recommended - and how do I install it?

 

p.s - my pc is low-mid range

1.0.4.0 or 1.0.7.0.

1.0.4.0 is recommended. How to install it? Well.. just like you did 1.0.3.0? I don't support pirating, I have steam version myself and you should too, but obviously if not you'll need a crack for the patch.

 

I didnt pirate, i thought the crack was required like in gta sa :blink: Well, thanks!

Share this post


Link to post
Share on other sites
kaow

 

 

Okay, so I had gta iv on my pc for quite t=some time, and finally I've got the courage to mod it. Currently, I'm at a halt. The current patch I have installed is 1.0.3.0 + crack. I've seen alot of mods require different ones, so which is most used or recommended - and how do I install it?

 

p.s - my pc is low-mid range

1.0.4.0 or 1.0.7.0.

1.0.4.0 is recommended. How to install it? Well.. just like you did 1.0.3.0? I don't support pirating, I have steam version myself and you should too, but obviously if not you'll need a crack for the patch.

 

I didnt pirate, i thought the crack was required like in gta sa :blink: Well, thanks!

 

Oh I completely forgot, sorry..In that case you must downgrade, google 'steam downgrade 1.0.4.0' and do as the guide says. it might sound a little complicated so I did it in other way, but it should work for you. Though you might be able to use crack with steam version.. but I'm not sure if that would work.

Edited by kaow

Share this post


Link to post
Share on other sites
josh2000

(piggybacking your thread as not to clutter the forum)

 

What patch for EFLC are we using now? and what base plugins are needed, i.e. ASI loader, scripthook? I did a lot of searching but all I could find was outdated info and dead links, I couldn't even get a trainer to work on the latest patch.

 

any help is much appreciated

Share this post


Link to post
Share on other sites
PacketOverload_x64bit

EDIT#1: Oh, you're running EFLC. These files probably won't help you then. Sorry mate.

 

Many of the things you need can be found by going to this thread:

http://gtaforums.com/topic/480297-enb-screenshots-and-artwork-thread/

ENB%20SCREENSHOT%20THREAD%20NIKO%20GUN%2

 

 

These are the files I use for 1020/1030/1040/1004. Make sure you backup your GTA Program Files folder (make a copy to somewhere) before you use. Look at the files inside. The filelist.pak, files.txt and filelist.txt files overwrite GTA Program File files. Just incase. But this has worked for me where everything else didn't.

http://www.mediafire.com/download/b44o5h0y4e6il5q/Get_Modding_Running_in_GTA_IV_Files_From_Packet.rar

Edited by PacketOVerload_x64Bit

Share this post


Link to post
Share on other sites
Nikopol89

It depends on your needs:

1.0.4.0 is considered the best patch for graphic enhancements (ENB) but lacks of multiplayer

1.0.7.0 has working multiplayer but less mods' compatibility (many mods aren't updated)

 

It's not a bad idea to have both choices (two GTA main folders) plus a backup one of the original installation =)

 

The great LCPDFR mod, for example, works on 1.0.7.0 only

 

If you're using steamversion, here's a simple guide to downgrade

[HowTo]Downgrade of the steamversion of GTAIV to 1.0.4.0 - GTAGaming Forums

Patch links provided in the guide didn't work for me (installer link dead - rar link not worked), so here's a working link:

http://download.gta-expert.it/gta-4/patch-prestazioni/6754-gta-4-patch-ufficiale-iv-versione-1040.html

 

Have fun =)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.