Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    2. News

    1. Red Dead Redemption 2

      1. News
      2. Red Dead Online
      3. The Armadillo Inn
    1. GTA Online

      1. After Hours
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Deji

[SA|REL] CLEO 4.3

Recommended Posts

acmilan13

hello
I just went and 4.3.16 can not start a custom mission.
Before I was in 4.4.1.3f this work.
Do you know why?
thank you

 

and message error :

 

17/10/2014 13:15:39.410 [0A94] Starting new custom mission MISSION/PIZZA.cm from thread named r3pizza
17/10/2014 13:15:39.411 Loading custom script MISSION/PIZZA.cm...
17/10/2014 13:15:39.411 Error during loading of custom script MISSION/PIZZA.cm occured.
Error message: Starting of custom mission when other mission loaded
17/10/2014 13:15:39.411 [0A94] Failed to load mission 'MISSION/PIZZA.cm' from script 'r3pizza'.

Share this post


Link to post
Share on other sites
LINK/2012

It says it all

 

 

Error message: Starting of custom mission when other mission loaded

By game standards you cannot run two missions at once (if you do, one will override the other and sh*t).

That means a mission is already running when you launched this one, or you are launching it twice.

Share this post


Link to post
Share on other sites
Deji

Good news everyone!

 

CLEO 4 was updated on the 2nd of January.

 

Not news then, but still good.

Share this post


Link to post
Share on other sites
Fantomax

Good news everyone!

 

CLEO 4 was updated on the 2nd of January.

 

Not news then, but still good.

 

Um... No ChangeLog?

Share this post


Link to post
Share on other sites
Blackbird88

 

Good news everyone!

 

CLEO 4 was updated on the 2nd of January.

 

Not news then, but still good.

 

Um... No ChangeLog?

 

It's in the ReadMe

  • Fixed potential future problem with 0AB0 which used methods with undefined behaviour
  • Fixed incorrect method used for 0AB7

Share this post


Link to post
Share on other sites
65536

I'm trying to make a script spawning various objects in SA and I want to use an FXT (CLEO TEXT). My issue is, I found I can't get in-game mod's FXT menu to display (or I can select) more than 12 lines, even in case FXT file itself has more than 12 lines entered and in script I've set in my menu all 26 lines (25 objects lines + exit in menu) to be shown in game when I activate my object spawner! Please for REPLY HOW TO MAKE CLEO to make in CLEO menu all lines after the 12th one to be shown and selectable?!? I'm crying for answer! :barf:

 

I'm using CLEO 4.3.16, if someone ask... Or can @Deji remove that restriction because I need more entries in my menu, but I do NOT have any experience at all about CLEO multi menus...

Edited by 65536

Share this post


Link to post
Share on other sites
Deji

I'm using CLEO 4.3.16, if someone ask... Or can @Deji remove that restriction because I need more entries in my menu, but I do NOT have any experience at all about CLEO multi menus...

There's no FXT limit. The limit for menu entries is a default game limit. If you want coding help or alternative ideas, ask the forum.

Share this post


Link to post
Share on other sites
65536

Sorry. It doesn't seems possible then... Although, I have a suggestion: It's possible to make CLEO do not allow player to activate two or more CLEO mods using menus simulateouly? I. e. if a player have two mods using menus (FXT CLEO text), activates the first mod via its shortcut key and while it's active, if player press (or type) the shortcut actvating the second mod, it to AUTOMATICALLY END the first script if it's already running. A.k.a. player can have only one script with CLEO menu active at time but not both (or three or more) at same time. I found having two CLEO menus simulateouly shown at once may not only break proper work on corresponding mods, but also may lead to game crashing... It's possible you can do this, Deji?

Share this post


Link to post
Share on other sites
Deji

Sorry. It doesn't seems possible then... Although, I have a suggestion: It's possible to make CLEO do not allow player to activate two or more CLEO mods using menus simulateouly? I. e. if a player have two mods using menus (FXT CLEO text), activates the first mod via its shortcut key and while it's active, if player press (or type) the shortcut actvating the second mod, it to AUTOMATICALLY END the first script if it's already running. A.k.a. player can have only one script with CLEO menu active at time but not both (or three or more) at same time. I found having two CLEO menus simulateouly shown at once may not only break proper work on corresponding mods, but also may lead to game crashing... It's possible you can do this, Deji?

Nigh impossible to detect reliably without breaking mods.

Share this post


Link to post
Share on other sites
Deji

CLEO 4 updated, should be on cleo.li shortly, meanwhile use the links from the first post.

Share this post


Link to post
Share on other sites
ashley slow
v4.3.20 nice updates.

I will try. ;)

Share this post


Link to post
Share on other sites
Junior_Djjr

 

 

Fixed issue with 0AB1 passing incorrect variable scope in missions

I think I had this some days ago, or this is another problem... my problem isn't in "missions" and I didn't understand this "scope"

 

So, I'm here to report a problem and I don't know if this is the same problem:

 

After release my Tuning Mod, a guy in my blog send to me a scrlog.log without reading the first line of the func label

The problem occured only in Tuning Mod - Vehicle Save.cs even the same thing was in Tuning Mod Script1 (Junior_Djjr).cs

To fix, I put some "0000:" in the start of label and released the mod again, so is all ok

And yes, I'm sure the problem is in cleo and not scrlog, the game crashed because skipped the first line

 

And I don't remember the guy to test the new version of cleo if this bug was fixed or not, and only 1 guy had this problem while the bugged mod was published (the mod was published almost 1 day in a blog of thousands peoples waiting for this mod for months, then I think hundreds of people downloaded and only 1 had this problem (or other not reported to me, which unfortunately usually happens)

Share this post


Link to post
Share on other sites
Seemann

CLEO 4 updated, should be on cleo.li shortly, meanwhile use the links from the first post.

I was slow :p

Share this post


Link to post
Share on other sites
goodidea82

 

Fixed issue with 0AB1 passing incorrect variable scope in missions

 

0AB1 now behaves differently in .cm cleo missions and in .cs cleo scripts.

 

When a function is called in a cleo script using 0AB1, then the function's memory is separate from the script that called it. When calling a function using 0AB1 from a mission script, the called function shares memory with the mission script. Is this really intended?

 

Test using in a .cs script:

{$CLEO .cs}03A4: name_thread 'FuncT1'wait 20000662: write_debug_message "FuncCall1:before call" [email protected] ="val A" 0662: write_debug_message [email protected]: call_scm_func @MyFunc 1 [email protected] [email protected]: write_debug_message "FuncCall1:after call"0662: write_debug_message [email protected]: end_custom_thread:MyFunc0662: write_debug_message "FuncCall1:inside func" [email protected] = "val B"0AB2: ret 1 "ret value"

Output is:

FuncCall1:before call

val A

FuncCall1:inside func

FuncCall1:after call

val A

 

Test using a mission script (and a mission starter script):

{$CLEO .cs}03A4: name_thread 'FuncCall3s'wait 60000662: write_debug_message "starting FuncCallTest3"0004: $ONMISSION =  1       0A94: start_custom_mission "FuncCallTest3" 0A93: end_custom_thread
{$CLEO .cm}03A4: name_thread 'FuncT3'0317: increment_mission_attempts//here starts the missionscript0004: $ONMISSION =  10662: write_debug_message "FuncCall3:before call" [email protected] ="val A" 0662: write_debug_message [email protected]AB1: call_scm_func @MyFunc 1 [email protected] [email protected]: write_debug_message "FuncCall3:after call"0662: write_debug_message [email protected]: $ONMISSION =  000D8: mission_cleanup004E: end_thread //End mission//-------------------------------------------------------:MyFunc0662: write_debug_message "FuncCall3:inside func" [email protected] = "val B"0AB2: ret 1 "ret value"

Output is:

starting FuncCallTest3

FuncCall3:before call

val A

FuncCall3:inside func

FuncCall3:after call

val B

 

It seems that in previous versions the function called by 0AB1 used to have separate memory from the memory of the mission script. Now all my mods that use 0AB1 in mission scripts crash.

What now?

Edited by goodidea82

Share this post


Link to post
Share on other sites
Seemann

Good point there. A SCM function should have its own scope for variables, so it's definetely a bug with 0AB1 not to restore local variables after 0AB2.

Share this post


Link to post
Share on other sites
joshua_blank

I don't know where it's the place for this but, after I installed MultiSave mod in GTA San Andreas, the pickups, like money and weapons, aren't spawning. This occurred after the Catalina missions and now I can't even pick money from dead peds. I already tested this in two computers and this bug continues. If anyone's know about a solution for this, please help. (sorry for my bad english)

[EDIT] The game is normal again. Probably I've done something wrong. Sorry for bothering you.

Edited by joshua_blank

Share this post


Link to post
Share on other sites
Deji

Everyone suffering from this bug should download the previous CLEO version which didn't have the SCM Functions in missions bugfix until I'm able to work on CLEO 4.3 again. That one will only crash in rare situations where SCM functions with arguments are used in missions.

 

Take advantage of unpermitted redistributions of CLEO and get 4.3.18!

Google "CLEO 4.3.18"

Edited by Deji

Share this post


Link to post
Share on other sites
gts.

4.3.18? But if cleo is going on the 4.3.20.

Share this post


Link to post
Share on other sites
LINK/2012

4.3.18? But if cleo is going on the 4.3.20.

Read the posts between the one goodidea linked and the post he makes the link (which is 4 posts), newer version has a bug and Deji suggested 4.3.18 as a bugless version which still have the bug.

Share this post


Link to post
Share on other sites
Deji

The 4.3.18 bug is more situation specific. The 4.3.20 bug is worse.

Share this post


Link to post
Share on other sites
LINK/2012

GET_TEXT_LABEL_STRING (0ADE) calls the CLEO.asi:CText__locale function (CText::Get as per R* namings), this causes any other gxt hook (such as Mod Loader's one) to be ignored. Please call gta_sa.exe:CText::Get!

Share this post


Link to post
Share on other sites
goodidea82

In CustomOpcodeSystem.cpp (source code of cleo 4.2) the function sqrt() is used in the opcode handlers of 0AE1, 0AE2, 0AE3 in order to check if an actor, vehicle, or object is within the search radius. Furthermore, the sqrt() function is called inside a for-loop and when this opcode is used in a cleo script it is usually also used in a loop. This is very inefficient.

 

Instead of :

for (unsigned index = last_found; index < pool.size; ++index){ ... float distance = sqrt(dx * dx + dy * dy + dz * dz); if (distance <= radius) {   last_found = index + 1;	// on next opcode call start search from next index   // obj.referenceType = 2; // add reference to found actor   *thread << pool.handleOf(&obj);   SetScriptCondResult(thread, true);   return OR_CONTINUE;  }}

it's better to write:

float radius2 = radius * radius;for (unsigned index = last_found; index < pool.size; ++index){ ... float distance2 = dx * dx + dy * dy + dz * dz; if (distance2 <= radius2) {   last_found = index + 1;	// on next opcode call start search from next index   // obj.referenceType = 2; // add reference to found actor   *thread << pool.handleOf(&obj);   SetScriptCondResult(thread, true);   return OR_CONTINUE;  }}
Edited by goodidea82

Share this post


Link to post
Share on other sites
little_idiot

Hope this is the right thread to ask for some help) Sorry if question was asked million times.

 

After changing CLEO 4.1 for CLEO 4.3.20 something went wrong: everytime I exit my game I've got crash: The instruction at "0x110205df" referenced memory at "0x02fee360". The memory could not be "read".

 

Tried both links from the first post in this topic as well as from cleo.li. My game is clean - no mods, no scripts, no plugins. In the log file below you can see one script - just a skin selector, but I've got crash without it.

 

Some tech data:

gta_sa.exe - 1.0 US Hoodlum - 14,383,616 bytes

Windows XP SP3

 

cleo.log

 

13/09/2015 22:46:43.187 Log started.
13/09/2015 22:46:43.187 Unprotecting memory region '.text': 0x00001000 (size: 0x00456000)
13/09/2015 22:46:43.187 Unprotecting memory region '.rdata': 0x00458000 (size: 0x0004C000)
13/09/2015 22:46:43.187 Unprotecting memory region '.text': 0x008B1000 (size: 0x0064A000)
13/09/2015 22:46:43.187 Parsing FXT file playerchanger.fxt
13/09/2015 22:46:43.187 Added FXT[MODEL]
13/09/2015 22:46:43.187 Unloading plugins...
13/09/2015 22:46:43.187 Loading plugin cleo/FileSystemOperations.cleo
13/09/2015 22:46:43.187 Loading plugin cleo/IniFiles.cleo
13/09/2015 22:46:43.187 Loading plugin cleo/IntOperations.cleo
13/09/2015 22:46:43.187 Started on game of version: SA 1.0 us
13/09/2015 22:46:43.187 Injecting MenuStatusNotifier...
13/09/2015 22:46:43.187 Replacing call: 0x0057B9FD
13/09/2015 22:46:43.187 Injecting DmaFix...
13/09/2015 22:46:43.187 Replacing call: 0x0053E981
13/09/2015 22:46:43.187 Injecting TextManager...
13/09/2015 22:46:43.187 Injecting function at: 0x006A0050
13/09/2015 22:46:43.187 Injecting SoundSystem...
13/09/2015 22:46:43.187 Replacing call: 0x007487A8
13/09/2015 22:46:43.187 Injecting CustomOpcodeSystem...
13/09/2015 22:46:43.187 Injecting ScriptEngine...
13/09/2015 22:46:43.187 Replacing call: 0x0046A21B
13/09/2015 22:46:43.187 Replacing call: 0x0058D552
13/09/2015 22:46:43.187 Replacing call: 0x0058FCE4
13/09/2015 22:46:43.187 Replacing call: 0x0053BDD7
13/09/2015 22:46:43.187 Replacing call: 0x005BA340
13/09/2015 22:46:43.187 Replacing call: 0x005D4FD7
13/09/2015 22:46:43.187 Replacing call: 0x005D18F0
13/09/2015 22:46:43.187 Replacing call: 0x005D14D5
13/09/2015 22:46:43.187 Injecting function at: 0x004667DB
13/09/2015 22:46:43.453 Creating main window...
13/09/2015 22:46:43.468 Found sound device 0: No sound
13/09/2015 22:46:43.468 Found sound device 1 (default): SoundMAX HD Audio O
13/09/2015 22:46:43.468 On system found 2 devices, 2 enabled devices, assuming device to use: 1 (SoundMAX HD Audio O)
13/09/2015 22:46:43.484 SoundSystem initialized
13/09/2015 22:46:43.484 Floating-point audio supported!
13/09/2015 22:46:43.484 Audio hardware acceleration disabled (no EAX)
13/09/2015 22:47:10.484 Scripts exclusively initialized
13/09/2015 22:47:10.500 Deleting dynamic fxts...
13/09/2015 22:47:10.500 Cleaning up script data... 0 files, 0 libs, 0 file scans, 0 allocations...
13/09/2015 22:47:10.500 Searching for cleo scripts
13/09/2015 22:47:10.500 Loading custom script sys_playerchanger_by_Dutchy3010.cs...
13/09/2015 22:47:10.500 Registering custom script named sys_pla
13/09/2015 22:47:12.734 Scripts initialized
13/09/2015 22:47:12.734 Unregistering custom script named player_mАwЪw
13/09/2015 22:47:12.765 Deleting dynamic fxts...
13/09/2015 22:47:12.765 Cleaning up script data... 0 files, 0 libs, 0 file scans, 0 allocations...
13/09/2015 22:47:12.765 Searching for cleo scripts
13/09/2015 22:47:12.765 Loading custom script sys_playerchanger_by_Dutchy3010.cs...
13/09/2015 22:47:12.765 Registering custom script named sys_pla
13/09/2015 22:47:12.781 void __cdecl CLEO::OnLoadScmData(void)
13/09/2015 22:47:12.781 Scripts loaded
13/09/2015 22:47:12.781 Unregistering custom script named sys_pla
13/09/2015 22:47:12.812 Deleting dynamic fxts...
13/09/2015 22:47:12.812 Cleaning up script data... 0 files, 0 libs, 0 file scans, 0 allocations...
13/09/2015 22:47:12.812 Loading cleo safe ./cleo/cleo_saves/cs6.sav
13/09/2015 22:47:12.812 Searching for cleo scripts
13/09/2015 22:47:12.812 Loading custom script sys_playerchanger_by_Dutchy3010.cs...
13/09/2015 22:47:12.812 Registering custom script named sys_pla
13/09/2015 22:47:18.390 Closing SoundSystem...
13/09/2015 22:47:18.390 Freeing BASS library

 

 

Tried both ASI-Loaders - Silent's ASI 1.2 and 1.3 - nothing changes.

 

Wondering what is wrong with my game.

Thanks.

 

P.S. Just mentioned string: 13/09/2015 22:47:12.812 Loading cleo safe ./cleo/cleo_saves/cs6.sav, but cleo_saves folder is empty. Weird?

Share this post


Link to post
Share on other sites
Deji

 

In CustomOpcodeSystem.cpp (source code of cleo 4.2) the function sqrt() is used in the opcode handlers of 0AE1, 0AE2, 0AE3 in order to check if an actor, vehicle, or object is within the search radius. Furthermore, the sqrt() function is called inside a for-loop and when this opcode is used in a cleo script it is usually also used in a loop. This is very inefficient.

To be honest though, micro-optimisation isn't that much of a goodidea... additionally, that's 4.2, not 4.3, the entire code was reworked (or rather "converted into a format that I could compile and not vomit at the sight of"). And don't underestimate a computers processing power - square rooting is pretty darn simple, and I believe R*'s original code also does it every time, because realistically, writing code faster > running code faster.

 

 

Don't know if I already said this, but unfortunately I don't have the CLEO 4.3 project (I forgot to copy it from my computer before we were separated, while remembering to copy the *cough* other CLEO project *cough*).

 

P.S. Just mentioned string: 13/09/2015 22:47:12.812 Loading cleo safe ./cleo/cleo_saves/cs6.sav, but cleo_saves folder is empty. Weird?

 

It probably just logs any attempt based on the fact you're loading the game, even if the file doesn't exist. It's generally more useful to log attempts rather than successes.

Edited by Deji

Share this post


Link to post
Share on other sites
ThirteenAG

Don't know if I already said this, but unfortunately I don't have the CLEO 4.3 project (I forgot to copy it from my computer before we were separated, while remembering to copy the *cough* other CLEO project *cough*).

So, cleo 4.3.* is done? What's next? Edited by ThirteenAG

Share this post


Link to post
Share on other sites
Deji

 

Don't know if I already said this, but unfortunately I don't have the CLEO 4.3 project (I forgot to copy it from my computer before we were separated, while remembering to copy the *cough* other CLEO project *cough*).

So, cleo 4.3.* is done? What's next?

 

 

It's not, I'll update 4.3 when I gain access to my stuff again, unless I happen to finish that other project first... in which case we won't even care :)

Share this post


Link to post
Share on other sites
goodidea82

There is a discussion on breaking the limit of global variables in main.scm. Breaking this limit would open great possibilities (not mentioning details) for projects such as SAxVCxLC and GTA Underground. In particular SAxVCxLC supports legacy mods, so CLEO support is really important (which could be complemented but not replaced by new solutions).

 

The limit is cause by the interpreter which uses __int16 for addressing global variables. Fastman92 would be able to break the limit of the interpreter, however, cleo would also have to be updated to support the bigger datatype (32bit). Could you add such support?

Share this post


Link to post
Share on other sites
fastman92

There is a discussion on breaking the limit of global variables in main.scm. Breaking this limit would open great possibilities (not mentioning details) for projects such as SAxVCxLC and GTA Underground. In particular SAxVCxLC supports legacy mods, so CLEO support is really important (which could be complemented but not replaced by new solutions).

 

The limit is cause by the interpreter which uses __int16 for addressing global variables. Fastman92 would be able to break the limit of the interpreter, however, cleo would also have to be updated to support the bigger datatype (32bit). Could you add such support?

I don't know if it's neccessarily required to update CLEO, or whether I can hack a limit in my FLA, but certainly the compiler (Sanny Builder) needs to be updated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 2 Users Currently Viewing
    1 Member, 0 Anonymous, 1 Guest

    • darkstorm1337
×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.