Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (92,267 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Deji

[SA|REL] CLEO 4.3

Recommended Posts

65536

From this was posted in this topic, seems many peoples have a LOTS of troubles and crashes with that CLEO version for San Andreas installed, so I have a suggestion to @Deji... I please him much to put back downloads for older versions of CLEO for GTA San Andreas, especially CLEO 3 and CLEO 4.1.1.30F on http://cleo.sannybuilder.com, since they are stable and doesn't causes a lots of CRASHES unlike newest CLEO library discussed here...

Edited by 65536

Share this post


Link to post
Share on other sites
Deji

From this was posted in this topic, seems many peoples have a LOTS of troubles and crashes with that CLEO version for San Andreas installed, so I have a suggestion to @Deji... I please him much to put back downloads for older versions of CLEO for GTA San Andreas, especially CLEO 3 and CLEO 4.1.1.30F on http://cleo.sannybuilder.com, since they are stable and doesn't causes a lots of CRASHES unlike newest CLEO library discussed here...

No, CLEO 4.1.1.30f does have a lot of problems. This 4.3 is an improvement on that and is already more stable and is being continuously updated with fixes (over 10 times within the last week already). I've fixed every report, except the most recent one about ZAZ's "Car Saloon", which I'm working on right now.

Share this post


Link to post
Share on other sites
Deji

CLEO 4.3.07 released!

 

First post updated with more information + download

.

 

@Zera - I was able to use that 'Car Saloon' mod no problems. I dont know if I fixed it without realising, but try the newest releases.

Share this post


Link to post
Share on other sites
ThirteenAG

Not noticing the same problems, though it reappears when first entering freefall mode.

I see, .cs3 works for me.

Share this post


Link to post
Share on other sites
Deji

Updated with a fix to a bug where SCM textures could be overwritten with ones loaded in CLEO scripts.

Share this post


Link to post
Share on other sites
Zera

@Zera - I was able to use that 'Car Saloon' mod no problems. I dont know if I fixed it without realising, but try the newest releases.

Yeah, it seems to be working fine now.

Share this post


Link to post
Share on other sites
Wesser

Deji, did you integrate SDDWG or what? :p

Share this post


Link to post
Share on other sites
Deji

Deji, did you integrate SDDWG or what? :p

 

Nah, from the look of it, with the power invested in me by CLEO, I was able to fix the bugs with a lot less effort than you seemed to have to gone to :p I will be making an attempt to fix all the problems which occur from the intrusiveness of CLEO, which have even been a problem before CLEO 4.

 

While CLEO grows from great achievements, it's heavily let down by SA's simplistic (and sometimes weird) scripting engine. For a long while I've wanted to add a completely new scripting engine (though still building on the SCR basis) as an alternate to how CLEO extends SA's own. The basis of CLEO is great, but it requires more than SA's scripting engine was built for (it's like nitro for a three-wheeler vehicle, if you ask me :p).

 

But ironically, I'm now working on CLEO, so I can try to instead build on that to achieve most of the ideas I've had for an improved scripting engine without it being too demanding for current scripters to adapt to. Maybe add that extra wheel. It'd be better when I can upgrade the stock parts too, but for now, I'll focus on stability ;)

 

 

By the way, that entire post just isn't aimed at Wesser, but I tend to veer off one subject and onto others I've thought about posting earlier sometimes.. just waiting for the right moment :p

Share this post


Link to post
Share on other sites
Zera

Got that crash with PimpMyCar again:

19/01/2014 00:16:15.661 [0A94] Starting new custom mission TUNING.cm from thread named pimpt19/01/2014 00:16:15.661 Loading custom script TUNING.cm...19/01/2014 00:16:17.229 [Error] Exiting with error: Error during loading of custom script TUNING.cm occured.Error message: Starting of custom mission when other mission loaded

This was a few minutes after starting a new game, so I never made it to Grove Street. Is heading to Grove Street in the beginning of the game an active mission?

Share this post


Link to post
Share on other sites
Deji

Got that crash with PimpMyCar again:

19/01/2014 00:16:15.661 [0A94] Starting new custom mission TUNING.cm from thread named pimpt19/01/2014 00:16:15.661 Loading custom script TUNING.cm...19/01/2014 00:16:17.229 [Error] Exiting with error: Error during loading of custom script TUNING.cm occured.Error message: Starting of custom mission when other mission loaded

This was a few minutes after starting a new game, so I never made it to Grove Street. Is heading to Grove Street in the beginning of the game an active mission?

 

No, but it's started as part of a mission. It stays active while you're within 30 meters of your starting point and not in a vehicle...

Share this post


Link to post
Share on other sites
Zera

No, but it's started as part of a mission. It stays active while you're within 30 meters of your starting point and not in a vehicle...

I was in San Fierro when the crash happened though (used a teleportation script and another to turn off the wanted level). I did get on the bike in the beginning.

Edited by Zera

Share this post


Link to post
Share on other sites
Asdf92

What about Ryosuke's Shell plugin incompatibility and DK's Plugin.dll?

it gets crashes but nothing related to it

Share this post


Link to post
Share on other sites
Ejikin91

I have many problems with new CLEO version too. I dont know why, but I have a problem with Advanced Aiming Mod by DK22Pac 1.0

Edited by Ejikin91

Share this post


Link to post
Share on other sites
Danikov

@two above me

 

Strange,I am not facing any problems with any of DKs mods,I am using the Mobile HUD,Advanced Aiming mod and the latest IMFX.

Share this post


Link to post
Share on other sites
Zera

@two above me

 

Strange,I am not facing any problems with any of DKs mods,I am using the Mobile HUD,Advanced Aiming mod and the latest IMFX.

Same here. No problem with DK's or Ryosuke's plugins whatsoever.

Edited by Zera

Share this post


Link to post
Share on other sites
Deji

What about Ryosuke's Shell plugin incompatibility and DK's Plugin.dll?

it gets crashes but nothing related to it

 

 

 

I have many problems with new CLEO version too. I dont know why, but I have a problem with Advanced Aiming Mod by DK22Pac 1.0

 

 

 

You guys are aware that other things, besides from the CLEO version, can cause problems, too? In order for your report to be more informative, stuff like .exe version/size, ASI loader version and all installed mods (if there's too many to list, you should try removing as many scripts as possible to reduce the possibility another script is causing a problem) should all be mentioned. I'll fix what I can find. If I cant find it, it's likely not a CLEO bug :p

Share this post


Link to post
Share on other sites
cabron-jon
Sometimes during the story missions off with this error

problem signature:
Problem Event Name: APPCRASH
application Name: gta_sa.exe
version of the application: 0.0.0.0
Application Timestamp: 427101ca
Module name in error: CLEO.asi
Version of the module with the error: 4.3.7.1
The time stamp module with the error: 52d992dc
exception code: c0000005
exception Offset: 00026c47
OS Version: 6.1.7600.2.0.0.256.1
language code: 1049
For more information 1: d68b
For more information 2: d68bd3b8282f5e72182bbd7e42e4d6c7
For more information 3: 6c49
For more information 4: 6c49d494190589b8dc6d7b57ccb74dfb

Share this post


Link to post
Share on other sites
Zera

I got the crash with PMC again, this time after activating it soon after I quit the Lowrider contest (so there really shouldn't be any active mission at that moment).

 

Isn't there any way to just prevent the mission script from activating if it detects another mission running? It would be better than just crashing to desktop every time this happens.

Share this post


Link to post
Share on other sites
KELASHI

Glad of support for steam version. I have one. But it can't start and crashes with CLEO.

 

The log:

20/01/2014 12:15:42.249 Log started.20/01/2014 12:15:42.250 Unprotecting memory region '.text': 0x00001000 (size: 0x004A3000)20/01/2014 12:15:42.250 Unprotecting memory region '.rdata': 0x004A5000 (size: 0x0006E000)20/01/2014 12:15:42.250 Loading plugin cleo/FileSystemOperations.cleo20/01/2014 12:15:42.251 Loading plugin cleo/IniFiles.cleo20/01/2014 12:15:42.251 Loading plugin cleo/IntOperations.cleo20/01/2014 12:15:42.252 Started on game of version: SA 3.0 steam20/01/2014 12:15:42.252 Injecting MenuStatusNotifier...20/01/2014 12:15:42.252 Replacing call: 0x0059137920/01/2014 12:15:42.252 Injecting DmaFix...20/01/2014 12:15:42.252 Replacing call: 0x0055117420/01/2014 12:15:42.252 Injecting TextManager...20/01/2014 12:15:42.252 Injecting function at: 0x006CCCE020/01/2014 12:15:42.252 Injecting SoundSystem...20/01/2014 12:15:42.252 Replacing call: 0x0078276D

Share this post


Link to post
Share on other sites
Deji

 

 

 

Glad of support for steam version. I have one. But it can't start and crashes with CLEO.

 

The log:

20/01/2014 12:15:42.249 Log started.20/01/2014 12:15:42.250 Unprotecting memory region '.text': 0x00001000 (size: 0x004A3000)20/01/2014 12:15:42.250 Unprotecting memory region '.rdata': 0x004A5000 (size: 0x0006E000)20/01/2014 12:15:42.250 Loading plugin cleo/FileSystemOperations.cleo20/01/2014 12:15:42.251 Loading plugin cleo/IniFiles.cleo20/01/2014 12:15:42.251 Loading plugin cleo/IntOperations.cleo20/01/2014 12:15:42.252 Started on game of version: SA 3.0 steam20/01/2014 12:15:42.252 Injecting MenuStatusNotifier...20/01/2014 12:15:42.252 Replacing call: 0x0059137920/01/2014 12:15:42.252 Injecting DmaFix...20/01/2014 12:15:42.252 Replacing call: 0x0055117420/01/2014 12:15:42.252 Injecting TextManager...20/01/2014 12:15:42.252 Injecting function at: 0x006CCCE020/01/2014 12:15:42.252 Injecting SoundSystem...20/01/2014 12:15:42.252 Replacing call: 0x0078276D

 

While CLEO (theoretically) has steam support, it only works when the .exe is decrypted. You need to either acquire see link below a decrypted steam .exe (which won't actually work with Steam - but still has changes of GTASA) or wait until Silent's ASI Loader gets an update, which should be able to take care of decryption before loading CLEO.

 

I posted more about this here: http://gtag.gtagaming.com/forums/index.php?s=&showtopic=1418&view=findpost&p=8271

 

 

 

I got the crash with PMC again, this time after activating it soon after I quit the Lowrider contest (so there really shouldn't be any active mission at that moment).

 

Isn't there any way to just prevent the mission script from activating if it detects another mission running? It would be better than just crashing to desktop every time this happens.

 

Preventing scripts from doing what they expect to do can cause problems. However, I'm currently trying to resolve this without changing the obvious bits...

 

People are getting a strange "ios::failbit_set" error. It's occurring because, for some reason, a script fails are occasionally failing to load. This seems to be the biggest problem and could potentially be causing other problems, so I'll try to fix this first.

Edited by Deji

Share this post


Link to post
Share on other sites
Asdf92

 

What about Ryosuke's Shell plugin incompatibility and DK's Plugin.dll?

it gets crashes but nothing related to it

 

You guys are aware that other things, besides from the CLEO version, can cause problems, too? In order for your report to be more informative, stuff like .exe version/size, ASI loader version and all installed mods (if there's too many to list, you should try removing as many scripts as possible to reduce the possibility another script is causing a problem) should all be mentioned. I'll fix what I can find. If I cant find it, it's likely not a CLEO bug :p

 

Alright, I'll explain the detailed one...

 

My GTA get crashed while playing using only the mentioned mods and the cleo library contains only newopcodes.cleo. Here's my game details

 

gta_sa.exe

version 1.0 Cracked by Hoodlum 14 383 616 bytes

Silent's ASI Loader 1.1

DK's IMFX (explosion udpate)

plugin.dll (latest update from mobile hud, but not using the .asi file from that)

CLEO Library contains only newopcodes.cleo comes with one script, master spark

Shell plugin from Ryosuke839

Share this post


Link to post
Share on other sites
Deji

CLEO 4.3.08 released!

 

Fixed a bug where 004E in custom missions would cause a crash later on.

 

Hopefully this should resolve some issues with 'Pimp My Car', although weirdly when I tried it there was no text. However, I managed to get to the tuning menu which worked fine and fixed the crash on exit.

 

I will try to look into the other bugs, but let me know if this update fixes any others.

Share this post


Link to post
Share on other sites
cabron-jon

flies:

21/01/2014 10:56:49.177 Loading audiostream CLEO\GTA5SOUNDS\WASTED.MP3 failed. Error code: 20
21/01/2014 10:56:49.177 Loading audiostream CLEO\GTA5SOUNDS\BUSTED.MP3 failed. Error code: 20
21/01/2014 10:57:33.614 Closing SoundSystem...
21/01/2014 10:57:33.615 Deleting fxts...
21/01/2014 10:57:33.615 Unregistering custom script named static_
21/01/2014 10:57:33.615 Unregistering custom script named Wasted_
21/01/2014 10:57:33.615 Deleting inactive script named outline
21/01/2014 10:57:33.615 Deleting inactive script named FPS De-
21/01/2014 10:57:33.615 Log finished.

Share this post


Link to post
Share on other sites
Zera

Still getting the exact same crash. Could it be because I'm activating it near the area where you start N-Races?

Share this post


Link to post
Share on other sites
Deji

 

flies:

 

21/01/2014 10:56:49.177 Loading audiostream CLEO\GTA5SOUNDS\WASTED.MP3 failed. Error code: 20
21/01/2014 10:56:49.177 Loading audiostream CLEO\GTA5SOUNDS\BUSTED.MP3 failed. Error code: 20
21/01/2014 10:57:33.614 Closing SoundSystem...
21/01/2014 10:57:33.615 Deleting fxts...
21/01/2014 10:57:33.615 Unregistering custom script named static_
21/01/2014 10:57:33.615 Unregistering custom script named Wasted_
21/01/2014 10:57:33.615 Deleting inactive script named outline
21/01/2014 10:57:33.615 Deleting inactive script named FPS De-
21/01/2014 10:57:33.615 Log finished.

 

 

Are you sure you're using the right path? And more importantly, does this occur with 3D audiostreams? The error code means "bad param".

Share this post


Link to post
Share on other sites
cabron-jon

 

 

flies:

 

21/01/2014 10:56:49.177 Loading audiostream CLEO\GTA5SOUNDS\WASTED.MP3 failed. Error code: 20
21/01/2014 10:56:49.177 Loading audiostream CLEO\GTA5SOUNDS\BUSTED.MP3 failed. Error code: 20
21/01/2014 10:57:33.614 Closing SoundSystem...
21/01/2014 10:57:33.615 Deleting fxts...
21/01/2014 10:57:33.615 Unregistering custom script named static_
21/01/2014 10:57:33.615 Unregistering custom script named Wasted_
21/01/2014 10:57:33.615 Deleting inactive script named outline
21/01/2014 10:57:33.615 Deleting inactive script named FPS De-
21/01/2014 10:57:33.615 Log finished.

 

 

Are you sure you're using the right path? And more importantly, does this occur with 3D audiostreams? The error code means "bad param".

 

 

Oh .. I apologize. Everything works I just threw in the folder sounds :catspider:

Share this post


Link to post
Share on other sites
Deji

A breakthrough has been made: http://gtag.gtagaming.com/forums/index.php?showtopic=1418&st=80

'Pimp My Car' has been confirmed as supported by CLEO 4.3 now - so try to get it to work on a clean game before reporting bugs about it. However, if it still causes problems with other scripts, I'll need to know specifically which scripts they are.

Share this post


Link to post
Share on other sites
Deji

CLEO 4.3.09 released!

 

Should've fixed the custom mission loading error after having been in a MAIN mission, as well as all this:

 

-- 4.3.9 --* Will now be able to start a CLEO mission after recently finishing a standard mission* Will no longer error & terminate when scripts fail to open and instead simply log the error* Will no longer terminate on warnings* No longer includes paths in automatically generated script names (e.g. cleo\dir\demo.cs is now named 'demo.cs' and not 'dir\dem')* Improved handling of script load errors

 

Now, even if there's an error, the game should continue running well as long as the error isn't critical (whereas before there was an error message, followed by forced termination) and any warnings/errors will be outputted to the log file. Download in first post, as always.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.