Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Arena War
      2. After Hours
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA Next

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Recommended Posts

jln22

You need to put the file inside a folder, for example modloader/a folder with any name you want, the name of the mod probably/mod content here

 

If you still don't get it, post the log (modloader/modloader.log) so I can analyze what's going on

I don't have any modloader.log file inside. I have a .data and a modloader.ini file in it. That's all.

Yes the files are in a subfolder that's inside modloader, exactly like "modloader/gta3.img/BMX/bmx.dff&bmx.txd".

Share this post


Link to post
Share on other sites
fastman92

Well, if you don't have a log it's probably because you don't have an asi loader to load modloader.asi

http://www.gtagarage.com/mods/show.php?id=21709

Or mod loader has no permissions to create a new file in root of GTA San Andreas if he installed the game in "Program Files(x86)"

 

That, assuming he's not running GTA San Andreas as administrator and the UAC is on.

Edited by fastman92

Share this post


Link to post
Share on other sites
Concavax

Link, mod loader have a bug with archive .dat.

 

The mod dont reconize the .dat files, i mean this have a bug with .dat files of overdosse efects 1.5 part one.

 

 

Object.dat

surfinfo.dat

Share this post


Link to post
Share on other sites
LINK/2012

Reading of those aren't implemented yet, check out modloader/.data/plugins/std-data.txt for the list of currently supported data files :)

Share this post


Link to post
Share on other sites
ZAZ

Amazing mod, have a cookie for that :cookie:

 

the addcars i didn't got to work, i made a folder ADDCAR and put there the three files

modloader\ADDCAR\MoreVehicles.asi

modloader\ADDCAR\HandlingAdder.asi

modloader\ADDCAR\HandlingAdder.ini

ingame the cars didn't appear but i'm wondering that the game didn't crashed (tried to spawn it with my script)

the modloader.log showed that the handler for HandlingAdder.ini wasn't found

 

btw. depending to the usage about ipl and gta.dat, i got my custom ipl working in this way:

i added this line to gta.dat

IPL modloader\VillaParadiso\VillaParadiso.IPL

placed the modified gta.dat and the ipl into modloader folder

modloader\VillaParadiso\gta.dat

modloader\VillaParadiso\VillaParadiso.IPL

Share this post


Link to post
Share on other sites
Concavax

I guess then files have a little problems when mixing.

 

 

-timecyc.dat
-popcycle.dat
-tracks%d.dat
-roadblox.dat
-fonts.dat
But i read this.
Currently it can handle the following files:
*.ide
*.ipl
default.dat / gta.dat
handling.cfg
carmods.dat
plants.dat
So this files don´t supported yet?

-Object.dat

-surfinfo.dat

Edited by Concavax

Share this post


Link to post
Share on other sites
TJGM

I guess then files have a little problems when mixing.

 

 

-timecyc.dat

-popcycle.dat

-tracks%d.dat

-roadblox.dat

-fonts.dat

 

But i read this.

 

 

Currently it can handle the following files:

*.ide

*.ipl

default.dat / gta.dat

handling.cfg

carmods.dat

plants.dat

 

So this files don´t supported yet?

 

 

-Object.dat

-surfinfo.dat

 

Reading of those aren't implemented yet, check out modloader/.data/plugins/std-data.txt for the list of currently supported data files :)

Share this post


Link to post
Share on other sites
Concavax

Emmmm, Im sorry :/

 

 

Some one know if this file supported?

 

 

effects.fxp

Share this post


Link to post
Share on other sites
ZAZ

Some one know if this file supported?

effects.fxp

yes, works for me, i have effects.fxp and effectsPC.txd in modloader

Share this post


Link to post
Share on other sites
LINK/2012

Amazing mod, have a cookie for that :cookie:

 

the addcars i didn't got to work, i made a folder ADDCAR and put there the three files

modloader\ADDCAR\MoreVehicles.asi

modloader\ADDCAR\HandlingAdder.asi

modloader\ADDCAR\HandlingAdder.ini

ingame the cars didn't appear but i'm wondering that the game didn't crashed (tried to spawn it with my script)

the modloader.log showed that the handler for HandlingAdder.ini wasn't found

 

btw. depending to the usage about ipl and gta.dat, i got my custom ipl working in this way:

i added this line to gta.dat

IPL modloader\VillaParadiso\VillaParadiso.IPL

placed the modified gta.dat and the ipl into modloader folder

modloader\VillaParadiso\gta.dat

modloader\VillaParadiso\VillaParadiso.IPL

About the add cars plugin:

The problem is with HandlingAdder and it's ini, I can't patch those (on the fly) to do path translation because of the way it opens the file, that happens both with Alexander and most of Ryosuke plugins. Other plugins (not of those authors) should work perfectly fine.

 

I should remember to add GTAIV_HUD.asi and those into the incompatibility list (and if them are found a error message would show up).

 

About the gta.dat stuff:

The way you did isn't wrong, but isn't the way I intended it to be used

Gonna quote std-data.txt

 

 

Usage:

 

For ide and ipl files, they must be together a gta.dat file (or a gta.dat line in a text file)

and they must be inside the folder the gta.dat requests it to be.

 

For example, if the gta.dat file says the IPL file is at:

IPL data/maps/mymap/map.IPL

 

Inside modloader the IPL files must be in a place something like:

modloader/mymod/data/maps/mymap/map.IPL

or even

modloader/mymod/folder1/folder2/folder3/data/maps/mymap/map.IPL

 

That applies to IDE files too.

 

For other files, such as handling.cfg, just place the file wherever you want (of course inside a mod folder)

Remember, it can detect lines from readme (.txt) files.

Share this post


Link to post
Share on other sites
ZAZ

all right so far, keep it up

Share this post


Link to post
Share on other sites
JosephIdris

I love this! It's GREAT. It's like I have original game but in the same time modded! haha!!

 

However, I got questions:

I don't know how to install IDE/PL/CLEOS/ASI through ModLoader.. I've only managed to install Effects & GTA3.IMG.

I want detailed explanation, please. :)

 

And.. can you take a look at this topic?

http://gtaforums.com/topic/692353-freezing/

 

thx

Share this post


Link to post
Share on other sites
LINK/2012

I love this! It's GREAT. It's like I have original game but in the same time modded! haha!!

 

However, I got questions:

I don't know how to install IDE/PL/CLEOS/ASI through ModLoader.. I've only managed to install Effects & GTA3.IMG.

I want detailed explanation, please. :)

 

And.. can you take a look at this topic?

http://gtaforums.com/topic/692353-freezing/

 

thx

Thanks, good to hear you're having fun :)

For CLEO/ASI, just drag 'n drop, no mistery, standard ML method.

For IDE/IPL, almost normal, except for one fact (that you can see on the readme) and I just quoted on my last post.

The freezes are probably not ML related, it's beta but it's pretty stable at the moment :p

But anyway, you could send the modloader.log just to be sure.

Edited by LINK/2012

Share this post


Link to post
Share on other sites
JosephIdris

 

I love this! It's GREAT. It's like I have original game but in the same time modded! haha!!

 

However, I got questions:

I don't know how to install IDE/PL/CLEOS/ASI through ModLoader.. I've only managed to install Effects & GTA3.IMG.

I want detailed explanation, please. :)

 

And.. can you take a look at this topic?

http://gtaforums.com/topic/692353-freezing/

 

thx

Thanks, good to hear you're having fun :)

For CLEO/ASI, just drag 'n drop, no mistery, standard ML method.

For IDE/IPL, almost normal, except for one fact (that you can see on the readme) and I just quoted on my last post.

The freezes are probably not ML related, it's beta but it's pretty stable at the moment :p

But anyway, you could send the modloader.log just to be sure.

 

I don't think I crash because of ModLoader, it happened before too when I was just using IMG Editor/whatever

 

Anyways I have another question: When I open modloader.ini and I try to disable all mods temporarily.. IGNORE_ALL=FALSE(I change to TRUE) then I start SA:MP 0.3d.. Right on screen, before I even get to load SERVER, game freezes.

 

P.S. Do I get drag ASI/CLEO and drop in ModLoader folder without having to create anything? Like this?

http://s10.postimg.org/dfgnc6sjd/sa_mp_140.png

 

P.S.2: Do I use IDE/IPL like this?

http://s10.postimg.org/trqp1x6ux/screenshot_6.jpg

Share this post


Link to post
Share on other sites
LINK/2012

P.S. Do I get drag ASI/CLEO and drop in ModLoader folder without having to create anything? Like this?

http://s10.postimg.o...d/sa_mp_140.png

Nope, mods should have folders at modloader directory, so, modloader/example name/example.cs

Same for ASI or anything else.

 

 

.S.2: Do I use IDE/IPL like this?

http://s10.postimg.o...creenshot_6.jpg

Yes, exactly like that.

The only exceptions are vehicles.ide, peds.ide and default.ide, if they aren't structured correctly, modloader will work with them anyway, since those are common IDEs I thought that would be a good idea. I'm going to put veh_mods.ide on this behavior too :)

 

 

Anyways I have another question: When I open modloader.ini and I try to disable all mods temporarily.. IGNORE_ALL=FALSE(I change to TRUE) then I start SA:MP 0.3d.. Right on screen, before I even get to load SERVER, game freezes.

I'll try to reproduce that later. Edited by LINK/2012

Share this post


Link to post
Share on other sites
JosephIdris

 

P.S. Do I get drag ASI/CLEO and drop in ModLoader folder without having to create anything? Like this?

http://s10.postimg.o...d/sa_mp_140.png

Nope, mods should have folders at modloader directory, so, modloader/example name/example.cs

Same for ASI or anything else.

 

.S.2: Do I use IDE/IPL like this?

http://s10.postimg.o...creenshot_6.jpg

Yes, exactly like that.

The only exceptions are vehicles.ide, peds.ide and default.ide, if they aren't structured correctly, modloader will work with them anyway, since those are common IDEs I thought that would be a good idea. I'm going to put veh_mods.ide on this behavior too :)

 

Anyways I have another question: When I open modloader.ini and I try to disable all mods temporarily.. IGNORE_ALL=FALSE(I change to TRUE) then I start SA:MP 0.3d.. Right on screen, before I even get to load SERVER, game freezes.

I'll try to reproduce that later.

 

OK, I got CLEO working now, I haven't tried ASI yet, but as you said, it's the same.

I forgot to ask, what about .ini and .txt that comes for example with Sound Overhaul? There's (weaponlimit.asi, weaponlimit.ini, weapons.txt, weaponsounds.txt) Where do I put these if I wanted to load with Mod Loader?

Share this post


Link to post
Share on other sites
LINK/2012

I forgot to ask, what about .ini and .txt that comes for example with Sound Overhaul? There's (weaponlimit.asi, weaponlimit.ini, weapons.txt, weaponsounds.txt) Where do I put these if I wanted to load with Mod Loader?

Ok, one thing you are not understanding about modloader is that it was built specifically for stuff already packed (for those long years of modding) to work without effort, just drag and dropping the mod files.

And that's it, just extract stuff as it is and let modloader care about the rest.

Anyway, Mod Loader will show a error saying weaponlimit.asi is impossible to be compatible or something and you should put it on the base folder, so do it, use weaponlimit (and it's ini or whatever) on base path.

 

But it should work for non-Ryosuke and non-Alexander ASI plugins.

Edited by LINK/2012

Share this post


Link to post
Share on other sites
JosephIdris

Apparently I didn't understand anything from your post either :p

I'm *stoobyid* Easy on meh ^^ (I placed all files that comes with weaponlimit.asi in the same folder, means all other files are in asi folder too, idk if that should work)

 

EDIT: NVM, it's incompatible

Edited by JosephIdris

Share this post


Link to post
Share on other sites
Gramps

I think all of Ryosuke's are incompatible, and some of Alexander Blade's too AFAIK.

Share this post


Link to post
Share on other sites
Jaybog

great, i love it :^:

Share this post


Link to post
Share on other sites
Semih95

I dont know why but when I want to use cleo mods I get a black screen ... I dont know how to install Cleo. What I have o do to install Cleo just normally ? I mean without using modloader ? I copied all the cleofiles in moadloader -> doesnt work, I disabled the modloader plugin for cleo and let the cleofiles in the game directory SA/Cleo ... -> doesnt work

 

Please help

Share this post


Link to post
Share on other sites
uokka
..\SA\cleo\some_script.cs

This is correct.

If you have installed CLEO, it should have installed a proper ASI loader too which is needed for CLEO as well as for Mod Loader.

If it still doesn't work, you might need to read the provided Readmes again to make sure you are using a compatible EXE.

 

However, you don't seem to have an issue with Mod Loader, so actually, support for native CLEO might be searched elsewhere.

Oh, I misunderstood.

 

 

Anyway, I think this is the proper way to install CLEO scripts via ML:

 

..\SA\modloader\SOME_MOD_FOLDER\cleo\some_script.cs

 

 

Edited by uokka

Share this post


Link to post
Share on other sites
Semih95

I dont have problems with Cleo. It works perfect without Modloader but I wanted to test Modloader because its very easy to install mods. However, when I install my Cleo scripts in SA/CLeo I have a blackscreen after loading. The same happens when I copy the cleoscripts into modloader

Share this post


Link to post
Share on other sites
LINK/2012

I dunno, doesn't look like a ML fault at all, isn't it a fault from one of the cleo scripts?

If you remove all those cleo scripts from the cleo folder does the game work?

Normally freezes are related to a cleo script that is looping infinitely

Edited by LINK/2012

Share this post


Link to post
Share on other sites
Semih95

I removed all Cleos and now its working ? But how is that possible ? When I use all my cleosmods in normal game (without modloader) it works fine ??

 

Edit I found the problem it was rlogos. I deleted the models and data folder so I could install this mod but I forgot that I have to put rlogos.txd in models/txd folder ::D

Edited by Semih95

Share this post


Link to post
Share on other sites
Apu889

just realized, is modloader compatible with GTA IV HUD mod?

 

mine's messed up:

1891475_862054650478764_83850037_o.jpg

inside outside modloader folder installation, doesn't affected. :/

Share this post


Link to post
Share on other sites
TJGM

Mods by Alexander won't work inside modloader, since he checks if the .asi is in the same place as the .exe, if it's not, it won't work. Same goes for pretty much all ryosuke mods.

 

But yeah, I had the same bug after Link updated, he didn't know what was causing it and it seemed like an issue I was only having, pretty odd bug.

Edited by TJGM

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.