Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Los Santos Tuners
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. GTA San Andreas

      1. Classic GTA SA
      2. Guides & Strategies
      3. Help & Support
    2. GTA Vice City

      1. Classic GTA VC
      2. Guides & Strategies
      3. Help & Support
    3. GTA III

      1. Classic GTA III
      2. Guides & Strategies
      3. Help & Support
    1. Grand Theft Auto Series

      1. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    6. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

      1. GTANet 20th Anniversary
    2. Support

    3. Suggestions

SilentPatch


Silent
 Share

Recommended Posts

The Lucky Mole
18 hours ago, Vaisaga said:

Hi, I noticed that the rain reflection for SA is only effective in some areas. 

I did not test everywhere in the map, but I find that the reflection is only effective around Ganton, Idlewood in Los santos and small towns like Montgomery, Blueberry and Dillimore. 

I can't see the reflection effect in San fierro, Las venturas, and mount chilliad. 

I have also tried to install the reffix and set ForceReflections to 1, which did not change anything. 

It's a map issue, check this out.

 

Link to comment
Share on other sites

36 minutes ago, The Lucky Mole said:

It's a map issue, check this out.

 

 

It worked, thanks!

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
Vinniethegreat

I'm not sure if this has been reported but Vice City freezes on the splash screen before the menu pops up and I have isolated the issue to Silent Patch. On clean installs the game does not freeze at that splash screen.Does anyone have any experience with this issue?

 

On version 1.0 retail CD copy of VC

 

 

(Worth mentioning that the Silent Patch and the DDraw component are the only mods I've been using)

Edited by Vinniethegreat
Added clarification for what mods I'm using
Link to comment
Share on other sites

  • 2 weeks later...
RandomModder84

Hey silent can you make a patch for driver parallel lines? Its really frustrating the cars handling are bad the lock on aiming too

Link to comment
Share on other sites

hey silent - sorry for requesting something as i know there's already been a million requests in this thread, but would you be willing to make a small script that would reverse the corona rotation fix? i'm trying to get a sort of vice city headlight effect in san andreas, where the lens flare is a big line, but that fix unfortunately makes it look kind of terrible

Link to comment
Share on other sites

  • 2 weeks later...

Has anyone ever noticed that, when you get a homie to take a photo of CJ, no camera crosshair is drawn and that holding a sniper rifle brings up its crosshair without aiming at all? Here's a quick fix:

 

0058E020    CHud::DrawCrossHairs proc
...
0058E7F0    EB 39             jmp     CHud::DrawCrossHairs+80Bh
..
0058E81A    8BD6              mov     edx, esi ; WEAPONTYPE_CAMERA
0058E81C    8DA424 00000000   lea     esp, [esp+0]
0058E823    8DA424 00000000   lea     esp, [esp+0]
0058E82A    90                nop
...
0058E82D    52                push    edx

012          345
678   9A   BCD
EFG HIJK LMN

OPQR  STUV
WX    YZ

Link to comment
Share on other sites

13 hours ago, Wesser said:

Has anyone ever noticed that, when you get a homie to take a photo of CJ, no camera crosshair is drawn and that holding a sniper rifle brings up its crosshair without aiming at all? Here's a quick fix:

 

0058E020    CHud::DrawCrossHairs proc
...
0058E7F0    EB 39             jmp     CHud::DrawCrossHairs+80Bh
..
0058E81A    8BD6              mov     edx, esi ; WEAPONTYPE_CAMERA
0058E81C    8DA424 00000000   lea     esp, [esp+0]
0058E823    8DA424 00000000   lea     esp, [esp+0]
0058E82A    90                nop
...
0058E82D    52                push    edx

Any chance of releasing that fix as a pre-compiled CLEO script? I know CLEO scripting but I'm not really sure if it's possible for me to get that working in-game...

Link to comment
Share on other sites

On 9/24/2021 at 5:35 AM, Wesser said:

Has anyone ever noticed that, when you get a homie to take a photo of CJ, no camera crosshair is drawn and that holding a sniper rifle brings up its crosshair without aiming at all? Here's a quick fix:

 

0058E020    CHud::DrawCrossHairs proc
...
0058E7F0    EB 39             jmp     CHud::DrawCrossHairs+80Bh
..
0058E81A    8BD6              mov     edx, esi ; WEAPONTYPE_CAMERA
0058E81C    8DA424 00000000   lea     esp, [esp+0]
0058E823    8DA424 00000000   lea     esp, [esp+0]
0058E82A    90                nop
...
0058E82D    52                push    edx

Saw it mentioned here: https://github.com/ThirteenAG/WidescreenFixesPack/issues/989

Link to comment
Share on other sites

On 9/24/2021 at 8:05 AM, Wesser said:

Has anyone ever noticed that, when you get a homie to take a photo of CJ, no camera crosshair is drawn and that holding a sniper rifle brings up its crosshair without aiming at all? Here's a quick fix:

 

0058E020    CHud::DrawCrossHairs proc
...
0058E7F0    EB 39             jmp     CHud::DrawCrossHairs+80Bh
..
0058E81A    8BD6              mov     edx, esi ; WEAPONTYPE_CAMERA
0058E81C    8DA424 00000000   lea     esp, [esp+0]
0058E823    8DA424 00000000   lea     esp, [esp+0]
0058E82A    90                nop
...
0058E82D    52                push    edx

 

My man.

Link to comment
Share on other sites

The mobile version of SA comes with a sort of cooldown feature among bunny hops as a mean to mitigate fast tapping which nicely fits in other platforms too:

 

00542A50    CPhysical::ApplyTurnForce proc

006BFA30    CBmx::ProcessControl proc
...
006BFA41    E9 00000000             jmp     _hook_6BFA41_CBmx__ProcessControl

006C0390    CBmx::LaunchBunnyHopCB proc
...
006C04F6    E9 00000000             jmp     _hook_6C04F6_CBmx__LaunchBunnyHopCB

006C0590    CBmx::ProcessBunnyHop proc

006C1470    CBmx::ProcessAI proc
...
006C184E    E9 00000000             jmp     _hook_6C184E_CBmx__ProcessAI

_hook_6BFA41_CBmx__ProcessControl:
00000000    0F85 00000000           jnz     CBmx::ProcessControl+117h
00000006    D905 5CCBB700           fld     CTimer::ms_fTimeStep
0000000C    D80D D8148700           fmul    flt_8714D8 ; 0.02
00000012    D82D 00000000           fsubr   fBunnyHopCooldown
00000018    D905 8C8B8500           fld     flt_858B8C ; 0.5
0000001E    D8D1                    fcom    st(1)
00000020    DFE0                    fnstsw  ax
00000022    F6C4 41                 test    ah, 41h
00000025    75 0F                   jnz     $L1
00000027    DDD8                    fstp    st
00000029    D9EE                    fldz
0000002B    D8D1                    fcom    st(1)
0000002D    DFE0                    fnstsw  ax
0000002F    F6C4 41                 test    ah, 41h
00000032    74 02                   jz      $L1
00000034    D9C9                    fxch    st(1)
00000036                            $L1:
00000036    D91D 00000000           fstp    fBunnyHopCooldown
0000003C    DDD8                    fstp    st
0000003E    E9 00000000             jmp     CBmx::ProcessControl+17h

_hook_6C04F6_CBmx__LaunchBunnyHopCB:
00000000    E8 00000000             call    CPhysical::ApplyTurnForce
00000005    C705 00000000 0000003F  mov     fBunnyHopCooldown, 0.5
0000000F    E9 00000000             jmp     CBmx::LaunchBunnyHopCB+16Bh

_hook_6C184E_CBmx__ProcessAI:
00000000    D9EE                    fldz
00000002    D81D 00000000           fcomp   fBunnyHopCooldown
00000008    DFE0                    fnstsw  ax
0000000A    F6C4 44                 test    ah, 44h
0000000D    0F8A 00000000           jp      CBmx::ProcessAI+3E5h
00000013    8BCE                    mov     ecx, esi
00000015    E8 00000000             call    CBmx::ProcessBunnyHop
0000001A    E9 00000000             jmp     CBmx::ProcessAI+3E5h

fBunnyHopCooldown dd 0.0

 

Meanwhile, I realized that the bicycle keeps accelerating normally without CJ even pedaling when holding down the "Secondary Fire" key to perform a bunny hop (drive-by and stoppie do have an impact onto speed). FIX:

 

004D68B0    RpAnimBlendClumpGetAssociation proc

006C1470    CBmx::ProcessAI proc
...
006C1A06    E9 00000000             jmp     _hook_6C1A06_CBmx__ProcessAI

_hook_6C1A06_CBmx__ProcessAI:
00000000    0F84 00000000           je      CBmx::ProcessAI+0A67h
00000006    8B48 18                 mov     ecx, [eax+CEntity.m_rwObject]
00000009    68 CE000000             push    ANIM_BMX_BUNNYHOP
0000000E    51                      push    ecx
0000000F    E8 00000000             call    RpAnimBlendClumpGetAssociation
00000014    83C4 08                 add     esp, 8
00000017    3BC3                    cmp     eax, ebx
00000019    74 14                   je      $L1
0000001B    D940 18                 fld     [eax+CAnimBlendAssociation.currentTime]
0000001E    D81D 8C8B8500           fcomp   flt_858B8C ; 0.5
00000024    DFE0                    fnstsw  ax
00000026    F6C4 41                 test    ah, 41h
00000029    0F84 00000000           jz      CBmx::ProcessAI+67Fh
0000002F                            $L1:
0000002F    8B86 60040000           mov     eax, [esi+CVehicle.pDriver]
00000035    E9 00000000             jmp     CBmx::ProcessAI+59Ch

 

Another indirectly related bug is the inability to fire from a bicycle but not handbraking at the same time. This is due to a wrong configuration of default vehicle controls which sees RCTRL being assigned to both "Fire" and "Handbrake" keys. Sounds like a key mapping mistake as you cannot bind a certain input key twice from the main menu. FIX:

 

00530640    CControllerConfigManager::InitDefaultControlConfiguration
...
00530A20    8DA424 00000000     lea     esp, [esp+0]
00530A27    8DA424 00000000     lea     esp, [esp+0]
00530A2E    6690                xchg    ax, ax

 

On 9/24/2021 at 6:13 PM, H-G said:

Any chance of releasing that fix as a pre-compiled CLEO script? I know CLEO scripting but I'm not really sure if it's possible for me to get that working in-game...

 

Don't wanna waste my cloud space plus here codes will stay permanently:

 

Spoiler
{$CLEO}

/*
jmp     CHud::DrawCrossHairs+80Bh
*/
0A8C: write_memory 0x0058E7F1 size 1 value 0x39 vp TRUE
/*
mov     edx, esi ; WEAPONTYPE_CAMERA
lea     esp, [esp+0]
lea     esp, [esp+0]
nop
*/
0A8C: write_memory 0x0058E81A size 4 value 0xA48DD68B vp TRUE
0A8C: write_memory 0x0058E81E size 4 value 0x24 vp TRUE
0A8C: write_memory 0x0058E822 size 4 value 0x24A48D00 vp TRUE
0A8C: write_memory 0x0058E826 size 4 value 0 vp TRUE
0A8C: write_memory 0x0058E82A size 1 value 0x90 vp TRUE
/*
push    edx
*/
0A8C: write_memory 0x0058E82D size 1 value 0x52 vp TRUE

0A93: terminate_this_custom_script
Edited by Wesser

012          345
678   9A   BCD
EFG HIJK LMN

OPQR  STUV
WX    YZ

Link to comment
Share on other sites

1 hour ago, Wesser said:

Don't wanna waste my cloud space plus here codes will stay permanently:

But what about the new bunny hop and player control-related fixes you just posted? Would be sweet to get those in CLEO code too.:)

Link to comment
Share on other sites

hi, i'm found bugs in gta sa, can you fix this in the next vesrion??

 

pictures:

 

https://ibb.co/XkPFpDQ
https://ibb.co/K2GC9k9
https://ibb.co/F5fRGs7
https://ibb.co/vQg16GD
https://ibb.co/BwZSXB5
https://ibb.co/27nmM7Q
https://ibb.co/mhH170P
https://ibb.co/ssQ94bf

 

Ambulance bugs:

When the ambulance arrives, the tailgates with the words Ambulamce written on them are half-finished. And the reflection behind it is more than the reflection of the rest of the car body.

The ambulance cabin is slightly to the left and is out of place. If you look closely at the photos, the ambulance wheel comes out of the fender.

 

Faggio bugs:

When we turn the steering wheel of the engine, it only spins the odometer and does not command to turn. If you look at the reflection on the right side of the engine. The head is out of place and instead of covering from right to left, it is from top to bottom.

 

Please fix these bugs, if you can introduce Mod to fix these bugs.👍🚶‍♂️

Edited by Maziar
  • Like 1
  • KEKW 2
Link to comment
Share on other sites

Razor_Vermillion
2 hours ago, Maziar said:

hi, i'm found bugs in gta sa, can you fix this in the next vesrion??

 

pictures:

 

https://ibb.co/XkPFpDQ
https://ibb.co/K2GC9k9
https://ibb.co/F5fRGs7
https://ibb.co/vQg16GD
https://ibb.co/BwZSXB5
https://ibb.co/27nmM7Q
https://ibb.co/mhH170P
https://ibb.co/ssQ94bf

 

Ambulance bugs:

When the ambulance arrives, the tailgates with the words Ambulamce written on them are half-finished. And the reflection behind it is more than the reflection of the rest of the car body.

The ambulance cabin is slightly to the left and is out of place. If you look closely at the photos, the ambulance wheel comes out of the fender.

 

Faggio bugs:

When we turn the steering wheel of the engine, it only spins the odometer and does not command to turn. If you look at the reflection on the right side of the engine. The head is out of place and instead of covering from right to left, it is from top to bottom.

 

Please fix these bugs, if you can introduce Mod to fix these bugs.👍🚶‍♂️


Those are model bugs, not game coding bugs.
You can simply use blender to maybe fix these i'm guessing.

You also have to understand somethings will clip in roads in these games and there's no avoiding it.

That's how games work and after all san andreas was released in 2004.

Edited by Razor_Vermillion
Link to comment
Share on other sites

On 6/29/2021 at 11:00 PM, Marsi4eg said:

Oh that's really game-breaking bug that must be fixed immidiately

On the plus side, CJ looks like Sam Fisher, kind of 😂.

Spoiler
Spoiler

 

 

 

Link to comment
Share on other sites

4 hours ago, Razor_Vermillion said:


Those are model bugs, not game coding bugs.

 

well a least the Faggio one should be possible since the handlebar is a separate obect I think - no need for a model change there - similar to the DFT-30 wheel fix.

 

 

 

 

Silent as you may remeber you fixed something about the comprules I pointed out so extra6 can be ramdomly created with 4fff. Thx again.

 

I have something else which is not really broken but would be a nice feature imo that does not interfere with/break anything.

Could you make 3fff behave the same way as 4fff please? Normally 3fff does not create anything but I would like it to randomly create (or not create) one of the six extras.

This would be useful when using both extra slots because just using 0/nothing/0fff for the second slot only assigns it the extras that are not already bound to the first slot. (So almost exactly the same behaviour as 4fff just with the possbility that no extra at all might be created.)

 

Thx for considering.

Link to comment
Share on other sites

SolveMyMaze

Hi all,

I've just installed GTA SA from the original disc and had the dreaded mouse problem many other on Win 10 get.

I've followed the steps to install Silents ASI Loader, as well as adding both the .asi and .ini file into the main directory for the game. Unfortunately, the problem still remains with the mouse in that I cannot use it at all in game.

The Nvidia splash screen is also still appearing which is making me think that the loader isn't loading up the patch properly.

 

Any help on this would be greatly appreciated.

 

 

Link to comment
Share on other sites

nothasuke455

sometime motor cops shoot cj from their bike even when you do not have a wanted level can that be fixed ?

  • Like 2
Link to comment
Share on other sites

@Silent

There are 2 more PS2 cheats that were cut in the PC version:

- Hookers pay you

- Taxi features

I've brought them back:

injector::WriteMemory(0x8A5CC8 + 90 * 4, 0x87B9BD79);
injector::WriteMemory(0x8A5CC8 + 91 * 4, 0x5715605C);

The combinations I used to make these hashes are:

HOOKERSPAYYOU

TAXIFEATURES

It would be cool if you could bring them back in SilentPatch.

Oh and btw taxi features cheat is toggable on PC only, on PS2 it always shows 'Cheat activated'.

Link to comment
Share on other sites

7 minutes ago, Vulcade92 said:

There are 2 more PS2 cheats that were cut in the PC version:

 

No, these two are features for finishing Pimping/Taxi missions that piggyback on the cheat system. I don't intend to make them usable cheats.

Link to comment
Share on other sites

On 10/2/2021 at 12:52 PM, SolveMyMaze said:

Hi all,

I've just installed GTA SA from the original disc and had the dreaded mouse problem many other on Win 10 get.

I've followed the steps to install Silents ASI Loader, as well as adding both the .asi and .ini file into the main directory for the game. Unfortunately, the problem still remains with the mouse in that I cannot use it at all in game.

The Nvidia splash screen is also still appearing which is making me think that the loader isn't loading up the patch properly.

 

Any help on this would be greatly appreciated.

 

 

Have you downgraded your game to 1.0 ? 

Link to comment
Share on other sites

hello i have an issue with the silent patch for san andreas

my sa is modded and i have this problem that makes artict 1 2 and 3 with double rear wheels

i need to know how to deactivate this}

 

Link to comment
Share on other sites

5 minutes ago, Saad31 said:

I hope you are getting ready for the remasters.

 

And get sued for unauthorized modding of such?

  • Like 8
Link to comment
Share on other sites

I highly doubt that he'll touch the remasters. Probably it would be in hot territory just like doing mods for GTA V. Also, inb4 the remasters features the same bugs from the original games.

EDIT: Ninja'd

Edited by mourthss
Link to comment
Share on other sites

16 minutes ago, Saad31 said:

I hope you are getting ready for the remasters.

Rockstar/Take-Two are going hard on people improving their games, it's best to not attempt it anymore and just hope Ruffian have fixed things.

  • Like 4
Link to comment
Share on other sites

On 10/3/2021 at 5:14 PM, Vulcade92 said:

There are 2 more PS2 cheats that were cut in the PC version:

- Hookers pay you

- Taxi features

I never really understood the purpose of these, why implement them as cheats too when they're supposed to be, and already exist as, side-mission rewards?

Link to comment
Share on other sites

The Lucky Mole
16 hours ago, H-G said:

I never really understood the purpose of these, why implement them as cheats too when they're supposed to be, and already exist as, side-mission rewards?

They are usable cheats on PS2 though...

Link to comment
Share on other sites

Aristotel2003
On 10/5/2021 at 11:27 PM, Silent said:

 

And get sued for unauthorized modding of such?

Exactly my concern about the DE editions, as if T2 didn't went loco enough. 

On 10/5/2021 at 11:39 PM, Ash_735 said:

Rockstar/Take-Two are going hard on people improving their games, it's best to not attempt it anymore and just hope Ruffian have fixed things.

Sad, man... very sad. 

Link to comment
Share on other sites

I already dowgraded form 1.01 to 1.0 using SADowngrade and put both the patch and the ASI loader files in the game directory, but when opening the game (the gta-sa.exe) file, it displays a message that says "you're using a 1.01 executable that is no longer supported by the patch" and that I should replace it with a 1.0 executable, despite the fact that I had already donwgraded it to 1.0 as stated.

Link to comment
Share on other sites

This message "can't" be wrong, so if it says so, then somehow you are still using 1.01, no doubts about that. Perhaps the downgrade failed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • 24 Users Currently Viewing
    1 member, 0 Anonymous, 23 Guests

    • MyLifer
×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.