Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Los Santos Tuners
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

      1. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

      1. GTANet 20th Anniversary
    2. Support

    3. Suggestions

SilentPatch


Silent
 Share

Recommended Posts

But everything is scripting fix. Only like

  • Some props in Malibu Club, Ocean View Hotel and Pole Position Club have been restored; more environment shows outside when player is in interior too (just like on PS2)

is not scripting and Dkluin should use, but it's Dkluin things not to include it!

HirLWl5.gif

Link to comment
Share on other sites

 

and instead ask the devs not to break any mod in existence.

b-b-but dkluin

 

But everything is scripting fix. Only like

  • Some props in Malibu Club, Ocean View Hotel and Pole Position Club have been restored; more environment shows outside when player is in interior too (just like on PS2)

is not scripting and Dkluin should use, but it's Dkluin things not to include it!

LEAVE @dkluin ALONE!!!

 

 

HJ2mE3C.jpg

 

 

Link to comment
Share on other sites

 

 

So silent patch for UG is already in development

Since when Underground is a NEW SEPARATE f*ckING GTA GAME?

Can your mind handle the fact Underground IS A SA MOD so you use SA mods with it just fine? Stop f*cking asking everyone to add Underground compatibility as if it was a new GTA and instead ask the devs not to break any mod in existence.

 

I think he wana say that can you combine all silent patches (III VC and SA ) into 1 Patch for UG Exactly
Link to comment
Share on other sites

 

 

 

So silent patch for UG is already in development

Since when Underground is a NEW SEPARATE f*ckING GTA GAME?

Can your mind handle the fact Underground IS A SA MOD so you use SA mods with it just fine? Stop f*cking asking everyone to add Underground compatibility as if it was a new GTA and instead ask the devs not to break any mod in existence.

 

I think he wana say that can you combine all silent patches (III VC and SA ) into 1 Patch for UG Exactly

 

 

--------

 

 

Can your mind handle the fact Underground IS A SA MOD SO YOU CAN USE SA MODS with it just fine?

 

 

CAN YOUR MIND HANDLE THE FACT UNDERGROUND IS A SA MOD

Edited by Ritorno
Link to comment
Share on other sites

The real question is whether it works with GTA United

It doesn't have San Andreas map so obviously it won't work! GTA games are defined by their maps of course! Who needs the game code when you have the map?

Edited by Blackbird88
Link to comment
Share on other sites

 

The real question is whether it works with GTA United

It doesn't have San Andreas map so obviously it won't work! GTA games are defined by their maps of course! Who needs the game code when you have the map?

 

This.

Link to comment
Share on other sites

The real question is whether it works with GTA United

 

Well, you can try. Other than your PC blowing up, and a black hole resulting from the explosion swallowing the entire galaxy, nothing can go wrong.

  • Like 3
Link to comment
Share on other sites

 

The real question is whether it works with GTA United

 

Well, you can try. Other than your PC blowing up, and a black hole resulting from the explosion swallowing the entire galaxy, nothing can go wrong.

 

It could be worse: imploding so the entire sun will get eaten and there's nothing that can save us from extinction.

Link to comment
Share on other sites

Try THIS? Should work with XP fine again.

Sorry for the late reply, but thanks, it works again.

I saw in the GTAGarage comments that I wasn't the only one with the game crashing bug, you should check into that.

 

Link to comment
Share on other sites

 

Try THIS? Should work with XP fine again.

Sorry for the late reply, but thanks, it works again.

 

I saw in the GTAGarage comments that I wasn't the only one with the game crashing bug, you should check into that.

 

 

Well you're running XP, and as we all know XP is officially unsupported by microsoft, so it seems like it's more of their problem then ours.

  • Like 1
Link to comment
Share on other sites

 

VERY anticipated things to come soon... :whistle::whistle::whistle: Joint forces of aap and Silent proudly present the fix.

Edited by Silent
Link to comment
Share on other sites

rip half peds and peds causing arfifacts, never forget, xoxo

 

eZejG3Gl.jpg

gl1clTtl.jpg

Link to comment
Share on other sites

The way this bug happens is this (some basics first):

In RW there is an RtAnimAnimation, which holds the raw keyframes of an animation. To play an animation, an RtAnimAnimation is given to an RtAnimInterpolator which then interpolates the keyframes into interpolation frames which are then used to animate e.g. a hierarchy by generating matrices from them.

But R* hasn't really used RW's animation system since III. In III and VC R* wrote their own interpolated animation data into a dummy RtAnimAnimation and practically didn't use the RtAnimInterpolator. In SA they went a step further and now write into the interpolation frames of the RtAnimInterpolator instead, almost completely avoid RtAnimAnimation. Almost! They're still attaching an RtAnimAnimation to an RtAnimInterpolator and this is where stuff breaks:

 

RW expects an interpolation frame to start with this:

 

struct RtAnimInterpFrameHeader{    RtAnimKeyFrameHeader    *keyFrame1;    RtAnimKeyFrameHeader    *keyFrame2;};
And the standard HAnim interpolation frames conform to this:

 

struct RpHAnimInterpFrame{    RpHAnimKeyFrame    *keyFrame1;    RpHAnimKeyFrame    *keyFrame2;    RtQuat              q;    RwV3d               t;};
R* however thought they could get away with optimizing this struct

since they don't use RW's interpolation functions:

 

struct GTAHAnimInterpFrame{    RtQuat              q;    RwV3d               t;};
But RtAnimInterpolatorSetCurrentAnim still expects the two key frame pointers and writes to where they should be, actually writing into the quaternion rotation thereby wrecking it. Some nodes apparently never update this field, consequently may generate botched matrices and propagate them down the hierarchy.

 

As to why this only happens with high memory usage: Low addresses are still close to 0.0 and don't produce very broken matrices, as more memory is allocated the addresses get higher and...unreasonably wrong.

Edited by The Hero
Link to comment
Share on other sites

Link to comment
Share on other sites

qIVzgZB.jpg

 

HOLY FLYING SH*T ON FIRE!!! :panic:

 

This can't be real, I must have entered an alternate universe or something.

 

The most cancerous bug in the entire universe was finally fixed, seriously aap and Silent thank you SO MUCH for this you guys are GODS!

jYzLR2j.png

Link to comment
Share on other sites

When I grow up I wanna be just like Silent and Aap :V /s

Despite the joke I'd really like to know how to do these things...

 

 

 

Seriously though, you guys are awesome, wonderful job fixing this bug :D.

Edited by BlackScout
Link to comment
Share on other sites

I never had this bug ( seems like it never happens in unmodded game ), but I love the feeling of massive bugfix ))

  • Like 2
Link to comment
Share on other sites

I never had this bug ( seems like it never happens in unmodded game ), but I love the feeling of massive bugfix ))

Technically it does - but the side effects are not visible.

 

 

EDIT:

Since almost nothing else was done for r27 yet, the fixes which were to appear in this release will appear in r28... I guess it makes sense to delay them instead of delaying the relase since this fix could be considered a milestone...

Edited by Silent
Link to comment
Share on other sites

I guess it makes sense to delay them instead of delaying the relase since this fix could be considered a milestone...

Not just a milestone easily the biggest milestone in SA modding history since 2005. :lol:

  • Like 1

jYzLR2j.png

Link to comment
Share on other sites

rip half peds and peds causing arfifacts, never forget, xoxo

 

 

eZejG3Gl.jpg

gl1clTtl.jpg

 

 

Damn, mah cookie nigga plz I liked this sh*t a lot but now is in some polishedgerman way fixed. Please add a ini key for it, I like this bug a lot.

 

Just kidding, great news for those who went crazy with this thing, I never had this bug/stream problem on my game also.

Edited by Inadequate
  • Like 1
Link to comment
Share on other sites

It looks far better now than my last attempt at tackling this bug:

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • 16 Users Currently Viewing
    0 members, 0 Anonymous, 16 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.