Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
      4. Frontier Pursuits
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Diamond Casino & Resort
      2. DLC
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA 6

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA IV Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA SA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA VC Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA III Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Dutchy3010

Bug Report Topic V8

Recommended Posts

PatrickW

Are you sure the am.mp3 file is a valid mp3-format?

You can play it in your regular music application ?

Share this post


Link to post
Share on other sites
PatrickW

 

 

 

 

When I'm doing a mission, add an actor to the vehicle as a drive-by but if I do the actor does not handle driving up car or not.

I don't know what you're talking about. Is it about the driver actor not driving when you set the player to drive by ?

 

Exactly! And sometimes the game is closed.

 

I haven't run into any trouble like that, I just created this little test-mission:

http://dyom.gtagames.nl/show/29990

 

Does that work for you?

Can you send a link to a mission that has the problem you describe ?

Share this post


Link to post
Share on other sites
danleon95

Are you sure the am.mp3 file is a valid mp3-format?

You can play it in your regular music application ?

 

Of course it is,i played it twice before moving it into the folder.

Share this post


Link to post
Share on other sites
PatrickW

 

Are you sure the am.mp3 file is a valid mp3-format?

You can play it in your regular music application ?

 

Of course it is,i played it twice before moving it into the folder.

 

Can you send me a link to the mp3 file, so i can test it on my system ?

Share this post


Link to post
Share on other sites
SatournFan

I don't know if it has been reported already or not, but I have an interesting find:

 

So I've downloaded The Flats Chapter 2 and, knowing about the unstability of Storyline Mode (the crashes in missions themselves and in between them, in free roam), decided to load them manually from DSL folder and play one-by-one. However, when I have tried to play the mission with the beginning inside some interior (the 0 objective was in interior is what I mean), the minimap disappeared as soon as the mission went outside of interiors. This occured to me on several tries, because I first thought it's just a one-time glitch. But when I loaded and played mission with the beginning outside the interior, the minimap didn't disappear.

 

So, long story short, if I try to manually load and play mission from DSL folder and the 0 objective is placed inside an interior, the minimap disappears as soon as the mission goes outside of interior. It really annoyed me, and the only thing that helped me to return minimap is to teleport outside of interior before starting the mission.

May I repost the bug I've experienced, because I think it was left out.

Share this post


Link to post
Share on other sites
ShadowCoderKing

@lance1234ize: I will look into it and get back to you soon:

 

@spidermight: That is in fact intended functionality: while you're driving in a objective car and there are multiple checkpoints in a row, then the location of the next two checkpoints are shown on the radar. To facilitate original SA-like races. If you don't want it in your situation, you can prevent it by simply inserting another objective in between the two checkpoints, for example a 0 second timeout.

 

@lance1234ize: I will look into it and get back to you soon:

 

@spidermight: That is in fact intended functionality: while you're driving in a objective car and there are multiple checkpoints in a row, then the location of the next two checkpoints are shown on the radar. To facilitate original SA-like races. If you don't want it in your situation, you can prevent it by simply inserting another objective in between the two checkpoints, for example a 0 second timeout.

i put a 0 second timeout between them and it still shows both markers

Share this post


Link to post
Share on other sites
Jimmy_Leppard

I don't know if this is the bug in 8.1 only for me or for everyone, but the animations from 122 to 128 don't work. It doesn't show which animation it is and when I spawn an actor with that animation, he just stands there.

Share this post


Link to post
Share on other sites
Illusive Prime

@Jimmy_Leppard There is I think. While scrolling through the animation list it's a face movement rather then a body animation, but the face is screwed up when ever the animation is selected.

 

I've tested animation 128 and it works for me, it's were the Actor/Player sits down and bangs on the computer desktop animation.

Share this post


Link to post
Share on other sites
lance1234ize

@lance1234ize: I've been able to reproduce the issue, there is a problem with the "route" of one of the three actors that should spawn at the time of the crash. (it's the only one with a "walk" animation)

I've fixed it for you: https://dl.dropboxusercontent.com/u/10716357/DYOM7.dat

 

The problem was probably caused by a bug in editing an actor and giving it a walk animation where it didn't have an animation before.

Do you remember to have given the walk anim to the actor in an "edit actor" action.

We will try to fix this issue.

 

 

There has also been a bug-report by "illusive Prime" in PM, that has been confirmed, and for which we need to test a solution. Hopefully we can patch them both with another bugfix release.

This issue concerns returning control to the player after a "drive" player animation, in combination with some specific route-point placements.

Thank you for the fast reply :) I do not remember giving the actor a walk animation in "edit actor" but neither do I remember not doing it, so I might as well have.

Edited by lance1234ize

Share this post


Link to post
Share on other sites
danleon95

 

 

Are you sure the am.mp3 file is a valid mp3-format?

You can play it in your regular music application ?

Of course it is,i played it twice before moving it into the folder.

 

Can you send me a link to the mp3 file, so i can test it on my system ?

 

Don't worry,i solved it already!!

I was actually testing the mission settings like the weather and starting hour,but i had no objectives or objects created...the only thing defined on the map was the player...

When adding the first objective DYOM was able to run on all it's glory...I guess that the "mission completed" sound being the first thing that plays when launched causes the crash.

 

Anyway:

THANK YOU VERY MUCH!

You provide an excellent support and incredibly quick responses!

Edited by danleon95

Share this post


Link to post
Share on other sites
PatrickW

@Satournfan: It was left out because we haven't found a solution for it. It is on our list, but thanks for reminding :)

@spidermight: I'll look into it, will come back to you on this one.

@Jimmy_Leppard: Most of them are "facial animation": happy, curious, scared, talking, chewing gum. Especially useful in close-ups of actors. They might not be all that obvious on all actors (depending on their model), but I've tested quite a few actors on which they are very obvious. (CJ being one of them)

@danleon95: Glad it's solved for you. We will look into it, to try to prevent the crash, when no objective is created yet, but an am.mp3 file is present.

 

Thanks for all the feedback, this surely helps to get DYOM more stable :)

Share this post


Link to post
Share on other sites
Jimmy_Leppard

I've came across another issue which I don't know if it's really a bug, it could be, but.. The actors and even the player (when given the player animation to perform driving sequences during the cutscene) don't follow the route so much. The route following was actually perfect in version 7 and even beta 8, but now, almost always, actors seem to turn right or left at the beginning of the route and go somewhere, they don't follow the route even if the route points are close to each other, some enemy actors won't even follow where the player is going if given an ''attack player'' function. That happens especially on the grounds outside of roads (for example Los Santos land and woods area, even the Willowfield canal (that huge canal under Grove Street).

 

EDIT: add - I tested the routes by playing some of the missions made with previous versions of DYOM to see if DYOM V8.1 maybe messes up them aswell, but those routes are fine. So, only routes given with V8.1 are messing up for some reason.

Edited by Jimmy_Leppard

Share this post


Link to post
Share on other sites
PatrickW

That sure sounds like a bug to me. Although it might have been caused by the same issue that caused trouble for lance1234ize.

We've got a solution for that one, so i will send you a test version, to verify if it also solves your issue.

 

If not, can you please upload a mission that shows the problem, so that we can analyse it.

Share this post


Link to post
Share on other sites
kk.

It's a minor bug, but anyway. When I select brass knuckels as a weapon for actor and then select fists, actor is still holding brass knuckels. But when playing the mission, he doesn't have them, so whatever.

Share this post


Link to post
Share on other sites
Jimmy_Leppard

That sure sounds like a bug to me. Although it might have been caused by the same issue that caused trouble for lance1234ize.

We've got a solution for that one, so i will send you a test version, to verify if it also solves your issue.

 

If not, can you please upload a mission that shows the problem, so that we can analyse it.

Unfortunately, it still doesn't work. I sent you the test mission I made again in the inbox.

Share this post


Link to post
Share on other sites
The Odyssey

It's a minor bug, but anyway. When I select brass knuckels as a weapon for actor and then select fists, actor is still holding brass knuckels. But when playing the mission, he doesn't have them, so whatever.

That's been happening to me ever since I discovered the mod when it was v6. Also happens with animations, when you select a worded animation (Walk, sit in car) after going past animation 1, he will still be doing animation 1 when browsing. The animation you select will work when playing the mission though.

Edited by The Odyssey

Share this post


Link to post
Share on other sites
Jimmy_Leppard

Blending in cutscene and gameplay doesn't work anymore either. I just tested that. When you have a player near a car and then put the objective ''Player animation'' > Sit in nearest car, then set the route > Cutscene (any kind) - Skip fading and skip widescreen > checkpoint objective, after the cutscene is done, the player gets stopped in a place even though in the cutscene he was driving at high speed. In 8.0, you'd just blend in the cutscene where you'd see a player drive a car, then when the cutscene was over, you could've just continued driving. In 8.1, after the cutscene is done, no matter how fast you go or what you drive, DYOM stops the player from moving and then you have to start driving again.

Edited by Jimmy_Leppard

Share this post


Link to post
Share on other sites
lance1234ize

Okay so here is another bug:

 

So I got a friend to test the missions of the first chapter of my storyline (it is only a beta version so far) when I test the storyline there was no problem. My friend starts up the storyline, no problems this far, he plays through the intro mission, he passes it. He walks into the the first mission marker, and it crashes.

 

The first mission (after the intro mission) starts with a cutscene with a dynamic soundtrack in the background, it has about 10-15 characters and 36 objectives. I will have the mission file downloadable, though it is only available for DSL, as my other missions for the storyline has overdated it.

 

Mission file: http://www.myupload.dk/showfile/c4drzt.Welcome

 

Let me know if you need the whole storyline, and I'll send it via PM.

Share this post


Link to post
Share on other sites
PatrickW

 

@lance1234ize: I will look into it and get back to you soon:

 

@spidermight: That is in fact intended functionality: while you're driving in a objective car and there are multiple checkpoints in a row, then the location of the next two checkpoints are shown on the radar. To facilitate original SA-like races. If you don't want it in your situation, you can prevent it by simply inserting another objective in between the two checkpoints, for example a 0 second timeout.

 

@lance1234ize: I will look into it and get back to you soon:

 

@spidermight: That is in fact intended functionality: while you're driving in a objective car and there are multiple checkpoints in a row, then the location of the next two checkpoints are shown on the radar. To facilitate original SA-like races. If you don't want it in your situation, you can prevent it by simply inserting another objective in between the two checkpoints, for example a 0 second timeout.

i put a 0 second timeout between them and it still shows both markers

 

Can you upload the mission to the site, so we can check. It really shouldn't show both checkpoints if there is a timeout in between them.

 

@lance1234ize: we look into it.

Share this post


Link to post
Share on other sites
ShadowCoderKing

i dont have the editable file anymore but i did upload the readonly mission without the timeout between checkpoints because i didnt think it would matter because it didnt work for me

anyway here it is:

http://dyom.gtagames.nl/show/29978

Share this post


Link to post
Share on other sites
omgkillitanddie

I had this annoying bugs IN DYOM V8.1 when i wanted to go pass though the checkpoint, when i reach the checkpoint, it does not unlock the next objective. here the link to the save file

 

http://dyom.gtagames.nl/show/30054

Edited by omgkillitanddie

Share this post


Link to post
Share on other sites
xweert123

Every past version of DYOM works fine, I have a clean install of GTA SA, but when I use CLEO 4 and DYOM v 8.1, the game crashes whenever I start a new mission, or when I go to give the player or an actor a weapon, I press shift to accept and it instantly crashes as soon as I edit ammo.. Come to think of it, any time I go to type something in.. :<

 

 

-EDIT-

 

I found the problem. Version 8 of DYOM does NOT work with GTA_SA Version 1.0, only GTA_SA Version 1.1.

 

But now we're faced with a new problem.

 

The text bar gets filled with '12345678901234567890123456789012345678901234567890' and on-and-on.

 

Damn, I was really looking forward to this.

Edited by xweert123

Share this post


Link to post
Share on other sites
MissionDesignerLazeR

I don't know if this is a bug or not. But whenever the player drives to a checkpoint, and after the checkpoint I set a ''Player Teleport Objective''. When I play it, I'm randomly dead, and teleports me to the nearest hospital.

Share this post


Link to post
Share on other sites
SatournFan

I don't know if this is a bug or not. But whenever the player drives to a checkpoint, and after the checkpoint I set a ''Player Teleport Objective''. When I play it, I'm randomly dead, and teleports me to the nearest hospital.

This happens if you hide the car player is driving right after he reaches the checkpoint. It's not a bug, the game just thinks the player dies when this happens, that's why you appear near the hospital.

Share this post


Link to post
Share on other sites
omgkillitanddie

I have this bug where after i kill a random enemy actor the mission will fail. i did not set the enemy to must survive. And my friend did not died

Edited by omgkillitanddie

Share this post


Link to post
Share on other sites
Chips237

The still unfixed invisible checkpoints glitch and the hovering cars glitch.

Share this post


Link to post
Share on other sites
KD himan

Hello everyone.this is my first Bug report in DYOM. is it me or i can't use the ''player animation'' feature? this feature doesnt works for me, when i add an player animation objective, then play the game, the objective does not work and skip it. what i am doing wrong here? or can you tell me how to make it work perfectly?

Share this post


Link to post
Share on other sites
Wolf247

No mission works for me, I can't load any mission at all!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.