Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. The Criminal Enterprises
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. Grand Theft Auto Series

      1. Bugs*
      2. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Classic GTA SA
      2. Guides & Strategies
      3. Help & Support
    6. GTA Vice City

      1. Classic GTA VC
      2. Guides & Strategies
      3. Help & Support
    7. GTA III

      1. Classic GTA III
      2. Guides & Strategies
      3. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

    2. Support

    3. Suggestions

Bug Report Topic V8


Dutchy3010
 Share

Recommended Posts

All are invisible, even the 3 closest to your current position ?

bS8xA.png
Link to comment
Share on other sites

All are invisible, even the 3 closest to your current position ?

All are. Always happens to me too

Link to comment
Share on other sites

 

All are invisible, even the 3 closest to your current position ?

All are. Always happens to me too

 

 

Yep, I agree with him, after reaching like 15 or 10 checkpoints or putting more than 20 or 30 actors, the checkpoints become invisible.

But you can make them visible using a cutscene, just select a cutscene and then cancel it, the checkpoint will appear :D

Link to comment
Share on other sites

I've been looking into the disappearing checkpoint Issue, and we seem to be running into a limitation of the engine there.

As far as I've been able to figure out, Sphere's are no longer able to being displayed by the engine after a certain number of "markers" have been created.

"Markers" are the cones displayed at the location of an objective at designtime, which are also causing the objectives to show up on the radar.

 

I'm not sure what the exact limit is, it might be system (or executable) dependent. On my system, spheres stop displaying when there are over 32 markers spawned.

 

At this point we have no fix for this issue. It's even unsure if we will be able to find a workable fix, but we will research further into this.

bS8xA.png
Link to comment
Share on other sites

@PatrickW I hear there is a mod called SA Limit Adjuster.

You heard right :^: , but this is not one of the limits that can be adjusted by that tool, as far as I know.

bS8xA.png
Link to comment
Share on other sites

DYOM crashes when I give guns to 'actors'.

 

I create an actor, choose the character, choose the weapon, but as soon as I hit 'enter', the game freezes for a sec, and then crashes. I have CLEO4 and no mods.

 

Help!

 

Update: It happens only with ranged weapons. I've switched back to DYOM7 and the problem's still there, maybe it's CLEO? If so, can anyone tell me how to solve this? Thanks!

 

Update 2: Problem solved by downloading gta_sa.exe american. Nevermind! :)

Edited by gheorgheM
Link to comment
Share on other sites

We're working on it;so somewhere in the coming days.

bS8xA.png
Link to comment
Share on other sites

Illusive Prime

@PatrickW That's great, did you get my video of bugs I made?

 

There is also a glitch which is really annoying me, I made a mission were you have to provide support for Sweet, and later have to escape enemies, I made a cutescene with the Player auto-driving the route I set, when that is completed I can't have manual control of the vehicle, I have to get out and get in to drive by my self.

 

I think I have a video of that on my YouTube channel.

Link to comment
Share on other sites

Yes I saw that video.

The issue you describe is one of the things that is fixed in the coming version

bS8xA.png
Link to comment
Share on other sites

Jimmy_Leppard

I don't know if this is a bug or just my PC, but when I have multiple actors and cars in a place, objective triggering becomes a pain in the ass. I can't trigger the checkpoints unless I go really slowly through them.. And to be honest, the mission requires you to go fast. Patrick or Dutchy, do you know what might be the problem?

Link to comment
Share on other sites

I don't know if this is a bug or just my PC, but when I have multiple actors and cars in a place, objective triggering becomes a pain in the ass. I can't trigger the checkpoints unless I go really slowly through them.. And to be honest, the mission requires you to go fast. Patrick or Dutchy, do you know what might be the problem?

 

Hey, im not patrick or dutch but.. Try to change the size of the objectives, make them as big as possible. :p If it doenst work with the big arrows, try using the cilinder objectives but invisible and that can be showed in the map

Link to comment
Share on other sites

Jimmy_Leppard

 

I don't know if this is a bug or just my PC, but when I have multiple actors and cars in a place, objective triggering becomes a pain in the ass. I can't trigger the checkpoints unless I go really slowly through them.. And to be honest, the mission requires you to go fast. Patrick or Dutchy, do you know what might be the problem?

 

Hey, im not patrick or dutch but.. Try to change the size of the objectives, make them as big as possible. :p If it doenst work with the big arrows, try using the cilinder objectives but invisible and that can be showed in the map

 

Well, I hear what you're saying and I understand your strategy, but you see, the problem is that the bigger/wider the objectives, it's actually even harder to trigger them. I tried to set them small, big, nothing works.. Sometimes even I have to stand in an objective for about a second to trigger it.. I don't know why that happens. I tried with different types of checkpoint objectives and it's the same thing with all of them.

Link to comment
Share on other sites

I had that problem few years ago on my old PC. After that, it never happened again, so it might depends of your PC, but i not sure, it could be a bug.

Link to comment
Share on other sites

Jimmy_Leppard

I had that problem few years ago on my old PC. After that, it never happened again, so it might depends of your PC, but i not sure, it could be a bug.

I actually tried to test it and it might be a bug. I just loaded one of my previously made missions from V7 and played them. In that missions, I can go through a checkpoint as fast as I want to and it triggers it perfectly. So, I guess it's not my PC's problem since just this testing mission I'm working on is having problems with triggering the checkpoints. I'll see what Patrick and Dutchy say.

Link to comment
Share on other sites

Puzzling. .. This fact that your old V7 mission has no problem with the checkpoints, and your new mission does It points in the direction of other stuff you got in your mission, since there is not a single difference between how this version handles checkpoints created with 7.0 and checkpoints created with 8.0. DYOM doesn't even see any difference.

One of the things that comes to mind that might be of influence on this, is the number of actors/cars/objects in your mission. Especially Actors/cars with "must-live".

Could you send me the missionfile that gives you these troubles, and indicate with which checkpoints you experience this slow reaction time.

We're constantly trying to optimize the speed of DYOM, so that it is as responsive as possible.

bS8xA.png
Link to comment
Share on other sites

DragonWarrior (DnW)

Hi guys, when I'm typing text in DYOM v8 it crash with a "gta_sa.exe stopped working" error. It happens when I type text for Cutscense, Mission name, Mission Designer etc.

 

I've installed the latest Cleo4 stable autoinstaller. Gta Sa v1.0. I've no other cleo mods or other mods installed except for some 2 or 3 vehicle and a new weapon pack (not cleo mods).

 

DYOM v7.2 worked fine.

 

Edit: I downloaded GTA SA HOODLUM and now the text problem is ok. What was the problem with my old one?

Edited by DragonWarrior (DnW)
Link to comment
Share on other sites

Jimmy_Leppard

Puzzling. .. This fact that your old V7 mission has no problem with the checkpoints, and your new mission does It points in the direction of other stuff you got in your mission, since there is not a single difference between how this version handles checkpoints created with 7.0 and checkpoints created with 8.0. DYOM doesn't even see any difference.

One of the things that comes to mind that might be of influence on this, is the number of actors/cars/objects in your mission. Especially Actors/cars with "must-live".

Could you send me the missionfile that gives you these troubles, and indicate with which checkpoints you experience this slow reaction time.

We're constantly trying to optimize the speed of DYOM, so that it is as responsive as possible.

Oh, well, you might be right if that's the case. I have 5 actors that are enabled ''must survive''. I also have around 5 cars in that same area. Well, I'll send it to you in your inbox.

Link to comment
Share on other sites

Thank, I had a look at your mission, and you did indeed have 6 mustlive-actors and 6 mustlive-cars, that are "alive" during the checkpoints section.

This caused additional processing that resulted in the slow response. I've send you a test-build in PM that should have the issue solved.

bS8xA.png
Link to comment
Share on other sites

When I'm doing a mission, add an actor to the vehicle as a drive-by but if I do the actor does not handle driving up car or not.

Link to comment
Share on other sites

When I'm doing a mission, add an actor to the vehicle as a drive-by but if I do the actor does not handle driving up car or not.

 

I don't know what you're talking about. Is it about the driver actor not driving when you set the player to drive by ?

Link to comment
Share on other sites

 

When I'm doing a mission, add an actor to the vehicle as a drive-by but if I do the actor does not handle driving up car or not.

 

I don't know what you're talking about. Is it about the driver actor not driving when you set the player to drive by ?

 

Exactly! And sometimes the game is closed.

Link to comment
Share on other sites

Illusive Prime

How soon Is the next bug

fix? I can't wait!

 

There is a mission I made during the beta period that has a bug that needs fixing so I can't really finish it without a fix.

Link to comment
Share on other sites

We're putting it out, when we're satisfied with it's stability.

bS8xA.png
Link to comment
Share on other sites

I have created a mission that firstly worked out pretty well, no bugs and no issues, but today when I tested the mission again, it crashed when I reached my first checkpoint. I have filmed the issue, and I'll send you the DSL file as well.

 

Dyom crash video:

 

Download file:

http://www.myupload.dk/showfile/c4e2i8.Partners

Edited by lance1234ize
Link to comment
Share on other sites

ShadowCoderKing

hi i dont know if this has been reported yet but im having two red markers pop up on the radar from two different checkpoints at the same time, very annoying that it wont go away no matter what i do

 

video of error: http://www.youtube.com/watch?v=tsesFs7WaVY

 

when i get on the motorbike then the error shows

Edited by spidermight
Link to comment
Share on other sites

@lance1234ize: I will look into it and get back to you soon:

 

@spidermight: That is in fact intended functionality: while you're driving in a objective car and there are multiple checkpoints in a row, then the location of the next two checkpoints are shown on the radar. To facilitate original SA-like races. If you don't want it in your situation, you can prevent it by simply inserting another objective in between the two checkpoints, for example a 0 second timeout.

bS8xA.png
Link to comment
Share on other sites

@lance1234ize: I've been able to reproduce the issue, there is a problem with the "route" of one of the three actors that should spawn at the time of the crash. (it's the only one with a "walk" animation)

I've fixed it for you: https://dl.dropboxusercontent.com/u/10716357/DYOM7.dat

 

The problem was probably caused by a bug in editing an actor and giving it a walk animation where it didn't have an animation before.

Do you remember to have given the walk anim to the actor in an "edit actor" action.

We will try to fix this issue.

 

 

There has also been a bug-report by "illusive Prime" in PM, that has been confirmed, and for which we need to test a solution. Hopefully we can patch them both with another bugfix release.

This issue concerns returning control to the player after a "drive" player animation, in combination with some specific route-point placements.

  • Like 1
bS8xA.png
Link to comment
Share on other sites

Im having a problem when adding ambient sound to my first mission.
When the folder exist with the am file in it,as soon as i play the mission,gta_sa.exe crashes.
When the folder is deleted,the mission is normally playable...is this some kind of bug or am i doing something wrong?
The file isn't longer than 3 minutes

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.