Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    2. News

    1. Red Dead Redemption 2

      1. News
      2. Red Dead Online
    1. GTA Online

      1. After Hours
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Dutchy3010

Bug Report Topic V8

Recommended Posts

Dutchy3010

I deleted the MPACK folder and replaced it with the beta one and got this nice message. Any advice?

Can you post a screenshot of your MPACK folder (with the "address" visible)?

Share this post


Link to post
Share on other sites
Jimmy_Leppard

I came across something and I hope this is a bug and not something that you did on purpose..

 

So, it's about cutscenes. I noticed that in this version the dialogue disappears right before the cutscene switches to the next one regardless of the cutscene lasting. In the previous versions, cutscene dialogue disappeared after 5-6 seconds of showing (if you know what I mean) and then disappeared from the cutscene completely. If a cutscene had a dialogue and was from 2-4 seconds long, the dialogues just switched, there wasn't that ''empty'' space between cutscene changing. In this version, even if the cutscene has dialogue and is less than 4 seconds long, the dialogue disappears right before the next cutscene kicks in which is a bad thing (at least for me). I tend to have double cutscenes sometimes like a movie where I have the same dialogue in 2 or 3 cutscenes in a row, but different look/different positions of the cutscene and it worked perfectly in the previous versions as when the dialogue was the same, it seemed like only the cutscene positions were changing and the dialogue just stayed there for a player to read. In this version, I get consecutive stops between cutscenes where the dialogue disappears and it looks dumb. Like, I have 2 cutscenes which say ''April 25th'' and the first cutscene has a view of a person, the next one a view of a building, but that ''April 25th'' is present in both cutscenes, but after the first cutscene ends and wants to switch to the next cutscene (which is a view of a building), the dialogue disappears for a split second and then comes back again when the second cutscene appears. Now there is no ability for having double cutscenes since the dialogue keeps disappearing and coming back as the cutscenes change.

 

EDIT: Possible bug number 2:

When choosing the ''Actor 3rd person'' view in the cutscene and making the actor walk on a certain route, the map appears in the bottom left corner as well as the health bar and money status in the upper right corner just like as it was a single player. I don't know if that is a bug or it just needs to be that way, but still.. In your picture of Actor 3rd person there is no map anything else showing :)

Edited by Jimmy_Leppard

Share this post


Link to post
Share on other sites
Kwabs

@Dutchy Here's a pic of the folder. It doesn't work when I try to load this.

 

XzSVbZul.png

 

But I downloaded it again, and everything seems to work now. So perhaps it was just a corrupt download.

 

 

EDIT: Possible bug number 2:

When choosing the ''Actor 3rd person'' view in the cutscene and making the actor walk on a certain route, the map appears in the bottom left corner as well as the health bar and money status in the upper right corner just like as it was a single player. I don't know if that is a bug or it just needs to be that way, but still.. In your picture of Actor 3rd person there is no map anything else showing :)

Probably because the screen was taken inside an interior.

Share this post


Link to post
Share on other sites
Jimmy_Leppard

 

EDIT: Possible bug number 2:
When choosing the ''Actor 3rd person'' view in the cutscene and making the actor walk on a certain route, the map appears in the bottom left corner as well as the health bar and money status in the upper right corner just like as it was a single player. I don't know if that is a bug or it just needs to be that way, but still.. In your picture of Actor 3rd person there is no map anything else showing :)


Probably because the screen was taken inside an interior.

 

EDIT: So the map will be shown if the Actor 3rd person cutscene is placed in an exterior?

Edited by Jimmy_Leppard

Share this post


Link to post
Share on other sites
Kwabs

nvm

Edited by Stromae

Share this post


Link to post
Share on other sites
Jimmy_Leppard

I came across something and I hope this is a bug and not something that you did on purpose..

 

So, it's about cutscenes. I noticed that in this version the dialogue disappears right before the cutscene switches to the next one regardless of the cutscene lasting. In the previous versions, cutscene dialogue disappeared after 5-6 seconds of showing (if you know what I mean) and then disappeared from the cutscene completely. If a cutscene had a dialogue and was from 2-4 seconds long, the dialogues just switched, there wasn't that ''empty'' space between cutscene changing. In this version, even if the cutscene has dialogue and is less than 4 seconds long, the dialogue disappears right before the next cutscene kicks in which is a bad thing (at least for me). I tend to have double cutscenes sometimes like a movie where I have the same dialogue in 2 or 3 cutscenes in a row, but different look/different positions of the cutscene and it worked perfectly in the previous versions as when the dialogue was the same, it seemed like only the cutscene positions were changing and the dialogue just stayed there for a player to read. In this version, I get consecutive stops between cutscenes where the dialogue disappears and it looks dumb. Like, I have 2 cutscenes which say ''April 25th'' and the first cutscene has a view of a person, the next one a view of a building, but that ''April 25th'' is present in both cutscenes, but after the first cutscene ends and wants to switch to the next cutscene (which is a view of a building), the dialogue disappears for a split second and then comes back again when the second cutscene appears. Now there is no ability for having double cutscenes since the dialogue keeps disappearing and coming back as the cutscenes change.

 

EDIT: Possible bug number 2:

When choosing the ''Actor 3rd person'' view in the cutscene and making the actor walk on a certain route, the map appears in the bottom left corner as well as the health bar and money status in the upper right corner just like as it was a single player. I don't know if that is a bug or it just needs to be that way, but still.. In your picture of Actor 3rd person there is no map anything else showing :)

Also, just to add something else to these two problems. For some reason, ''Follow actor'' and ''Actor 1st and 3rd person'' cutscene options don't work if you put them after a smooth or linear cutscene. I don't know why. The objective is there, but it just gets over it like it isn't there.

Share this post


Link to post
Share on other sites
PatrickW

I came across something and I hope this is a bug and not something that you did on purpose..

 

So, it's about cutscenes. I noticed that in this version the dialogue disappears right before the cutscene switches to the next one regardless of the cutscene lasting. In the previous versions, cutscene dialogue disappeared after 5-6 seconds of showing (if you know what I mean) and then disappeared from the cutscene completely. If a cutscene had a dialogue and was from 2-4 seconds long, the dialogues just switched, there wasn't that ''empty'' space between cutscene changing. In this version, even if the cutscene has dialogue and is less than 4 seconds long, the dialogue disappears right before the next cutscene kicks in which is a bad thing (at least for me). I tend to have double cutscenes sometimes like a movie where I have the same dialogue in 2 or 3 cutscenes in a row, but different look/different positions of the cutscene and it worked perfectly in the previous versions as when the dialogue was the same, it seemed like only the cutscene positions were changing and the dialogue just stayed there for a player to read. In this version, I get consecutive stops between cutscenes where the dialogue disappears and it looks dumb. Like, I have 2 cutscenes which say ''April 25th'' and the first cutscene has a view of a person, the next one a view of a building, but that ''April 25th'' is present in both cutscenes, but after the first cutscene ends and wants to switch to the next cutscene (which is a view of a building), the dialogue disappears for a split second and then comes back again when the second cutscene appears. Now there is no ability for having double cutscenes since the dialogue keeps disappearing and coming back as the cutscenes change.

This was a deliberate change, but I clearly didn't oversee the consequences. During testing, we made some short cutscenes and noticed that the text was visible when the cutscene already ended. So I made a quick fix, but failed to realize the consequences as this "bug" has clearly been used by many to get the effect you describe. We'll revert that fix, to get back to the previous behaviour on this point.

 

EDIT: Possible bug number 2:

When choosing the ''Actor 3rd person'' view in the cutscene and making the actor walk on a certain route, the map appears in the bottom left corner as well as the health bar and money status in the upper right corner just like as it was a single player. I don't know if that is a bug or it just needs to be that way, but still.. In your picture of Actor 3rd person there is no map anything else showing :)

During cutscenes, the HUD should not be visible when using "widescreen". This used to be the standard, but now you can skip that. In that case, the HUD (map, weapons, money and stuff) will stay visible. You might have run into this, because the beta contain a (already solved) bug, that uses the properties setting of the previous cutscene by default, unless you change them explicitly.

 

Also, just to add something else to these two problems. For some reason, ''Follow actor'' and ''Actor 1st and 3rd person'' cutscene options don't work if you put them after a smooth or linear cutscene. I don't know why. The objective is there, but it just gets over it like it isn't there.

Good find!!! Confirmed and solved. We'll try to get a new beta version out shortly, with all the found issues solved.

Share this post


Link to post
Share on other sites
Mariojav97

Another bug I found is that when you put pickups in previous goals, and a future goal put "grab all similar pickups" pickups (similar) previously put on the counter still count even if you grabbed.

 

Sorry for my bad English.

Edited by Mariojav97

Share this post


Link to post
Share on other sites
PatrickW

Another bug I found is that when you put pickups in previous goals, and a future goal put "grab all similar pickups" pickups (similar) previously put on the counter still count even if you grabbed.

 

Sorry for my bad English.

 

Yes, but you should hide all "old" similar pickups, that you don't want to use, before adding the "grab all similar pickups"-objective.

The "grab all similar pickups"-objective is designed to require all spawned similar pickups that are not yet hidden.

Share this post


Link to post
Share on other sites
Doublepulse

So just got a good explanation on what the "Skipping Wide screen" option does.

The hud showing in a cutscene, is not a bug, but it is a feature for the "blend-in cutscenes"

If you select no on the "skip widescreen" option, you will see the cutscene normally with no hud.

If you select yes, the hud will show.

Now, some people may or may not have "widescreen on" in the advance graphic options. If you do, you will not see so much of a difference because the black bars are removed from the cutscenes. Only the hud will be present.

 

I hope that explains the situation well. :)

Share this post


Link to post
Share on other sites
SoftTouch

When the first cutscene starts you see the player for a second, then it fades and the cutscene starts. That's normal ?

Share this post


Link to post
Share on other sites
JoshDa1

I don't know if someone have told it. But, i just want to say i found a bug. It's a cutscene bug. After i made a cutscene, and i want to make another cutscene i can't make it. After i click ready there is no textbox at the top left corner including the cutscene objective icon. The option that i used is follow actor & 3rd person. Maybe it happen to all cutscene options or meaby not.

Share this post


Link to post
Share on other sites
Astrobix

Here we got another bug that i call: The Health bug.

 

It's simple, create the player and set his HP to 200... Then put a player objective > Teleport. Teleport the player and put 200 HP again.. Ta dah!! The player will appear with 150's HP bar but with a small extra life (because you set 200) that of course you can't see..

 

2db3vvk.png

 

91jext.png

Share this post


Link to post
Share on other sites
Dutchy3010

When the first cutscene starts you see the player for a second, then it fades and the cutscene starts. That's normal ?

We will look into that.

 

 

I don't know if someone have told it. But, i just want to say i found a bug. It's a cutscene bug. After i made a cutscene, and i want to make another cutscene i can't make it. After i click ready there is no textbox at the top left corner including the cutscene objective icon. The option that i used is follow actor & 3rd person. Maybe it happen to all cutscene options or meaby not.

Known issue, is already solved for the next beta.

 

 

Here we got another bug that i call: The Health bug.

 

It's simple, create the player and set his HP to 200... Then put a player objective > Teleport. Teleport the player and put 200 HP again.. Ta dah!! The player will appear with 150's HP bar but with a small extra life (because you set 200) that of course you can't see..

Good find, confirmed and solved.

Share this post


Link to post
Share on other sites
Astrobix

Well, there's something that as i can see it's only happening to me in MY dyom..

 

Well, i installed Dyom V8 perfectly with CLEO 4, but when i add a checkpoint and try to type something, the game crashes instantaneously :S anyone else having this problem?

 

EDIT: I discovered that is not only with creating an objective or sth.. I CAN'T TYPE ANYTHING IN ANY TEXTBOT!!!!! even to create a mission D:

 

nvm im an idiot..

 

 

_____________

 

Dyom developers.. Something that i was noticing.. Since you guys added the substract and add money stuff.. Why don't you add the same capacity of money in the storyline ? I mean for example since we have the "add money" in the v8 and it can give from $1 to $99,999,999, why don't you allow the same capacity in the Storyline mode after completing a mision? Because the capacity of mohey to get there is only $1 - $99,999

 

Oh and, will we be able to select more than 1 object to damage / shoot / photograph in the Alpha version of the V8? Just asking :p

Edited by Astrobix

Share this post


Link to post
Share on other sites
PatrickW

 

Dyom developers.. Something that i was noticing.. Since you guys added the substract and add money stuff.. Why don't you add the same capacity of money in the storyline ? I mean for example since we have the "add money" in the v8 and it can give from $1 to $99,999,999, why don't you allow the same capacity in the Storyline mode after completing a mision? Because the capacity of mohey to get there is only $1 - $99,999

 

Oh and, will we be able to select more than 1 object to damage / shoot / photograph in the Alpha version of the V8? Just asking :p

 

We'll increase the max amount for storyline mode, no problem :)

 

Multiple objects objective: Maybe in a future version, but unlikely in V8.0

Share this post


Link to post
Share on other sites
JoshDa1

I just found a bugs. It's all about "Leave nearest car" animation.

Bugs:

TEXT

  1. I make an actor with leave nearest car animation. I set the actor as driver, enemy, normal behaviour with a gun. Make the route then i start the mission. The bug is the actor leave the car but he doesn't attack me even i shoot him. He just stand like a statue. This bug is usually occur at the first time i make a new mission just after starting DYOM.
  2. I make an objective actor same us above with leave nearest car animation. I set the objective actor as driver, enemy, normal behaviour with a gun. Make the route then i start the mission. The difference with the bug above is the objective actor won't leave the car. He just sit in the car and doing nothing. If i force by take him out from his car he won't attack me too.

VIDEO

Edited by JoshDa1

Share this post


Link to post
Share on other sites
Gummy 

There's a problem when we try to make cutscenes with the Follow Actor options, when we make a cutscene with a follow actor option and make another cutscene which have different options sometimes it will just stay on the one with the follow actor one.

Share this post


Link to post
Share on other sites
PatrickW

@JoshDa1: Those are indeed known issues, that were already present in the previous version. We haven't been able to find a solution for them yet. Just don't count on "leave nearest car" actors to do anything worthwhile after they get out of the car.

 

@Prince Gumball: that is probably the same issue that has been reported before and that will be solved in the next beta.

Share this post


Link to post
Share on other sites
Astrobix

There's a bug that i just discovered a moment ago testing the storyline $ rewards.. Okay so i set the first storyline mission to give me 500,000$ of money reward. - Good.

 

But, when i did set the second one to give $1,000,000 money reward, it didn't give me 1m. It gave me a negative number. In fact, it substracted me money instead of giving me..

 

o6xlr4.jpg

Share this post


Link to post
Share on other sites
Dr. John

All right. I have been testing the beta 2 and seems to crash after a few moments. I am using CLEO 4 and clean GTA SA. It seems like the checkpoint objectives start to dissapear after putting 20 to 30 checkpoints. :/

 

Any solutions? I will try to reinstall as well.

Share this post


Link to post
Share on other sites
PatrickW

@astrobix:

Apparently the engine can't handle such big numbers when adding/subtracting money. I guess there was a good reason we limited the mission-reward amount to 99,999

To prevent issue we will revert the maximum mission-reward to 99.999, and will also set the max for adding/subtractng money objectives to that, as the same issue will undoubtedly be present there.

 

@Dr.John:

Just to clearify: Did it crash or did the checkpoints disappear? Or both ?

 

On a crash, without further info it's hard to judge/fix, so what did you do when s crashed, and what had you done before that (as much info as possible, please)

 

On disapearing checkpoints: You do know that in designmode only the 3 nearest checkpoint to the player are shown ? (that is a deliberate choice, to prevent limitations on the engine)

Share this post


Link to post
Share on other sites
Dr. John

No, no. It first crashed while testing a few objectives. The dissapearing checkpoints were present even before the crash.

 

It crashed while I was trying to set an Actor Objective. While scrolling, I got an error from windows and was sent out. It doesn't crash after I try to reload. It frequently happened afterwards, though.

 

As for the checkpoints, I know that we can only see three checkpoints near the player but I am talking about distant checkpoints (like one is in the Grove Street and the other in Los Santos Airport). It seems like repeated placing of checkpoints in different parts of the map causes some problems which doesn't make the checkpoint visible (only in design mode).

 

I am reinstalling the game and shall give my report again.

Share this post


Link to post
Share on other sites
TeMkA69

In the second version sometimes appear strange signs. Strange characters and squares ...

Share this post


Link to post
Share on other sites
Jimmy_Leppard

I have found a bug in beta 2.

 

So, I simply wanted to test the last new feature, which is player animation with a following cutscene. I read the note that the Player animation objective needs to be placed in front of the cutscene, so I did. Now, I set the player where he begins the mission, after that a checkpoint objective which he needs to walk into and then I set a Player animation and chose some animation and after that a static cutscene which was pointed towards the checkpoint (the place where the player stopped.) So, what happened is that after I walk into the checkpoint, a letter ''d'' appears for a brief second (before the player animation kicks in) and then disappears when the static cutscene begins. I tried to choose a different cutscene, so I chose the Follow player cutscene and I also tried to choose a different player animation. The letter ''d'' appears anyways in both of those situations as soon as player animation objective kicks in.

Share this post


Link to post
Share on other sites
MyxacH

shift + ~ and crashes

Share this post


Link to post
Share on other sites
Astrobix

@astrobix:

Apparently the engine can't handle such big numbers when adding/subtracting money. I guess there was a good reason we limited the mission-reward amount to 99,999

To prevent issue we will revert the maximum mission-reward to 99.999, and will also set the max for adding/subtractng money objectives to that, as the same issue will undoubtedly be present there.

 

Lol no, much before that i tested the add and substract money and it works perfectly. Even with bigger ammounts of THAN that. The system of Storyline money rewards starts to freak out when it has to give more than 1,000,000. So the limit favourable its 999,999 if you ask me..

Edited by Astrobix

Share this post


Link to post
Share on other sites
SoftTouch

You wierdly slow down when you enter a new objective.

Share this post


Link to post
Share on other sites
Dude1

I can't rotate the effect objects. Can you please fix that?

Share this post


Link to post
Share on other sites
PatrickW

Thanks for the reports.

But be sure to include as much details and info as possible.

If we can't figure out, how to reproduce the issue you report, we can't solve it.

 

 

@Jimmy_leppard:

Where exactly did the "d" appear ?

At the bottom of the screen, where normally the objective texts appear ?

Did you notice any of the objective texts you set, missing ?

Can you send me a mission file that contains this bug for you ? (sofar i'm unable to reproduce)

 

@SoftTouch:

Please try to give more information: Did this happen while designing or playing a mission ?

What objective did you enter?

What was the next objective?

Did it happen once or constantly ?

 

@MyxacH:

Did this happen once or costantly?

I assume this happened while you tried to enter an objective text?

What objetive was the text for?

How many text had you already typed in the input box when you type <ctrl+~> >

 

@TeMkA79:

Can you be a bit more specific about when this happens (what were you trying to do, detailed, please) and where on the screen do they appear?

 

@Dr.John13:

Exactly at what point does it crash, what were you trying to do, and what were you last actions.

Which objective(s) cause this ?

 

@dude1: Rotation is not supported for Effect Objects.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.