Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

stefan-west1

Taxi Bug will not go away!

Recommended Posts

stefan-west1

Hi everyone, I know this has been posted a lot but I have tried everything everybody has said to get rid of this bug. I am running gta IV 1.0.7.0 on windows 7, I have a lot of modded cars, I have traffic load and chikamru's real traffic installed, both are being started according to the asi log but I am still getting this god damn bug. How can I get rid of this? surely I must be doing something wrong!

Share this post


Link to post
Share on other sites
stefan-west1

anyone?

Share this post


Link to post
Share on other sites
Rocket7575

How big is your vehicles.img file?

Also what kind of video card, how much ram on card, and how much ram on system?

Share this post


Link to post
Share on other sites
stefan-west1

The vehicles.img file is 270MB

 

The video card is Nvidia GTX 680 with 2GB video RAM

 

The RAM on the system is 16GB

Edited by stefan-west1

Share this post


Link to post
Share on other sites
quechus13

Just don't get Vehicle Mods that are more than 1MB of size.

I have many mods of mine (which I created) and I don't get the Taxi Bug.

Share this post


Link to post
Share on other sites
stefan-west1

I do have a lot of car mods but surely my rig can handle that?

Share this post


Link to post
Share on other sites
quechus13

I do have a lot of car mods but surely my rig can handle that?

 

The thing is... GTA IV can't.

Share this post


Link to post
Share on other sites
Rocket7575

No your system should definitely not have the traffic bug. I am running Win 7 64bit, had the 660gtx with 2gb ram, 10gb system ram, and I don't have the bug.
My vehicles file is also 510mb. I just now got my evga step up 770gtx, but I haven't even installed it yet I literally just got at my door and brought it in.
-Also, I have every single car modded. The only stock IV vehicle is the trash truck (I even replaced AirTug with Grave Digger etc), every other car is downloaded, so you should not have the bug.

With your setup you want to make sure that you don't have cars over 8mb. The 1mb thing, that is not an issue trust me, I actually have 2 different GTA IV's because I've replaced the cars 2x over and have all different cars in both versions.

 

I'll post some things that will help here in a bit, just got off work and relaxing.

Edited by Rocket7575

Share this post


Link to post
Share on other sites
Rocket7575

There are many things that can start to help get rid of the traffic bug, and it can be caused by multiple things. I have replaced no joke over 500 vehicles in IV so I have figured out what kind of kicks it back into taxi bug mode.

 

1st-go into veh file and reduce amount of all taxi's to 1 for frequency, and 1 for amount to draw, this will reduce the amount they are drawn as much as possible.

2nd-go into Spark, organize by highest file size. Take anything over 7mb and edit it in the vehicle.ide again so that freq and amt are 1,1. Why? Because if your pc tried to draw too many of your highest quality cars, bam the traffic file crashes and it loads up police and taxi's instead.

3rd-check all your cars. Literally use trainer and go through each 1. If you find one that freezes spawning, write it down. If you frequently have issues making this car spawn, it especially needs to be at 1,1 as above (or very possibly needs to be deleted if frequently it will not spawn, it MUST be deleted or its guaranteed to F-it up. You can reduce the amount of times it tries to draw, but can't stop it completely 0,0 or u get errors). Why? Because if IV tries to load this car and it can't, you don't get the "unable to spawn" message, you get a traffic file crash. It may start up later again after driving around again, but this is linked to cars that have problems spawning.

-Also just for reference, I only use chikamru's real traffic, and my vehicle.img file is 510mb. I don't have the traffic bug, but it might kick back in if IV has a problem with one of my HQ cars spawning automatically as traffic. As I add new cars I have to make sure they spawn easy, if not then it's going to cause the traffic bug, it takes quite awhile to filter all the cars u have installed to find the exact problem, but when you find it/them, you will instantly see a change in the traffic mix.

Edited by Rocket7575

Share this post


Link to post
Share on other sites
jpm1

traffic in GTA is one of most ressource demanding thing that's why when you mod the game with ressource demanding mods one of the first things that is impacted it's the traffic . a bad traffic can be caused by heavy sized cars but also by high res environment textures or even a too demanding timecyc .. you should keep this in mind each time you mod the game . and this has definitly nothing to do with the hardware that happens because of GTA structure . so do not install above 4 Mo cars (except 2 or 3 that mean a lot for you) , and each time you install new stuff keep in mind that heavy sized stuff will demand higher ressources

Edited by jpm1

Share this post


Link to post
Share on other sites
unbid

traffic in GTA is one of most ressource demanding thing that's why when you mod the game with ressource demanding mods one of the first things that is impacted it's the traffic . a bad traffic can be caused by heavy sized cars but also by high res environment textures or even a too demanding timecyc .. you should keep this in mind each time you mod the game . and this has definitly nothing to do with the hardware that happens because of GTA structure . so do not install above 4 Mo cars (except 2 or 3 that mean a lot for you) , and each time you install new stuff keep in mind that heavy sized stuff will demand higher ressources

Anyway, just asking. Is the 4mb rule only apply to either .wft/.wtd file, or both?

Share this post


Link to post
Share on other sites
jpm1

wft + wtd = 4 Mo max

 

if the thing is driving you mad there's another thing but it's radical . remove one or 2 taxis in the vehicle.img file

Share this post


Link to post
Share on other sites
unbid

wft + wtd = 4 Mo max

 

if the thing is driving you mad there's another thing but it's radical . remove one or 2 taxis in the vehicle.img file

 

The taxi actually doesn't overspawn even I modded 2 of them (I use the 1,1 spawn setting on both Taxi), but the really pain is that the police cars are overspawn, even when I set the frequency and amount to 1,1.

 

Most of my mods are 4 Mo or less, but the rest doesn't exceed 5.5 Mo. Even the police cars that I use are less than 4 Mo.

Share this post


Link to post
Share on other sites
_MK_

Img is 516mb here and working perfect with real traffic mod. using my method

 

 

Edited by MKIIIX

Share this post


Link to post
Share on other sites
jpm1

does not work perfect man , you have dept of field off . i do not call this perfect . i tried that commandline thing several times , and each time after been playing several hours i got problems

 

taxi and probably police cars are very likely a special traffic file . in cargrp you have the fbi and the nstockade in police group but they never spawn in traffic . i'm pretty sure these cars are sent when game is overloaded that's why you keep seing these vehicles spawning even once you have modified the vehicle.ide . as i said only 2 solutions i know is to have lot of different taxi liveries or to remove the model from vehicle.img , but i canno't guarantee it won't make your game to become unstable

 

edit : cargrp not popcycle

Edited by jpm1

Share this post


Link to post
Share on other sites
BigSlongsDaddy

the best thing i find to do is to set the vehicle density to 1 and let a traffic spawner do the spawning of you car pack im on latest patch for balled of gay tony.

Share this post


Link to post
Share on other sites
jpm1

if you use that method you'll have to keep vehicles.img file size tiny or the game will become bugguey . IMHO it's a bit of waste as GTA can have up to 170 different cars installed

Share this post


Link to post
Share on other sites
fefenc

my vehicles.img is 86MB and I'm having this motherf*cking issue with an added not replaced mercedes slk. This game has been coded with R* devs' p***ses!!!

 

EDIT: f*ck this sh*tty IV car modding thing, I give up this sh*t! I'd rather use the low poly default IV+TBoGT cars instead of getting frustrated with this sh*t that hasn't any true fix at all...

 

EDIT2: Unless someone FIX this issue, modding cars on GTA IV will be impossible due to how this sh*tty xbox 360 emulator works.

Edited by fefenc

Share this post


Link to post
Share on other sites
MaazS

Calm...your...tits....

Share this post


Link to post
Share on other sites
TJGM

Nice useless bump. :^:

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.