Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Los Santos Tuners
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. GTA San Andreas

      1. Classic GTA SA
      2. Guides & Strategies
      3. Help & Support
    2. GTA Vice City

      1. Classic GTA VC
      2. Guides & Strategies
      3. Help & Support
    3. GTA III

      1. Classic GTA III
      2. Guides & Strategies
      3. Help & Support
    1. Grand Theft Auto Series

      1. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    6. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

      1. GTANet 20th Anniversary
    2. Support

    3. Suggestions

Project2DFX


ThirteenAG
 Share

Recommended Posts

Does the limit adjuster in binaryIPL in bonus argue with the limit adjuster in 2DFX?

 

With both active in modloader reliably crashes. Deactivate binaryIPL and it's quite happy and quite, quite beautiful.

Link to comment
Share on other sites

If anyone still testing 3.0 for SA, download this: https://www.sendspace.com/file/jpm4t9

And tell me if you have better/worse performance with it.

Edited by ThirteenAG
Link to comment
Share on other sites

So, overall performance is much better. I have 35-45 with FL off and rock-solid 30 with FL on. Well its ok, since I always use FL :)

BUUUT !!! after 15-20 minutes of roaming each next night becomes more laggy (28 fps first, next - 26, next - 24... the lowest was 18). I tested it in the same few areas in different cities. Every time performance is good at the beginning but gets worse after a while. I noticed that with previous version of 3.0 but thought that was my fault. It wasn't. It never happened with 2.5.

To reproduce it faster you may just put NIGHTPROWLER cheat and roam around for 15-20 minutes. It would be nice if someone could check this kind of issue.

 

P.S. Default ini settings, [DrawDistanceChanger] and [AdaptiveDrawDistance] are completely disabled.

Edited by uncaged
Link to comment
Share on other sites

Guess this thread is the best place to post this... If not then whatever this needs to be shared somehow.

 

Oh my gawd I can't belive my eyes :inlove: , I DID IT !!!!!! (no this isn't an april fools joke)

 

mcY2KLk.png

 

After many hours of trial and error I finally managed to increase the LOD distances without any bugs, map holes, weird screen stuff or lag yaaaay!

 

-How to do it-

 

1) Before anything you need to use the following scripts/mods:

  • Open Limit Adjuster
  • IDE_DD_Tweaker (from this thread)
  • binaryipl.cs (also from this thread)
  • PreloadLODs.asi (can be found somewhere in this thread but the link is broken)
  • EDIT: render.cs by Skript47 (loads the map first then puts the player on it)

2) Then use these settings for IDE_DD_Tweaker and OpenLA:

 

IDE Tweaker:

 

 

[MAIN]enable=1patch_tobjs=1patch_lods=1patch_generic=0patch_all_normal=1 //do not use at the same time with patch_generic=1[TOBJS]tobjs_draw_distance_multiplier = 2.0[LODS]lods_draw_distance_multiplier = 0.0lods_new_draw_distance = 2000.0 //if multiplier is set, this value will be ignored[OBJS]max_draw_distance_for_normal_objects = 800.0 // it's better not to touch it at allgeneric_new_draw_distance = 800.0normal_new_draw_distance = 800.0

 

 

 

OpenLA:

 

 

[sALIMITS]PtrNodeSingle = unlimitedPtrNodeDouble = unlimitedEntryInfoNode = unlimitedPeds = 140PedIntelligence = 140Vehicles = 110Buildings = 150000Objects = 35000Dummys = 95000ColModel = unlimitedTask = unlimitedEvent = unlimitedPointRoute = unlimitedPatrolRoute = unlimitedNodeRoute = unlimitedTaskAllocator = unlimitedPedAttractors = unlimitedVehicleStructs = unlimitedMatrixList = unlimitedOutsideWorldWaterBlocks = 500AlphaEntityList = unlimitedVisibleEntityPtrs = unlimitedVisibleLodPtrs = unlimitedStreamingObjectInstancesList = 75000AtomicModels = unlimitedDamageAtomicModels = unlimitedTimeModels = unlimitedClumpModels = unlimitedVehicleModels = unlimitedPedModels = unlimitedWeaponModels = unlimitedEntitiesPerIpl = unlimitedEntityIpl = unlimitedStaticShadows = 2048Coronas = 20048ScriptSearchLights = 1024FrameLimit = 30MemoryAvailable = 4%

 

 

 

Please keep in mind that for this line you MUST put a percentage that represents less than around 400mb of ram, otherwise you will get the infamous screen polygon thingy bug (this may depend on the system, I honestly have no idea, but at least on my end the bug doesn't occur if the limit is less than 400mb)

MemoryAvailable = 4%

In my case I set 4% since I have 8192mb of ram, that means the game is using around 327mb of streaming memory.

 

If it works, have fun :D.

Edited by Reyks

jYzLR2j.png

Link to comment
Share on other sites

:lol: ^ Works great ! Thank you ! I quess now we dont have to worry about poppin-up objects any more :) It now looks very atmospheric even with crappy PS2 Draw Distances.

Link to comment
Share on other sites

PreloadLODs.asi doesn't seem to do anything in SAMP for me... :/ LODs loading up slowly still when game starts.

Well...SA-MP is know for it's incompatibility with mods, maybe the author can make it compatible (i think Link made that script but I don't know for sure).

:lol: ^ Works great ! Thank you ! I quess now we dont have to worry about poppin-up objects any more :) It now looks very atmospheric even with crappy PS2 Draw Distances.

Glad it worked, the only downside of this is that the world takes a while to load, but I guess that's expected. Btw if your draw distance is lower than 800 then there's no need to have it set to 800 in the tweaker, may help performance a bit as well.

  • Like 2

jYzLR2j.png

Link to comment
Share on other sites

327Mb seems a bit too low. Map holes and slow texture loading are likely to occur, especially when setting distances to 800.

Link to comment
Share on other sites

327Mb seems a bit too low. Map holes and slow texture loading are likely to occur, especially when setting distances to 800.

In theory yes, but surprisingly it doesn't :p. The only time texture loading is slow is when you first load up a save or start a new game(EDIT: Sometimes when you die or get busted as well), and there's no map holes at all if you use that .asi.

 

Problem is if I set it any higher than that, weird buggy stuff starts to show up on screen. So yeah unless someone manages to fix that bug, we will have to deal with memory limitations.

Edited by Reyks
  • Like 2

jYzLR2j.png

Link to comment
Share on other sites

Please keep in mind that for this line you MUST put a percentage that represents less than around 400mb of ram, otherwise you will get the infamous screen polygon thingy bug (this may depend on the system, I honestly have no idea, but at least on my end the bug doesn't occur if the limit is less than 400mb)

You'll still get the bug regardless, just fly around for awhile. The only safe value is 100 or below.

Edited by Zera
Link to comment
Share on other sites

After many hours of trial and error I finally managed to increase the LOD distances without any bugs, map holes, weird screen stuff or lag yaaaay!

I wish it to be true, but after some loads/reloads of my different save slots (which is different places on the map) CJ appears under the map.

Link to comment
Share on other sites

@up

 

-How to do it-

 

1) Before anything you need to use the following scripts/mods:

  • Open Limit Adjuster
  • IDE_DD_Tweaker (from this thread)
  • binaryipl.cs (also from this thread)
  • PreloadLODs.asi (can be found somewhere in this thread but the link is broken
Edited by NcShane
Link to comment
Share on other sites

First post in this thread, look for the "Bonus Scripts" link.

fxoNkvf.png
Link to comment
Share on other sites

What about combining your solution with the LOD Mod, Reyks?

What does PreloadLODs.asi do? Never heard of it.

Edited by MrMateczko
Link to comment
Share on other sites

Hm what PreloadLODs.asi do? That's a hard question... maybe... it... preloads LODs? :| I mean... are you serious?

Edited by nyolc8
Link to comment
Share on other sites

Is there any way to make sa memory fix work with gta-sa.exe - it's used by steam (not only gta_sa.exe)?

 

I think it's the way to fix any map holes and increase percentage of 'MemoryAvailable'

Or will it cause some other issues?

Link to comment
Share on other sites

You'll still get the bug regardless, just fly around for awhile. The only safe value is 100 or below.

Trust me, I played the game for 2 hours yesterday flying around with the hydra loading as much stuff as possible, blocking highways to pile up cars, and all sorts of crazy stuff, and nothing happened. I'm guessing it depends heavily on your system and mods you're using, but I ain't sure.

 

Btw try getting a PIX frame of the bug and send it to The Hero, maybe he can fix it.

I wish it to be true, but after some loads/reloads of my different save slots (which is different places on the map) CJ appears under the map.

Hmm, try using render.cs by Skript47, it loads the map first then puts the player on it.

 

 

EDIT: Holy sh*t looks like this is my 1000th post, yay :cool:.

Edited by Reyks
  • Like 2

jYzLR2j.png

Link to comment
Share on other sites

Guess this thread is the best place to post this... If not then whatever this needs to be shared somehow.

 

Oh my gawd I can't belive my eyes :inlove: , I DID IT !!!!!! (no this isn't an april fools joke)

 

 

 

After many hours of trial and error I finally managed to increase the LOD distances without any bugs, map holes, weird screen stuff or lag yaaaay!

 

-How to do it-

 

1) Before anything you need to use the following scripts/mods:

  • Open Limit Adjuster
  • IDE_DD_Tweaker (from this thread)
  • binaryipl.cs (also from this thread)
  • PreloadLODs.asi (can be found somewhere in this thread but the link is broken)

2) Then use these settings for IDE_DD_Tweaker and OpenLA:

 

IDE Tweaker:

 

 

[MAIN]enable=1patch_tobjs=1patch_lods=1patch_generic=0patch_all_normal=1 //do not use at the same time with patch_generic=1[TOBJS]tobjs_draw_distance_multiplier = 2.0[LODS]lods_draw_distance_multiplier = 0.0lods_new_draw_distance = 2000.0 //if multiplier is set, this value will be ignored[OBJS]max_draw_distance_for_normal_objects = 800.0 // it's better not to touch it at allgeneric_new_draw_distance = 800.0normal_new_draw_distance = 800.0

 

 

 

OpenLA:

 

 

[sALIMITS]PtrNodeSingle = unlimitedPtrNodeDouble = unlimitedEntryInfoNode = unlimitedPeds = 140PedIntelligence = 140Vehicles = 110Buildings = 150000Objects = 35000Dummys = 95000ColModel = unlimitedTask = unlimitedEvent = unlimitedPointRoute = unlimitedPatrolRoute = unlimitedNodeRoute = unlimitedTaskAllocator = unlimitedPedAttractors = unlimitedVehicleStructs = unlimitedMatrixList = unlimitedOutsideWorldWaterBlocks = 500AlphaEntityList = unlimitedVisibleEntityPtrs = unlimitedVisibleLodPtrs = unlimitedStreamingObjectInstancesList = 75000AtomicModels = unlimitedDamageAtomicModels = unlimitedTimeModels = unlimitedClumpModels = unlimitedVehicleModels = unlimitedPedModels = unlimitedWeaponModels = unlimitedEntitiesPerIpl = unlimitedEntityIpl = unlimitedStaticShadows = 2048Coronas = 20048ScriptSearchLights = 1024FrameLimit = 30MemoryAvailable = 4%

 

 

 

Please keep in mind that for this line you MUST put a percentage that represents less than around 400mb of ram, otherwise you will get the infamous screen polygon thingy bug (this may depend on the system, I honestly have no idea, but at least on my end the bug doesn't occur if the limit is less than 400mb)

MemoryAvailable = 4%

In my case I set 4% since I have 8192mb of ram, that means the game is using around 327mb of streaming memory.

 

If it works, have fun :D.

Well, too bad. It's not working for me. Game starts fine but it crashes after a minute or two.

Link to comment
Share on other sites

Well, too bad. It's not working for me. Game starts fine but it crashes after a minute or two.

That's weird, are you sing the Draw Distance Changer? Crazy draw distances may crash the game.

jYzLR2j.png

Link to comment
Share on other sites

 

Well, too bad. It's not working for me. Game starts fine but it crashes after a minute or two.

That's weird, are you sing the Draw Distance Changer? Crazy draw distances may crash the game.

 

I tried with and without Draw Distance. But without Draw Distance, the distance looks like PS2's which makes this quite useless.

Maybe it's the binairyipl?

 

EDIT

Yes, it's the binairyipl.cs. When this is installed, I load a savegame and go to the middle of Grove street.

Just at that moment when I rotate the camera to Downtown, game immediately crash.

I removed it and no crash. But not for sure for how long when playing.

Edited by SilverRST
Link to comment
Share on other sites

 

 

Well, too bad. It's not working for me. Game starts fine but it crashes after a minute or two.

That's weird, are you sing the Draw Distance Changer? Crazy draw distances may crash the game.

 

I tried with and without Draw Distance. But without Draw Distance, the distance looks like PS2's which makes this quite useless.

Maybe it's the binairyipl?

 

The script is fine, it does what it's supposed to do. Probably some sort of limit, try increasing the buildings limit a little more.

Link to comment
Share on other sites

I tried with and without Draw Distance. But without Draw Distance, the distance looks like PS2's which makes this quite useless.

Try using this modified pc timecyc, all draw distance values set to 1500 (except foggy/rainy weathers).

jYzLR2j.png

Link to comment
Share on other sites

I wish it to be true, but after some loads/reloads of my different save slots (which is different places on the map) CJ appears under the map.

Hmm, try using render.cs by Skript47, it loads the map first then puts the player on it.

 

Nope. Didn't helped.

Link to comment
Share on other sites

that binaryipl.cs crashes the game a few seconds after game loaded, I tried to watch limit adjuster values while the game crashes, but not any value has been exceed the limit (not even got near to it)

Link to comment
Share on other sites

that binaryipl.cs crashes the game a few seconds after game loaded, I tried to watch limit adjuster values while the game crashes, but not any value has been exceed the limit (not even got near to it)

What he said.

And I also increased the Building limits up to 250000 and still crashes after a minute or two.

Link to comment
Share on other sites

So after tested that binaryipl.cs, it somehow totally broke my game (no idea how is this possible). It crashes at startup.

I even removed ALL asi files (so whole CLEO removed too) and it still crashes immediately at startup. I didn't do anything, just tested that cs file... sometimes I really-really hate this game :D

 

edit: game works, only SAMP got broken by it somehow...

Edited by nyolc8
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.