Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (85,265 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Brandeeno

Need help with modding gta iv

Recommended Posts

Brandeeno

hello i would like some help with my gta iv because i cannot mod or put mods in the game whatsoever... i have the mods installed correctly as shown the asi loader correct everything done but when i run the game it says DSOUND.dll does not have permission to do --- i cant remember the rest because it only shows once and then the next time i run it, it just stops responding and crashes confused.gif i have spent over a week and half trying to get the hulk mod working but im not getting any luck, i cant get past the dsound problem, can anyone help? i am frustrated to the point of rage so if anyone could help me that would be awesome ^_^

 

heres the specs on my Laptop:

Toshiba Satelite L775D

AMD A6 3420M Quad core 1.5 Ghz With:

Radeon HD 6520G (single graphics card)

8GB RAM 64 bit operating system

Windows 7 Home Premium Service Pack 1

 

and i was reading through the forums and seen that i had to have NET fx 3.5 installed for asi loader to work but i downloaded it from the link given and i clicked it.... nothing, it would show extracting or even respond... it also said to try the 2.0 if the 3.5 doesnt work for some reason but the link was broken confused.gif

also with the asi loader not installed the game works perfectly fine and i can install the hulk PED skin and works fine, as soon as i install it crashes and gives me all sorts of problems btw my gta iv is 1.0.0.0 i believe i dont want to update because it has a slight lag problem with 1.0.7.0

if i didint list anything just let me know ^_^ one more thing, when i went to install the 2.0 it said that .NET fx is already on my computer and comes with the system software.

i figured out how to get the error again and heres the exact error:

 

Exception EFCreateError in module DSOUND.dll at 000116C5. Cannot create file "C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV\asilog.txt". Access is denied.

 

The Application was unable to start correctly (0xc0000142). Click OK to close application.

Edited by Brandeeno

Share this post


Link to post
Share on other sites
Skorpro

 

...DSOUND.dll does not have permission to do...

Exception EFCreateError in module DSOUND.dll at 000116C5. Cannot create file "C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV\asilog.txt". Access is denied.

Try:

 

Right-click on "Rockstar Games" folder (eg. C:\Program Files (x86))

 

Choose Properties

 

Click on Security tab

 

Click the EDIT button

 

Now choose you account (eg. USER) in "Group or user names" window

 

In "Permissions for ..." window (below) click the "FULL CONTROL" checkbox

 

Click APPLY then OK button

 

 

 

if i didint list anything just let me know ^_^ one more thing, when i went to install the 2.0 it said that .NET fx is already on my computer and comes with the system software.

I think you need Microsoft .NET Framework 4 (Standalone Installer) too. (After installing make an Windows update!)

 

 

 

btw my gta iv is 1.0.0.0 i believe i dont want to update because it has a slight lag problem with 1.0.7.0

Try GTA IV Update v1.0.4.0... it should have the best performance for many mods and systems...

 

But first try the "folder properties" step!

 

Good luck... smile.gif

Share this post


Link to post
Share on other sites
pedro2555
...DSOUND.dll does not have permission to do...

Exception EFCreateError in module DSOUND.dll at 000116C5. Cannot create file "C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV\asilog.txt". Access is denied.

Try:

 

 

Right-click on "Rockstar Games" folder (eg. C:\Program Files (x86))

 

 

Choose Properties

 

 

Click on Security tab

 

 

Click the EDIT button

 

 

Now choose you account (eg. USER) in "Group or user names" window

 

 

In "Permissions for ..." window (below) click the "FULL CONTROL" checkbox

 

 

Click APPLY then OK button

 

 

 

 

if i didint list anything just let me know ^_^ one more thing, when i went to install the 2.0 it said that .NET fx is already on my computer and comes with the system software.

I think you need Microsoft .NET Framework 4 (Standalone Installer) too. (After installing make an Windows update!)

 

 

 

btw my gta iv is 1.0.0.0 i believe i dont want to update because it has a slight lag problem with 1.0.7.0

Try GTA IV Update v1.0.4.0... it should have the best performance for many mods and systems...

 

But first try the "folder properties" step!

 

Good luck... smile.gif

Windows Update is not needed, just .NET 4.5 (it supports 4.0 as well) any profile is ok.

Share this post


Link to post
Share on other sites
Brandeeno
...DSOUND.dll does not have permission to do...

Exception EFCreateError in module DSOUND.dll at 000116C5. Cannot create file "C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV\asilog.txt". Access is denied.

Try:

 

 

 

Right-click on "Rockstar Games" folder (eg. C:\Program Files (x86))

 

 

 

Choose Properties

 

 

 

Click on Security tab

 

 

 

Click the EDIT button

 

 

 

Now choose you account (eg. USER) in "Group or user names" window

 

 

 

In "Permissions for ..." window (below) click the "FULL CONTROL" checkbox

 

 

 

Click APPLY then OK button

 

 

 

 

 

if i didint list anything just let me know ^_^ one more thing, when i went to install the 2.0 it said that .NET fx is already on my computer and comes with the system software.

I think you need Microsoft .NET Framework 4 (Standalone Installer) too. (After installing make an Windows update!)

 

 

 

btw my gta iv is 1.0.0.0 i believe i dont want to update because it has a slight lag problem with 1.0.7.0

Try GTA IV Update v1.0.4.0... it should have the best performance for many mods and systems...

 

But first try the "folder properties" step!

 

Good luck... smile.gif

Windows Update is not needed, just .NET 4.5 (it supports 4.0 as well) any profile is ok.

thank you guys so much! biggrin.gif i will try this and let you know if it works ^_^

Share this post


Link to post
Share on other sites
Brandeeno

okay i managed to launch the game because i updated to 1.0.1.0 then it didnt work so i updated to 1.0.4.0 and it managed to launch with no errors but im using a different mod which is left4liberty but when it went to load the savegame it just exits completly and almost instantly so i read the script hook log and heres the log:

 

Log start: Wed Aug 07 18:38:10 2013-----------------------------------------------[iNFO] GTA IV Script Hook 0.5.1 - © 2009, Aru - Initialized[iNFO] Process base address: 0x1300000[iNFO] Auto detecting game version[iNFO] Using game version 1.0.0.4 (patch 5)[iNFO] [scriptHookDotNet] Thread started[iNFO] Script Hook - Shutdown

 

i dont know what happenned it just shuts down at the save game load and it doesnt even tell me the error please help!

Share this post


Link to post
Share on other sites
pedro2555
okay i managed to launch the game because i updated to 1.0.1.0 then it didnt work so i updated to 1.0.4.0 and it managed to launch with no errors but im using a different mod which is left4liberty but when it went to load the savegame it just exits completly and almost instantly so i read the script hook log and heres the log:

 

Log start: Wed Aug 07 18:38:10 2013-----------------------------------------------[iNFO] GTA IV Script Hook 0.5.1 - © 2009, Aru - Initialized[iNFO] Process base address: 0x1300000[iNFO] Auto detecting game version[iNFO] Using game version 1.0.0.4 (patch 5)[iNFO] [scriptHookDotNet] Thread started[iNFO] Script Hook - Shutdown

 

i dont know what happenned it just shuts down at the save game load and it doesnt even tell me the error please help!

Can you be more specific ? Have you just installed the game, or have you just started using mods ?

What do you mean by 'a different mod', different from what ? Please provide a list of of mods before the error, and a list of mods after the error. Including vehicle mods, which maybe the cause.

Also I suggest you to update to 1.0.7.0.

Share this post


Link to post
Share on other sites
Brandeeno
okay i managed to launch the game because i updated to 1.0.1.0 then it didnt work so i updated to 1.0.4.0 and it managed to launch with no errors but im using a different mod which is left4liberty but when it went to load the savegame it just exits completly and almost instantly so i read the script hook log and heres the log:

 

Log start: Wed Aug 07 18:38:10 2013-----------------------------------------------[iNFO] GTA IV Script Hook 0.5.1 - © 2009, Aru - Initialized[iNFO] Process base address: 0x1300000[iNFO] Auto detecting game version[iNFO] Using game version 1.0.0.4 (patch 5)[iNFO] [scriptHookDotNet] Thread started[iNFO] Script Hook - Shutdown

 

i dont know what happenned it just shuts down at the save game load and it doesnt even tell me the error please help!

Can you be more specific ? Have you just installed the game, or have you just started using mods ?

What do you mean by 'a different mod', different from what ? Please provide a list of of mods before the error, and a list of mods after the error. Including vehicle mods, which maybe the cause.

Also I suggest you to update to 1.0.7.0.

please read the past posts

Share this post


Link to post
Share on other sites
pedro2555
okay i managed to launch the game because i updated to 1.0.1.0 then it didnt work so i updated to 1.0.4.0 and it managed to launch with no errors but im using a different mod which is left4liberty but when it went to load the savegame it just exits completly and almost instantly so i read the script hook log and heres the log:

 

Log start: Wed Aug 07 18:38:10 2013-----------------------------------------------[iNFO] GTA IV Script Hook 0.5.1 - © 2009, Aru - Initialized[iNFO] Process base address: 0x1300000[iNFO] Auto detecting game version[iNFO] Using game version 1.0.0.4 (patch 5)[iNFO] [scriptHookDotNet] Thread started[iNFO] Script Hook - Shutdown

 

i dont know what happenned it just shuts down at the save game load and it doesnt even tell me the error please help!

Can you be more specific ? Have you just installed the game, or have you just started using mods ?

What do you mean by 'a different mod', different from what ? Please provide a list of of mods before the error, and a list of mods after the error. Including vehicle mods, which maybe the cause.

Also I suggest you to update to 1.0.7.0.

please read the past posts

Sorry.

 

Following Skorpro's suggestion, you might have to get ownership of the files and folders in GTAIV directory.

 

On the security tab click Advanced. Select the Owner tab, and change the owner to yourself (you must be a local sys admin to do this).

 

Also make sure effective permissions allow your user to have full control (as well as SYSTEM user).

 

 

Just for the record, I use Win 7 Enterprise SP1 (Windows Update service fully disabled), Visual C++ 2005/2008/2010 and .NET 4.5 (since 4.5 there is only one profile, Full Profile)

Share this post


Link to post
Share on other sites
Brandeeno

well i dont know what is going on but everytime i run gta iv it crashes whenever i put the scripthookDotNet.asi back in the folder it crashes when its trying to load the game confused.gif i followed your intructions and changed the owner to me and my account is all checked for permissions, is there any other scripthookDotNet.asi files i could get that would work and load the scripts properly, i heard there was another asi loader called: .NetScripthook.asi or something like that maybe theres scripthookdontnet.asi compatible with my version which is 1.0.4 any ideas?

Share this post


Link to post
Share on other sites
Skorpro

 

well i dont know what is going on but everytime i run gta iv it crashes whenever i put the scripthookDotNet.asi back in the folder it crashes when its trying to load the game confused.gif i followed your intructions and changed the owner to me and my account is all checked for permissions, is there any other scripthookDotNet.asi files i could get that would work and load the scripts properly, i heard there was another asi loader called: .NetScripthook.asi or something like that maybe theres scripthookdontnet.asi compatible with my version which is 1.0.4 any ideas?

Hi!

1st: GTA IV v1.0.0.4 is not v1.0.4.0!

 

[iNFO] Using game version 1.0.0.4 (patch 5)

 

2nd: It's not a good idea to use ScriptHook v0.5.1 with GTA IV v1.0.0.4!

 

[iNFO] GTA IV Script Hook 0.5.1 - © 2009, Aru - Initialized

 

wink.gif

 

What you need is....:

Note:
  • Some mods are incompatible with the ScriptHook v0.4!
  • Never use two ASI Loaders! (dsound.dll OR xlive.dll!!!)
  • Some info
Have fun smile.gif

 

 

EDIT: GTA IV versions ascending order: ...v1.0.2.0, v1.0.3.0, v1.0.4.0, v1.0.0.4, v1.0.7.0

Edited by Skorpro

Share this post


Link to post
Share on other sites
reaszon

all this doesnt work

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.