Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
      4. Frontier Pursuits
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Diamond Casino & Resort
      2. DLC
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA 6

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Silent

GInput

Recommended Posts

Inadequate

If the switch's games are almost unplayable with that thing of controller, now imagine gta. Lol.

Share this post


Link to post
Share on other sites
Silent
15 hours ago, Renato725 said:

This mod didn't recognize my Switch joycons (but the game without the mod did), i have already used x360ce and XOutput, none of both worked

 

If joycons work without GInput but do not with it, then it means they are showing themselves as a DirectInput controller. x360ce should help you, so maybe you didn't configure things correctly enough in it. GInput can't help with it.

Share this post


Link to post
Share on other sites
MordFustang

Hey Silent, is is possible for the car to produce a sound < 50 % gas

Share this post


Link to post
Share on other sites
Marsi4eg

Interesting. But I think it's about re-writing all engine sound related logic, so not easy.

BTW there also isn't engine sound in PS2 and even Xbox original versions (dunno if it is in X360 "remaster")

Share this post


Link to post
Share on other sites
Silent
On 8/18/2019 at 10:23 PM, KittenHammer said:

I installed this mod and was not able to sprint. GTA3 V1.1 using xbox one controller. 

I checked against III 1.0 and 1.1 and was not able to confirm this.

Share this post


Link to post
Share on other sites
Jigzat

Hello, I apologize for parachuting into this thread but I haven't been able to get analog acceleration using a DualShock 3. I followed Marsi4eg instructions using SCPDriver 1.2.0.60 the controls work fine but vehicles accelerate instantly. I'm under Windows 10 Pro with GTA SA 1.0 I installed GInput and San Andreas Revival Project. Can someone please point me to the right direction?

Share this post


Link to post
Share on other sites
Silent

Have you also grabbed SCP's xinput1_3.dll (Win32 version) and placed it in San Andreas directory?

Share this post


Link to post
Share on other sites
Jigzat
10 hours ago, Silent said:

Have you also grabbed SCP's xinput1_3.dll (Win32 version) and placed it in San Andreas directory?

Thank you, yes I did. I even made a clean Windows installation but there are no changes. Everything works well except analog throttling. I modified the ini file to increase face buttons sensitivity to 1.

 

I even try to use only GInput with the SCP Driver ASI loader and xinput1_3.dll and ditched Revival but it doesn't seem to do anything. Not sure if ASI is loading anything because I don't see anything different. It doesn't replace the generic Joystick button names with Xbox or PS ones. And the controller works partially, the analog triggers are not detected nor the right stick.

Edited by Jigzat

Share this post


Link to post
Share on other sites
Silent
3 hours ago, Jigzat said:

And the controller works partially, the analog triggers are not detected nor the right stick.

That actually sounds like GInput does not work at all. Are you getting button prompts? If you're not getting them then sounds like you're either a victim of missing DirectX End User Runtimes which GInput (but not stock SA) relies on, or have not grabbed an ASI Loader.

 

Not relying on those runtimes is trivial, but I just can't get to it as I have plenty of outstanding changes to GInput - maybe I should shelve them all and just update 1.11 with removal of this dependency :(

Edited by Silent

Share this post


Link to post
Share on other sites
Jigzat
14 hours ago, Silent said:

That actually sounds like GInput does not work at all. Are you getting button prompts? If you're not getting them then sounds like you're either a victim of missing DirectX End User Runtimes which GInput (but not stock SA) relies on, or have not grabbed an ASI Loader.

 

Not relying on those runtimes is trivial, but I just can't get to it as I have plenty of outstanding changes to GInput - maybe I should shelve them all and just update 1.11 with removal of this dependency :(

Right now I went back to SA Revival with the last version of SCPTools and I managed to get the analog triggers working by switching to layout 2. And installed PCSX2 and the analog buttons are working correctly there.

 

UPDATE:

 

I haven't manage to get it right but I just found out that if I use x64 xinput1_3.dll instead of the x86 (from SCPDriver 1.2.0.60) at least it loads (without using SA Revival) and the layout 2 with trigger braking and acceleration works fine.  I also installed directx_Jun2010_redist.exe but there are no noticeable changes.

Edited by Jigzat

Share this post


Link to post
Share on other sites
Jigzat

Is there any way to download GInput 1.10? I have been looking around but I cannot find older versions, I want to try with it, maybe is a new bug.

Share this post


Link to post
Share on other sites
Humpty Dumpty

I need some help with using the analog face buttons on my PS3 Controller. I have SCP installed, copied the XInput1_3.dll in the games directory and put the face button sensitivity value to 100 in the GInput,ini file but no matter how hard I press the buttons it always recognizes it as a full button press. This kinda sucks for me because sometimes I like to just drive around a bit without crashing into everything I see. Even if I gently press the button in very slightly the vehicle goes 100% and that drives me nuts because it shouldn't be like that. I use the GInput with III, Vice City and San Andreas and it's the same in all three of them. Everything works perfectly except the analog face buttons. I'm used to play these games on my PS2 back in the day and I always was a fan of the analog face buttons so I wanted to kind of recreate that feeling on my PC to get the best experience out of it but I can't figure out why it's not working. My DualShock 3 is completely fine I can take advantage of the analog face buttons just fine in all the PS3 games that use this feature. Is there something I missed? I would be very thankful if someone could help me solving this problem.

Share this post


Link to post
Share on other sites
Marsi4eg
5 minutes ago, Humpty Dumpty said:

and put the face button sensitivity value to 100 in the GInput,ini

Why did you do this? Write default sensivity values back and try again.

 

Also analog buttons don't work with latest SCP toolkit. you need older version:

 

Share this post


Link to post
Share on other sites
Humpty Dumpty
7 minutes ago, Marsi4eg said:

Why did you do this? Write default sensivity values back and try again.

 

Also analog buttons don't work with latest SCP toolkit. you need older version:

 

It didn't work with the default settings either so I read through the .ini file and thought that it depends on the FaceButtonsSensitivity value because it says

"Face buttons sensitibity (don't affect triggers nor analog sticks). A value of 100 means the button has to
; be 100% pressed for the game to register a full button press; 75 means the button has to be 75% pressed to
; register a full button press, and so on"

(English is not my native language so there is a chance that I got that wrong somehow)

I don't know which SCP version I have but I have this thing installed for quite a while and in the test app that comes with it, it recognizes everything right I don't know if that has something to do with it though so I will go and check out some older version to see if that works.

Share this post


Link to post
Share on other sites
Marsi4eg

Check SCP Toolkit version. Correctly working test app says nothing about compatibility with GInput 😉

Share this post


Link to post
Share on other sites
Humpty Dumpty
1 hour ago, Marsi4eg said:

Check SCP Toolkit version. Correctly working test app says nothing about compatibility with GInput 😉

Thank you very much for your help! I got it to work now I already had the right SCP Toolkit Version though. I think what I did wrong was that I took the XInput1_3.dll from the Win64 folder instead of the one in the Win32 folder for some reason. I also changed the FaceButtonsSensitivity back to 50 like you said and now it works perfectly! Thanks for your advice :D 

Share this post


Link to post
Share on other sites
Silent

Indeed, that's how this will manifest itself. Glad to hear you got it to work though!

Share this post


Link to post
Share on other sites
Silent

Ginput for VC received a hotfix! Turns out, it started conflicting with SilentPatchVC starting with Build 9, so I had to hotfix it from there. No other changes have been included!

 

DOWNLOAD for GTA Vice City

Share this post


Link to post
Share on other sites
Veroder

Two sets of button prompts show up during the dancing minigame whenever I install Widescreen Fix. Did I screw something up or...?

Share this post


Link to post
Share on other sites
Silent

I'm not sure if GInput is a factor there or not - does it still happen without it?

Share this post


Link to post
Share on other sites
Veroder

Setting ApplyMissionSpecificFixes to zero "fixes" it, though instead of button prompts you of course get arrows.

 

 

 

 

Edited by Veroder

Share this post


Link to post
Share on other sites
gts.
23 hours ago, Silent said:

... No other changes have been included!

Damn, I was hyped for a second! :p

Edited by gts.

Share this post


Link to post
Share on other sites
Cryev
Posted (edited)

Hi, I just installed VC and downloaded GInput. I tried using an Xbox One and PS4 controller with DS4 Windows, it works but the left joystick moves the camera just like the right one. I can only move with the d-pad which is not ideal. There's any config I'm missing?

I played SA using the same mod without any issue.

 

Thanks.

Edited by Cryev

Share this post


Link to post
Share on other sites
Silent

That's a bit weird - are you sure GInput is even working in SA? If you don't have DirectX End-User Runtimes, it just won't load and will not let you know about it.

Share this post


Link to post
Share on other sites
Cryev
2 minutes ago, Silent said:

That's a bit weird - are you sure GInput is even working in SA? If you don't have DirectX End-User Runtimes, it just won't load and will not let you know about it.

Yes, I completed SA with the Dualshock 4 no problem. GInput is working in VC because the xbox prompts appear but I don't know why the left joystick does nothing in Classic mode and just moves the camera in Standard.

Share this post


Link to post
Share on other sites
Silent

Ah, are you playing on Steam? I think Steam Controller configurations do some weird stuff (because they assume DirectInput yet with GInput game uses XInput), so you may need to force that off for III and Vice City.

Share this post


Link to post
Share on other sites
Cryev
6 minutes ago, Silent said:

Ah, are you playing on Steam? I think Steam Controller configurations do some weird stuff (because they assume DirectInput yet with GInput game uses XInput), so you may need to force that off for III and Vice City.

Yes, I'm using Steam. If I disable the controller support in big picture the game won't recognize it though.

Share this post


Link to post
Share on other sites
Silent

Well, you are using DS4Windows and a X1 pad so you should be able to turn off Steam Controller mappings and it should work fine.

Share this post


Link to post
Share on other sites
Cryev
2 minutes ago, Silent said:

Well, you are using DS4Windows and a X1 pad so you should be able to turn off Steam Controller mappings and it should work fine.

I start the game using the .exe and it works. If I open VC from Steam directly even with the Steam mappings disabled it didn't work. Well, that's strange. Thank you!

Share this post


Link to post
Share on other sites
cj_ryder_smoke&sweet

I made an account literally just to post this, I got to know how to play co-op with this mod it's been bugging me for years people say they play co-op with it but whenever I plug 2 controllers in and go to the co-op marker that's on consoles the marker is not there. is there a setting or something in the .ini that turns it on?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 3 Users Currently Viewing
    0 members, 0 Anonymous, 3 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.