Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (91,463 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Silent

GInput

Recommended Posts

FabioB
8 minutes ago, LaDiDa said:

You put .asi, .ini and models folder in folder where .exe is located and you're done. Do make sure that global.ini doesn't only load from scripts folder.

Just solved installing all runtimes. Thank you.

Share this post


Link to post
Share on other sites
Torhque

Anyone know how to fix the problem where your camera doesn't lock onto the target you are locked onto? I made a gif of my problem:

 

Here is a video I found showing how the camera /should/ be behaving

 

Share this post


Link to post
Share on other sites
YoshiFan Gaming
Posted (edited)

I've installed it fully it (SA) and plugged in my PS3 controller but it doesn't work.

And I have the downgraded version.

Edited by YoshiFan Gaming

Share this post


Link to post
Share on other sites
Silent

DualShock 3 doesn't work out of the box with Windows, you need drivers.

Share this post


Link to post
Share on other sites
YoshiFan Gaming
Just now, Silent said:

DualShock 3 doesn't work out of the box with Windows, you need drivers.

Oh. What is that? Does the Ps2 controller need that too?

i can't see the reply lol

Share this post


Link to post
Share on other sites
B Dawg
Posted (edited)

Get SCP Toolkit for PS3 controller.

Edited by B Dawg

Share this post


Link to post
Share on other sites
YoshiFan Gaming

I've installed it. Now what?

 

Share this post


Link to post
Share on other sites
B Dawg

Not the same link I used, but the program interface is the same, so yes.

Share this post


Link to post
Share on other sites
YoshiFan Gaming

There's not even a menu in the game that appears and my controller has no function still.

Share this post


Link to post
Share on other sites
Marsi4eg
Posted (edited)

Pressure sensitive buttons may not work with the latest scp toolkit.

I use this old release and it works like a charm, no need to update to something newer with tons of graphical garbage and tons of notifications.

 

https://forums.pcsx2.net/Thread-XInput-Wrapper-for-DS3-and-Play-com-USB-Dual-DS2-Controller

 

Correctly uninstall your current toolkit release

Get version 1.2.0.160, unzip it, plug in your DS3 controller and launch ScpDriver.exe, click install and wait. You'll see first slot indicator appears on your pad (when unrecognized - all 4 just flash).

Then copy Xinput1_3.dll file from Win32 folder to GTA root directory.

Your DS3 should work correctly.

 

P.S. make sure you launch the game AFTER your DS3 is already turned on, or it will act like usual xinput controller (no pressure sensitive/sixaxis features)

Edited by Marsi4eg

Share this post


Link to post
Share on other sites
YoshiFan Gaming
Posted (edited)

 

10 hours ago, Marsi4eg said:

Pressure sensitive buttons may not work with the latest scp toolkit.

I use this old release and it works like a charm, no need to update to something newer with tons of graphical garbage and tons of notifications.

 

https://forums.pcsx2.net/Thread-XInput-Wrapper-for-DS3-and-Play-com-USB-Dual-DS2-Controller

 

Correctly uninstall your current toolkit release

Get version 1.2.0.160, unzip it, plug in your DS3 controller and launch ScpDriver.exe, click install and wait. You'll see first slot indicator appears on your pad (when unrecognized - all 4 just flash).

Then copy Xinput1_3.dll file from Win32 folder to GTA root directory.

Your DS3 should work correctly.

 

P.S. make sure you launch the game AFTER your DS3 is already turned on, or it will act like usual xinput controller (no pressure sensitive/sixaxis features)

OK thanks. Will try.

 

The controller doesn't turn on. All four lights are flashing.

Edited by YoshiFan Gaming

Share this post


Link to post
Share on other sites
YoshiFan Gaming

CJ walks around in big circles

Share this post


Link to post
Share on other sites
Marsi4eg
Posted (edited)

Then you do something wrong, check if drivers are installed (in device manager).

Also when you use SCPDriver.exe make sure you launch it as Administrator, read logs, seems like it doesn't install SCP service for you

 

Oh, and a stupid question, but do you connect your DS3 with USB cable or trying to install it wirelessly? It must be connected via usb when installing drivers

Edited by Marsi4eg

Share this post


Link to post
Share on other sites
Torhque

No tips on my issue above? It's the second post from the top of this page.

I've been dealing with it in the meantime, but big firefights are such a hassle lol

Share this post


Link to post
Share on other sites
Marsi4eg

Do you have this problem on clean game, v1.0 exe, without any other mods and/or scripts, with only Ginput placed into mss directory?

I've never seen this behavior in the current Ginput, and in older releases. This target lock is a native game code, it's not added by GInput, so looks like some other things broke it for you.

Edited by Marsi4eg

Share this post


Link to post
Share on other sites
Torhque
1 hour ago, Marsi4eg said:

-snip-

Haven't tested that. I only have GInput installed

Is my save merely a file on my machine somewhere? I'll do a fresh reinstall of the game and test, but I don't wanna lose my progress

 

/update

 

Well I first verified the integrity of the cache on Steam. No camera lock still

Then I completely uninstalled the game, and reinstalled. No GInput yet, straight vanilla Camera does not natively lock.

 

The hell am I missing lol

Edited by Torhque
Update

Share this post


Link to post
Share on other sites
Nytestryke

So i've got an interesting problem (although probably not unique), I have GTASA 1.0 installed from the original dvd on two windows 10 machines. One is a desktop one is a laptop, both have had the game installed exactly the same and both are using 3 mods (SilentPatch/Silents ASI Loader/Ginput). The desktop loads SilentPatch/Ginput without an issue, full X360 controller support where as the laptop will only load SilentPatch but not gInput leaving me without the ability to use my X360 controller as is possible on my desktop. It seems although GInput is not loading correctly when launching the game, to further work through this i've fully uninstalled and reinstalled the game twice while also restarting each time. Both machines are running the same driver version for X360 controller (10.0.171.134.1) not that I think it's relevant but thought i'd mention it anyway.

 

Are there any other variables that I might be missing which would prevent GInput from being loaded on the laptop but not desktop?

 

Mod Versions:

gInputSA 1.11

SilentPatchSA 1.1

Silents ASI Loader 1.3

Edited by Nytestryke

Share this post


Link to post
Share on other sites
George Costanza

Maybe some other input device is forcing itself as primary input, i remember having issue with remote controller. (which was even fixed by logging in into different account the machine)

other issue could be USB - if laptop has usb 3 and usb 2, try plugging it in usb 2

Edited by George Costanza

Share this post


Link to post
Share on other sites
Silent
8 hours ago, Torhque said:

The hell am I missing lol

 

Isn't this related to your camera mode? I vaguely recall no lock on when using the furthest camera mode - try changing it to one of the two closer ones.

 

14 minutes ago, Nytestryke said:

Are there any other variables that I might be missing which would prevent GInput from being loaded on the laptop but not desktop?

https://www.microsoft.com/en-US/download/details.aspx?id=35

Share this post


Link to post
Share on other sites
Marsi4eg

lol, it really doesn't lock while in the furthest cam mode. Gonna try it also on ps2

 

PS2 has the same behavior, so it's rather a feature than a bug

Edited by Marsi4eg

Share this post


Link to post
Share on other sites
Nytestryke
1 hour ago, George Costanza said:

Maybe some other input device is forcing itself as primary input, i remember having issue with remote controller. (which was even fixed by logging in into different account the machine)

other issue could be USB - if laptop has usb 3 and usb 2, try plugging it in usb 2

 

1 hour ago, Silent said:

 

Isn't this related to your camera mode? I vaguely recall no lock on when using the furthest camera mode - try changing it to one of the two closer ones.

 

https://www.microsoft.com/en-US/download/details.aspx?id=35

It was DirectX, I should of known that from past games but haven't had any setup on the laptop before. Thanks for the help guys, I'm looking forward to yet another re-clear of a great game.

 

Great addons as well Silent.

Edited by Nytestryke

Share this post


Link to post
Share on other sites
Torhque
9 hours ago, Silent said:

 

Isn't this related to your camera mode? I vaguely recall no lock on when using the furthest camera mode - try changing it to one of the two closer ones.

-snip-

Holy sh*t, you're right. Thanks man!

I hate how simple that solution was haha

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 4 Users Currently Viewing
    0 members, 0 Anonymous, 4 Guests

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.