Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Los Santos Summer Special
      2. The Diamond Casino Heist
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA VI

      1. St. Andrews Cathedral
    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    6. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    7. GTA III

      1. Guides & Strategies
      2. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions

DK22Pac

SA::Render

Recommended Posts

S Y E D

pulpatres, enbseries is not a crap. Please shut your mouth.

 

On-topic.

I've tried to compile sa render and Render.asi built succesfully. I put Render.asi, D3DDeviceReset.dll, Shaders folder and Textures folder into gta sa directory. Then I run gta sa and before it launch I got this error message.

 

user posted image

Share this post


Link to post
Share on other sites
lpgunit
pulpatres, enbseries is not a crap. Please shut your mouth.

 

On-topic.

I've tried to compile sa render and Render.asi built succesfully. I put Render.asi, D3DDeviceReset.dll, Shaders folder and Textures folder into gta sa directory. Then I run gta sa and before it launch I got this error message.

 

user posted image

Try moving the shader and texture files to the root SA folder.

Share this post


Link to post
Share on other sites
S Y E D

I think i've done that. Do you mean Shaders and Textures folder? I have move that to gta sa root.

This is how my gta sa root looks:

Click on the thumbnail to zoom.

user posted image

 

Share this post


Link to post
Share on other sites
lpgunit

What I mean is that you should copy the contents of both the shaders and textures folder to the root.

Share this post


Link to post
Share on other sites
S Y E D

Okay, I got that.

Mood: Finished compiling! colgate.gif

 

@PetkaGTA and @dk22pac, nice work guys. Keep it up! icon14.gif

Edited by Jengsebong007

Share this post


Link to post
Share on other sites
Performer

Open Source? wow.gif

 

OMG Thanks... This will help me learn smile.gif

Share this post


Link to post
Share on other sites
elMarcoPL

Kinda bug

 

 

user posted image

Share this post


Link to post
Share on other sites
PetkaGtA

@xXaerooff2Xx can be so cause of screen resolution

Share this post


Link to post
Share on other sites
cp1dell

This is going to be one hell of an .asi script.

Share this post


Link to post
Share on other sites
S Y E D

 

xXaerooff2Xx, try to turn anti-aliasing to 0 and visual fx quality to low.

Edited by Jengsebong007

Share this post


Link to post
Share on other sites
elMarcoPL

Thanks guys, changing visual fx quality helped.

But it seems like nothing, except sky box is working. And after a few seconds of gameplay it becomes so laggy.

Is it my fault (badly compiled asi or something else)?

 

user posted image

Share this post


Link to post
Share on other sites
Performer

What the f**...

 

NOTHING HAS CHANGED. The plugin was compiled loaded without any errors but the game looks like always. And YES I got an working ASI LOADER...

 

sad.gif

 

Edit:

 

user posted image

 

Didnt saw this one confused.gif

Share this post


Link to post
Share on other sites
Silent

You guys really didn't bother reading previous post, did you?

Share this post


Link to post
Share on other sites
Performer

http://ft.trillian.im/3ccbb3ae68e7c7560687...B3G2XmOmEmo.jpg

 

 

Got It working now.... Well... I got it working until the start cutscene ends. After that ---> Crash

 

Edit: GTA IV HUD was causing it wink.gif

 

Edit2: I probably doing something wrong because silents screen are looking different. Its because of my AMD card?

 

http://ft.trillian.im/3ccbb3ae68e7c7560687...RWhcgt7RNZX.jpg

Edited by Performer

Share this post


Link to post
Share on other sites
The_GTA

No matter what I do, it always show me this.

 

user posted image

 

I set resolution to 800x600x16, visual fx quality to lowest. Disabled mip-mapping too.

What GFX card requirements do the shaders have?

Share this post


Link to post
Share on other sites
Silent
Edit2: I probably doing something wrong because silents screen are looking different.

It's not looking different than my screens.

Share this post


Link to post
Share on other sites
Performer

 

Edit2: I probably doing something wrong because silents screen are looking different.

It's not looking different than my screens.

I got no shadows and no sunburn... IT HAS TO BE SOMETHING DIFFERENT!

 

@THE_GTA

 

You need 800x600_32 and not 16.wink.gif

Share this post


Link to post
Share on other sites
Silent

 

I got no shadows and no sunburn... IT HAS TO BE SOMETHING DIFFERENT!

You really didn't bother reading the posts. I pointed out it was an older build like... three times?

Share this post


Link to post
Share on other sites
The_GTA

 

@THE_GTA

 

You need 800x600_32  and not 16.wink.gif

Did not fix it confused.gif

Share this post


Link to post
Share on other sites
Silent

Tried disabling antialiasing too?

Share this post


Link to post
Share on other sites
The_GTA
Tried disabling antialiasing too?

Yuppers. SA::Render requires 1.0 US right?

Share this post


Link to post
Share on other sites
MRZ

Well, people are compiling the SA::Render , do anybody have it working ?

Please , if anybody have it compiled , please send the link to me , by PM or post the link here , i want to test it out confused.gif

Share this post


Link to post
Share on other sites
PetkaGtA

strange i thought, that someone of you guy can uncomment something to get shadows working... well i think i need to do some define to help you out biggrin.gif but i will do this only when i get some improvements(well some fixes) inside renderers

Share this post


Link to post
Share on other sites
Silent

 

strange i thought, that someone of you guy can uncomment something to get shadows working... well i think i need to do some define to help you out  biggrin.gif but i will do this only when i get some improvements(well some fixes) inside renderers

Didn't look into the code much.

 

EDIT:

Looks like computeshadowmap isn't enough, hm... Are lights defined properly in the code?

 

Forget that.

Edited by SilentPL

Share this post


Link to post
Share on other sites
PetkaGtA

 

Looks like computeshadowmap isn't enough, hm...

yep

 

half lighting = saturate(dot(normalize(lightDirection),normal)).x/*GetShadow(fSplitIndex, shadow)*/;

 

here is the main thing btw don't forget this

 

/*for(int i = 0;i<4;i++) { SAFE_RELEASE(shadowSurface[i]); SAFE_RELEASE(shadow[i]);}*/

 

and this

 

/* for(int i =0;i<4;i+=2){ 	if(!shadow[i]){   g_Device->CreateTexture(RsGlobal->MaximumWidth,RsGlobal->MaximumHeight,0,D3DUSAGE_RENDERTARGET,D3DFMT_R5G6B5,D3DPOOL_DEFAULT,&shadow[i],NULL);   shadow[i]->GetSurfaceLevel(0,&shadowSurface[i]); 	} } for(int i =1;i<4;i+=2){ 	if(!shadow[i]){   g_Device->CreateTexture(RsGlobal->MaximumWidth,RsGlobal->MaximumHeight,0,D3DUSAGE_DEPTHSTENCIL,D3DFMT_D24S8,D3DPOOL_DEFAULT,&shadow[i],NULL);   shadow[i]->GetSurfaceLevel(0,&shadowSurface[i]); 	} } */

 

Share this post


Link to post
Share on other sites
Silent

Yeah, I had all these except the shader - still, game just flashes when I launch it.

 

Something seems terribly butchered about that code too, these two D3DXMATRIX's which are passed to function are never initialised.

Share this post


Link to post
Share on other sites
Ivars

All I see are some strange codes and I have no idea what the hell is going on smile.gif But I'm sure you guys know what you are doing.

 

But for some reason I feel like all this is just too much for only few guys.

Share this post


Link to post
Share on other sites
cp1dell
Well, people are compiling the SA::Render , do anybody have it working ?

Please , if anybody have it compiled , please send the link to me , by PM or post the link here , i want to test it out confused.gif

Maybe you should leave it to the guys who actually know what they're doing. Too many people in this thread are compiling the .asi and complaining about it having problems. Well no sh*t. Petka didn't release the source code so you screwballs could "test it out." He released it so people like SilentPL can contribute to it and help.

Share this post


Link to post
Share on other sites
The_GTA
Well, people are compiling the SA::Render , do anybody have it working ?

Please , if anybody have it compiled , please send the link to me , by PM or post the link here , i want to test it out confused.gif

Maybe you should leave it to the guys who actually know what they're doing. Too many people in this thread are compiling the .asi and complaining about it having problems. Well no sh*t. Petka didn't release the source code so you screwballs could "test it out." He released it so people like SilentPL can contribute to it and help.

Testing is contributing. You prolly aint knowing who you are talking to.

Share this post


Link to post
Share on other sites
cp1dell
Well, people are compiling the SA::Render , do anybody have it working ?

Please , if anybody have it compiled , please send the link to me , by PM or post the link here , i want to test it out confused.gif

Maybe you should leave it to the guys who actually know what they're doing. Too many people in this thread are compiling the .asi and complaining about it having problems. Well no sh*t. Petka didn't release the source code so you screwballs could "test it out." He released it so people like SilentPL can contribute to it and help.

Testing is contributing. You prolly aint knowing who you are talking to.

Sure, people are able to test it out and find bugs, but it's barely even finished. I would understand if Petka released an already compiled script and wanted people to test it, but he didn't. He release the source code, so people can work on it with him.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.