Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (85,780 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

PatrickW

BugReport Topic V7.0.1

Recommended Posts

NexusUndead
Sometimes whan designing and you spawn a car it howers in edit mode wow.gif, but doesnt whan actually playing, though whan you edit the car during edit mode, the car goes back to the ground.

It's been like that for long now. It's nothing special, atleast it doesn't hover too high.

Yes, but it's still a bug.

Share this post


Link to post
Share on other sites
AlanCrytex

Why in v7 bomb is explode in same time?

I mean I make 6 bombs on streets and in v6 it will explode one by one but

in v7 it explode in one time.

I don't want that sad.gif

Share this post


Link to post
Share on other sites
PatrickW

The behavior in V6 was a bug, that was fixed. They were suppose to explode simultaneous.

If you want them spreaded, put timouts in between..

Share this post


Link to post
Share on other sites
Zizo008

sad.gif

I really needed that delay to make death runs from explosives. Sure it may come to the benefit of other designers, but please, if possible make another explosive object with the delay.

Share this post


Link to post
Share on other sites
lance1234ize

@PatrickW i don't wanna be all bitchy, but you really need to check out the link i gave you, there is a bug that freezes/quits your game in the middle of a player driveby.

Share this post


Link to post
Share on other sites
Stuntzman

A few things I should point out:

 

1. The weapon model is missing during driveby mode.

2. When adding an objective, the text from a previous cutscene is there, it's annoying to delete it.

3. Maybe it's just the way the SA engine is, but friendly actors with 'Leave nearest car' and are not driving the vehicle don't get in the car and then get out, they immediately run to the player. The driver does, however, drive the car.

The enemies with 'attack player' and 'leave nearest car' work fine.

4. The actors still drive quite erratically because of the new driving system.

Share this post


Link to post
Share on other sites
PatrickW

 

@Zizo008: timeouts might be able to solve your problem.

@lance1234ize: We will look into that

@stuntzman:

1) Yeah, That's the engine. It only shows the models for the weapons that can also be used for driveby in the normal game.. ( e.g. TEC9) Not much we can do there from SCM, as far as I know.

2) We will look into that

3) We will look into that

4) Yeah, this is the best we could tweak the engine todo from the context of SCM, concerning user defined routes. We will keep investigating this, and trying to find better ways.

Share this post


Link to post
Share on other sites
Zizo008
@Zizo008: timeouts might be able to solve your problem.

 

 

The problem is that it'll consume alot of objectives, and timeouts work a bit slower and the checkpoint will spawn only when they're over sad.gif

 

4) Yeah, this is the best we could tweak the engine todo from the context of SCM, concerning user defined routes. We will keep investigating this, and trying to find better ways.

I did this drive-by once on a highway, and even though he should stay on it in a certain routepoints, he leaves it, takes a turn and enters from a different place so that he drives back to it, sadly i don't have a DYOM file for it whatsthat.gif

I really don't understand anything about SCM, but when making missions with coding, they have a way to make them drive perfectly, is there any possibility to implement that "way" on DYOM?

Share this post


Link to post
Share on other sites
PatrickW

 

I really don't understand anything about SCM, but when making missions with coding, they have a way to make them drive perfectly, is there any possibility to implement that "way" on DYOM?

The "perfect driving", is done along predefined paths that are stored in fixed gamefiles.

We can't use that method for several reasons:

1) One of our design principles for DYOM, is that people can still play the original game unchanged.

2) Updating all those gamefiles when loading a new mission, is beyond the (our) power of SCM coding.

Share this post


Link to post
Share on other sites
Stuntzman
1) Yeah, That's the engine. It only shows the models for the weapons that can also be used for driveby in the normal game.. ( e.g. TEC9) Not much we can do there from SCM, as far as I know.

 

But what's the difference of actors drivebying and the player's drivebying, while the actors have weapon models?

Share this post


Link to post
Share on other sites
Zizo008

I'm not sure if this is a bug, but sometimes (or always i think) on V7, when we're doing cutscenes, if there's a teleport player objective, it shows him, then returns to the cutscenes, this is really bad to be honest, please fix it.

Share this post


Link to post
Share on other sites
PatrickW

Yeah, that's not really a bug, that's made that way, but I understand your problem. We'll look into it.

Share this post


Link to post
Share on other sites
NexusUndead
I'm not sure if this is a bug, but sometimes (or always i think) on V7, when we're doing cutscenes, if there's a teleport player objective, it shows him, then returns to the cutscenes, this is really bad to be honest, please fix it.

Yeah, that bug is annoyining, i noticed it too.

Share this post


Link to post
Share on other sites
Kwabs

I've a new bug for you. V7 crashes when you walk into an interior for some reason. This is a good example of it. When played with v6.1 not a single crash occurs, but when played with v7 it crashes when walking into the marker. I've some more examples, so this is clearly a v7 bug and not a bug in the mission.

Share this post


Link to post
Share on other sites
Kaydee.

When browsing the interiors list, some interiors are skipped.

For example, I'm in the interior 80, then I press Y and it leads me to interior 85, skipping some interiors.

 

Not sure if that is a bug, but it occurs when browsing other interiors too, also I'm not able to get to the interiors through DYOM menu.

 

I've got no mods besides DYOM, I'm using CLEO 3 and the version of my game is 1.0, it's not pirated of course.

Share this post


Link to post
Share on other sites
PatrickW
When browsing the interiors list, some interiors are skipped.

For example, I'm in the interior 80, then I press Y and it leads me to interior 85, skipping some interiors.

 

Not sure if that is a bug, but it occurs when browsing other interiors too, also I'm not able to get to the interiors through DYOM menu.

 

I've got no mods besides DYOM, I'm using CLEO 3 and the version of my game is 1.0, it's not pirated of course.

That's true, some interiors are intentionally skipped, as they caused unexplained crashes, teleporting into them. It has been this way for several versions.

Share this post


Link to post
Share on other sites
AlanCrytex

 

I'm not sure if this is a bug, but sometimes (or always i think) on V7, when we're doing cutscenes, if there's a teleport player objective, it shows him, then returns to the cutscenes, this is really bad to be honest, please fix it.

Yeah, that bug is annoyining, i noticed it too.

It happens to me too sad.gif

 

EDIT : Sometimes checkpoint is still visible although we already go to that checkpoint. It's not annoying but I hope you can fix it smile.gif

And the explosion. I want it explode one by one. I have try use timeout, it works but it may crash because of many objectives in mission.

Edited by apit2010

Share this post


Link to post
Share on other sites
PatrickW

 

And the explosion. I want it explode one by one. I have try use timeout, it works but it may crash because of many objectives in mission.

Dude, you now mentioned that more than enough times, and you had our answer. Keep coming up with that, and it makes you very annoying. icon13.gif

Share this post


Link to post
Share on other sites
Kwabs
I've a new bug for you. V7 crashes when you walk into an interior for some reason. This is a good example of it. When played with v6.1 not a single crash occurs, but when played with v7 it crashes when walking into the marker. I've some more examples, so this is clearly a v7 bug and not a bug in the mission.

And my bug was totally ignored even though this doesn't only occurs for me confused.gif

Share this post


Link to post
Share on other sites
NexusUndead
I've a new bug for you. V7 crashes when you walk into an interior for some reason. This is a good example of it. When played with v6.1 not a single crash occurs, but when played with v7 it crashes when walking into the marker. I've some more examples, so this is clearly a v7 bug and not a bug in the mission.

And my bug was totally ignored even though this doesn't only occurs for me confused.gif

It doesnt occurs to me, so it really doesnt occurs to everyone.

Share this post


Link to post
Share on other sites
Kwabs

I didn't say everyone, but it also occurs for Doublepulse and Zizo. So it's not just me.

Share this post


Link to post
Share on other sites
PatrickW
I've a new bug for you. V7 crashes when you walk into an interior for some reason. This is a good example of it. When played with v6.1 not a single crash occurs, but when played with v7 it crashes when walking into the marker. I've some more examples, so this is clearly a v7 bug and not a bug in the mission.

And my bug was totally ignored even though this doesn't only occurs for me confused.gif

Your bug wasn't ignored, but your description was clear enough, that it didn't need further information. We will of course look into all reported bugs.

Share this post


Link to post
Share on other sites
Doublepulse

Alright I found a somewhat annoying bug when creating objectives.

 

Most of you know that when you create an objective with text, then later decide to edit it, the text will remain there. The problem I have is when I start a new mission from scratch and create objectives, it saves the texts from other missions I created. So the text is already written, but it was for another mission. This annoying because in order to put new text I have to delete the old text first..

 

I hope the description was clear enough. Thanks a lot for looking at the bug reports and working on problems. Keep up the good work. icon14.gif

Share this post


Link to post
Share on other sites
guib
Most of you know that when you create an objective with text, then later decide to edit it, the text will remain there. The problem I have is when I start a new mission from scratch and create objectives, it saves the texts from other missions I created. So the text is already written, but it was for another mission. This annoying because in order to put new text I have to delete the old text first..

Had the same bug.

Share this post


Link to post
Share on other sites
ProtoZeroZ

So do i when im playing Apit`s MP

Share this post


Link to post
Share on other sites
NexusUndead
Most of you know that when you create an objective with text, then later decide to edit it, the text will remain there. The problem I have is when I start a new mission from scratch and create objectives, it saves the texts from other missions I created. So the text is already written, but it was for another mission. This annoying because in order to put new text I have to delete the old text first..

Had the same bug.

Yeah, and it's so damn annyoining whan you have written huge text, you need to hit backspace like 50 times.

Share this post


Link to post
Share on other sites
AlanCrytex

It always happen to me although I have deleted the save games (?????.dat)

Share this post


Link to post
Share on other sites
PatrickW

Yeas, confirmed.. will be fixed ..

Share this post


Link to post
Share on other sites
AlterMann

The problem with the text from the previous mission will be solved?

Sorry

Share this post


Link to post
Share on other sites
PatrickW

Yeah, but not not immediately, we're probably bunch it up with a couple of other issues that have and will pop up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.