Jump to content
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Updates
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. Grand Theft Auto Series

      1. Bugs*
      2. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Classic GTA SA
      2. Guides & Strategies
      3. Help & Support
    6. GTA Vice City

      1. Classic GTA VC
      2. Guides & Strategies
      3. Help & Support
    7. GTA III

      1. Classic GTA III
      2. Guides & Strategies
      3. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

    2. Support

    3. Suggestions

*DO NOT* SHARE MEDIA OR LINKS TO LEAKED COPYRIGHTED MATERIAL. Discussion is allowed.

IMG Organizer


fastman92
 Share

Recommended Posts

kamikami333

When I looked at the batch file, it did not support various environments, so I made the following changes.

 

@echo off

 

cd /d %~dp0
if exist IMG_organizer.log del /f IMG_organizer.log
if exist models\exported rmdir /S /Q models\exported

 

if "%PROCESSOR_ARCHITECTURE%" == "x86"   goto :32bit
if "%PROCESSOR_ARCHITECTURE%" == "AMD64" goto :64bit

 

:32bit
IMGconsole_32-bit\fastman92ImgConsole32.exe -script "IMG_organizer.ims" >> "IMG_organizer.log"
goto :End

 

:64bit
IMGconsole_64-bit\fastman92ImgConsole64.exe -script "IMG_organizer.ims" >> "IMG_organizer.log"
goto :End

 

:End
if exist models\exported rmdir /S /Q models\exported
pause
exit

Link to comment
Share on other sites

kamikami333

Found out why the game crashes while loading.
It's the "Modloader".
So, if you have Modloader installed, please add the following syntax to gta.dat.

 

# From archive: 'models\gta3.img'
IMG data\maps\veh_mods\veh_mods.img
IMG data\maps\leveldes\levelmap.img
IMG data\maps\leveldes\seabed.img
IMG data\maps\leveldes\levelxre.img
IMG data\maps\generic\procobj.img
IMG data\maps\country\countn2.img
IMG data\maps\country\countryN.img
IMG data\maps\country\countryS.img
IMG data\maps\country\countrye.img
IMG data\maps\country\countryW.img
IMG data\maps\country\counxref.img
IMG data\maps\SF\SFn.img
IMG data\maps\SF\SFs.img
IMG data\maps\SF\SFSe.img
IMG data\maps\SF\SFe.img
IMG data\maps\SF\SFw.img
IMG data\maps\SF\SFxref.img
IMG data\maps\vegas\VegasN.img
IMG data\maps\vegas\VegasS.img
IMG data\maps\vegas\vegasE.img
IMG data\maps\vegas\VegasW.img
IMG data\maps\vegas\vegaxref.img
IMG data\maps\interior\propext.img
IMG models\txd.img
IMG models\radar.img
IMG models\componentpeds.img
IMG models\weapons.img
IMG models\vehicles.img
IMG models\nodes.img
IMG anim\anim.img
IMG data\maps\generic\barriers.img
IMG data\maps\generic\dynamic.img
IMG data\maps\generic\dynamic2.img
IMG data\maps\generic\multiobj.img
IMG data\maps\generic\vegepart.img
IMG data\maps\LA\LAxref.img
IMG data\maps\LA\LAs.img
IMG data\maps\LA\LAs2.img
IMG data\maps\LA\LAe2.img
IMG data\maps\LA\LAe.img
IMG data\maps\LA\LAn.img
IMG data\maps\LA\LAn2.img
IMG data\maps\LA\LaWn.img
IMG data\maps\LA\LAw.img
IMG data\maps\LA\LAw2.img
IMG data\maps\LA\LAhills.img

 

# From archive: 'models\gta_int.img'
IMG data\maps\interior\props.img
IMG data\maps\interior\props2.img
IMG data\maps\interior\int_LA.img
IMG data\maps\interior\int_SF.img
IMG data\maps\interior\int_veg.img
IMG data\maps\interior\int_cont.img
IMG data\maps\interior\gen_int1.img
IMG data\maps\interior\gen_int2.img
IMG data\maps\interior\gen_intb.img
IMG data\maps\interior\gen_int3.img
IMG data\maps\interior\gen_int4.img
IMG data\maps\interior\gen_int5.img
IMG data\maps\interior\stadint.img
IMG data\maps\interior\savehous.img

Link to comment
Share on other sites

On 1/15/2022 at 4:10 PM, kamikami333 said:

When I looked at the batch file, it did not support various environments, so I made the following changes.

 

@echo off

 

cd /d %~dp0
if exist IMG_organizer.log del /f IMG_organizer.log
if exist models\exported rmdir /S /Q models\exported

 

if "%PROCESSOR_ARCHITECTURE%" == "x86" goto :32bit
if "%PROCESSOR_ARCHITECTURE%" == "AMD64" goto :64bit

 

:32
IMGconsole_32-bit\fastman92ImgConsole32.exe -script "IMG_organizer.ims" >> "IMG_organizer.log"
goto :End

 

:64
IMGconsole_64-bit\fastman92ImgConsole64.exe -script "IMG_organizer.ims" >> "IMG_organizer.log"
goto :End

 

:End
if exist models\exported rmdir /S /Q models\exported

pause exit

Your code does not work (Windows 11). Can you help please?

Link to comment
Share on other sites

kamikami333
19 hours ago, SLM said:

Your code does not work (Windows 11). Can you help please?

Are you running the batch file as administrator?

Link to comment
Share on other sites

17 hours ago, kamikami333 said:

Are you running the batch file as administrator?

Yes, but nothing happens. The bat file doesn't even start. The bat file from fastman runs, but does not find the path.

Link to comment
Share on other sites

kamikami333
2 hours ago, SLM said:

Yes, but nothing happens. The bat file doesn't even start. The bat file from fastman runs, but does not find the path.

Please do the following to confirm.
1. delete "@echo off" from the batch file.
2. run the batch file again (as administrator).
3. then upload the image like I did.

 

spacer.png

Link to comment
Share on other sites

I have already tried removing "@echo off". But the bat file still won't open.

Edited by SLM
Link to comment
Share on other sites

1 hour ago, kamikami333 said:

Please do the following to confirm.
1. delete "@echo off" from the batch file.
2. run the batch file again (as administrator).
3. then upload the image like I did.

 

spacer.png

I have already tried removing "@echo off". But the bat file still won't open.

Link to comment
Share on other sites

kamikami333
1 hour ago, SLM said:

I have already tried removing "@echo off". But the bat file still won't open.

Enable "SMB 1.0 / CISF File Sharing Support" under "Control Panel \ Programs \ Turn windows features on or off".

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.