Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (84,674 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Silent

[REL|OpenSrc] Silent's ASI Loader

Recommended Posts

Silent

I even tried to reinstall GTA San Andreas through Steam but it seems like it doesn't automatically install the infamous dxwebsetup :lol:.

Yeah it doesn't, even though newsteam versions REQUIRE it. gj R*

Share this post


Link to post
Share on other sites
BlackScout

 

I even tried to reinstall GTA San Andreas through Steam but it seems like it doesn't automatically install the infamous dxwebsetup :lol:.

Yeah it doesn't, even though newsteam versions REQUIRE it. gj R*

 

xD, R* vision.

By the way, I'm very unlucky and had problems with Windows again, so everything I did was reverted.

It seems Visual C++ 2013/2010 was needed too, I also did that before, should have mentioned.

Also, don't you think it's a good idea to state this in OP? Just in case someone faces the same problems :)

Share this post


Link to post
Share on other sites
Silent

Also, don't you think it's a good idea to state this in OP? Just in case someone faces the same problems :)

But it's plugins which require it, not the loader.

Share this post


Link to post
Share on other sites
TH_009

HEY !! DO YOU HAVE ASI LOADER for GTA VICE CTY :sly:

 

Share this post


Link to post
Share on other sites
OG Viking

In order to install it, you just need to place both DLL files into game directory, overwriting the old files.

Both DLL files? I can only see one DLL file, where is the other?

 

 

I unpack silents_asi_loader_13.zip and I get this:

 

 

silents_asi_loader_13 containing:

advanced_plugin_management_example

scripts

ReadMe.txt

vorbisHooked.dll

Should I copy all these items into the game directory?

 

EDIT: This is for San Andreas.

Edited by OG Viking

Share this post


Link to post
Share on other sites
Blackbird88

Then you downloaded it wrong somehow. There should be vorbisFile.dll too Redownload it from GTAG again.

Edited by Blackbird88

Share this post


Link to post
Share on other sites
OG Viking

Then you downloaded it wrong somehow. There should be vorbisFile.dll too Redownload it from GTAG again.

I downloaded it again, and Norton ate vorbisFile.dll. It may be a false positive, but it could also be infected. :/

 

The threat is called WS.Reputation.1.

 

 

Edit,

Am I supposed to copy everything and not just the two DLLs into the San Andreas folder? I've read the instruction but it's a bit fuzzy and not clear enough for a newbie.

Edited by OG Viking

Share this post


Link to post
Share on other sites
DoggeMetter

NICE

Edited by DoggeMetter

Share this post


Link to post
Share on other sites
Gasmon

Hello, i need your help guys.

Is there any way to use this loader, but to rename vorbisFile.dll to something else, ex: vorbisFile1.dll?

Or, how to edit sensfix.asi to load this renamed file vorbisFile1.dll instead of original vorbisFile.dll?

Please if anyone can help me i will pay you becouse this is wery important to me.

Share this post


Link to post
Share on other sites
LINK/2012

Hello, i need your help guys.

Is there any way to use this loader, but to rename vorbisFile.dll to something else, ex: vorbisFile1.dll?

Or, how to edit sensfix.asi to load this renamed file vorbisFile1.dll instead of original vorbisFile.dll?

Please if anyone can help me i will pay you becouse this is wery important to me.

Use Ultimate ASI Loader I guess?

Share this post


Link to post
Share on other sites
Gasmon

 

Hello, i need your help guys.

Is there any way to use this loader, but to rename vorbisFile.dll to something else, ex: vorbisFile1.dll?

Or, how to edit sensfix.asi to load this renamed file vorbisFile1.dll instead of original vorbisFile.dll?

Please if anyone can help me i will pay you becouse this is wery important to me.

Use Ultimate ASI Loader I guess?

 

Man... you are my hero.

Share this post


Link to post
Share on other sites
Firzo

Any idea why this doesn't work with 1.0 US exe?

Everytime my game loads up all I get is a screen like that in the background, only that it overlays all objects and all I can see is text & hud.

https://i.ytimg.com/vi/afFVDfRuPJg/hqdefault.jpg

 

It works with 1.0 EU exe..

Edited by Firzo

Share this post


Link to post
Share on other sites
bidh

I'm using the 1.0 EU exe but I keep getting errors with some asi, like improved-vehicle-features or fast loading and SilentPatch 1.1 Build 26
but not with limit adjuster.

I even tried the compact exe but the errors still showed up.

It's on XPSP3 computer...

 

I'm completely at loss.

 

Error when silentpatch files are in GTASA folder

 

 

AppName: gta_sa.exe AppVer: 0.0.0.0 ModName: silentpatchsa.asi
ModVer: 0.0.0.0 Offset: 00007301

 

 

Error when silentpatch folder is in modloader folder

 

 

Mod Loader has started up!

Opening file for streaming "MODELS\GTA3.IMG"

Game version: GTA SA 1.0 EURO
Unhandled exception at 0x02507301 in SilentPatchSA.asi (+0x7301): 0xC0000005: Access violation reading location 0x00000000.
Register dump:
EAX: 0x00000000 EBX: 0x00000000 ECX: 0x00000000 EDX: 0x00C9ACF0
EDI: 0x00000018 ESI: 0x00000000 EBP: 0x0023FA5C EIP: 0x02507301
ESP: 0x0023F904 EFL: 0x00210206 CS: 0x0000001B SS: 0x00000023
GS: 0x00000000 FS: 0x0000003B ES: 0x00000023 DS: 0x00000023

Stack dump:
0x0023F904: 00000000 00000000 00000000 00000000 00000000 00000000
0x0023F91C: 00000000 00000000 00000000 00000000 00000000 00000000
0x0023F934: 00000000 00000000 00000000 00000000 00000000 00000000
0x0023F94C: 00000000 00000000 00000000 00000000 00000228 00000000
0x0023F964: 00000000 00000000 00000000 00000000 00000000 00000FA0
0x0023F97C: 0000B261 01D743D0 0023F9A0 7C920A36 00000186 01D743D0
0x0023F994: 01D70000 01D739C8 00000000 0023FA74 01D70178 0023FA74
0x0023F9AC: 7C920981 01D70608 7C92005D 00000FA0 0082AD65 00C9ACF0
0x0023F9C4: 0023F9FC 00836F15 00000007 00836F0D 00000018 00000000
0x0023F9DC: 00000000 00B71AE0 0023F9D4 01D70178 0023FBD4 00825EE4
base: 0x00040000 top: 0x0023F904 bottom: 0x00240000

Backtrace (may be wrong):
=>0x02507301 in SilentPatchSA.asi (+0x7301) (0x0023FA5C)
0x7C8106D8 CreateRemoteThread+0x1dc in kernel32.dll (+0x106d8) (0x0023F9B8)
0x0082AD65 in gta_sa.exe (+0x42ad65) (0x00000FA0)

 

 

Share this post


Link to post
Share on other sites
gts.

I'm using the 1.0 EU exe but I keep getting errors with some asi, like improved-vehicle-features or fast loading and SilentPatch 1.1 Build 26

but not with limit adjuster.

I even tried the compact exe but the errors still showed up.

It's on XPSP3 computer...

 

 

 

I'm completely at loss.

 

Error when silentpatch files are in GTASA folder

 

 

AppName: gta_sa.exe AppVer: 0.0.0.0 ModName: silentpatchsa.asi

ModVer: 0.0.0.0 Offset: 00007301

 

 

Error when silentpatch folder is in modloader folder

 

 

Mod Loader has started up!

Opening file for streaming "MODELS\GTA3.IMG"

Game version: GTA SA 1.0 EURO

Unhandled exception at 0x02507301 in SilentPatchSA.asi (+0x7301): 0xC0000005: Access violation reading location 0x00000000.

Register dump:

EAX: 0x00000000 EBX: 0x00000000 ECX: 0x00000000 EDX: 0x00C9ACF0

EDI: 0x00000018 ESI: 0x00000000 EBP: 0x0023FA5C EIP: 0x02507301

ESP: 0x0023F904 EFL: 0x00210206 CS: 0x0000001B SS: 0x00000023

GS: 0x00000000 FS: 0x0000003B ES: 0x00000023 DS: 0x00000023

 

Stack dump:

0x0023F904: 00000000 00000000 00000000 00000000 00000000 00000000

0x0023F91C: 00000000 00000000 00000000 00000000 00000000 00000000

0x0023F934: 00000000 00000000 00000000 00000000 00000000 00000000

0x0023F94C: 00000000 00000000 00000000 00000000 00000228 00000000

0x0023F964: 00000000 00000000 00000000 00000000 00000000 00000FA0

0x0023F97C: 0000B261 01D743D0 0023F9A0 7C920A36 00000186 01D743D0

0x0023F994: 01D70000 01D739C8 00000000 0023FA74 01D70178 0023FA74

0x0023F9AC: 7C920981 01D70608 7C92005D 00000FA0 0082AD65 00C9ACF0

0x0023F9C4: 0023F9FC 00836F15 00000007 00836F0D 00000018 00000000

0x0023F9DC: 00000000 00B71AE0 0023F9D4 01D70178 0023FBD4 00825EE4

base: 0x00040000 top: 0x0023F904 bottom: 0x00240000

 

Backtrace (may be wrong):

=>0x02507301 in SilentPatchSA.asi (+0x7301) (0x0023FA5C)

0x7C8106D8 CreateRemoteThread+0x1dc in kernel32.dll (+0x106d8) (0x0023F9B8)

0x0082AD65 in gta_sa.exe (+0x42ad65) (0x00000FA0)

 

 

 

 

You need GTA SA 1.0 US not EU.

Edited by gts.

Share this post


Link to post
Share on other sites
bidh

You need GTA SA 1.0 US not EU.

 

Not according to the readmes but I tried with the US and the compact exes to be sure.

Share this post


Link to post
Share on other sites
Blackbird88

Just because ASI loader supports 1.0 EU doesn't mean the ASI mods you use support it.

Share this post


Link to post
Share on other sites
Shooter Hex

Can you show the changelog from 1.2 to 1.3?

Share this post


Link to post
Share on other sites
Silent

Updated to work with the new sh*tty SA Steam EXE.

The only change is the addition of GetStartupInfoW hook - earlier EXEs use GetStartupInfoA.

Edited by Silent

Share this post


Link to post
Share on other sites
Shooter Hex

@Silent Thx :pp

Share this post


Link to post
Share on other sites
lpgunit

 

Updated to work with the new sh*tty SA Steam EXE.

The only change is the addition of GetStartupInfoW hook - earlier EXEs use GetStartupInfoA.

 

Was it because of Unicode versus ANSI differences?

Share this post


Link to post
Share on other sites
REv01

Hey Silent. Thanks for making this loader. I'm having a bit a problem with installing it though. As you are obviously aware; In the zip folder there are two .DLL files vorbisFiles.dll and vorbisHooked.dll and the install instruction says copy and replace TWO files in the root directory.

My problem is that I only have one of those files (vorbisFiles.dll) in my root directory. the other one is simply called vorbis.dll. I'm using the latest steam version (bought 2 days ago)

 

What would I do to get the loader to work in this situation. I tried just putting them in there replacing vorbisFiles.dll and simply adding the other one (vorbisHooked.dll) but that doesn't seem to do anything. Any help would be greatly appreciated :)

Share this post


Link to post
Share on other sites
Barto

Hello, I installed this Loader on actually Steam version, and mods like your Silent Patch and Searchlights don't working, why?

Share this post


Link to post
Share on other sites
Ash_735

Because even though the LOADER works with Steam exe's, the actual mods themselves still need to support the exercise and sadly most mods do not as they'll only target HOODLUM (pirate exe) or Compact exe.

Share this post


Link to post
Share on other sites
muh linucs

Should I use "scripts" folder for .asi files or always place them in the main game directory? Or does it make difference whatsoever?

Edited by Binding of Isaac

Share this post


Link to post
Share on other sites
Light Syde Riandy

Why I experienced errors in certain missions like messed up in game cutscenes in "Cut Throat Business".

Share this post


Link to post
Share on other sites
KyleSforza

This might be the weirdest bug that has been brought to your attention. Not sure if its just me. :p

 

But my game won't load / crashes whenever I install this and your patch. Game is clean, I follow this -

 

Install SA from Steam

Downgrade it using this - http://gtaforums.com/topic/753764-steam-downgrader/

Use SA:MP using this - http://steamcommunity.com/sharedfiles/filedetails/?id=190532454

The ASI loader

The Patch

 

and game starts crashing at launch as soon as I put the patch in the directory (without opcodes) just the "GTA has stopped working" error.

 

Any solutions?

Share this post


Link to post
Share on other sites
Ingramsl19

Silent,But I Use the ASI Loader on GTA SA but ASI Loader cannot load MTA SA Like This:

7pSBewL.png

How to fix This?

 

And Vice City? [VC-MP]

MSG: Blocked plugin 'gtavc.widescreenfix.asi', ASI mods are not allowed in VC:MP

I Know, Before I Place to Silent's ASI Loader to C:\Program Files (x86)\MTA San Andreas 1.5\MTA work or doesn't work for me

Edited by SSRenz

Share this post


Link to post
Share on other sites
Jinx.

I think those errors are self-explanatory enough.

Share this post


Link to post
Share on other sites
ULTIMANTE.CVNT

So I have new Steam version. Will this ASI loader let me use CLEO mods?

Share this post


Link to post
Share on other sites
Ash_735

So I have new Steam version. Will this ASI loader let me use CLEO mods?

No, even though the ASI loader works with the EXE, CLEO does not.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.