Jump to content

GTA IV Loading Screen Loop


iGtaV

Recommended Posts

So it starts off great gets through the rockstar logos and the gta iv logo fine gets to the menu I hit start login its great up until the loading screen with characters come It sits there and loops the music plays for hte first 2 loops then the music turns off the character slideshow still goes. At this point I'm aggrivated I've search the internet for answers im getting no great help or answers from former topics. ROCKSTAR ITS BEEN f*ckING 4 YEARS HAVE A FIX OUT OR SOMETHING. THIS IS FOR PC...

 

Specs

 

HDD: 500gb

Ram: 4gb

Processor: Intel Pentium® Dual-Core CPU E5400 @ 2.70ghz 2.70ghz

Graphics: Intel® G45/G43 Express Chipset All DirectX Feature enabled..

 

Link to comment
Share on other sites

What is your graphics card? Oh, right I see, I don't think it will run well on that, if at all.

Edited by luceberg
Link to comment
Share on other sites

I bought the game off of Rockstars Official Amazon account, there are no mods installed on it. The game is practically installed brand new I literally got it today around 12:00pm and I've sat in front of my computer for 6 hours trying to figure out why it keeps looping sad.gif

Link to comment
Share on other sites

lydianduck

I think your problem is caused by having vsync enabled, disable it through the graphics menu, once you enter the game you can enable it again, it's a bug in the engine of the game.

 

If you do not have vsync in your graphics menu it means you haven't updated your game, update it to 1.0.7.0 or preferably to patch 1.0.4.0 since it's the most performance friendly.

 

Give it a try, im almost certain it'll fix it!

Link to comment
Share on other sites

the other poster had it right both times imo. the original poster is trying to run the game off some intel onboard video, like x3100. original poster, don't waste our time here if you can't pay attention. the game won't load because of video incompatibility. get a real graphics card, even a 9500gt or hd 6670 will let you start the game, so you can tweak the settings.

Link to comment
Share on other sites

the other poster had it right both times imo. the original poster is trying to run the game off some intel onboard video, like x3100. original poster, don't waste our time here if you can't pay attention. the game won't load because of video incompatibility. get a real graphics card, even a 9500gt or hd 6670 will let you start the game, so you can tweak the settings.

No, in this particular case the game has most probably not been updated and since v-sync is (again, most probably) turned on, it loops on the loading screen. It's a known issue.

 

Once it does start, I'm sure it will run like crap.

Link to comment
Share on other sites

so as most of you are sayin disable v sync which i have and im stil erroring so i guess its time for a good or atleast decent graphics card, seems

good enough thanks everyone for the help does clear things up

Link to comment
Share on other sites

if you have a vanilla install and your game is new , the only thing i see it's that a firewall is doing crap somewhere , somehow

 

edit : just seen your specs , it's more likely your graphics , man . you should seriously think of upgrading your stuff

Edited by jpm1
Link to comment
Share on other sites

If you post the make and model of the pc, we could find out if it will take a graphics card.

 

Otherwise, just take the side off and look for a graphics card slot, also what is written on the psu.

 

Better still, build a new pc, if you can afford it, or buy an xbox/ps3.

Link to comment
Share on other sites

I know yous will laugh and sh*t but I have a Dell Inspiron i560-2050nbk everything inside is what came from the factory and i have been lookin into graphics cards i have a 16x PCI Express slot for graphics

Link to comment
Share on other sites

mobiles have their advantages but they have inconvenients too , that's how it goes . hope you'll be able to update soon smile.gif

Link to comment
Share on other sites

Dells are usually terrible for upgrading as they don't leave a lot of wiggle space. Usually, when you upgrade anything at minimum you need to change the PSU.

Link to comment
Share on other sites

Dells are usually terrible for upgrading as they don't leave a lot of wiggle space. Usually, when you upgrade anything at minimum you need to change the PSU.

not necessarily . i have a i3 with a 5770 and i still have my Corsair CX400 . but that's a top notch psu and i've removed my DVD drive that i use once a year too , and i disconnect my 3 backup HD when i don't use them which is 99% of the time . i have W7 home pre and it runs very smooth . if i don't use a feature/hardware it's systematically removed/uninstalled

Link to comment
Share on other sites

So lately I've been looking at this Graphics Card, I haven't seen it in person yet but it looks very good and it looks like my PSU will be able to take the load its going to be put under after I put this graphics card in.

 

The graphics card I'm looking at is Galaxy - GeForce GT 610 2gb DDR3 PCI Express 2.0 Graphics Card.

 

What I'm trying to figure out is this graphics card going to fit my 16x PCI Express, I just don't want to buy something and bring it home and come to find out it won't fit sad.gif If you guys know any websites that have Graphics Card at the price of 56.99 or less and support PCI Express 16x that will help alot! biggrin.gif

Link to comment
Share on other sites

That GPU is about 25% better then what you have currently. I don't think you can find a decent upgrade for $57, at least not a new card.

 

This is the only item that I could find which fits that price range and could be considered a gaming device, not new http://www.newegg.ca/Product/Product.aspx?...N82E16814150594

Edited by mkey82
Link to comment
Share on other sites

Purpeltendire

Accidentally edited this post out, here is my recreation of it. tounge.gif

 

This isn't a hardware issue.

 

I too bought the game through Amazon and downloaded it via Amazon Games Downloader. Near the end of the install, the file "C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV\pc\models\cdimages\componentpeds.img" comes up as corrupted, followed by a warning that the installer is not verified. I proceeded to ignore the warning and finish the installation. After finishing, I started the game and let Windows Live update to 1.0.7.0. Then I proceeded to the main menu and loading screen before experiencing the same loop and freeze that the OP had.

 

My system:

AMD Phenom II X4 965 BE @ 3.8GHz

2x EVGA GTX 260 Core 216 in SLI. Driver 301.42

8 GBs Crucial Ballistix 1866MHz 9-9-9-24

Western Digital Caviar Black 1TB 7200RPM

Antec 850W PSU

Windows 7 64-bit.

 

Obviously my hardware can handle the game.

 

If someone could upload the componentpeds.img to a MediaFire account somewhere and either post or PM a link, that would be much appreciated.

 

Thanks in advance,

--Purpeltendire.

Edited by Purpeltendire
Link to comment
Share on other sites

seems the DVD version of the game has lot of issues . i bought myself on Steam , never had any problem

Link to comment
Share on other sites

Purpeltendire

Okay. I found a copy of the file here: LINK and replaced the one that is in the directory with the downloaded file. I was able to launch the game and make it past loading! Only to encounter an issue where I would either get stuck on the Loading The Brothers Bellic screen, or load into a random area with the Platypus ship and no objectives or pedestrians/other characters at all.

 

I've heard that 1.0.7.0 doesn't work without a savegame, would this have anything to do with it?

 

Yes, this game is fraught with bugs.

 

--Purpeltendire

Link to comment
Share on other sites

You'll have to contact Amazon about their freaking installer, others had that problem as well. Your best bet is to claim your money back and buy the game from Steam or in retail.

 

That information about patch 7 needing the savegame is incorrect.

Link to comment
Share on other sites

Purpeltendire

Yep, I have. Waiting to hear back via email from Amazon CS right now actually. And then I'll go back to waiting for the game to go on sale on Steam again! tounge.gif

 

Alright, thanks.

Link to comment
Share on other sites

Purpeltendire

Although Amazon doesn't offer refunds for game downloads, they were nice and refunded me because of the problem. So that was nice of them, +1 for their customer service too.

Link to comment
Share on other sites

  • 3 weeks later...

I have the DVD Version, sorry for grave digging just been on vacation. Also I found some good graphics card 2.0 pci express and there like 80 bucks from best buy customer reviews are great to so I think Im just going to grab one of those and see what happens.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.