Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Garju67

[WIP|IV-EFLC] GTA III Rage Classic

Recommended Posts

Garju67
Just wondering: What'll happen to the closed tunnel upon Shoreside Vale? That tunnel what's blocked with Roadblocks (And heard by rumors leads to another city). Gonna close it too, or make the feature Rockstar didn't show there?

Nope closed too. wink.gif

Share this post


Link to post
Share on other sites
Wass

 

Ok update on my issues, I realised I was playing the IV version of SA:IV yesterday, I am having the same buildings disappearing etc on IV:SA too so whatever my issue is it's with the EFLC version only.

That's weird,cuz I have this problem only on 3RC but IV:SA works normally without any disappearings tounge.gif (both of eflc and iv versions)

@Blaster:you can open the demo "anim" archive and replace the walk/sprint anim only tounge2.gif

Edited by Wass

Share this post


Link to post
Share on other sites
Jestic

 

Ok update on my issues, I realised I was playing the IV version of SA:IV yesterday, I am having the same buildings disappearing etc on IV:SA too so whatever my issue is it's with the EFLC version only.

That's weird,cuz I have this problem only on 3RC but IV:SA works normally without any disappearings tounge.gif (both of eflc and iv versions)

@Blaster:you can open the demo "anim" archive and replace the walk/sprint anim only tounge2.gif

I know how to do it, I just didn't thought of it in time, it's not needed anymore when there is no update planned.

Share this post


Link to post
Share on other sites
SNAKE DOC
It's the Copmodel. Spawn the LSPD Cop with SNT: Crash.

Nice find mister!

 

Here's a quick-fix: copy 'componentpeds.img' from "EFLC\TBoGT\pc\models\cdimages" to "EFLC\TLAD\pc\models\cdimages" and the same crash shouldn't occur. I had the cops chasing and shooting at me for 15 ish min with no crashes.

Share this post


Link to post
Share on other sites
Sebianoti
Fake lights ? What you mean ?
+1

I've been wondering what they're referring to ever since someone first mentioned it a couple weeks ago. From what i've seen, all IIIRC and IVSA lights use the same method that vanilla GTAIV uses: traditional lights inside the wdr file.

Hmm, well whenever you run into a lamp post the light never goes out, it's also weirdly floating once you run into it, they don't fall over like in IV

Share this post


Link to post
Share on other sites
Compeast
Just wondering: What'll happen to the closed tunnel upon Shoreside Vale? That tunnel what's blocked with Roadblocks (And heard by rumors leads to another city). Gonna close it too, or make the feature Rockstar didn't show there?

Nope closed too. wink.gif

Okay, thanks!

 

@Blaster_nl What PM? Empty inbox *forever alone* lol

Share this post


Link to post
Share on other sites
_Rob_

Just a visual example of the buildings disappearing bug, this time no traffic spawned at all, other than that everything was fine, I explored Sal's mansion for a bit and then everything started disappearing, jumped off the cliff and died, the image below is right after spawning at the hospital.

 

user posted image

Share this post


Link to post
Share on other sites
Garju67
Just a visual example of the buildings disappearing bug, this time no traffic spawned at all, other than that everything was fine, I explored Sal's mansion for a bit and then everything started disappearing, jumped off the cliff and died, the image below is right after spawning at the hospital.

 

user posted image

Ah damn, i had the same bug with GTA2 Rage. Never found a way to fix it... confused.gif

Share this post


Link to post
Share on other sites
_Rob_

Damn, it'eird that it loads generic objects fine though, but the most odd thing is that I only seem to get this issue with the EFLC version of SA:IV and not the Vanilla IV.

 

Will be interesting to see if the IV version of III Rage Classic will work for me or not.

Share this post


Link to post
Share on other sites
Garju67
Weird that it loads generic objects fine though, but the most odd thing is that I only seem to get this issue with the EFLC version of SA:IV and not the Vanilla IV.

 

Will be interesting to see if the IV version of III Rage Classic will work for me or not.

Indeed. I guess beta testing will start soon. If you are ok, i can make a application. So ?

Share this post


Link to post
Share on other sites
Frank.s

Due to the fact that lamp posts load, it seems to be an issue with the map files that are loaded as "streamed" instead of "always loaded".

Open your images.txt (or equivalent on mod/dlc) and change all 0 to 1, 0 is streamed and 1 is always loaded.

Also, maybe the problem is caused by bad img files? If you feel like doing a bunch of crap that might not even work: extract all files from the imgs and make new empty imgs and add all the stuff back in. monocle.gif

Share this post


Link to post
Share on other sites
Garju67

user posted image

 

tounge.gif

Reminder : We really need a vehicle converter. Please people help us, and join the team now ! smile.gif

Share this post


Link to post
Share on other sites
wahgah

can anyone give me a heads up on what walk and run are in the anim.img? I don't see those key words in there.

 

EDIT:: didn't realise that player_move was both walk and run, thought I could have johnny walk and niko run...

Edited by wahgah

Share this post


Link to post
Share on other sites
SNAKE DOC
can anyone give me a heads up on what walk and run are in the anim.img? I don't see those key words in there.

 

EDIT:: didn't realise that player_move was both walk and run, thought I could have johnny walk and niko run...

Actually, you can. By using this script by HippieCommunist. I've always disliked the way they run in EFLC, so this script has come in handy.

Share this post


Link to post
Share on other sites
Squirlkiller

i called them fake lights, because of the texture. it just looked "fake" seeing the texture of the light never rotate when you moved. And the fact that the texture doesn't seem to be centered with where the light should be emitted Also because I remember in IVSA beta 2, when you knocked over a lamppost, the light stayed on while it was falling (and possibly when on the floor as well), where as in IV, it turns off right when you crash it

Share this post


Link to post
Share on other sites
Dingleman

Finally got it working, and it was definitely worth the hassle. With the RAGE lighting, walking around the streets felt like a first time experience all over again. This has to be the first time since 2001 that the city has seemed so dark and intimidating to me, and it's really brought out some sweet nostalgia. blush.gif

 

Took a couple of pictures.

 

user posted image

 

user posted image

 

user posted image

 

Great job converting this guys, and especially Garju.

Share this post


Link to post
Share on other sites
nkjellman

In that first pic, it looks like Claude is waring makeup.

Share this post


Link to post
Share on other sites
yurban

 

user posted image

This screen is very good, just bad that ground textures are ugly, is it possible to replace them?

Edited by yurban

Share this post


Link to post
Share on other sites
Frank.s

Great pictures. I agree with yurban about the roads too, too much specular destroying the texture.

Share this post


Link to post
Share on other sites
Compeast

Indeed, those screens make LC look intimidating. I love it.

Share this post


Link to post
Share on other sites
yurban
user posted image

 

Cool, but strange lights on cranes, also night windows must be real tobj and have other (night ver.) textures.

Share this post


Link to post
Share on other sites
Frank.s
night windows must be real tobj and have other (night ver.) textures.

Why not night ver.+emissivenight shader? It seems to look ok in those screenshots. However they are a bit too bright, lower the multiplier or the vertex colors please garju. smile.gif

Share this post


Link to post
Share on other sites
yurban
night windows must be real tobj and have other (night ver.) textures.

Why not night ver.+emissivenight shader? It seems to look ok in those screenshots. However they are a bit too bright, lower the multiplier or the vertex colors please garju. smile.gif

I mean that not whole window should be bright, just glass, its possible just with tobj, you can't set standart +night texture in one model.

Share this post


Link to post
Share on other sites
Frank.s

Ah i see what you mean: the vertex coloring method lights up the window frames and other incorrect things which can be fixed with custom tobj objects.

Share this post


Link to post
Share on other sites
_Rob_
Due to the fact that lamp posts load, it seems to be an issue with the map files that are loaded as "streamed" instead of "always loaded".

Open your images.txt (or equivalent on mod/dlc) and change all 0 to 1, 0 is streamed and 1 is always loaded.

Also, maybe the problem is caused by bad img files? If you feel like doing a bunch of crap that might not even work: extract all files from the imgs and make new empty imgs and add all the stuff back in. monocle.gif

I'm having trouble finding the "images.txt" with the lines you talked about.

Share this post


Link to post
Share on other sites
Frank.s

The equivalent file for the IVSA version might be in pc/ivsa/img/ folder, try that. icon14.gif

Share this post


Link to post
Share on other sites
yurban
The equivalent file for the IVSA version might be in pc/ivsa/img/ folder, try that. icon14.gif

Does it change game performance on not so powerful PCs?

 

And guys, sorry for late question - are there xbox textures in mod? Why do roads look so?

Share this post


Link to post
Share on other sites
Frank.s

 

Does it change game performance on not so powerful PCs?
I don't think so, the kb/mb size of the map is so small (especially compared to IV's LC) that it shouldn't cause issues to constantly have it loaded. But that's just a theory.

Share this post


Link to post
Share on other sites
_Rob_

Yes you are right about the location, so I can test that for IV:SA, but as for 3RC I think the right file is "C:\Program Files\Rockstar Games\EFLC\TLAD\III\img\images_iii.txt" The contents of which are below, but unlike the SA one there are no 0's or 1's to change.

 

 

III/img/script_iii

common/data/cdimages/script_network

common/data/cdimages/carrec

 

pc/anim/cuts

pc/anim/cutsprops

pc/anim/anim

 

pc/data/maps/props/E1_xref

 

pc/models/cdimages/componentpeds

pc/models/cdimages/pedprops

III/vehicles/vehicles_iii

III/weapons/weapons_iii

 

pc/data/cdimages/navmeshes

III/vehicles/paths_iii

pc/data/cdimages/scriptTxds

III/img/radar_iii

 

III/map/industNE/industNE

III/map/industNW/industNW

III/map/industSE/industSE

III/map/industSW/industSW

III/map/mono/mono

III/map/portroads/portroads

III/map/props/ext_veg

III/map/props/salc

III/map/props/making

III/map/props/temppart

III/map/props/vegapart2

III/map/props/bridge_demo

III/map/props/comlod_demo

III/map/props/limits_demo

III/map/props/nitelites

III/map/props/lights

III/map/props/wtd_indust

 

 

Also another interesting screen showing generic objects and traffic spawning this time

user posted image

Share this post


Link to post
Share on other sites
Dingleman

 

[snap]

This screen is very good, just bad that ground textures are ugly, is it possible to replace them?

I'd say the fact my texture settings were on medium are partly to blame.

 

Here's from another angle on high.

 

user posted image

 

Oh, and by chance, on my first attempt to snap this in the editor lightening just so happened to flash. So I couldn't help but make a GIF. tounge2.gif

 

user posted image

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • 1 User Currently Viewing
    0 Members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.