Jump to content

GTA IV FPS Problem


CoDeZ

Recommended Posts

Hello..

Before i start describing the problem here is my specs:

 

MB : Asrock H61M-HVS

CPU : Intel Core i3 2100 3.10 GHz

GPU : Asus Geforce GTX 550ti OC ( Stock )

RAM : 4GIG ( 2x2 )

 

 

I Installed GTA IV ( With No Patches ) recently on my pc

 

Se-ted the Settings to this and ran the Benchmark Tool.

 

Statistics

Average FPS: 53.67

Duration: 37.40 sec

CPU Usage: 73%

System memory usage: 72%

Video memory usage: 85%

 

Graphics Settings

Video Mode: 1024 x 768 (85 Hz)

Texture Quality: High

Render Quality: Very High

View Distance: 45

Detail Distance: 46

 

But Yet whenever i turn on the shadow density the game lags and my fps drops down

Also when i turn on the car lights ( By pressing H during morning )

Fps Drops down to 20...

 

Googled that problem so i found that i have to upgrade to v 1.0.7.0

But then the textures got messy its like i am running into a wall without seeing it.

 

So What can i do about it?

Is it because i got a 2 Core CPU instead of 4?

And what is that commandline thingy? i don't really get it ..

 

Help ASAP Please.

Link to comment
Share on other sites

 

But Yet whenever i turn on the shadow density  the game lags and my fps drops down

Also when i turn on the car lights ( By pressing H during morning )

Fps Drops down to 20...

 

Googled that problem so i found that i have to upgrade to v 1.0.7.0

But then the textures got messy its like i am running into a wall without seeing it.

 

I know the answer for this. The answer is: Commandline.txt.

 

Make a txt file "Commandline.txt" without double inverted comma. Add these data:

 

 

-height 800 (Default)-width 600 (Default)-DX9/high-noprecache-renderquality 2-shadowdensity 8-texturequality 1-viewdistance 56-detailquality 77-novblank-percentagevidmem 100-availablevidmem 2.0 (Don't go more than 18.0!)-novblank-stereo-framelimit 0-noswapdelay-forcer2vb-monspecaudio-norestriction-noprecache -safemode -fullscreen-memrestrict 188743680-memrestrict 209715200-memrestrict 230686720 -minspecaudio-fullscreen-usedirectinput

 

 

Remember, set the height and width as per your wish. (I don't think so. tounge.gif)

You can also keep availablevidmem at any rate but not higher than 18.0 or your PC will fry. devil.gif

 

It should work.

 

 

Edited by Dr. John13
Link to comment
Share on other sites

Thanks Dr.John but wooaaah.

what the hell is availablevidmem ?

 

and why should i add all these memstricts? shouldn't i have only one?

and why should i add these settings while i can configure them from inside the game?

Link to comment
Share on other sites

Why can't u just update the game ?

Because the textures gets f*cked up and making the game more lame to play.

Link to comment
Share on other sites

Well, actually, I should have asked it before only but what is the space in your Video card?. I am serious, if your Video card's space is less, your RAM (I guess) will become hot and it will damage the system. Well, these are used when some textures are missing. This is just the start. If I will tell you the whole step then we will only complete after a fortnight. tounge.gif

 

This should work, if any error comes, please post it here. Also, download this application-

 

Contig.exe (Google it)

 

Here are the steps what to do-

 

Download Contig.exe, a defragmentation file, and place it in the GTA 4 root directory. Create a shortcut to the file on the desktop, go to the shortcut's properties, and add " -s" to the end (without the quotation marks [space at the front]). Now run the shortcut.

 

The Contig.exe file defragments the GTA 4 directory, causing a HUGE performance boost in the game.

 

 

 

 

Link to comment
Share on other sites

Will Download the file and try then answer here

 

MY VGA Space is 1GB

And i disagree with you.

How can you explain to me then the pro rig which have like 16 Gigs of ram and only the space of their VGA is 2 gigs?

 

Link to comment
Share on other sites

Because I happen to get this problem too. I found many of them experienced this type of problem. Commandline.txt should be kept in GTA 4 Folder. It should work fine. Yes, if the rig is good enough like mine 4GB then it shouldn't cause much heating but the video card which you have of 1GB may get affected. Keep everything at the lowest settings and turn off the Clip Capture for more Fraps. This Contig helps in increasing the speed of the game.

Link to comment
Share on other sites

Well thanks the game runs smoothly now but still some stuttering when i change the camera with mouse

I'll See those -memstrict thingy

Link to comment
Share on other sites

 

memstrict thingy

They are called memory restriction. If you telling that while turning mouse, it lags then I suggest you to keep your resolution low and patch your game to latest 1.0.7.0 Version. I can't help anymore as I am out of ideas, so unh happy gaming. tounge.gif

Edited by Dr. John13
Link to comment
Share on other sites

What did you do? Did you patch your game? I thought everything was fine. confused.gif

Link to comment
Share on other sites

Patched it to 1.0.7 then those lame textures kept disapperin tryed to downgrade to 1.0.4 but still disappering.. confused.gif

Link to comment
Share on other sites

Hmm... Re-Install the game. Actually the patch should fix some bugs. I guess you don't need a patch. Just do what I said and don't patch. Everything should be fine.

Link to comment
Share on other sites

Did you do something more? Like added any mod? Oh! BTW, did you buy the game?

Link to comment
Share on other sites

Erm no i didnt mod it

my friend bought this game and i took his DVD's And installed it biggrin.gif

 

Anyways i finished the game biggrin.gif

Link to comment
Share on other sites

Are you using CD while playing or using any No-CD Crack?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.