Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

fastman92

IMG Limit Adjuster

Recommended Posts

Eminem Jeff

I tried to install SRT3 v1.7 mod with your tool ,it worked in gta sa

 

And I tried to install Project_Oblivion_2010HQ mod with your tool ,it worked in gta sa too.......

 

The problem is when I install them both with your tool(First SRT3 V1.7 mod then Project_Oblivion_2010HQ mod) it crashed in loading screen (Around 50 or 60%)

 

In readme(Project_Oblivion_2010HQ mod) said"For the installation you need any IMG editor, but if you want to use the mod with SRT3 Continue V1.7, you must use only

"Alci's IMG Editor 1.5" or "IMG Manager V.1.5".

 

Open archive GTA3.img (Games\GTA San Andreas\models) and replace the original files on the files from the

Folder gta3img, from the archive with the mod. Then rebuild the archive after the change is required.

 

Note: if you want to use the mod with SRT3 Continue V1.7, then you must:

1. Install SRT3 first.

2. Next install Project oblivion.

 

then copy "gta_sa.exe", data and models folders into GTASA folder (For example: C:\Games\GTA San Andreas).

Confirm the change "

 

How can I do to install both mods with your tools without errors?

 

P.s I had tried and tried many times by following your steps to install mods and keep failing and failing (like this situation) again............

Share this post


Link to post
Share on other sites
BLlTZ

Seriously, why do you think xmen IMG Tool is actually causing your game to crash. You don't know how to make them both work and what you need is to learn. You really don't know how to replace things ?

 

Oh, wait wrong thread, scuse me for that.

But I still don't get it, you come here to post for IMG Manager or fastman tool, there are differences, you know.

Edited by -BLITZ-

Share this post


Link to post
Share on other sites
fastman92

 

I tried to install SRT3 v1.7 mod with your tool ,it worked in gta sa

 

And I tried to install Project_Oblivion_2010HQ mod with your tool ,it worked in gta sa too.......

 

The problem is when I install them both with your tool(First SRT3 V1.7 mod then Project_Oblivion_2010HQ mod) it crashed in loading screen (Around 50 or 60%)

 

In readme(Project_Oblivion_2010HQ mod) said"For the installation you need any IMG editor, but if you want to use the mod with SRT3 Continue V1.7, you must use only

"Alci's IMG Editor 1.5" or "IMG Manager V.1.5".

 

Open archive GTA3.img (Games\GTA San Andreas\models) and replace the original files on the files from the

Folder gta3img, from the archive with the mod. Then rebuild the archive after the change is required.

 

Note: if you want to use the mod with SRT3 Continue V1.7, then you must:

1. Install SRT3 first.

2. Next install Project oblivion.

 

then copy "gta_sa.exe", data and models folders  into GTASA folder (For example: C:\Games\GTA San Andreas).

Confirm the change "

 

How can I do to install both mods with your tools without errors?

 

P.s I had tried and tried many times by following your steps to install mods and keep failing and failing (like this situation) again............

Actually it's BLITZ's fault that he put filenames with different cases than original filenames.

For example:

 

BLITZ's name: CornerStore_LOD.dff

Original name: cornerstore_lod.dff

 

Of course GTA SA game is case insensitive and works. The problem comes when using IMG editors, including IMG Organizer where it finds names with case sensitivity to export & remove.

I wrote my little PHP script to rename files back to original names:

 

<?php$originalFilenames = Array();foreach (new DirectoryIterator('original') as $file){if(!$file -> isDot())$originalFilenames [] = $file -> getFilename ();}unset($file);$originalFilenamesLowered = array_change_key_case($originalFilenames, CASE_LOWER);$iterator = new RecursiveIteratorIterator(new RecursiveDirectoryIterator('GTa San Andreas .Lod Mod\files'),                                             RecursiveIteratorIterator::CHILD_FIRST);            foreach($iterator as $file){ if(!$file -> isFile()) continue; $id = array_search(strtolower($file->getFilename()), $originalFilenamesLowered);  if( $id !== FALSE ) { echo "<br/>".$file->getPathname()." -> ".$file->getPath().'\\'.$originalFilenames[$id]; rename($file->getPathname(), $file->getPath().'\\'.$originalFilenames[$id]); }}?>

 

Here is BLITZ's last version of DLC with fixed names: http://www.mediafire.com/?hwhq57wg8wp44iy

Valid to install along with IMG Organizer.

Edited by fastman92

Share this post


Link to post
Share on other sites
BLlTZ

I hope this method with low caps will work to him, otherwise what you uploaded was done in vain. Can't wait to see if this is really working, then I will see what I will do for another setup and another upload.

Share this post


Link to post
Share on other sites
Apu889

using IMG Organizer 2.0 .

where the gates? notify.gif

 

user posted image

 

im not install any map mods. just install a few car mods before this happen. confused.gif

Share this post


Link to post
Share on other sites
magnum-WG

IMG Limit Adjuster is incompatible with Maps folder changes, if you install PO2010 & SA .Lod Mod, your game'll crash, but then if you delete *asi of IMG LA, your game'll work ok.

 

Share this post


Link to post
Share on other sites
Nori Yaro

I tried using it but I get a crash at 50 % game load

gta.dat

## Load IDEs first, then the models and after that the IPLs#IMG DATA\PATHS\CARREC.IMGIMG DATA\SCRIPT\SCRIPT.IMGIMG MODELS\CUTSCENE.IMGIMGLIST DATA\IMAGES.TXTSPLASH loadsc2#.............

 

 

images.txt

 

CLEO\SKIN.IMGMODELS\CARS.IMGMODELS\CARS2.IMG

 

also tried using with the 'img' infront

Share this post


Link to post
Share on other sites
juanma_16

Hi. It worked fine for me.

But my question is, what should i do if the mod i want to install adds more than 2 GB of files? In readme it says it doesn't work with 2 GB or more img files.

Share this post


Link to post
Share on other sites
fastman92
Hi. It worked fine for me.

But my question is, what should i do if the mod i want to install adds more than 2 GB of files? In readme it says it doesn't work with 2 GB or more img files.

It's about IMG Organizer, caused by SparkCS.exe.

You should export & remove some files to Desktop/temporary to keep gta3.img size under 2 GB.

Run IMG Organizer.bat. gta3.img will be shrunk.

Open gta3.img using IMG editor, restore files from Desktop/temporary.

Run IMG Organizer.bat again.

Enjoy game.

Share this post


Link to post
Share on other sites
juanma_16

Mmm, not worked. When i load my game it never start after loading the bar.

 

Edited by juanma_16

Share this post


Link to post
Share on other sites
MRZ

for me it doesn't work

i have problem with the US .exe version

tried the US version and the PO 2010 , PO 2007 nothing worked

why?

Share this post


Link to post
Share on other sites
fastman92

I sent you PM, please collaborate with me to find a exact reason of crash, i cannot understand anything from "it doesn't work".

Share this post


Link to post
Share on other sites
Drathian

These all work great for me, cept they don't work for sa-mp afaik FYI: cause samp statically gets the list of img's doesn't get it from gta.dat or default.dat.

 

I love the tool. Only suggestion which i'm not certain sparkcs supports is an auto-rebuild of all the img files after the updates are done via IMG_Organizer.bat ; it does save small amounts of space and keep corruption down.

 

Just in case anyone else trys fastman92's source is compatible with delphi but not lazarus (freepascal delphi clone). I noticed this when i attempted to

add other exe's to the list via:

 

 

begincase PByte($400088)^ of  $CA:;  $D0:;  $8A:;      else      MessageBoxA(0,PChar('Sorry, but this version of gta_sa.exe is not supported'+#13+                   'Supported EXEs:'+#13+                   '    1.  GTA San Andreas v1.0 [uS] HOODLUM No-CD  Fixed EXE:'+#13+                   '         EXE size:  14 383 616 bytes'+#13+                   '    2.  GTA: San Andreas v1.01 [EURO] No-CD/Fixed EXE:'+#13+                   '         EXE size: 15 806 464 bytes'+#13+Footer_comunique),                   'SA Multi version Limit Adjuster error!',MB_OK);      ExitProcess(0);end;

 

 

While the check works fine, it seems adding other exes might need the address calls changed since i get a crash after start, i'm not about to attempt that, i'm not that good of coder.

 

I was attempting to add the Hoodlum 1.0 eu, Hoodlum 1.0 eu patchfx fix, and the 1.1 eu edition. (I was also going to try gta_sa_compact.exe (uses $CA also) however I can't ever get it to run on windows 7-64x stupid directx error) Seems that the Hoodlum 1.0 us is still the most stable version.

 

P.S. i don't think there ever was a cracked 2.0 (second edition) or 3.0 (steam) exe, but I can get the 2.0 with full security if you want it.

Edited by Drathian

Share this post


Link to post
Share on other sites
fastman92
These all work great for me, cept they don't work for sa-mp afaik FYI: cause samp statically gets the list of img's doesn't get it from gta.dat or default.dat.

 

I love the tool. Only suggestion which i'm not certain sparkcs supports is an auto-rebuild of all the img files after the updates are done via IMG_Organizer.bat ; it does save small amounts of space and keep corruption down.

 

Just in case anyone else trys fastman92's source is compatible with delphi but not lazarus (freepascal delphi clone). I noticed this when i attempted to

add other exe's to the list via:

 

P.S. i don't think there ever was a cracked 2.0 (second edition) or 3.0 (steam) exe, but I can get the 2.0 with full security if you want it.

Right, address might need to be changed for another address that would contain unique value, i considered 4 gta sa exes only when writing this function.

 

SparkCS can't rebuild. I recently released "fastman92 IMG Console" where following commands were added.

-rebuild

or this

-rebuildIfMoreUselessSpaceThen 31457280

 

Now i need to update IMG Organizer to use my own IMG Console and will use rebuildIfMoreUselessSpaceThen to rebuild an archive.

 

Please send me gta_sa.exe 2.0 and gta_sa.exe 3.0 if you can. It doesn't need to be cracked.

Share this post


Link to post
Share on other sites
andre011710

hei,fastman.Why every time i put the ImgLimitAdjuster.asi it crash. angry.gif But i put the other asi script it`s work fine!!!?? biggrin.gif

Any solution??

Share this post


Link to post
Share on other sites
fastman92

1. What is size of gta_sa.exe in bytes.

2. When it crashes?

3. Why is your information so vague?

Share this post


Link to post
Share on other sites
HowardGees

Sorry,im New,and Brazilian colgate.gif

 

I Have an Ask.

 

My SA-MP Closes automatically after installing this mod.

 

 

I think it's because of GTA3.IMG

 

 

How do I solve this?

 

Share this post


Link to post
Share on other sites
kira1995

Is there any easier step by step tutorials or am I doing something wrong? I watched the youtube vid by Yuni Anto, Did everything exactly the same as the vid showed to get this and the organizer installed but it always fails and my img organizer batch file only finishes after 2 seconds instead of 5 minutes like he has. Then He ends up with so many other folders while nothing in mine has changed. Am I missing anything? Cleo 4 and IMG tool is already installed correcly.

 

Using version 1.00.00001

Downloaded the 1.0 (US) e.x.e or whatever it was called from another place. (tried installing with and without)

Have bought the actual pc game, not pirated. =/

 

 

Maybe pictures of where the folders and files are would help me? Idk .-. . Here's the link to the vid I watched.

 

 

Share this post


Link to post
Share on other sites
fastman92

I have been informed about this problem by many of Vista/Seven users, though batch files work for me exactly like they should.

 

To run IMG organizer:

after you copied all neccessary files like in the video, open command prompt AS ADMINISTRATOR.

type it:

cd /d C:\Program Files\Rockstar GAMES\GTA San Andreas

 

put a path of your GTA SA here.

 

type it:

IMG_organizer.bat

press Enter.

 

IMG organizer should work.

Share this post


Link to post
Share on other sites
kira1995

Trying it now, I'll let you know if I got it working later ^^". Still gotta practice on how to do the mods afterwards.

Share this post


Link to post
Share on other sites
kira1995

Ok, looks like it's working now. Haven't installed any mods to it yet though but it still runs ok and I got the new img files n stuff in there. Just gotta figure out how to add the mods to it later when I find some. smile.gif Also, thanks for the help Fastman!

Share this post


Link to post
Share on other sites
fastman92

 

Ok, looks like it's working now. Haven't installed any mods to it yet though but it still runs ok and I got the new img files n stuff in there. Just gotta figure out how to add the mods to it later when I find some. smile.gif Also, thanks for the help Fastman!

it's easy, just put them to gta3.img / gta_int.img depending on where they should have been placed.

Run IMG_Organizer.bat once again.

Run game and test if it works.

Share this post


Link to post
Share on other sites
kira1995

How to know what mods go in which? I mean the gta and the gta int.

Share this post


Link to post
Share on other sites
fastman92
How to know what mods go in which? I mean the gta and the gta int.

gta3.img / gta_int.img

How do you know? It's a simple question. How to the present time you knew where to put mod files?

With IMG Organizer it's the same.

 

In case of the uncertainty you can always open IMG_Organizer.txt and verify where the imported file belongs to (gta3.img / gta_int.img)

Share this post


Link to post
Share on other sites
kira1995
How to know what mods go in which? I mean the gta and the gta int.

gta3.img / gta_int.img

How do you know? It's a simple question. How to the present time you knew where to put mod files?

With IMG Organizer it's the same.

 

In case of the uncertainty you can always open IMG_Organizer.txt and verify where the imported file belongs to (gta3.img / gta_int.img)

Well, I only know how to mod my player so far to play as something else, Haven't ever figured out the vehicles and ect. I sorta just wanted to do like the maps and jutsus and all like others I've seen. So far the game crashes when I use certain things. Does it have to do with the SAMI installer? I've tried putting in a certain mod without the organizer or the adjuster using SAMI but it also crashed. Was just testing it to see if it would do something, just got curious of what would happen. I wanted the limit adjuster because I wanted unlimited modding, like the new maps and stuff. Idk if you seen that Naruto ENB Series thing on youtube or not but sorta what I wanted to aim for. And I just really can't figure out what I need to do t get it to work. (first time really modding) Do you think I'm missing something? I've got like the 1.0 hoodlum u.s. exe no disc or whatever it's called, 13.7mb. Sorry to bother you so much. confused.gif

 

Besides that I've got the Sannybuilder, Cleo 4 ,img limit adjuster, and the organizer. My version is 1.00.00001. (Not sure if that's the 1.0 that every1 says you need before you try modding anything, never found any downgraders for that.)

Share this post


Link to post
Share on other sites
markueschen

hello fastmann92,

IMG Organizer.bat not respond at work.Administrators is disabled. I have my Vista 32-bit operating system on a laptop.GTASA version 1.0 Exe (us Hoodlum) and cleo 4.2. Imgadjuster limit included 3.0.how can I edit solution?mfg markueschen please help me that I make time Windows 7 64-bit also same. sad.gif

Share this post


Link to post
Share on other sites
fastman92
hello fastmann92,

IMG Organizer.bat not respond at work.Administrators is disabled. I have my Vista 32-bit operating system on a laptop.GTASA version 1.0 Exe (us Hoodlum) and cleo 4.2. Imgadjuster limit included 3.0.how can I edit solution?mfg markueschen please help me that I make time Windows 7 64-bit also same. sad.gif

Try this solution: http://www.gtaforums.com/index.php?showtop...st&p=1062396097

Tell me if it works/doesn't work.

Share this post


Link to post
Share on other sites
markueschen
Try this solution: http://www.gtaforums.com/index.php?showtop...st&p=1062396097

Tell me if it works/doesn't work.

Ok, I've found something.cmd not working correctly. That hot "input requirement is Adminator is disabled.there always says a popular key would not care button pressed and finished.there is a mistake somewhere in the operating system.I could not even write a cd.

Share this post


Link to post
Share on other sites
markueschen
Try  this solution: http://www.gtaforums.com/index.php?showtop...st&p=1062396097

Tell me if it works/doesn't work.

Ok, I've found something.cmd not working correctly. That hot "input requirement is Adminator is disabled.there always says a popular key would not care button pressed and finished.there is a mistake somewhere in the operating system.I could not even write a cd.

Now I've done. Error was Vista operating system. confused.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.