Jump to content
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Los Santos Drug Wars
      2. Updates
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Blood Money
      2. Frontier Pursuits
      3. Find Lobbies & Outlaws
      4. Help & Support
    3. Crews

    1. Grand Theft Auto Series

      1. Bugs*
      2. St. Andrews Cathedral
    2. GTA VI

    3. GTA V

      1. Guides & Strategies
      2. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA San Andreas

      1. Classic GTA SA
      2. Guides & Strategies
      3. Help & Support
    6. GTA Vice City

      1. Classic GTA VC
      2. Guides & Strategies
      3. Help & Support
    7. GTA III

      1. Classic GTA III
      2. Guides & Strategies
      3. Help & Support
    8. Portable Games

      1. GTA Chinatown Wars
      2. GTA Vice City Stories
      3. GTA Liberty City Stories
    9. Top-Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. Red Dead Redemption 2

      1. PC
      2. Help & Support
    2. Red Dead Redemption

    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. Design Your Own Mission
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Announcements

    2. Forum Support

    3. Suggestions

[REL|SA] GTA San Andreas .LOD Mod


Recommended Posts

  • 2 weeks later...


Objects and parts of map disappear here


user posted imageuser posted imageuser posted image


Same bug was somewhere in the LV, but I forgot to take some screenshots of it. And what is strange...these disappearance is not always show up.


Back from where we left.

I really have no idea the cause of this. I mean, I'm flying with the jetpack in circles for over five minutes while using project oblivion trees.

Link to comment
Share on other sites

Yeah I was getting this as well; but used render.cs from Skript47, which avoided objects/trees/buildings from disappearing.


But, I do get the 'bug' where parts of the map disappear. See 1st and 2nd screenshot, in the distance on the left hand side, a bit of the map has disappeared. I suffer from this; and haven't found a fix for it yet. So, I tend to stay on the ground, and don't go up high @ all.

Link to comment
Share on other sites

Could this possible be from fastman stream to cause this only to some systems since we don't use any other tool that increases our limits. Is not that I accuse fastman for that, but you get the idea. Anyone else tried 256 or 1024 instead of 512 ?


I also finished fixing all the reported posts. Tomorrow I will update and in two days or so, the update will be at Moddb.

Link to comment
Share on other sites

So your saying you suffer from this 'bug' as well?


It even happens with the .asi version of the StreamMemFix.


I stopped using the CLEO version because of this reason :


Some people suffer from it, others do not. It can take anywhere from 5min-1hour for the bug to start happening for me.

Fastman92 thinks its an IDE/IPL limit problem. He was working on his own version of a Limit Adjuster; but he has so many projects on the go at the moment, that not much progress is happening.

Link to comment
Share on other sites


So your saying you suffer from this 'bug' as well?


No I don't suffer, that's why. However, I hit the limit back then with the Hospital in Los Santos, textures where starting to go nuts. And this is coming only from IPL limits since back then all I did was to add 300 new IPLs.

Link to comment
Share on other sites

  • 11 months later...

First page updated. I cleaned and sorted everything. Compact and more easy to be read. I apologize for any kind of misunderstanding words, setence or phrase, on of my English.


Mod is out.




* Moddb Website

* Moddb Download Link

Edited by BLlTZ
  • Like 3
Link to comment
Share on other sites

Installed everything as instructed, it looks good, all the bugs I've noted on previous versions have been fixed. But I'm getting a lot of holes on map.

Link to comment
Share on other sites

Do you have fliker, 512MB.cs installed, rebuild archive ?

Link to comment
Share on other sites

Can you take some photos of the crime scene ?

Link to comment
Share on other sites

Yeah, you're right. I will verify because something I did wrong when I sorted everything.


Got it. Go to 'put into gta3.img' -> STREAM.IPL and take vegasn_stream3 & vegasn_stream4 from that folder and replace them.


It seems that these two files from SA Lod Mod With Trees -> 'put into gta3.img' are in fact bugged coming from an older test of mine. I don't know how the manage to get there, but it did. I forgot. And take Also vegasn.ipl from Without Trees version.



I will make another setup. It seems that I confused stuff last night. Too night, late time hour.


Okay, another installer was uploaded on Moddb and waiting approval.




New Download Link! Moddb guys are extraordinary


Edited by BLlTZ
Link to comment
Share on other sites

Well... I've tried to isntall it about 10 or more times... That was amazing. I mean I've thought I'm really idiot. I was afraid even only to think about it - that setup files has some errors. Whole day is gone but if it will work now - you've done a great job, Blitz! Even if my game will crash again =)

Link to comment
Share on other sites

Like what ?

Link to comment
Share on other sites

SA Lod Mod With Trees


A lot of holes - just though whole map. I've tried all of fastmans' scripts, Alexander's plugins and even map_render_fix by skript47. But nothing helps =( I've got standart timecyc.dat.


And just one issue - you can't see it on screen but sometimes (only in planes\helis) the map inside radar ring is just disappears. It likes the empty circle with icons inside it - but there is no radar texture.






Edited by little_idiot
Link to comment
Share on other sites

Like what ?


Don't know, you tell me. In this updated setup you just changed some files for the "With trees" version, right? I don't use the "with trees" version, so I don't need to reinstall nothing, at least I think so.

Link to comment
Share on other sites

* There's another 'Put into gta3.img' folder in this version "With Trees". These Binary Stream.IPL files are different configurated from the onces from the version "Withou Trees". When installing
from the main 'Put into gta3.img' folder with the other threes folders included inside, don't choose the specific three files, but instead use these from the "With Trees" version.


Yeah, I wrote kinda fast.

There is a difference between this two version on stream binary so had to separate them in some way and I had to remake and rename the folder with the same name "put into gta3.img" to understand where those 3 files go . Once you installed all of those files from the main (139MB) excluding lae2_stream0 & sfn_stream0 & vegasn_stream0, you have to go to "With Trees" folder and from there you have to choose these three files, because the other three are actually for the normal Lod Mod which don't have trees.


little_idiot, = flicker.asi, cleo4, stream512mb.cs,

Link to comment
Share on other sites


little_idiot, = flicker.asi, cleo4, stream512mb.cs,


Yes, of course - this combination I've tried right after the install (as it is in readme file: flicker.asi, cleo4, stream512mb.cs). Results on first 3 screens.


After I tried just different combinations of flicker.asi, 512\1024\2048.cs with CLEO 4\CLEO 4.2\Newest CLEO 4.3 - nothing changes (other screens). And I've got another plugins and scripts (about 20) - they work properly and surely there are no conflicts between them - I checked it long ago. Something is going wrong, but I can't understand what =(

Edited by little_idiot
Link to comment
Share on other sites

Have you tried matrix.asi from the bonus of 2dfx ? Somewhere there is a conflict. What you are showing there is definitely stream not being activated.


To be sure about, install a clean game and ONLY SA LOD and nothing else somewhere else in your hard and that means you will have two SA games in your PC. I think the DVD/game installer can allow you install the game mutiple times.


At least I have two SA games in my HDD, one for test and one for playing.

Link to comment
Share on other sites

Well I have four SA games in my HDDs, one for test, one for playing, other two - for different mods. I've reinstalled game just after first attempts to install LOD Mod, so the game is clear. After new downloading I've tested only 2dfx Project 1.6 and it worked fine. So I've just added .LOD Mod to it but I still have that "holes".


The only one thing that is different - I don't modified my gta3.img (I'm using VSAi) so all the .LOD Mod files is placed inside the folder (even not img-archive) and asi-plugin loads it to the game (like gta3.img). Maybe the reason is hidden inside this feature but this really will be the first time when I face any troubles with this plugin. I need more time to check it because it takes a long time for my PC to delete\add 4k files to gta3.img and then rebuild it. I will give report tomorrow.

Thanks for response!

Link to comment
Share on other sites

Okay. Le'me install on clean game SRt3+Lod Mod and see if I get as well.

(Morning to all)


I remember about something. Did any of you installed ASI Loader as well, from the new CLEO4 ?

Edited by BLlTZ
Link to comment
Share on other sites

Yes. It seems that I'm getting the same problem while plaing with Srt3 + Lod Mod. But I never got this before. I think I modified the game too much. I will see what I can do to fix this.



Also, after a long talk with Link yesterday night, today I tested both mods with this Modloader and they are being accepted.


For example. Make a folder and named it SA LOD Mod and inside move exactly how they are "Put into gta3.img" & "SA Lod Mod With Trees" or "Without trees" (everyone what what version likes)

Path should be like this.


modloader/SA LOD Mod/Put into gta3.img

modloader/SA LOD Mod/SA Lod Mod With Trees



modloader/SA LOD Mod/SA Lod Mod Without Trees


And the same goes for SRt3. Just moved the folder.



Link to comment
Share on other sites

Well, this is really strange but now all works properly! I don't know why - it's a secret for me and I can't explain it =)


First I've tried only modloader and my game was crashing in the middle of load-bar with follow error (in log file):

"Unhandled exception at 0x00534134 in "G:\Grand Theft Auto - San Andreas\gta_sa.exe": 0xC0000005: Access violation reading location 0x00000000.
Calling loader.Shutdown();


After I just added VSAi plugin - so actually now I got 2 x LOD Mod files in my game folder (one for VSAi and one more for modloader). I start the game - and there are no holes in the map more! Yeah!


I don't know how, I don't know why - but now everything is OK. Need time to find out the reasons.




Updated: The holes still appears - a lof of in LS and SF. But LV and Countryside don't have it. Very strange things. Hmm...

Edited by little_idiot
Link to comment
Share on other sites

Yes and I think I know why.


From the early years of modding, I notice that there is a script (I don't know how to call it exactly) that is being use to minimize the visuals of the game while flying or using jetpack even when the game is unmodified. The further you accelerate with the speed, the quick all of the generic objects will disappear and as well when you get higher in the sky. This is something that I've notice a long time when I was doing small mod installments like vehicles and such.


If you use S/back arrow for Jet to slow the speed, all the objects will start to appear shortly as the engine of the game start to have some kind of free space to process back all of those objects or it's blocked by a script/command to process the objects at certain point. I activated all the commands from Twaker while using Srt3 with mipmaps and Lod Mod with trees, the game doesn't have enough power to process everthing fast. At least this is how I understand. Is too heavy modified, we have to recognized this.


So far, I don't know what to do to fix this, because it seems that there is no tool/program/command to solve the problem while flying.

Link to comment
Share on other sites

Hey Blitz, I found something funny, without trees version


There's some kind of invisible barrier in this part of the map



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.