Jump to content

resource usage problem


8monster

Recommended Posts

SPECS

 

Processor Intel® Core i7-2760QM CPU @ 2.40GHz, 2401 Mhz, 4 Core(s), 8 Logical Processor(s)

 

Installed Memory: 8.00 GB (7.90 GB usable)

 

Graphics Card: NVIDIA GeForce GT 555M

 

My problem is http://img51.imageshack.us/img51/7217/gtai...11218060748.png

 

58 mb.....come on, i believe GTA is trying to run the game with my Intel Graphics Accelerator even tho i have it set to run with my NVIDIA in nvidias control panel. any help into why its doing this would be great, thanks!

 

Link to comment
Share on other sites

Put -norestrictions in commandline.txt in the root of the GTA4 installation directory. If commandline.txt does not exist, create it.

DU8afL0.jpg

Link to comment
Share on other sites

(double check that i did what you said properly) went to C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV and made a text document directly in there called "commandline" where i typed "-norestrictions" and saved it, still getting the same problem

Link to comment
Share on other sites

Have you created a specific profile for "LaunchGTAIV.exe" in Nvidia Control Panel to tell it to use Nvidia graphics? i.e. not just use the global setting to specify it.

 

Are you using any graphics mods? More specifically, those that require you to place d3d9.dll in the directory? These will never work with the Nvidia card regardless of how you set it up.

DU8afL0.jpg

Link to comment
Share on other sites

in NVIDIAS control panel in program setting i have launchgtaiv.exe set to run with the High Performance NVIDIA processor and i just installed the game on this brand new computer and havent installed any mods and dont see that file in the directory

Link to comment
Share on other sites

Add this line to your commandline arguments "-adapter" (use the specified screen adapter number (zero based).

The Hardware Device Manager will tell you what "device" number is assigned to which adapter so you can enter the correct value for the command line.

Good Luck.

 

edit: I've also had problems in the past when running my onboard graphics alongside my addon card with dual monitors. Sometimes the machine wants to use the onboard as the main adapter no matter how I setup the display properties.

Edited by Majormodz
Link to comment
Share on other sites

in the device manager i see PCI bus 1, device 0, function 0...so would my number be 0? and the commandline.txt should be

-norestrictions-adapter0

or am i wrong?

Link to comment
Share on other sites

Yes, device 0.

But make sure each argument is on it's own line, like this.

 

-norestrictions

-adapter 0

 

I hope it works for you.

 

edit: If you'd like to see the entire list of arguments, add -help to your commandline.txt

I just took a screen of the list for future reference, then removed the argument so the game would launch.

Edited by Majormodz
Link to comment
Share on other sites

I ended up electing to disable my onboard in the bios, and now run my 2nd monitor from my Dual DVI GT 440.

 

I'll re-post if I come across anything else that "might" help.

A second monitor is almost manditory when trying to complete stunt jumps and pigeons.

Edited by Majormodz
Link to comment
Share on other sites

With -norestrictions in the commandline you should be able to raise the graphics options past the artificial limits.

DU8afL0.jpg

Link to comment
Share on other sites

thanks for your help so far guys, but im still getting just 58 mb of usable vram and every setting stuck on absolute lowest. this is because its running with my Intel Chip correct? i also tried updating the driver from device manager but it said i was at my latest version, comps brand new anyway. any other ideas would be appreciated. i played this game for years on an ATI Mobility Radeon HD 4650 with vista and would really like to play with some fps increase

Link to comment
Share on other sites

Disable the onboard in the bios at start-up. I'm betting you'll get a different result on your next launch of the game. Not to mention the extra system resources you'll be freeing up by doing so.

Link to comment
Share on other sites

well since this computer is brand new i really dont want to go editing the bios and disabling things. their is no command to force my game to run with my card?

 

Link to comment
Share on other sites

 

well since this computer is brand new i really dont want to go editing the bios and disabling things. their is no command to force my game to run with my card?

You won't be able to disable it in the BIOS anyway if it's even there, considering the two GPUs inside the laptop (intel and nvidia with optimus) work together (in a sense) to display the output to the screen.

 

If it were a desktop even then you wouldn't have to go and disable it in the BIOS because your monitors would be plugged in the back of your graphics card and thus make use of that primarily.

 

You are on the latest drivers, just to make sure? I don't know what else you could try; the game works fine on my Optimus laptop after I add the custom profile into the control panel.

 

 

I'm betting you'll get a different result on your next launch of the game.

Yep. A black screen before even getting past POST. sigh.gif

DU8afL0.jpg

Link to comment
Share on other sites

ya i suspected having my windows run on a gaming card only would not be a good idea, via device manager it says its at the latest version but i also downloaded a driver manager which scanned and also said it was at its latest version which is 8.17.12.6959

 

ive also tried updating it via nvidias site, when it tries to detect what card i have it cant and when i manuely choose the 500m series, 555m, etc. it directs me to a download that once i download just tells me the NVIDIA installer cant continue because it could not find compatible graphics hardware

Edited by 8monster
Link to comment
Share on other sites

well ive made some progress, after updating the card directly from its directory using setup.exe, i started up the game and the options were still set to low and the vram was still 58 mb but they WERE adjustable now, so i click recommended settings and it puts everything on high my resolution on highest and my distances to 40-50. every thing applied with the vram STILL at 58 mb. but when i started a game and the flashing images of characters loading screen came up it never got past that, just continued

the flashing people, never loads. my guess is even tho its letting me adjust the setting and measuring my recommended setting from the card its still trying to load the game with those settings using the chip. whatsthat.gif

Link to comment
Share on other sites

  • 2 weeks later...
Scottthegamer

I had the same problem with a laptop with dual cards. One was an nvidia gt 540m and the other was the intel integrated chip. Games never worked correctly on it. Before however my gateway laptop with a radeon 5650m played games fine including gta 4.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.