Jump to content

Trying to get an ASI Loader to work


Chabby

Recommended Posts

Hello guys,

I tried to avoid creating a new thread, but there are so much threads everywhere that I couldn't find a straight answer. So I'll make it short.

 

1- I wanted to use the Player Selector Mod for my GTA 4 1.0.7.0, I'm on Windows 7 64 bits.

I found out in a thread that some of you were suggesting to use Simple Native Trainer instead (since it's more recent, allows more option and there is a model swapping included).

 

2- I downloaded this version:

http://www.gtagaming.com/downloads/gta-iv/script-mods/2115

(aka Simple Trainer Version 6.3)

 

3- I put every files downloaded in my main game directory (program files\Rockstar Games\Grand Theft Auto IV)

(Scripthook.dll, ScriptHook.dll - OLD PATCHES, trainer.asi, trainer.ini, Trainertbogt.asi, Trainertlad.asi, trainertlad.ini)

 

4- Launched the game: Pressing F3-F4 did nothing.

 

5- Guessed I needed an asi loader...?

 

6- Downloaded this Asi loader (yaasil) since I found a post on the last page stating it worked for 1.0.7.0

http://www.gtaforums.com/index.php?showtopic=394806

 

7- Tried to launch the game: Pressing PLAY on the launcher did nothing.

 

8- Downloaded Script Hook 0.5.1 BETA [1.0.7.0 + EFLC 1.1.2.0] GTAIV and put it in my main directory

 

9- Now, whetever I press PLAY or PLAY (OFFLINE) on the launcher window, the game just doesn't launch.

 

 

What did I do wrong? What exact files do I need to put on my main folder to be sure it works?

I'm not really looking forward 'cheating' online, just want to have some fun in single player, so I don't mind to be unable to play online with it.

 

Thanks! smile.gif

Link to comment
Share on other sites

  • 2 weeks later...

hey i dont have any answers but noticed a couple mistakes you made with the files you installed. Ive got a similar problem, cant get that trainer to work either, infact no scripts are working for me, but you might been wrong assuming the response in the Yassi asi loader thread, that 1.0.7.0 is supported was legit, someone answering "Yes" didnt sound too sure, was it too hard to say who/what they were replying to? And it looks like you didnt see the Simple trainer 6.3 readme: your not meant to put all the files in the GTAIV folder: If you have EFLC you put ones with those suffixes in that folder, and since your using 1.0.7.0 wouldnt use "ScriptHook.dll - OLD PATCHES" either cause its for patches <1.0.6.0 (but still, those irrelevant scripts shouldnt have affected it working in your GTAIV)

 

My issue is i downgraded the Steam version 1.0.7.0 to 1.0.4.0 doing *everything* here http://www.gtagaming.com/forums/showthread.php?t=128300 and with the "For all users of ScriptHook" also added Alexander ASI loader, cause its mentioned in the downloads. And ive unchecked the read only tag for the GTAIV folder. THen for safe measure, followed the "Modding guide" text in the ICEnhancer download, installing DirectX (think it was 9.0c), then GFWL, but didnt install the Microsoft Visual C+ Redist (assumed its allready installed cause it just asked to roll it back), then last Microsoft .NET 4 full. Havent tried ICEnhancer yet, just some script mods but nothing activates ingame, so ive done something wrong. The only option left looks like returning to 1.0.7.0 and looking for compatible script tools like Chabby's trying.

Edited by ndsn
Link to comment
Share on other sites

Do you have any log files in your main GTA IV folder? The C++ hook should generate a "ScriptHook.log" file, and the .NET hook should generate a "ScriptHookDotNet.log" file. Your ASI loader might also generate a log file. If you don't have these files, then the script hooks aren't even trying to load, which would probably mean that some file isn't in the right place.

 

Also, try different ASI loaders. Chabby tried YAASIL and ndsn tried Alexander's ASI loader — you should each try the other one. I personally use Xliveless, but just FYI, it disables multiplayer (to prevent cheating) and moves your savegame folder (so you can use other people's save files).

Edited by AngryAmoeba
Link to comment
Share on other sites

hi, thanks for the reply Angry, yea theres two logs

 

for the scripthook text it says

 

Log start: Sat Dec 10 12:45:29 2011-----------------------------------------------[iNFO] GTA IV Script Hook 0.4.0 - © 2009, Aru - Initialized[iNFO] Process base address: 0x1320000[iNFO] Auto detecting game version[iNFO] Using game version 1.0.4[iNFO] [scriptHookDotNet] Thread started[iNFO] [scriptHookDotNet] Thread killed[iNFO] Script Hook - Shutdown

 

 

for the scripthookdotnet text says

 

2011-12-10 12:45:29 - Initializing ScriptHookDotNet v1.7.1.7 BETA (on GTA IV version 1.0.4.0 with C++ Hook version 0.4.0)2011-12-10 12:47:04 - Direct3D device created!2011-12-10 12:47:06 - SEARCHING FOR SCRIPTS...2011-12-10 12:47:06 - Loading scripts in Assembly 'scripts\Trainer.net.dll' ...2011-12-10 12:47:06 -  ...found script 'Trainer.Regenerator'!2011-12-10 12:47:06 -  ...found script 'Trainer.CarSpawner'!2011-12-10 12:47:06 -  ...found script 'Trainer.PedSpawner'!2011-12-10 12:47:06 -  ...found script 'Trainer.Explode'!2011-12-10 12:47:06 -  ...found script 'Trainer.Speedometer'!2011-12-10 12:47:06 -  ...found script 'Trainer.WeatherController'!2011-12-10 12:47:06 -  ...found script 'Trainer.TaxiSpawner'!2011-12-10 12:47:06 -  ...found script 'Trainer.KeyController'!2011-12-10 12:47:06 -  ...found script 'Trainer.TimeChanger'!2011-12-10 12:47:06 -  ...found script 'Trainer.PoliceController'!2011-12-10 12:47:06 -  ...found script 'Trainer.ConsoleController'!2011-12-10 12:47:06 -  ...found script 'Trainer.WeaponSelector'!2011-12-10 12:47:06 -  ...found script 'Trainer.InGameMenu'!2011-12-10 12:47:06 -  ...found script 'Trainer.ScreenDraw'!2011-12-10 12:47:06 -  ...found script 'Trainer.Invincibility'!2011-12-10 12:47:06 -  ...found script 'Trainer.Backup'!2011-12-10 12:47:06 -  ...found script 'Trainer.ColorChanger'!2011-12-10 12:47:06 -  ...found script 'Trainer.WindowExapleScript'!2011-12-10 12:47:06 -  ...found script 'Trainer.Bodyguard'!2011-12-10 12:47:06 -  ...found script 'Trainer.WindowMasterControlScript'!2011-12-10 12:47:06 -  ...found script 'Trainer.WindowWarningScript'!2011-12-10 12:47:06 - DONE! 21 valid scripts found!2011-12-10 12:47:06 - STARTING SCRIPTS...2011-12-10 12:47:06 - INFO: Phone number checks are not available!2011-12-10 12:47:06 -  ...successfully started script 'Trainer.WindowWarningScript'!2011-12-10 12:47:06 -  ...successfully started script 'Trainer.WindowMasterControlScript'!2011-12-10 12:47:06 -  ...successfully started script 'Trainer.Bodyguard'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.WindowExapleScript'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.ColorChanger'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.Backup'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.Invincibility'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.ScreenDraw'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.InGameMenu'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.WeaponSelector'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.ConsoleController'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.PoliceController'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.TimeChanger'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.KeyController'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.TaxiSpawner'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.WeatherController'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.Speedometer'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.Explode'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.PedSpawner'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.CarSpawner'!2011-12-10 12:47:07 -  ...successfully started script 'Trainer.Regenerator'!2011-12-10 13:13:58 - Direct3D device lost!2011-12-10 13:13:59 - SCRIPTS TERMINATED!

 

 

So, considering the times listed, looks like the 2nd last line "Direct3D device lost" mightve only been cause i exited the game, not from any error. Anyway ill try YASILLS and Xlivless now.

 

Also for some reason the console ~ key doesnt appear to active at all. Is that only accessable when the scripting tools are all functioning. Bethesda games using the same console key, and its working on those so isnt a hardware issue afaik.

 

---

 

EDIT: lol so everythings working now (even the console key) just wanted to double check it again before trying different script configurations - I swear none of the keys worked yesterday - and the only explanation i can think of is earlier today I installed another game thru Steam that just happened to auto install Microsoft Visual C+ Redist as part of that intstall so it mustve been THAT step i skipped that stopped GTAIV doing its thing

 

Thanks again, and sorry for hijacking your thread Chabby, good luck on sorting it out smile.gif

Edited by ndsn
Link to comment
Share on other sites

Btw Chabby for Simple trainer 6.4 if you have the EFLC dlc you do actually put all the asi files in GTAIV folder, i miss read the readme, mybad

 

and also noticed at the end of the install notes it says, it requires launching the game as Administrator

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.