Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Arena War
      2. After Hours
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA Next

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

Sign in to follow this  
Jacko427

Errors compiling main.scm

Recommended Posts

Jacko427

I want to remove some missions from main.scm.

But each time I remove, I get that error:

 

 

The definition of mission expected but EXTERNAL_SCIPTS found.

 

First I removed:

DEFINE MISSION 135 AT Example mission

 

And:

//-------------Mission 135---------------

 

But I keep getting that error.

Coding has never been my favorite part, so I don't understand.

All I want is to remove these freaking missions.

 

Will anyone please explain how to remove without that definition external scripts error crap?

Share this post


Link to post
Share on other sites
Adler

lol you should've just PMed me to open the other topic but meh... this is alright.

 

Look for the "DEFINE MISSIONS" line right before all the missions are defined and change the number next to that.

Share this post


Link to post
Share on other sites
Jacko427
lol you should've just PMed me to open the other topic but meh... this is alright.

 

Look for the "DEFINE MISSIONS" line right before all the missions are defined and change the number next to that.

Even doing that it gives me the error confused.gif

Share this post


Link to post
Share on other sites
Jacko427

 

lol you should've just PMed me to open the other topic but meh... this is alright.

 

Look for the "DEFINE MISSIONS" line right before all the missions are defined and change the number next to that.

Well, a lock is not needed in the first place.

I have posted a request and no one is helping with it.

But you're a mod, so I have nothing to say.

 

I tried what you said about the DEFINE MISSIONS,

but even doing that it gives me the error confused.gif

 

http://imgur.com/HBUZV

 

 

EDIT

I wasn't aware of doubleposting.

The battery of my 6 years old laptop died in a few minutes and laptop was shut down immidiately.

Edited by Jacko427

Share this post


Link to post
Share on other sites
Adler

Share this post


Link to post
Share on other sites
fireguy109

What you need to do is remove the triggers themselves, not the defined missions. The errors are coming from the triggers, where they say "start mission 135" - a now nonexistent mission. turn.gif

Share this post


Link to post
Share on other sites
Adler

 

I change the 164 to 135, then there you go, a freaking error.

Did you really remove that many missions? Be sure that the number next to DEFINE MISSIONS matches how many missions there are defined (there's also a MISSION 0 defined so take that into account as well).

Edited by Adler

Share this post


Link to post
Share on other sites
Jacko427
I change the 164 to 135, then there you go, a freaking error.

Did you really remove that many missions? Be sure that the number next to DEFINE MISSIONS matches how many missions there are defined (there's also a MISSION 0 defined so take that into account as well).

It won't work.

I tried many ways, first I change the DEFINE MISSIONS 164 to 135.

Error.

Then removing the triggers and changed the 164 to 135 too, error.

And removed the entire missions and change the 164 to 135, error.

 

I'm darned with this.

Share this post


Link to post
Share on other sites
fireguy109

 

What you need to do is remove the triggers themselves, not the defined missions. The errors are coming from the triggers, where they say "start mission 135" - a now nonexistent mission. turn.gif

moto_whistle.gif

 

Also, define one number past the actual number of missions.

Share this post


Link to post
Share on other sites
Jacko427
What you need to do is remove the triggers themselves, not the defined missions. The errors are coming from the triggers, where they say "start mission 135" - a now nonexistent mission. turn.gif

moto_whistle.gif

 

Also, define one number past the actual number of missions.

Can you explain that, please?

My English is not my first language.

Share this post


Link to post
Share on other sites
fireguy109

If the last mission you are defining is Mission 134, then the number of missions defined needs to be 135.

 

And what you need to do is search for the triggers in the script. Basically, they check whether or not the player is in position to start the mission. Damage them by making an impossible request (like checking if the player is in a car, in a boat, in a plane, and on foot, all at the same time) to disable them.

Share this post


Link to post
Share on other sites
Jacko427

Ugh, coding is not my thing and I don't know anything.

Well, I want to ask very nicely if someone could do that.

I want the entire missions be completely removed, 136-164.

Then I can see what is needed to be removed here and there.

There are other scripts out there apart from the main.scm I'd want to modify.

 

 

Please bear in mind coding is really not my thing.

And I'm very sorry if I have annoyed anyone with this kind problem.

 

Hope you understand blush.gif

Share this post


Link to post
Share on other sites
Adler

 

I want the entire missions be completely removed, 136-164.

Remove the DEFINE MISSION entries for all 136-164 and remove the missions themselves. Then change the DEFINE MISSIONS line to 137. That oughta do it. wink.gif

Share this post


Link to post
Share on other sites
Jacko427

 

I want the entire missions be completely removed, 136-164.

Remove the DEFINE MISSION entries for all 136-164 and remove the missions themselves. Then change the DEFINE MISSIONS line to 137. That oughta do it. wink.gif

SannyBuilder hates me.

I did exactley what you said, but I get this error:

http://i.imgur.com/ITgFj.png

Share this post


Link to post
Share on other sites
Adler

Change DEFINE MISSIONS to 136 then.

Share this post


Link to post
Share on other sites
Jacko427

 

Change DEFINE MISSIONS to 136 then.

Still the same error.

 

 

 

Tried combining the mission 135 into original main.scm.

Everything copied at the right places like in spaceeinstein's mod.

I was compiling, when at 99%, NONAME_8 blabla not declarered error.

Everything is exactley copied, but still errors confused.gif

Edited by Jacko427

Share this post


Link to post
Share on other sites
fireguy109

facedesk.gif

 

Search for these lines in the script and remove them -

 

 

0417: start_mission 1360417: start_mission 1370417: start_mission 1380417: start_mission 139

 

 

... all the way up to 164. Don't change the number of defined missions.

Share this post


Link to post
Share on other sites
spaceeinstein

I realized my file was too unnecessarily complex. I'll delete the missions for you when I have the time. Really, I doubt it will solve any of your problems.

Share this post


Link to post
Share on other sites
Jacko427

 

I realized my file was too unnecessarily complex. I'll delete the missions for you when I have the time. Really, I doubt it will solve any of your problems.

Thanks for your reply.

 

It is OS specific.

The 3.0 works without crashes at certain area's on a machine with XP.

On Vista it crashes frequently ath certain area's.

I had to remember lots of these places wich cause the game to crash.

 

Can't these scripts:

 

Perfect Start

Parked Cars

Rockstar Changes

Home Brains

Headlights

Engine Operation

Steed

Bullet Time

Real Time

MultiMod

Mod Shop

Superbrake

SuperNOS

 

be converted to cleo?

So I can play with the original main.scm.

 

I really have a bad luck with this.

Share this post


Link to post
Share on other sites
spaceeinstein

Yes, it's possible to place anything into a CLEO file given enough work, but in practice it's really not worth it. The code in my file are mixed along with R*'s code. It's not a simple create_thread and thread format for each feature. A sure but tedious way to make sure you don't break anything is to remove only one stuff at a time and test it. Your attempt at removing the missions by mass deleting code does not work. Same idea applies to those specific features.

Share this post


Link to post
Share on other sites
Jacko427

Hmm, that sucks.

So Cleo can't have R* things?

If possible, the only the Modshop and Multi mod are fine.

Home Brains would be nice too, but I read it's a R* hidden code.

I assume Rockstar Changes is a R* thing code too.

 

But the biggest problem, I don't have any knowledge about coding.

I'm will-less blush.gif

Share this post


Link to post
Share on other sites
spaceeinstein

I may have found a possible cause to the problem. Running the game with the mod and Firefox in the background seems to guarantee a crash. Firefox had been so troublesome to me with some of the other games I played, but I didn't realize it would do that to SA. Try closing every background programs and see if the game runs with my original files. The problems may or may not be a problem with the OS or Sanny Builder because I can't get any consistencies from it. Compiling the same file twice will work the first time but break the game the next time.

Edited by spaceeinstein

Share this post


Link to post
Share on other sites
Jacko427

That's weird.

I always close Firefox when not on internet.

Wich OS do you have?

 

 

EDIT

 

I left Firefox in the background while playing SA.

It doesn't make SA crash at certain area.

This is tested on XP machine.

 

Go with the vortex or a boat and drive under the bridge in the desert.

That bridge is this:

http://i.imgur.com/k9R39.jpg

 

I apologise for the crappy graphics.

XP laptop is 5 years old with Intel videochip.

Edited by Jacko427

Share this post


Link to post
Share on other sites
spaceeinstein

I use Vista 32-bit. I'm doing trial and error now and the problem seems to be coming from mission 1 "INITIL2" thread. I'll see if I can make progress on this. So far commenting out the 9 lines that loads the "HOME_BRAIN" script seems to ease the random crashing. I think the problem may be that too many external scripts are loaded at the same time. So try deleting those lines in a freshly decompiled script and see what happens.

Edited by spaceeinstein

Share this post


Link to post
Share on other sites
Jacko427

At wich moments is your game crashing?

 

I really appreciate your work and help smile.gif

Edited by Jacko427

Share this post


Link to post
Share on other sites
spaceeinstein

When the game crashes for me, it will crash after the loading bar finishes and before the first cutscene loads, so that was getting me stuck when trying to remove the missions. I thought my problem may be similar to yours. Did my solution worked for you? I have no problems at all traveling through and around the bridge, or anywhere in the state, with the external script triggers removed.

Edited by spaceeinstein

Share this post


Link to post
Share on other sites
Jacko427

Ow great, then it is structure OS specific suicidal.gif

Mine's Vista x64 Home.

 

I dont know what to remove the correct scripts/lines.

I always get errors after deleted scripts and decompiled it.

But I know removing the DEFINE MISSIONS 136-164 will glitch the game very very bad.

When going to the cellphone where the red sphere is marked, at Jefferson Hotel, 'Big Bank Job',

it will start the very first cutscene, after CJ is arrived from the airport.

 

But anyway, Multimod, Modshop and Rockstar Changes are the best and only used by me.

Copying them into a fresh original Rockstar's main.scm might not cause the game crash.

 

I tried copying the Modshop, in the end I got error about NOT Found things.

Share this post


Link to post
Share on other sites
spaceeinstein

Still blaming the computer and not the game? If you're still not convinced, I have removed most of the extra missions and all external script triggers.

Download

I did not test this extensively, but I think this should fix the random crashes at the expense of missions and activities.

 

Share this post


Link to post
Share on other sites
Jacko427

Haha, well, when I had only XP machine, the game never crashed once.

I could go anywhere else without crashes.

I bought later a new notebook for gaming and such and it has Vista x64 when purchased it.

GTA SA is the exact copy as on XP machine, no mods, only yours.

Random crashes on that Vista notebook.

 

But I'll test it.

And thank you very much you have time to trail and test smile.gif

 

 

EDIT

Still random crashes when at the area's.

Edited by Jacko427

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.