Jump to content

TXD Workshow alpha import doesn't work


kmasdmk

Recommended Posts

Hi there. I want to import alpha map. I exported texture, changed it, saved, but when I click import, it replaces a normal texture. No alpha map ! I have selected alpha map in a buttom panel in txd workshop.

I use version 4.8. What to do ? I need it.

Link to comment
Share on other sites

Have you saved the Alpha picture in 8-bit bmp format?

 

Have you named the Alpha picture the same as the non-alpha picture, but added an "a" to the name? Example: texture.bmp (normal texture) and texturea.bmp (alpha texture).

 

Have you ticked the box called Älpha is used" in the "image properties"?

Link to comment
Share on other sites

In this video you can see how it's supposed to be done:

 

BTW, you saved your alpha texture as 256 colour bitmap. Is that the same as 8 bit? I think you need paint.NET to make it 8-bit.

Link to comment
Share on other sites

Another way you could try would be to save your alpha on its own. Give it the same name as the texture but with an 'a' on the end. Then select the texture it will go with. Now on the bottom of the tool switch it to alpha on the little tab. THEN click import. Now by switching through the normal alpha and blend you should see the results. Make sure to go to the properties and give it the dx3 compression and save it. See if that works for you.

 

-Fox

Link to comment
Share on other sites

It's the same how I did it on the video. Compresion is on, alpha used too. When I import it, it goes still as a normal texture. So when you do it, it works for you normaly ?

Link to comment
Share on other sites

In my opinion this is a program bug. Xforceman in his video did everything as it should be done. Im using TXD Workshop 4.5 try to do this with 4.5 version and see how it goes.

 

@RobbieG-NL: keep in mind that an 8 bit picture will always be a 256 color picture so 256 colors and 8 bit are the same thing.

 

@foxunitone: It isnt necessary for the textures to be compressed. I made TXD files with normal non-transparent textures (with no alpha channel) compressed to TXD2 and for the textures with alphas i left them uncompressed and the game still worked.

Edited by yo5pev
Link to comment
Share on other sites

I'm glad i could help smile.gif. Just as a side note, TXD Workshop 4.5 is full of bugs as well so i recommend you to save often if you plan to import lots of files into your TXD's. I often encountered crashes after importing a texture or tried to check the "compressed" box plus i couldn't save the textures already imported so i had to close the program, open it again and remake the whole TXD.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.