Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (86,318 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Alexander Blade

[GTA IV|EFLC|REL] Scocl

Recommended Posts

Tufu600

You're bad ass. This should certainly come in handy.

Share this post


Link to post
Share on other sites
Fantaseb

 

the point is that everyone who can actually code scripts can handle everything regarding scocl by himself cuz all needed info for such people is already available in the *.chm

scripts of gta iv is a lot more than sa and all previous versions , u need to have C coding skillz anyway to use this

 

Okay I understand C but when I go to edit a file, that save it does nothing and I am using the scocl.exe, so like I am confused now. Anyway I also wanna know, how do I load these into the scripts.img file? I want to put mods in multiplayer, alright I am going to message you ok?

Edited by Fantaseb

Share this post


Link to post
Share on other sites
Terreur69

I have my games in 1.7, when i put the placed sco zombomd already Compiler, it works perfectly, but against, if i compile all .c , game crash through eror " SRCP40 " confused.gif

Share this post


Link to post
Share on other sites
Alexander Blade

Tufu600

Do u think that R* cud open separate script coder vacation for handy tool ? job at R*N

 

terreur69

R u replacing all 11 sco scripts ? r u compiling using visual studio ? remember that startup must be compiled with globalseg

Share this post


Link to post
Share on other sites
Terreur69

it's good, i forgot the space between out" and globalseg colgate.gif

Share this post


Link to post
Share on other sites
SILENT_Pavel

Alexander Blade

Privet! biggrin.gif Awesome project pal, cos using standart script - it's just right what we need, i think smile.gifuser posted image

 

 

terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon.

Can you please write something like converter to edit SCO mods from 7 patch to NON patched gta iv original? Or just another version/update Scocl to use with non-patchet IV?

 

Why i'm asking that thing? Cos in this way we CAN do scripting on Xbox360 and PS3 with no problem!!

 

Istn its just great breakthrough in modding, do you agree? I thing many people will support me in this desire, right, guys? wink.gif

 

Well, what do you think, comrade? Thanks in advance!

Share this post


Link to post
Share on other sites
Frank.s

Is there a list of what the (IS_KEYBOARD_KEY_PRESSED( 31 )) numbers are? I tried the old (same as SannyBuilder) decimal keycodes and they aren't the same.

Edited by Frank.s

Share this post


Link to post
Share on other sites
Skorpro

 

Is there a list of what the (IS_KEYBOARD_KEY_PRESSED( 31 )) numbers are? I tried the old (same as SannyBuilder) decimal keycodes and they aren't the same.

Hi, try this...

 

Virtual Key Codes (for Delphi in hexadecimal)

or

Virtual Key Codes (the same list...)

 

(Hope it works! In C ++ it works great!)

 

Maybe you need this too: "IS_CONTROL_PRESSED"

CONTROL Key Codes (the 5th post by Spaceeinstein!)

 

Have fun biggrin.gif

Share this post


Link to post
Share on other sites
iriedreadlock23

Hi Alexander!

 

Thank you for your incredible effort. This is perfect SDK for all developers, as the script performance is now exactly where it should be.

 

I wonder if it's possible to read/write external file data from compiled scripts? I need to use dynamic data (to save/load vector data), so can you explain how can we achieve this? Is there any workaround? I've been using ScriptHook interface to achieve this in the past, but now SCO would help me build more quick and direct version of my mods.

 

Thanks in advance.

Share this post


Link to post
Share on other sites
LostDerp
terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon .

 

Rapier

Im not sure if ill do an update for the Alice , cuz almost noone used it . And about delphi - no , i can't rewrite the whole compiler , C-like syntax is easy to learn anyway .

Can you please add 1040 support?

Share this post


Link to post
Share on other sites
ShakingASS
terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon .

 

Rapier

Im not sure if ill do an update for the Alice , cuz almost noone used it . And about delphi - no , i can't rewrite the whole compiler , C-like syntax is easy to learn anyway .

Can you please add 1040 support?

1.0.4.0 is lame use new patch enb now support for 1.0.7.0

Share this post


Link to post
Share on other sites
Symbiote

 

1.0.4.0 is lame use new patch enb now support for 1.0.7.0

That's simply not true. ENB Series does not fully support 1.0.7.0. If you want all ENB features to be enabled, you have to use 1.0.4.0 or 1.0.3.0.

Share this post


Link to post
Share on other sites
ShakingASS
1.0.4.0 is lame use new patch enb now support for 1.0.7.0

That's simply not true. ENB Series does not fully support 1.0.7.0. If you want all ENB features to be enabled, you have to use 1.0.4.0 or 1.0.3.0.

Wrong you are my enb series works with all effects check out ChinaGreenElvis shader fix it actually fixed it.

Share this post


Link to post
Share on other sites
LostDerp
terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon .

 

Rapier

Im not sure if ill do an update for the Alice , cuz almost noone used it . And about delphi - no , i can't rewrite the whole compiler , C-like syntax is easy to learn anyway .

Can you please add 1040 support?

1.0.4.0 is lame use new patch enb now support for 1.0.7.0

The game barely works for me on 1.0.7.0.

Share this post


Link to post
Share on other sites
ShakingASS

 

terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon .

 

Rapier

Im not sure if ill do an update for the Alice , cuz almost noone used it . And about delphi - no , i can't rewrite the whole compiler , C-like syntax is easy to learn anyway .

Can you please add 1040 support?

1.0.4.0 is lame use new patch enb now support for 1.0.7.0

The game barely works for me on 1.0.7.0.

1.0.4.0 doesn't give any fps.Just use shader fix then your set.

Also graphics better on patch 1.0.7.0

Share this post


Link to post
Share on other sites
LostDerp
terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon .

 

Rapier

Im not sure if ill do an update for the Alice , cuz almost noone used it . And about delphi - no , i can't rewrite the whole compiler , C-like syntax is easy to learn anyway .

Can you please add 1040 support?

1.0.4.0 is lame use new patch enb now support for 1.0.7.0

The game barely works for me on 1.0.7.0.

1.0.4.0 doesn't give any fps.Just use shader fix then your set.

Also graphics better on patch 1.0.7.0

I can run 1.0.4.0 at a clear 60fps at max, 1.0.7.0 runs at about 30fps and gets extreme slowdowns every minute or two. Stop telling me to use 1.0.7.0, I'm not going to.

Share this post


Link to post
Share on other sites
ShakingASS
terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon .

 

Rapier

Im not sure if ill do an update for the Alice , cuz almost noone used it . And about delphi - no , i can't rewrite the whole compiler , C-like syntax is easy to learn anyway .

Can you please add 1040 support?

1.0.4.0 is lame use new patch enb now support for 1.0.7.0

The game barely works for me on 1.0.7.0.

1.0.4.0 doesn't give any fps.Just use shader fix then your set.

Also graphics better on patch 1.0.7.0

I can run 1.0.4.0 at a clear 60fps at max, 1.0.7.0 runs at about 30fps and gets extreme slowdowns every minute or two. Stop telling me to use 1.0.7.0, I'm not going to.

Well i perfer better graphics and use damn fps tweaks.Just helping you out.

Share this post


Link to post
Share on other sites
Tufu600

 

terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon .

 

Rapier

Im not sure if ill do an update for the Alice , cuz almost noone used it . And about delphi - no , i can't rewrite the whole compiler , C-like syntax is easy to learn anyway .

Can you please add 1040 support?

1.0.4.0 is lame use new patch enb now support for 1.0.7.0

The game barely works for me on 1.0.7.0.

1.0.4.0 doesn't give any fps.Just use shader fix then your set.

Also graphics better on patch 1.0.7.0

I can run 1.0.4.0 at a clear 60fps at max, 1.0.7.0 runs at about 30fps and gets extreme slowdowns every minute or two. Stop telling me to use 1.0.7.0, I'm not going to.

Nobody is going to bend over backwards for you just because you don't want to run the newest patch. It's your problem, so fix it.

/endof

Share this post


Link to post
Share on other sites
LostDerp
terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon .

 

Rapier

Im not sure if ill do an update for the Alice , cuz almost noone used it . And about delphi - no , i can't rewrite the whole compiler , C-like syntax is easy to learn anyway .

Can you please add 1040 support?

1.0.4.0 is lame use new patch enb now support for 1.0.7.0

The game barely works for me on 1.0.7.0.

1.0.4.0 doesn't give any fps.Just use shader fix then your set.

Also graphics better on patch 1.0.7.0

I can run 1.0.4.0 at a clear 60fps at max, 1.0.7.0 runs at about 30fps and gets extreme slowdowns every minute or two. Stop telling me to use 1.0.7.0, I'm not going to.

Nobody is going to bend over backwards for you just because you don't want to run the newest patch. It's your problem, so fix it.

/endof

It's not just me, 3 other people have requested it in this thread. Also I'm not demanding it, I'm asking for it.

Share this post


Link to post
Share on other sites
ShakingASS
terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon .

 

Rapier

Im not sure if ill do an update for the Alice , cuz almost noone used it . And about delphi - no , i can't rewrite the whole compiler , C-like syntax is easy to learn anyway .

Can you please add 1040 support?

1.0.4.0 is lame use new patch enb now support for 1.0.7.0

The game barely works for me on 1.0.7.0.

1.0.4.0 doesn't give any fps.Just use shader fix then your set.

Also graphics better on patch 1.0.7.0

I can run 1.0.4.0 at a clear 60fps at max, 1.0.7.0 runs at about 30fps and gets extreme slowdowns every minute or two. Stop telling me to use 1.0.7.0, I'm not going to.

Nobody is going to bend over backwards for you just because you don't want to run the newest patch. It's your problem, so fix it.

/endof

It's not just me, 3 other people have requested it in this thread. Also I'm not demanding it, I'm asking for it.

No sorry.

Share this post


Link to post
Share on other sites
janusantsky

hello this is very cool but can someone do a tutorial to know wich file i have to copy to make for an example the zombi mod working

 

and with this can of script can we add weapons to the game ?

Share this post


Link to post
Share on other sites
LostDerp
terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon .

 

Rapier

Im not sure if ill do an update for the Alice , cuz almost noone used it . And about delphi - no , i can't rewrite the whole compiler , C-like syntax is easy to learn anyway .

Can you please add 1040 support?

1.0.4.0 is lame use new patch enb now support for 1.0.7.0

The game barely works for me on 1.0.7.0.

1.0.4.0 doesn't give any fps.Just use shader fix then your set.

Also graphics better on patch 1.0.7.0

I can run 1.0.4.0 at a clear 60fps at max, 1.0.7.0 runs at about 30fps and gets extreme slowdowns every minute or two. Stop telling me to use 1.0.7.0, I'm not going to.

Nobody is going to bend over backwards for you just because you don't want to run the newest patch. It's your problem, so fix it.

/endof

It's not just me, 3 other people have requested it in this thread. Also I'm not demanding it, I'm asking for it.

No sorry.

It's ok I got it working on 1.0.4.0 by changing the natives.cfg to one for 1.0.4.0.

Share this post


Link to post
Share on other sites
Frank.s

Could someone please tell me what is the native function that creates the mission arrows?

 

user posted image

Edited by Frank.s

Share this post


Link to post
Share on other sites
jitsuin

 

terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon .

 

Rapier

Im not sure if ill do an update for the Alice , cuz almost noone used it . And about delphi - no , i can't rewrite the whole compiler , C-like syntax is easy to learn anyway .

Can you please add 1040 support?

1.0.4.0 is lame use new patch enb now support for 1.0.7.0

The game barely works for me on 1.0.7.0.

1.0.4.0 doesn't give any fps.Just use shader fix then your set.

Also graphics better on patch 1.0.7.0

i have EFLC using ChinaGreenElvis ENB, which does look awesome, and I have GTA IV 1.0.4 using Icenhancer 1.35 and Ice is 100000000000x better wink.gif

 

1.0.4.0 with Icenhancer 1.35 is the best, no substitute!

Share this post


Link to post
Share on other sites
AlphaWolF_uk

Ive never attempted scripting before but im looking in to this one because from what i understand this method should be the only way to script mod from now on as its about as you can get to how rock-star actually did it, and seems to use the modded scripts from the script img file as the game intended to do EG: native! , correct me if im wrong ?.

 

It would be really cool of you if you would do a brief guide/tutorial

 

My noob question is in the in the (open4.decompiled ) folder i can see all the scripts for each game version iv/lad/bogt,

are those just the decompiled game scripts for viewing how things were done or could i actually edit and compile for use.

 

and noob question again take for example tbogt folder it seems from what ive seen the scripts that are named like tony1/tony2/tony3 & so on they would be the missions that he gives you in that order ? because that could open up real possibility with completing changing the missions to what you want.

Share this post


Link to post
Share on other sites
ShakingASS
terreur69

Oh , u cant use this with 1040 , cuz 1040 is using old native hashes , only newest patches biggrin.gif I'll do the update for the scocl soon .

 

Rapier

Im not sure if ill do an update for the Alice , cuz almost noone used it . And about delphi - no , i can't rewrite the whole compiler , C-like syntax is easy to learn anyway .

Can you please add 1040 support?

1.0.4.0 is lame use new patch enb now support for 1.0.7.0

The game barely works for me on 1.0.7.0.

1.0.4.0 doesn't give any fps.Just use shader fix then your set.

Also graphics better on patch 1.0.7.0

i have EFLC using ChinaGreenElvis ENB, which does look awesome, and I have GTA IV 1.0.4 using Icenhancer 1.35 and Ice is 100000000000x better wink.gif

 

1.0.4.0 with Icenhancer 1.35 is the best, no substitute!

You can put other enb's it's a fix he just included his enb which i don't use.

Share this post


Link to post
Share on other sites
jitsuin

@ShakingAss

 

Which ENB do you use?

Share this post


Link to post
Share on other sites
ShakingASS
@ShakingAss

 

Which ENB do you use?

My own i made.

Share this post


Link to post
Share on other sites
Terreur69

new for compatible old natives ???

Share this post


Link to post
Share on other sites
ShakingASS
new for compatible old natives ???

Patch 1.0.7.0 is better don't do patch 1.0.7.0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.