Jump to content

Games lag


Bad.boy!

Recommended Posts

I have this problem when running games. First everything worked normal, but when I installed some updates (louds of them because I recently formatted my HDD) and when I start a game it lags. But the weird thing is that when I reboot my computer and start a game up everything works fine. But when I exit the game and start it up again it lags, I have this with multiple games.

 

Does anyone know the problem?

 

HP Pavilion dv6

MS Windows 7 Home Premium 64-bit SP1

Intel Core i3 350M @ 2.27GHz

3,00 GB Dual-Channel DDR3 @ 532MHz (7-7-7-20)

Hewlett-Packard 144A (CPU) --> motherboard

ATI Mobility Radeon HD 5470 (HP)

313GB Western Digital WDC WD3200BEKT-60V5T1 (SATA)

IDT High Definition Audio CODEC

Link to comment
Share on other sites

Make sure applications running in the background are closed when gaming, e.g. virus scanners. Also, regularly defragment your harddrive(s).

DU8afL0.jpg

Link to comment
Share on other sites

Maybe your pc is overheating, clean it up and see if the problem still persists.
Link to comment
Share on other sites

Make sure you defrag

In fact I would do a full system cleaning with CCleaner, chkdsk and lastly defrag.

Link to comment
Share on other sites

@OverTheBelow I have only few background running, and they're not the problem

 

@Narcis_speed6 It's not overheated, because when I put my pc to sleep(??), and turn it on again it still lags.

 

@Wolf68K I am using CCleaner already, and I defraged my HDD already and checked the hdd for problems

Link to comment
Share on other sites

AndrefromEstonia

Don't put it to sleep then... Do a restart maybe. If games lag even on low settings, then use Game Booster, closes all background programs and turns the GPU/CPU up a bit. Then again, your videocard isn't meant for gaming. Not the best choice.

user posted image
Link to comment
Share on other sites

AndrefromEstonia

Mafia 2 is such a game that tends to lag sometimes without reason. At least thats what ive read. And i have some minor lag sometimes too.

user posted image
Link to comment
Share on other sites

What if you try something older like Team Fortress 2 or HL2?

Link to comment
Share on other sites

Dead space 2 only works fine on startup, and mafia 2 lags a lot. This recently happend.

Monitor the CPU usage does it change a lot when you run those games? What is it normally?

Link to comment
Share on other sites

This is when I was playing dead space 2 while lagging:

user posted image

*NOTE: the last peak was when I switched from game to taskmanager

 

And this is right now:

user posted image

 

But I don't think that my laptop is actually trying because if I render something big with 3ds max, I hear the fan twice as loud and it uses about 99%

Link to comment
Share on other sites

Check your GPU usage with MSI Afterburner while playing. If it is at 99% then there is nothing you can do about the lag, short of overclocking.

DU8afL0.jpg

Link to comment
Share on other sites

Just because the GPU is at 99% doesn't have anything to do with the lag.

I can BFBC2 and my GPU will be near 99% and I get zero lag, no including server lag.

 

This is why I'm trying to find out if it's doing this to all games, even older games like Team Fortress 2 or just newer high end games. And testing with TF2 is easy now, all you need is a Steam account since the game is free-to-play now.

Link to comment
Share on other sites

 

Just because the GPU is at 99% doesn't have anything to do with the lag.

Yes it does, especially with a weak video card. If the GPU is at 99% usage, the current framerate is the maximum you are going to get in the current situation. The GPU is almost always the bottleneck when it reaches 99%+ usage in gaming.

 

If a game is for example running at 15fps with 100% GPU usage, the framerate won't go higher until the scene changes/gets less demanding.

 

 

I can BFBC2 and my GPU will be near 99% and I get zero lag, no including server lag.

All of your GPU is being used and is powerful enough to run at more than 30fps i.e. your "zero lag". If Bad company 2 was putting my graphics card at 99% usage, it'd be running at around 50-75fps on max settings. On lowest settings, at 99% usage my framerate would be above 160fps.

DU8afL0.jpg

Link to comment
Share on other sites

Framerate does not necessarily equal game lag. Yes when you're only get 10fps then there is some lag, that's video lag. However it's also completely possible to get 100fps and still have game lag cause by something else.

 

The ONLY thing he's reported the problem on are 2 games. Both of which are newer and call for a really good system. So let's see what happens if he uses an older game, ie TF2. If the lag happens there then there is a real problem. If not and if it's only in the 2 games he listed then the problem is there.

Yes he said multiple games, but doesn't say what all games that is.

Link to comment
Share on other sites

I used after burner this time this is when I was dead space 2 with video lag:

user posted image

 

And this is dead space 2 without any lag:

user posted image

 

I think that the core clock is the problem. But anyway I'll try to install GTA San Andreas unmodified, and see what happens.

Link to comment
Share on other sites

Reinstall your AMD drivers and ensure the AMD Overdrive feature is disabled in CCC. Looks like your card is failing to switch out of its low-power mode during gaming.

DU8afL0.jpg

Link to comment
Share on other sites

I notice that during the video lag run the Core only got to 300Mhz while the no lag was at it's full 750Mhz

So what else was different that you might have done to cause that?

Link to comment
Share on other sites

Well, my pc hasn't got that feature.

----------------------------------------

Found the problem, Power play is disabled by default and my pc used maximize battery life settings for some reason. I enabled power play and set it to maximize performence and everything works fine now.

 

user posted image

Edited by Bad.boy!
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.