Jump to content

[Q] Problem with cutscene model...


OOM-44

Recommended Posts

Hey everyone. I just signed-up.

 

I wanted to ask for help about some mods I used (I hope this is the right section to post this).

 

I downloaded some skins for GTA:SA and was using them to mod the characters in the story. I used the .dff and .txd files to replace the ones in gta3.img and cutscene.img. They all look good in-game, but some of the mods looked wrong during the cutscenes:

 

http://img638.imageshack.us/img638/189/modcutscene.png

 

http://img850.imageshack.us/img850/5029/modcutscene2.png

 

As you can see, the some of the textures are missing on two characters, while the others look great with them. Again, the skins all work in-game, but the cutscenes are where the problem appears. I opened the .txd files with TXDworkshop, but couldn't see what was wrong. I also rebuilt the cutscene.img file many times, but nothing changed.

 

I already tried searching if other people had this problem but couldn't find anything. Does anyone know what is the problem? Thanks!

Link to comment
Share on other sites

i guess its because thoose peds have cartoon shading effect..this effect only work for ingame...so you cant fix it unless if you want to delete the effect itself..

Edited by indra p
Link to comment
Share on other sites

Sometimes the odd positioning and mild deforming of models in the cutscene can cause this. Its because of 'transkeys' in the animation sequence. To fix that, you need to download Ryoske's animation tool, use it to load the cutscenes, load the models, and then remove the transkeys for the 'actor' that has the problem. I am very familiar with the Lucky Star models and they work fine.

 

-Fox

Link to comment
Share on other sites

Thanks for responding guys!

 

Update:

Well, I followed your advice, foxunitone, and used GTA Animation Manager to try to fix the problem. I removed the transkey on the problem characters in the cutscenes, and saved the cuts.img file. I watched the cutscene but the black texture was still present. However...

 

I was messing around in the Animation manager program, and I found an option that said "Disable culling" and was unchecked. I checked it and the model I loaded (the same skin with the problem) appeared identical to the cutscene model, with the same black texture! So I figured it did have something to do with the shading, like indrap said.

 

Don't know if there's an option to fix the culling, though. If you guys know more about that, I'd appreciate the help! Thanks for helping me in the meantime!

Link to comment
Share on other sites

From looking at those pictures it appears that all alpha transparency on actors gets disabled during cutscenes, i've no idea how that could be re-enabled.

Link to comment
Share on other sites

Hello again, everyone!

 

Well, I think the problem has been fixed! I saw Frank.s' post about alpha transparency and decided to learn more about it. I took what I learned and used it to edit the problem .png files in the .txd of the models. I saw some black spaces in the images and added an alpha .bmp file to them, where I added transparency to the black spaces. I saved, loaded them up onto cutscenes.img and (after a few trials and errors), behold:

 

http://img26.imageshack.us/img26/2683/cutscenefixed.png

 

Thanks to all of you for helping me with this issue! I appreciate all the help you all gave me.

 

Thanks again!

Link to comment
Share on other sites

  • 9 years later...
On 8/22/2011 at 12:17 AM, indraCG said:

i guess its because thoose peds have cartoon shading effect..this effect only work for ingame...so you cant fix it unless if you want to delete the effect itself..

Can you please tell me how to delete these effects?

 

Link to comment
Share on other sites

On 8/22/2011 at 7:46 PM, OOM-44 said:

Hello again, everyone!

 

Well, I think the problem has been fixed! I saw Frank.s' post about alpha transparency and decided to learn more about it. I took what I learned and used it to edit the problem .png files in the .txd of the models. I saw some black spaces in the images and added an alpha .bmp file to them, where I added transparency to the black spaces. I saved, loaded them up onto cutscenes.img and (after a few trials and errors), behold:

 

http://img26.imageshack.us/img26/2683/cutscenefixed.png

 

Thanks to all of you for helping me with this issue! I appreciate all the help you all gave me.

 

Thanks again!

Can you please teach me how to do that?

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.