Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTAForums Annual Awards 2018

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Arena War
      2. After Hours
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA Next

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

ikt

[IV]TrafficLoad

Recommended Posts

RokDrk

You guys do know that if you have or downloaded one of these "car packs" or installed a couple cars that are larger than 4mb and use this its pretty much suicide for your pc...

 

If you have missing textures you can use the -memrestrict on the commandline to fix disappearing textures...

http://www.gtaforums.com/index.php?showtopic=404147

 

Share this post


Link to post
Share on other sites
bigboy19_07

 

Yo, i put it in my GTA4 folder but everytime i launch GTA 4 all i get is TAXI"S!!!!, i've checked everything to see if i did something wrong, nothing, and theres no tutorials online on how to do it, please help!!

in order to make trafficload to work, you must have some files in gta 4 directory:

- xliveless 0.999b (xlive.dll)

- scripthook.dll (0.4.0 for patch 1.0.0.4 and 0.5.1 for patch 1.0.0.7)

- asiloader (dsound.dll) -THIS IS BAD, DO NOT DO THIS, XLIVELESS DOES THIS FOR YOU

- trafficload.ini and trafficload.asi

- msvcr100d.dll

I fully agree with you except for the part I highlighted in ORANGE

wow, i've never known that until you mention it... thanks man... smile.gif

 

You guys do know that if you have or downloaded one of these "car packs" or installed a couple cars that are larger than 4mb and use this its pretty much suicide for your pc...  If you have missing textures you can use the -memrestrict on the commandline to fix disappearing textures... http://www.gtaforums.com/index.php?showtopic=404147

here is the commandline i currently use:

 

-norestrictions -nomemrestrict  -percentvidmem 100 -memrestrict 681574400 -memrestrict 629145600 -availablevidmem 2 -noprecache -novblank

 

it works for me about an hour with no text missing problem, i also set the traffic cycle in trafficload.ini to 10. My custom carpack is about 200 mb (replace all 2-door cars into HD supercars and all bikes) and extra car pack 81mb, ingame settings for traffic density is 40. confused.gif

Edited by bigboy19_07

Share this post


Link to post
Share on other sites
RokDrk

 

-norestrictions

-nomemrestrict 

-percentvidmem 100

-memrestrict 681574400

-memrestrict 629145600

-availablevidmem 2

-noprecache

-novblank

 

Well I don't know much about the percentvidmem even being there because when I would use it, it used to crash my game and my wouldn't even allow me to see videos after the crash..

 

My car pack is around 145mb I just replaced all the exotics and the muscle cars and some 4 door cars, and I have a added cars .img that compose of cars that are bigger than 3mb which is around 55mb my traffic density is 5 mostly because I'm using the Realism Traffic/Pedestrian Mini-Mod and spawns around 15-20 cars around me.

 

-noprecache

-memrestrict 681574400

-memrestrict 629145600

-availablevidmem 5.0

 

My commandline I can pretty much run this game pretty much all day...

Share this post


Link to post
Share on other sites
ikt

I don't give a f*ck anymore.

 

People who want the source, see the OP.

Share this post


Link to post
Share on other sites
RokDrk

suicidal.gif Damn

 

Anyways it works perfectly for me I just don't know why it doesn't work for the others...

 

Mostly either your pcs can't handle it or you have so many car mods and you still wonder why your game runs slow/disappearing textures... facedesk.gif

 

Thanks for the mod ikt!!! biggrin.gif

Edited by RokDrk

Share this post


Link to post
Share on other sites
ikt
suicidal.gif Damn

 

Anyways it works perfectly for me I just don't know why it doesn't work for the others...

 

Mostly either your pcs can't handle it or you have so many car mods and you still wonder why your game runs slow/disappearing textures... facedesk.gif

 

Thanks for the mod ikt!!! biggrin.gif

I've done a little bit here and there so if you're unsatisfied you can grab the version from the source code in the OP.

 

Reposting here for clarity.

Download

.ini instructions in first post.

Share this post


Link to post
Share on other sites
v3teran

 

suicidal.gif  Damn

 

Anyways it works perfectly for me I just don't know why it doesn't work for the others...

 

Mostly either your pcs can't handle it or you have so many car mods and you still wonder why your game runs slow/disappearing textures...  facedesk.gif

 

Thanks for the mod ikt!!!  biggrin.gif

I've done a little bit here and there so if you're unsatisfied you can grab the version from the source code in the OP.

 

Reposting here for clarity.

Download

.ini instructions in first post.

Hi IKT.

Would like to say that your mod is the best traffic fix i have used and i very rarely get taxis or texture popups.

Here is a quick vid i made with L3VO enb,HD textures and other mods Maxed out at 1200p on a GTX 690.

 

 

I do want to ask you a couple of questions though....

The scipt that you added in your original OP.this one...

 

[Options] //multipliers in %

CustomDensity=0 //0 is false 1 is true

PedDensityMultiplier=400 //100 is default, 50 is half, 200 is double, etc. Value has no effect when CustomDensity is 0

CarDensityMultiplier=400 //same as peddensitymultiplier

CarsPerCycle=10 //10

 

[AddedCars] //refer to the readme for more info

Enable=0

Amount=2

1=ambulance

2=firetruk

 

 

Do i get rid of the old taxi script ini and copy and paste this one in?

Whats the difference between them?

Also when i change say ped/cardensitymultiplier to any value apart from the default and set customdensity to 1 using the older taxi script ini,all the cars or peds on the road are gone,its does not seem to work except for using the default values.Does this newer script fix that?

 

I would appreciate it if you could answer these questions please.

Thanks alot and i will continue to use this Taxi fix as like i said its the best.

Edited by v3teran

Share this post


Link to post
Share on other sites
RokDrk

 

Would like to say that your mod is the best traffic fix i have used and i very rarely get taxis or texture popups.

Here is a quick vid i made with L3VO enb,HD textures and other mods Maxed out at 1200p on a GTX 690.

 

 

Judging from the video there was around 4-6 taxis wherever you were sarcasm.gif

 

Share this post


Link to post
Share on other sites
v3teran

 

Would like to say that your mod is the best traffic fix i have used and i very rarely get taxis or texture popups.

Here is a quick vid i made with L3VO enb,HD textures and other mods Maxed out at 1200p on a GTX 690.

 

 

Judging from the video there was around 4-6 taxis wherever you were sarcasm.gif

But it still has variable cars and its nowhere near as bad as it was before,im happy with it,oh yeah i get no texture popup so its working well,all fully maxed out biggrin.gif

Edited by v3teran

Share this post


Link to post
Share on other sites
raggazam

share as it is set, because I carpack of a 170mb even after 30 minutes, I lose textures

 

Share this post


Link to post
Share on other sites
v3teran

Try this for starters....

im using a car pack and have everything on full,some car packs give you massive texture popup because of the amount of data that each car takes up,so i went with this pack which has great graphics but is not extreme.

http://www.youtube.com/watch?v=K_2Sa...ature=youtu.be

 

Also put this in your commandline.txt

-norestrictions

-nomemrestrict

-percentvidmem 100

-memrestrict 681574400

-memrestrict 629145600

-availablevidmem 4.0

-noprecache

-novblank

 

 

 

-novblank is no vsync but for some reason adding it here gives me better performance,without it i get popup,i just force vsync through inspector and it works great.....very wierd in the way this game works

Share this post


Link to post
Share on other sites
RokDrk

Question why do you guys dl cars packs? Rly...

Can't you just find cars that fit your taste and avoid these cars packs that have super sh*tty cars...

Share this post


Link to post
Share on other sites
v3teran

 

Question why do you guys dl cars packs? Rly...

Can't you just find cars that fit your taste and avoid these cars packs that have super sh*tty cars...

Because they save time.

 

Couple more vids.

Raining Video

 

Daytime-Sunny-Raining also near the end of video.

 

 

Edited by v3teran

Share this post


Link to post
Share on other sites
sammydogbro

So this trafficloader is my last rescue. Everything else has failed on me, and I really really really want to have at least 25 modded cars in the game.

 

However, It doesn't work. It seems like I still have the problem with every single car being a taxi as soon as I jump into a modded car. Even when I drive default cars, the traffic seems to have unusually many cars of the same model I'm driving. Like every second car. It seems like there's always only like two different types of cars in the game at one time.

 

So I'm running version 1.0.4. It seems like trafficload doesn't load properly. I tried copying msvcr100.dll to my game folder, whoever this crashes me game when it loads my save.

 

It seems like I only get an entry in the scripthook log when I use msvcr100.dll.

 

Log start: Tue Aug 14 03:18:05 2012

-----------------------------------------------

[iNFO] GTA IV Script Hook 0.5.1 - © 2009, Aru - Initialized

[iNFO] Process base address: 0x1300000

[iNFO] Auto detecting game version

[iNFO] Using game version 1.0.4

[iNFO] [TrafficLoad] Thread started

 

I've played the game many times since the 15th without msvcr100.dll. (because, well it makes the game crash)

 

Whatever should I do? I'm desperate!

 

 

========System Specs=========

 

Windows 7 Home Pro 64bit

8 gig RAM

Geforce 670 graphics card

intel i5k processor

 

 

Share this post


Link to post
Share on other sites
Trigger_85

 

I've played the game many times since the 15th without msvcr100.dll. (because, well it makes the game crash)

It's not that msvcr100.dll cause the problem but mod it self. I think traficload worked well only with xlive less. I have asi loader and it does not work so good. It keep on crashing after a while of gaming

Share this post


Link to post
Share on other sites
serka757
I've played the game many times since the 15th without msvcr100.dll. (because, well it makes the game crash)

It's not that msvcr100.dll cause the problem but mod it self. I think traficload worked well only with xlive less. I have asi loader and it does not work so good. It keep on crashing after a while of gaming

Absolutely right. I'm using the script only with Xliveless and I have no game crashes.

Share this post


Link to post
Share on other sites
Platinumjsi

Hi, Modding nub here, can someone advise me what I am doing wrong? as per the instructions I have copied the files into my GTA IV directory and fired up the game but after a few mins I still just get taxis?

Share this post


Link to post
Share on other sites
meganfoxer

Hi, i've just installed the ultimate vehicle car pack, and the only issue is when the trainer (the f4/f3 button) is not loaded, i've got a taxi bug. However, if the trainer works and i could spawn cars etc, i got missing textures.

 

I've done all the necessary steps including copying the trafficload. Also, i got scripthook in my gta directory, i've also tried using commandline and reducing all the graphical settings such as vehicle density,view distance, etc. Also, making the shadow,texture filter in low settings and leaving only the video mode to its maximum (1920x1080). But, still got the missing textures. sad.gif

 

If its because there are too many car models, is there any way to fix it??

Please help me guys..!! cryani.gif

 

 

Share this post


Link to post
Share on other sites
Wass
Hi, i've just installed the ultimate vehicle car pack, and the only issue is when the trainer (the f4/f3 button) is not loaded, i've got a taxi bug. However, if the trainer works and i could spawn cars etc, i got missing textures.

 

I've done all the necessary steps including copying the trafficload. Also, i got scripthook in my gta directory, i've also tried using commandline and reducing all the graphical settings such as vehicle density,view distance, etc. Also, making the shadow,texture filter in low settings and leaving only the video mode to its maximum (1920x1080). But, still got the missing textures. sad.gif

 

If its because there are too many car models, is there any way to fix it??

Please help me guys..!! cryani.gif

I had missing textures bug in TBoGT too,my clip "capture setting" was On,first when I launched the game everything was fine,but then(after around 10-15 min) all textures dissapeared at the same time wow.gif ,I only saw a few lods,but it was fixed when I turned the clip capture off,and everything got back to normal tounge.gif ,try it

Share this post


Link to post
Share on other sites
meganfoxer
Hi, i've just installed the ultimate vehicle car pack, and the only issue is when the trainer (the f4/f3 button) is not loaded, i've got a taxi bug. However, if the trainer works and i could spawn cars etc, i got missing textures.

 

I've done all the necessary steps including copying the trafficload. Also, i got scripthook in my gta directory, i've also tried using commandline and reducing all the graphical settings such as vehicle density,view distance, etc. Also, making the shadow,texture filter in low settings and leaving only the video mode to its maximum (1920x1080). But, still got the missing textures.  sad.gif

 

If its because there are too many car models, is there any way to fix it??

Please help me guys..!!  cryani.gif

I had missing textures bug in TBoGT too,my clip "capture setting" was On,first when I launched the game everything was fine,but then(after around 10-15 min) all textures dissapeared at the same time wow.gif ,I only saw a few lods,but it was fixed when I turned the clip capture off,and everything got back to normal tounge.gif ,try it

Did you mean the clip capture below the auto save setting?? if thats what u meant, it still didn't work. sad.gif

Share this post


Link to post
Share on other sites
Platinumjsi

Bump, anyone got any tips? / better guide?

Share this post


Link to post
Share on other sites
SimViper66

I edited my cargrp.dat and vehicles.ide and without this mod and without carmods I added the Bus, Sultanrs, Infernus, Comet and Roman's Taxi, and also the Sanchez appears more often. But with this mod installed (which I need even with one carmod if it's over 3MB) I miss Roman's Taxi and the Sanchez. Although I like it that every other vehicle appears, most even outside their regular neighborhood, I hope you can make Roman's Taxi and the Sanchez appear in a future update.

Share this post


Link to post
Share on other sites
ikt
I edited my cargrp.dat and vehicles.ide and without this mod and without carmods I added the Bus, Sultanrs, Infernus, Comet and Roman's Taxi, and also the Sanchez appears more often. But with this mod installed (which I need even with one carmod if it's over 3MB) I miss Roman's Taxi and the Sanchez. Although I like it that every other vehicle appears, most even outside their regular neighborhood, I hope you can make Roman's Taxi and the Sanchez appear in a future update.

You can do that yourself by enabling the loading of custom cars and then adding a the filename of Romans cab and whatever you want too.

 

Sanchez should spawn normally though.

Share this post


Link to post
Share on other sites
SimViper66
I edited my cargrp.dat and vehicles.ide and without this mod and without carmods I added the Bus, Sultanrs, Infernus, Comet and Roman's Taxi, and also the Sanchez appears more often. But with this mod installed (which I need even with one carmod if it's over 3MB) I miss Roman's Taxi and the Sanchez. Although I like it that every other vehicle appears, most even outside their regular neighborhood, I hope you can make Roman's Taxi and the Sanchez appear in a future update.

You can do that yourself by enabling the loading of custom cars and then adding a the filename of Romans cab and whatever you want too.

 

Sanchez should spawn normally though.

So even stock rockstar vehicles can be added to the added vehicles. I thought that only worked for added cars (in added vehicles.img etc) Thanks for the info! I should have tried it before.

Share this post


Link to post
Share on other sites
boss06

ikt texture problems.. msvcr100d.dll how to fix ??

Share this post


Link to post
Share on other sites
Hypertenzion

Works like a charm!

Thanks! cool.gif

Share this post


Link to post
Share on other sites
JLJ89

Can someone help me please? I tried many methods and I'm tired already. The game keeps on crash, here's the details:

 

Problem signature:

Problem Event Name: APPCRASH

Application Name: GTAIV.exe

Application Version: 1.0.7.0

Application Timestamp: 4bd9efbe

Fault Module Name: GTAIV.exe

Fault Module Version: 1.0.7.0

Fault Module Timestamp: 4bd9efbe

Exception Code: c0000005

Exception Offset: 007e7c24

OS Version: 6.1.7600.2.0.0.256.1

Locale ID: 1033

Additional Information 1: fea7

Additional Information 2: fea78afc140967119290cc27385e0510

Additional Information 3: 20ce

Additional Information 4: 20ce3e492a2aa7e5b8cfe9b7b1f05b42

 

 

Someone help me please.... sad.gifsad.gifsad.gifsad.gifsad.gif

Share this post


Link to post
Share on other sites
Trigger_85

So does someone has knowledge about how to make this awesome mod work with dsound (asi loader) only. I like to play multiplayer from time to time. I haven' check xliveless but assuming that it works for others it will do the trick. Problem is I wont be having possibility to launch multiplayer.

Share this post


Link to post
Share on other sites
Rainbow Swag
ikt texture problems.. msvcr100d.dll how to fix ??

The readme said to put the included file there, worked for me. Author apparently forgot to compile it as release.

 

 

 

@Trigger:

This won't work in MP.

Share this post


Link to post
Share on other sites
Trigger_85

if it works without xliveless it will work on mp. Problem is it crush the game on random moment during play with asi load only smile.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 Members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.