Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (86,018 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

ikt

[IV]TrafficLoad

Recommended Posts

lolleroz
report, I'm at 43 cars replaced now and I start experiencing random crashes (maybe it was at 40 already)

 

is this fixable?

 

can you try this mod on these cars packs that replace 100 cars or something???

 

and oh I back tracked to reduce the number of cars but in the game I could only get maybe 10 different cars on all streets, I mean I lacked variety, the mod seem to love to spawn stock cars and only some modified cars and then copy paste them to all streets confused.gif

It is an issue with the engine.

 

Seems like you cannot have more than 40 or so different cars. It will eventually crash once you get pass the 40 car barrier.

 

Not sure if the problem is only related to modded cars only. Maybe you can have more than 40 cars with stock models (or models of the same size).

That, my friend, is bullsh*t. I'm running my game with about all cars replaced except for 10, and added 5 new cars as well. I'm not experiencing any crashes, except for FPS slowdowns which is self-explanatory. There is no limit, either your game has memory leaks cause of too much polygons on car models, or one of the models is f*cked up

Share this post


Link to post
Share on other sites
thogan2012
report, I'm at 43 cars replaced now and I start experiencing random crashes (maybe it was at 40 already)

 

is this fixable?

 

can you try this mod on these cars packs that replace 100 cars or something???

 

and oh I back tracked to reduce the number of cars but in the game I could only get maybe 10 different cars on all streets, I mean I lacked variety, the mod seem to love to spawn stock cars and only some modified cars and then copy paste them to all streets confused.gif

It is an issue with the engine.

 

Seems like you cannot have more than 40 or so different cars. It will eventually crash once you get pass the 40 car barrier.

 

Not sure if the problem is only related to modded cars only. Maybe you can have more than 40 cars with stock models (or models of the same size).

That, my friend, is bullsh*t. I'm running my game with about all cars replaced except for 10, and added 5 new cars as well. I'm not experiencing any crashes, except for FPS slowdowns which is self-explanatory. There is no limit, either your game has memory leaks cause of too much polygons on car models, or one of the models is f*cked up

What car pack do you use? Or are you just adding them one by one?

 

You might have most of your cars modded, but it doesn't mean that your game is loading or using all of them. Set your vehicle density to 100, are all your cars varied?

 

I'm using stock vehicles and using three copies of trafficflow. Each .ini can load 20 cars, so 3 is 60. It will crash under 5 minutes if you have them all pushed into the game's memory.

 

 

Share this post


Link to post
Share on other sites
lolleroz

No, the cars aren't varied too much, I'm not using any traffic mods except for this. I installed 'em one by one, friend. I have about 5 different cars on each district, depending on the setting of cargrp file I believe. For example in Algonquin, it's Admiral>Taxi>Washington>Oracle>Police. It all changes after walking down a few streets to other pattern. I don't have a big problem with the fact cars aren't too much varied, cause it's how it is on original game as well

 

but either way, I don't have any game crashes.

Share this post


Link to post
Share on other sites
ikt

Busses not showing up? Three varities of taxis not showing up? It does here.

Share this post


Link to post
Share on other sites
Geri Beuh

I think your mod is awesome....but i don't know how to install it colgate.gif Do I need a specifical version of gta 4 , currently my gta iv is a 1.0.4.0, a specifical version of scripthook ?

Thank you

Share this post


Link to post
Share on other sites
ikt
I think your mod is awesome....but i don't know how to install it colgate.gif Do I need a specifical version of gta 4 , currently my gta iv is a 1.0.4.0, a specifical version of scripthook ?

Thank you

It should work if you have ScriptHook working.

 

I really can't understand where all these complaints are coming from about it not working, I've gotten it to work with both xliveless and dsound (both with ScriptHook (0.4.0 on patch 3 4 and 5 and 0.5.1 on patch 6 and 7) and IT JUST WORKS.

Share this post


Link to post
Share on other sites
XXLpeanuts

Does absolutely nothing for me, and other asi and scripts work fine, so its definately the thing itself

Share this post


Link to post
Share on other sites
napoleonic
I think your mod is awesome....but i don't know how to install it  colgate.gif  Do I need a specifical version of gta 4 , currently my gta iv is a 1.0.4.0, a specifical version of scripthook ?

Thank you

It should work if you have ScriptHook working.

 

I really can't understand where all these complaints are coming from about it not working, I've gotten it to work with both xliveless and dsound (both with ScriptHook (0.4.0 on patch 3 4 and 5 and 0.5.1 on patch 6 and 7) and IT JUST WORKS.

ikt, I have an issue of your mod no longer working if I died and reload a save...

Share this post


Link to post
Share on other sites
Syn1st3r

Doesn't really fix the taxi bug for me unless I did something wrong or forgot something.

Share this post


Link to post
Share on other sites
danteafk

can we have finally an alternative downloadlink ? the file is still awaiting approval on gtamods.

 

i use xliveless.dll and scripthook 0.40 and neither trafficload v2, v3 nor v4 does work for me.

 

i hope it works with v5? please post a new dl link smile.gif

Share this post


Link to post
Share on other sites
ikt

It's done. Read the readme and enjoy!

Share this post


Link to post
Share on other sites
napoleonic

thanks I'll try that...

 

ok ikt, I got more taxis than the v3more version dozingoff.gif so this is not really an improvement

Edited by napoleonic

Share this post


Link to post
Share on other sites
Syn1st3r
thanks I'll try that...

 

ok ikt, I got more taxis than the v3more version dozingoff.gif so this is not really an improvement

I get more taxis than regular cars. So this kinda works.

Share this post


Link to post
Share on other sites
desertfox11194

I can't get this to work, either. I have the newest one off of GTA4-mods.com, and it's being loaded according to the xliveless logs, but its nonfuctional. I'm using game version 1.0.4.0, xliveless .999b7, scripthook 0.4.0 and scripthookdotnet v1.7.1.7 beta. I have simpletrainer v6.3 installed and it works, so all of these files are the correct ones. All other .asi that I have tried also work, except other traffic mods in .asi form. Traffic mods that are Scripts work fine as well, such as traffic control system. I do want to try this one though, but I can't get it working.

Share this post


Link to post
Share on other sites
Geri Beuh

the same thing for me, the script don't load anymore, nothing in the scripthook.log.... but i think there is an issue, in the ikt's read me file there are instructions about security, how to ?

Share this post


Link to post
Share on other sites
egorka

Hello, IKT.

 

First, Thank you for solving traffic problem.

 

i have some advice:

 

make cfg or ini file, where we can configure traffic load, for exmaple:

 

1) number of simultaneously loaded cars and time interval of updating cars.

2) list of cars that script use - I have many added cars (like blista2, blista3 and so on...), so script do no know their names and could no

t load them.

3) other parametres

 

 

Is it possible? It would be great, especially car list (2.)

 

Thank you.

Share this post


Link to post
Share on other sites
ikt
Hello, IKT.

 

First, Thank you for solving traffic problem.

 

i have some advice:

 

make cfg or ini file, where we can configure traffic load, for exmaple:

 

1) number of simultaneously loaded cars and time interval of updating cars.

2) list of cars that script use - I have many added cars (like blista2, blista3 and so on...), so script do no know their names and could no

t load them.

3) other parametres

 

 

Is it possible? It would be great, especially car list (2.)

 

Thank you.

1 Can do, but may conflict with other mods (HippieCommunists zombie mod wherin you can set Traffic/Ped Density etc)

TrafficDensity = 1.0 //Traffic density multiplier, ingame to 50 and here to 2.0 means equal as 100 ingame.

PedDensity = 1.0

Should look like that

 

2 Can't do car variants.

 

3 There aren't any more parameters tounge.gif

Share this post


Link to post
Share on other sites
Geri Beuh

Just a question , IKT what is your OS ? ( sorry for bad english , i am a french guy ^^ )

I think the fix depends of the OS, because i have windows 7 64 bits and it doesn't work

Share this post


Link to post
Share on other sites
ikt
Just a question , IKT what is your OS ? ( sorry for bad english , i am a french guy ^^ )

I think the fix depends of the OS, because i have windows 7 64 bits and it doesn't work

Windows 7 64-bit

 

Totally turn off or remove where possible UAC, antivirus and other so-called security measures. Antivirusses won't stop people who want to do real harm and you shouldn't visit suspicious porn websites on the same computer you do your bank stuff on.

Share this post


Link to post
Share on other sites
Geri Beuh

Please can you make a screenshot of your gta iv directory ?

Share this post


Link to post
Share on other sites
desertfox11194

By added cars I think he means cars added, not replaced. Not exactly car variants.... just new cars. The game can use them, as they sometimes appear in traffic and parking lots if you are driving one, but will not spawn otherwise. (must use trainer or manually add them to cargrp.dat) There has to be a way for the mod to be aware of the file path containing these cars, similar to the way you can make the game's own car spawning system aware of them.

 

EDIT: I got this working and it does spawn added cars for me. I've not added them to cargrp.dat, but if I've driven them recently the mod spawns them more often then any other model. (this may be the game, not the mod, unless your mod completely overrides the games normal car spawner). My ONLY complaint right now that this causes the disappearing textures bug. I also ran out of video memory after about 10 minutes. Both of these are likely my lack of RAM and VRAM, but I can't afford to upgrade, so a config file allowing me to lower the number of cars spawned would be nice. Until then, traffic control system is the only option for me. Sad because I am very impressed with the variety of cars spawned by the mod. TCS only spawns half of the possible vehicles, and with far more model repetition in a given area.

Edited by desertfox11194

Share this post


Link to post
Share on other sites
Syn1st3r
EDIT:I've driven them recently the mod spawns them more often then any other model. (this may be the game, not the mod, unless your mod completely overrides the games normal car spawner).

I've noticed this to. Tbh I'm tired of seeing 50 Turismo's , 20 taxis and 5 cop cars repeating. Great mod but there needs to be more variety.

Share this post


Link to post
Share on other sites
ikt

desertfox, try the new archive with less traffic (there are 2 versions), computers with graphics card with insufficient VRAM tend to make textures disappear when you have many high poly cars on screen, or lower your traffic density. If yourse now is at 100, it means with the normal (the one with more traffic) is equal to 350.

 

Syn1st3r, there can't be any more variety than this due to how it loads. I can do make it load faster but that would eventually make your game crash if you aren't moving fast enough to make old cars disappear.

Share this post


Link to post
Share on other sites
Geri Beuh

Your fix works now, thanks for pm, but i think you must write in your read me that we must have a msvcr100d.dll for those the fix doesn't work. ( sry for bad english )

Share this post


Link to post
Share on other sites
napoleonic
desertfox, try the new archive with less traffic (there are 2 versions), computers with graphics card with insufficient VRAM tend to make textures disappear when you have many high poly cars on screen, or lower your traffic density. If yourse now is at 100, it means with the normal (the one with more traffic) is equal to 350.

 

Syn1st3r, there can't be any more variety than this due to how it loads. I can do make it load faster but that would eventually make your game crash if you aren't moving fast enough to make old cars disappear.

why does your newest version (v4?) has more taxis than v3more version?

 

and oh btw I have an odd thing, I've replaced around 45 cars now, however there's 1 car that NEVER EVER SPAWNED with all of your trafficload : PATRIOT that replaced with Hummer H2!

 

I'm very confused here, why that one car never spawned automatically while all other cars have at least once in different playing times.... confused.gif

Share this post


Link to post
Share on other sites
desertfox11194

I will try that. However my traffic density is already at 1. I've played with it at one since I got any modded cars in order to keep framerates up.

Share this post


Link to post
Share on other sites
ikt
desertfox, try the new archive with less traffic (there are 2 versions), computers with graphics card with insufficient VRAM tend to make textures disappear when you have many high poly cars on screen, or lower your traffic density. If yourse now is at 100, it means with the normal (the one with more traffic) is equal to 350.

 

Syn1st3r, there can't be any more variety than this due to how it loads. I can do make it load faster but that would eventually make your game crash if you aren't moving fast enough to make old cars disappear.

why does your newest version (v4?) has more taxis than v3more version?

 

and oh btw I have an odd thing, I've replaced around 45 cars now, however there's 1 car that NEVER EVER SPAWNED with all of your trafficload : PATRIOT that replaced with Hummer H2!

 

I'm very confused here, why that one car never spawned automatically while all other cars have at least once in different playing times.... confused.gif

Good call, forgot Patriot. Sorry, I tend to overlook some things when doing 84 lines of car.

Newest version (ditch the versions, they suck) loads every taxi, not just one taxi. And it's New York. Taxis really are common.

Share this post


Link to post
Share on other sites
egorka

so, and what about editable car spawn list and editable number of cars loaded at the one moment?

Share this post


Link to post
Share on other sites
ikt
so, and what about editable car spawn list and editable number of cars loaded at the one moment?

All cars are spawned, there is no need for a editable car spawn list.

The numbers of cars loaded at one moment is tweaked to give a good balance between boring taxi traffic and crashing. If you fiddle around with that the game is almost sure to crash, or to load only taxis. Besides, it works good enough. If one batch of cars has left another one already has been spawned.

Share this post


Link to post
Share on other sites
Geri Beuh

It works now for me, i just add a mscvr100d.dll ... u didn't say we have to download this file in your readme. so the needed files for this amazing fix are an asi loader, arus scripthook (curently i have a 0.4.0) and the mscvr100d.dll . i encourage IKT to make updates for this script, i would like to help you but i dont know how script so if i can do a thing to help you, tell me !! ( some people stoped to play gta iv because they cant bear taxibug )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.