Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (84,918 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

coin-god

[GTA IV] Player Rigging Tutorial

Recommended Posts

Pants_Johnson

Hi Fidox,

 

Thanks for the reply buddy i have been tinkering for the last 24 hours to no end. So i have set the material id to 1, whenever i import niko's head it says there are no textures, i thought thebase texture file was kept in the model file and only the diffuse was kept somewhere else...? I also used the include function as opposed to the dictionary item. I apologize for my noobness, im a zbrush user and only just started using max for gta4, otherwise im a maya user, and a very basic one at that. smile.gif

Share this post


Link to post
Share on other sites
FidoX

Oh I see.It happened to me as well.I don't know why but while exporting, max (or the script) deleted my texture files.The solution was that I put the texture files in the folder (head_000_r/texinclude) which the script created and made them read-only.You can store the diffuse map(base texture) bump and spec. map in the model file but the game loads the diffuse map from the wtd file anyway.

Edit: I started to mod GTAIV like a month ago so no problemo biggrin.gif I'm a noob too smile.gif

Edited by fidox

Share this post


Link to post
Share on other sites
Pants_Johnson

THanks fidox i will try that later on tonight! ps any idea about the eyes? When i removed nikos head there was nothing but the bones, do i need to make eyes? Do i need to close the holes in my model is is that not necessary?

Share this post


Link to post
Share on other sites
FidoX

The original head model includes the eyes too.So yes, you need to make the eyes.You could use Niko's eyes as well but it would be a pain in the ass(putting Niko's eyes' textures to yours and then reUVmaping it...).As long as the holes doesn't appear ingame it's not a problem.

Share this post


Link to post
Share on other sites
wapeddell

I will be adding a tutorial on how to do facial animations it's a 30 minute tutorial and I made a video that will show you how.

Share this post


Link to post
Share on other sites
Pants_Johnson

Thanks for all the help guys, your the best!!!! I got my model working without rigging the face, also got my textures working, i had to use the gims editor and not the 3dsmax one..im not sure why but its working and as they say if it aint broke dont fix it! Im posting some shots of my working head! Im waiting for the next tut so i can get the eyes working! I also need to remove the hair because my model is supposed to be bald smile.gif

 

user posted image

user posted image

user posted image

 

Share this post


Link to post
Share on other sites
Pants_Johnson

ps anyone know why my zbrush texture looks so crap ingame, im using a 4096 tex that retains most of its clarity even in photoshop? Im posting a zbrush shot to show you guys, i dont think my bump map is working? Any ideas?

user posted image

 

Share this post


Link to post
Share on other sites
coin-god
Try to reduce it's size. 4k seems alot. 2k is more than enough.

Share this post


Link to post
Share on other sites
N-field

I just recently learned that alot of models for other games dont use bones for facial animations at all, but rather blendshapes, and I also see blendshapes files for gta4 for cutscene peds..... is there another way to do face animations in gta4??? I heard that blendshapes can do a much wider range of facial expressions....

Share this post


Link to post
Share on other sites
Marty McFly

What do I have to do if the face uses multiple textures? My model has one for the face, one for the hair and one for the eyes...

Share this post


Link to post
Share on other sites
coin-god
What do I have to do if the face uses multiple textures? My model has one for the face, one for the hair and one for the eyes...

Merge them in 1 texture and UV map it again.

Share this post


Link to post
Share on other sites
covarasa

hi friend! I have a question... I need to change just the head of my character, but the head is divided into: skull, eyes, hair and hat. I have a texture to each of these parts ... it is possible to merge all parts into a single and transform all textures in one only?

Edited by covarasa

Share this post


Link to post
Share on other sites
coin-god
hi friend! I have a question... I need to change just the head of my character, but the head is divided into: skull, eyes, hair and hat. I have a texture to each of these parts ... it is possible to merge all parts into a single and transform all textures in one only?

Yes, as I said above your post. Merge the textures on 1, and UV map your head again.

You should be able to find tutorials in Google.

Share this post


Link to post
Share on other sites
covarasa
hi friend! I have a question... I need to change just the head of my character, but the head is divided into: skull, eyes, hair and hat. I have a texture to each of these parts ... it is possible to merge all parts into a single and transform all textures in one only?

Yes, as I said above your post. Merge the textures on 1, and UV map your head again.

You should be able to find tutorials in Google.

ok man! thanks for answering.

Share this post


Link to post
Share on other sites
Dud123

what if i just want to rigg a head?

Share this post


Link to post
Share on other sites
coin-god
what if i just want to rigg a head?

Just... rig the head.

Share this post


Link to post
Share on other sites
Dud123

i cant get the unwrap uvw technique to work.

any tutorial that you used?

Share this post


Link to post
Share on other sites
NIRS11

PLEASE HELP ! when i eport my model from GIMS iv i gets an error saying "devmodel/ig_brucie have no geometries"

please solve this

Share this post


Link to post
Share on other sites
spoonweg

hi all,

is there a tutorial like this for making new ped models ?

 

since 4 days i try to use this tutorial for making a new ped model.

i dont have ODR files, i have ODD, so i cant use this tutorial...

 

while browsing with gims iv to the models i found in the cutsprops.img a nice model called "cs_whippinggirl".

i want to use this for making a new "f_y_stripperc02" model.

since the "cs_whippinggirl" had no X on the breasts and is nice textureable.

 

user posted image

 

so first i did was replacing old "f_y_stripperc02" .wdd .wdt .wft with the ones from "cs_whippinggirl".

result: shows up in game, but model wont fit to the animations sad.gif

 

next i use same step without the skelleton file .wtf

result: massive grafic errors since new model polygones floating the whole screen sad.gif

 

so last step was using this tutorial, to fit the model.

result: 4 days working, model shown up but no animations...

 

heres what i did:

i want to use "uppr_000_r" from "cs_whippinggirl" ped model in "f_y_stripperc02" ped model, to have new breasts only.

so i merge "cs_whippinggirl" "uppr_000_r" to the "f_y_stripperc02" ped model scene, next i attach it to "f_y_stripperc02" "uppr_000_r".

(while attaching the skelleton structure will used on "cs_whippinggirl - uppr_000_r" from "f_y_stripperc02 - uppr_000_r".)

then i remove all polygones from the old "uppr_000_r", so have only left the new polygones from new "uppr_000_r".

i got it working to export as ODD with creating new textures ODT.

wen i convert them with gims iv to .wdd and .wdt it shows up in the game, but theres no animations...so fail.

 

so i give up now, dont know more what to do sad.gif

 

maybe one of you have a idea what can i do to get it working or can point me to a tutorial for making new ped models ?

or how to get the ODR files and not a ODD, so i can step up this tutorial ?

 

Share this post


Link to post
Share on other sites
YouKilledKenny17

I finished rigging the head of the hl2 gman model, but when i put it into the game, it crashes on loadup.

 

Any ideas?

Share this post


Link to post
Share on other sites
YouKilledKenny17

I've tried every freaking solution, i've followed ALL of the steps, but EVERYTIME i rig the head and put it in the game, it CRASHES ON LOADUP!!!!!!!!!!!

 

I REALLY need help on this!!!!!! angry.gifangry.gifangry.gif

Share this post


Link to post
Share on other sites
snipeingkicker

user posted image

 

now if i delete dev model

 

user posted image

Share this post


Link to post
Share on other sites
RoosterArmament

Hi guys,

 

If anyone here knows how to rigg players and peds, I would need some help please:

 

1) I successfully converted a Player to GTA IV and it works as a Player but when I try to turn it to a Ped, it crashed my game.

 

2) I've converted another model but this time taking a PED as a base, I do everything I'm supposed to do and then export it as an ODD. Then when I open it whith Open IV, the Head has been turned 90 degrees to the left. I try it ingame and it crashes.

 

Could you help?

Share this post


Link to post
Share on other sites
Mr. Jago
Yeah black, that's the bug. On some wheaters it looks okay though.

 

SpartanTMcC: You are not blind, 3D MAX is a professional tool, it's expensive. You can downlaod the 30 Days trial.

And no, only 3D Max can be used.

 

I got something better:

 

http://students.autodesk.com/?nd=download_center

 

If you say you're homeschooled on the survey then you can get a student key which is basically full activation, except it lasts two years if I remember correctly.

 

Share this post


Link to post
Share on other sites
TehStranger

Hey. I did every single thing exactly like the tutorial and i get the following errors...user posted image

Share this post


Link to post
Share on other sites
YouKilledKenny17

user posted image

 

Is it a 3ds max problem, the gims iv, or both?

Share this post


Link to post
Share on other sites
aliliel

I get a file validator Error saying:

 

Invalid File "Filename > in this case head_000_r.odr"!

It has wrong Format, or Encrypted!

 

and then I can press ok and it didn't import anything confused.gif

Share this post


Link to post
Share on other sites
DlZZEE

Could anyone help? I can't import files confused.gif.

 

user posted image

 

Also OP should update the post, It's outdated and he didn't even finished the tutorial after 2 years sad.gif.

Share this post


Link to post
Share on other sites
kadu
Reserved.

Torso and Legs rigging.

 

Soon...

And torso?????????

Share this post


Link to post
Share on other sites
Firstyminator

May i be so bold, to ask this simple question?

 

I have a PED, which had two uppr_ models.

 

I removed the uppr_000, and renamed uppr_001 to 000 - Everything seems normal in both 3DS and OpenIV.

 

But when i get ingame, the uppr_000 does not show at all, its invisible.

 

Materials seems to be mapped correctly. This is a ped that worked before the removal of uppr_000, i only remapped UV, and changed the texture file.

 

Any idea what could cause this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.