Jump to content

GTA IV lags but there shouldn't be any


Rafuezo

Recommended Posts

Hello.

 

I have a strange problem, because GTA IV shouldn't lag on my pc (and it sometimes doesn't, but rarely). I normally have 25-30 fps, so it's not that bad and it should run not too bad. Sometimes I complete 2,3 or 4 missions and it's OK (no lags). But I have a problem because after some time playing there occurs a big lagging, fps go down (even to 3!). I don't even know where it come from, it lags hard even if processor usage is only like 60%. Sometimes even if I start the game it lags immadietely at the menu, I move the mouse on the screen and it jumps from place to place (hardly move). There's no a special moment in the game when the lags appear, they can start at every moment of the game, for example in menu, when I go out a house ingame or when I drive a car for a moment, or when I go to a mission, on a cutscene, or when I go out a cab... But also it can not lag (very very rarely). There is no concrete moment in the game when the lags occur (big explosions or something). The lagging is very dissapointing because I can't play the game normally. My commandline looks like this: -novblank -DX9 /high -refreshrate 60 -notimefix -minspecaudio -nomemrestrict -norestrictions -noprecache. I have the newest drivers for my graphic card and sound card. Game version 1.0.7.0. The game is legally bought.

 

Hardware:

Processor: AMD Athlon 64 X2 Dual Core Processor 5000+ 2.61 GHz

Graphic card: ATI Radeon 4600 series

2.00 GB RAM

Modecom MC 500W

OS: Windows XP Professional Service Pack 3

Sound card: Realtek HD Audio output

 

What is the cause of this lagging problem? I tried to give you all the important info that can be useful to help me, but if I forgot about something write it please and I will answer. Guys, I will really appreciate your help. Please, help me!

PS Sorry for my English but it's not my first language.

 

 

Link to comment
Share on other sites

No, I would say use less as some of those you have there don't even exist.

Link to comment
Share on other sites

Hmm, so plz tell me which of them don't exist, I will tell you what I use them for.

 

Those DX9 /high, nomemrestrict and norestrictions, novblank help me to have better performance when I play. (if u think some of those are unnecessary, please tell me)

The refreshrate 60 command is for my pc refreshrate, because I had a problem with DD3D80 fatal error and people said it's because of my refreshrate. I don't know if this command helped, or something else I did but I don't have this error now and I don't want to risk to have this problem again.

The minspecaudio and notimefix are here because I also had a sound overlaping problem (the sounds of game were overlaping on eachother and there were neverending, like when i used a horn in my car I heard it for all the time, when I get out of a car I could still hear the radio, when I clicked sometihng on my mobile phone I could hear this sound, and those sounds were overlaping on eachother making a huge noise)

 

I don't know which command doesn't do anything, please tell me.

 

Also I have a tip for you guys that can be useful to help me solve my problem (thanks for trying to do so anyways). So I read somewhere that 1 guy had same problem as me, and he said that the cause of this bug was pagefile. It can be changed in properties of My Computer->Advanced->Performance->Settings->Virtual memory->Change. (I don't know if i wrote the path right because I have Windows in polish and I just translated the path to english). Then I read that Microsoft recommend to set it to Custom Size then type in Initial size your RAM*1,5 and in Maximum size your RAM*3, which I did. Then I was able to play normally (Hooray!) but only for once... (Ohh...). When I wanted to play GTA again the problem was back. Can you guys help me? Please?

Link to comment
Share on other sites

Ok, I will look at my commandline and try to choose the best commands for me, but what would you say about this pagefile I wrote in the previous post? Can it be something with it?

Link to comment
Share on other sites

I don't think you can actually fix anything with the page file, there are many of these temporary GTAIV "fixes".

Link to comment
Share on other sites

Like I already said, your CPU is underpowered, you're low on RAM and the GPU is not the best for this game (I'm assuming it's at least a 4670). I'm not sure what you're shooting for, there is not much you can do but making sure you have the least amount of processes running in the background and lowering the settings a bit. Absolutely skip the norestrict commandline options.

Link to comment
Share on other sites

It can't be something with my hardware if I get 30+ fps. I do meet the minimum requirements of the game and also half of the recommended. I can play sometimes without lags, it happens rarely but it does. Also when I click Auto Config it choose higher details than I have chosen. Thanks for your help anyways.

Link to comment
Share on other sites

My CPU is about 2.5-3 times stronger (raw computing power) then yours, I get about 35-38FPS.

 

One last time, you're deluding yourself, meeting minimum specs does not mean being able to play trouble free on too high settings.

Link to comment
Share on other sites

But it means playing lag-free on lowest settings. And if I meet minimum and half of recommended I try to play low/medium. I play on resolution 1024x768 (60Hz) and medium settings. Distance is set to 10 and detail distance to 15. On that settings 30 fps when the problem doesn't occur.

Link to comment
Share on other sites

So, is there any fix? Today I played few missions without lags, but then it happened again...

Link to comment
Share on other sites

OverTheBelow

Is your processor overheating? Download Realtemp and check if it goes above 80C. This is roughly the area at which the CPU will begin to throttle itself to get rid of the heat, in result slowing down GTA 4 substantially. If it does go above 80C, you need to get rid of the mountains of dust probably in your case and/or consider adding another fan or two.

 

The same happens with graphics card overheating - check in Catalyst Control Panel performance -> overdrive section if it is going above 80C.

DU8afL0.jpg

Link to comment
Share on other sites

The temperatures are ok, I checked them with HWmonitor, here are the results:

user posted image

 

Link to comment
Share on other sites

Listen to mkey82, he is completely right. Your computer is not good enough to run GTA IV without any hiccups, simply put.

Link to comment
Share on other sites

Right, so there no chance to play without it? Even when sometimes it doesn't happen? Ok... sad.gif So requirements lies...

Link to comment
Share on other sites

  • 3 weeks later...
PacketOverload_x64bit

Try this:

 

When you load from your savegame and you're standing inside your apartment, press ESC, go to options, change water quality to something "other" than what it is set to i.e.: Currently Set to High > Set it to "Very High" or "Medium"

 

 

You can do it when the menu first loads after the loadscreens, but you'll have to do it again after the game loads in your apartment. This might help and it's easy so... smile.gif

Link to comment
Share on other sites

YankeesPwnMets
Right, so there no chance to play without it? Even when sometimes it doesn't happen? Ok... sad.gif So requirements lies...

[sARCASM]NO WAY! The requirements only speak the truth[/sARCASM]

What you expect? GTA IV has been around for several years and even people with recommend requirements have issues with performance while running the game. Your PC barely breaks the MINIMUM requirements, so why do you expect you can run the game flawlessly?

 

You need to get some more RAM. 2.0GB isn't enough RAM for GTA IV. 2GB of RAM shouldn't be in the recommended requirements. 2GB should be in the absolute minimum requirements. In game, the actual recommended is 4GB of RAM

 

Also, download and install this update from AMD

 

http://sites.amd.com/us/game/downloads/Pag...deon_xp-32.aspx

Link to comment
Share on other sites

 

... GTA IV has been around for several years and even people with recommend requirements have issues with performance while running the game ...

Indeed, check my signature. I passed at the recommended, and even I can barely hold 30 fps on normal graphics (no ENB) confused.gif

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.