Jump to content

Weapon sound lag


Dudecar4

Recommended Posts

Hello all, let me start out by showing you my specs...

 

OS-Windows XP Home Edition SP3 2GB RAM

Processor-Intel Celeron 2.70GHz

Graphics card-NVIDIA ge-force 8400gs 512mb (Omega drivers) <- this is not the issue, I'm sure.

Sound card-Diamond Xtreme sound 7.1 PCI

 

Alright, this problem starts out by me pulling out a weapon and

shooting it, as I shoot a weapon, my fps drops very low and then climbs

back up when I stop shooting.I approximately go from (60fps to about 20) VERY fast.

I am using a cracked no DVD exe, but I'm not 100% sure if that's the problem, I looked at the "collected audio fixes" on this site and nothing on here seemed to fix it, I have looked everywhere to see if anyone is having this issue, but no luck. I can handle SA very well, it's just the stupid weapon lag that is bothering me, if anyone out there could help I'd be much obliged,

 

Thanks! biggrin.gif

 

~Dudecar4

Edited by Dudecar4
Link to comment
Share on other sites

Get rid of the crack, play the game from the disc and see if it makes any difference.

Link to comment
Share on other sites

This did seem to fix it a bit, but still experiencing a bit of lag, any other suggestions, if so, i'd be glad colgate.gif

 

~Dudecar4

Link to comment
Share on other sites

Try running the game in Windows 98 compatibility mode.

If it still doesn't help, then you can try disabling sound acceleration from the DirectX Diagnostic Tool.

Link to comment
Share on other sites

 

girishb

Try running the game in Windows 98 compatibility mode.

If it still doesn't help, then you can try disabling sound acceleration from the DirectX Diagnostic Tool.

I tried the two methods, but no use. I'm still getting tiny bits of lag from shooting confused.gif

 

 

lil weasel

Try:

CAN YOU RUN IT SITE:

http://www.systemrequirementslab.com/cyri/

I already said that my CPU can handle the entire game perfectly, it's just the weapon sound lag. Any other suggestions? smile.gif

 

~Dudecar4

Link to comment
Share on other sites

Since you have XP SP3, try "Rolling Back" to SP2-it is easy, since Windows automatically creates a restore point before you upgraded to SP3 in case you ran into any problems you would be able to "Roll Back" without losing any to very little. If this does not work, then that means it is a Sound card issue. Are your Driver's up to date for the Sound card? Also, Is this the Retail(DVD) version OR a Downloaded version? If Downloaded, from where? If Retail, Is this the Original DVD or a Copy of the DVD?

 

*Rolling back to SP2 can be done easily through System Restore-just select the point right before you installed SP3. This should improve performance, since you have a Single Core processor(as Intel Celeron processors are Single core as far as I know). Just a friendly heads up...

Link to comment
Share on other sites

lil weasel

I was under the impression that the test also covered the capability of the Audio Card and memory use, beyond the CPU.

Link to comment
Share on other sites

I was under the impression that the test also covered the capability of the Audio Card and memory use, beyond the CPU.

Actually, that site you linked to does not seem to work for SA-I tried it on my Windows 7 laptop, and it just came up as unrecognized. It worked great for IV though. I know I am above recommended for SA anyway, as I have an Intel I5 Quad core, 6GB DDR3 ram, ATI Radeon HD5470 and a Intel GMA HD Video card(Switchable graphics), Beats Audio(IDT HD Audio), 7 Home Premium 64-bit. I can Run IV at High settings, and SA Maxed out-even though for some reason AA causes Sound issues. I have V2 of the game, so it is up to date. That is probably because I noticed it says under the Required OS it says "2000/XP ONLY", so that could be why it is not working right for SA? Just a heads up. smile.gif

Link to comment
Share on other sites

 

radioman

Since you have XP SP3, try "Rolling Back" to SP2-it is easy, since Windows automatically creates a restore point before you upgraded to SP3 in case you ran into any problems you would be able to "Roll Back" without losing any to very little. If this does not work, then that means it is a Sound card issue. Are your Driver's up to date for the Sound card? Also, Is this the Retail(DVD) version OR a Downloaded version? If Downloaded, from where? If Retail, Is this the Original DVD or a Copy of the DVD?

 

*Rolling back to SP2 can be done easily through System Restore-just select the point right before you installed SP3. This should improve performance, since you have a Single Core processor(as Intel Celeron processors are Single core as far as I know). Just a friendly heads up...

Thanks a bunch for this idea, I did it and I saw a bit of a tiny fix to the weapon sound lag. It still lags a tiny, tiny bit, but I gotta say, it did improve the performance of the game a lot. By the looks of it, if nothing else is going to remove the weapon lag completely then, perhaps it may be my sound card.

 

P.S. I just switched from a integrated to a regular PCI sound card a few weeks ago, weird that it didn't fix all the weapon lag sad.gif .

 

If there is any other smart, techno people out there, would there be any other solutions or improvements to this issue?

 

Thank you!

 

~Dudecar4

 

 

Link to comment
Share on other sites

I forgot to mention also, try Adjusting the Sound Acceleration level for your Sound Card-just go to: Start, Run, Type in DXDIAG and Press Enter, then select the Sound tab and turn the Acceleration to either Basic OR None-this should help. It helped with the "Rain/storm" bug on my XP Pro laptop. Since you have XP, that is another option you can try. I didn't think about that when I was typing my last post, cause i'm used to Vista and 7(which do not have this option, as it is disabled on ALL Vista OS and Most Windows 7 PC's(Unless you have Windows 7 with the Beats Audio built in-those Windows 7 machines still have Sound Acceleration enabled.)

 

But, yeah, it seems like with XP, SA runs better on SP2 than it does SP3 for some reason. That's why I suggested that option first. But, try adjusting the Sound Accelaration and it might help some more with the Sound lag. HTH.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.