Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTANet.com

    1. GTA Online

      1. Los Santos Summer Special
      2. The Diamond Casino Heist
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA 6

      1. St Andrews Cathedral
    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

      1. Documentation
    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Movies & TV
      5. Music
      6. Sports
      7. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. Announcements

    2. Support

    3. Suggestions

Sign in to follow this  
Strengthcamp

Help Needed

Recommended Posts

Strengthcamp

Ok so I attempted to attach an mp3 to a car and failed miserably, I tried taking bits of someone else's code and using it to build off of. Help!

 

 

{$VERSION 3.1.0027}{$CLEO .cs}//-------------MAIN---------------0000: NOP :NONAME_2wait 0 if   Player.Defined($PLAYER_CHAR)else_jump @NONAME_2 if and  Actor.Driving($PLAYER_ACTOR)84A7:   not actor $PLAYER_ACTOR driving_boat 84A9:   not actor $PLAYER_ACTOR driving_heli   not Actor.DrivingPlane($PLAYER_ACTOR)84C8:   not actor $PLAYER_ACTOR driving_flying_vehicle 89AE:   not actor $PLAYER_ACTOR driving_train else_jump @NONAME_2 if   Actor.DrivingVehicleType($PLAYER_ACTOR, #BULLET)else_jump @NONAME_2 0AAC: $HMP3 = load_mp3 "CLEO\PLAYLIST\01.MP3" if  $HMP3 == 0 else_jump @NONAME_2 if 0AB0:   key_pressed 87 else_jump @NONAME_2 if   Actor.Driving($PLAYER_ACTOR)  not Car.Wrecked([email protected])82BF:   not car [email protected] sunk 8741:   not actor $PLAYER_ACTOR busted wait 0 Object.RemoveReferences([email protected])jump @NONAME_2 

 

Share this post


Link to post
Share on other sites
Bad.boy!

This is a shorter begin:

 

:NONAME_2wait 0 if   Actor.DrivingVehicleType($PLAYER_ACTOR, #BULLET)else_jump @NONAME_2 03C0: [email protected] = actor $PLAYER_ACTOR car jump @NONAME_X 

 

Share this post


Link to post
Share on other sites
DK22Pac

I think here it is what you wanted

 

{$CLEO .cs}audiostream.Load3D([email protected], "CLEO\PLAYLIST\01.MP3"):NONAME_2wait 250 if and   player.Defined(0)   0AB0: key_pressed 87jf @NONAME_2 if and   Actor.DrivingVehicleType($player_actor, #BULLET)   8741:  not actor $player_actor busted jf @NONAME_2 0811: [email protected] = actor $player_actor car_nosaveif    82BF: not car [email protected] sunk jf @NONAME_2audiostream.PerformAction([email protected], PLAY)audiostream.LinkToCar([email protected], [email protected])jump @NONAME_2

 

Share this post


Link to post
Share on other sites
metacortex

Try this:

 

{$CLEO}0000:while true   wait 20   if and   0256:   player $PLAYER_CHAR defined    Actor.DrivingVehicleType($PLAYER_ACTOR, #BULLET)   0AB0:   key_pressed 87   0AAB:  file_exists "CLEO\PLAYLIST\01.MP3"   then       repeat           wait 10       until   0AC1: [email protected] = load_audiostream_with_3d_support "CLEO\PLAYLIST\01.MP3" //IF and SET       03C0: [email protected] = actor $PLAYER_ACTOR car        while 00DB:   actor $PLAYER_ACTOR in_car [email protected]           0AC5: link_3d_audiostream [email protected] to_vehicle [email protected]       end       Car.RemoveReferences([email protected])       0AAE: release_audiostream [email protected]   endend

 

 

CLEO 4 required!!

Share this post


Link to post
Share on other sites
Strengthcamp

I'm sorry but I don't know what to do with that. I hit compile and it tell me unknown opcode.

 

Also, will the mp3 be heard from outside the car?

 

And originally I wanted this to work for every car, I don't know why I put Bullet only.

Share this post


Link to post
Share on other sites
Bad.boy!

compile should work, this script should work with every car:

 

 

{$CLEO .cs}//-------------MAIN---------------0000: NOP :NONAME_2wait 20 if and  Player.Defined($PLAYER_CHAR)  Actor.Driving($PLAYER_ACTOR)0AB0:   key_pressed 87 0AAB:   file_exists "CLEO\PLAYLIST\01.MP3" else_jump @NONAME_141 :NONAME_55wait 10 Audiostream.Load3D([email protected], "CLEO\PLAYLIST\01.MP3")else_jump @NONAME_55 03C0: [email protected] = actor $PLAYER_ACTOR car :NONAME_101  Actor.InCar($PLAYER_ACTOR, [email protected])else_jump @NONAME_131 Audiostream.LinkToCar([email protected], [email protected])jump @NONAME_101 :NONAME_131Car.RemoveReferences([email protected])Audiostream.Release([email protected]):NONAME_141jump @NONAME_2 

 

Share this post


Link to post
Share on other sites
Strengthcamp

This is so confuse for a noob like me. I get error message "Unknown directive Audiostream.Load3D([email protected], "CLEO\PLAYLIST\01.MP3")."

 

But in cleo I made a folder "Playlist" and inside I put an mp3 named 01.mp3..

Share this post


Link to post
Share on other sites
DK22Pac

Maybe that's cause you have not the lates classes.db.

 

{$CLEO}0AC1: [email protected] "CLEO\PLAYLIST\01.MP3"while true   wait 0    if and       player.Defined(0)       0AB0: key_pressed 87   then       if           actor.Driving($player_actor)       then           0811: [email protected] = actor $player_actor car_nosave           0AAD: [email protected] 1           0AC5: [email protected] [email protected]       end   endend

 

Share this post


Link to post
Share on other sites
Strengthcamp

I just downloaded sannybuilder and installed again. Same compile problem.

Share this post


Link to post
Share on other sites
Silent

Upgrade a classes.db from latest CLEO4 build and opcodes.txt with sascm.ini from GTAG Opcode Database. Or just download sascm.ini and replace a class to regular opcode.

Share this post


Link to post
Share on other sites
Strengthcamp

Okay I downloaded those two things and it doesn't error anymore. Thank you.

 

I have tried all of your scripts and they all seem to crash after load screen.

 

I think the problem is CLEO\MUSIC.mp3 maybe it supposed to be CLEO/MUSIC.mp3. I don't know I'm not genius like you guys tounge2.gif

 

edit:: okay, so I try to change where the folder check is. And it seems to work when I try CLEO/MUSIC.mp3 but still crash right after loading bar finish.

 

 

And why when I save the code and open it again it's different?

 

THIS BECOMES:

 

{$CLEO}0AC1: [email protected] "CLEO/MUSIC.MP3"while true  wait 0  if and      player.Defined(0)      0AB0: key_pressed 87  then      if          actor.Driving($player_actor)      then          0811: [email protected] = actor $player_actor car_nosave          0AAD: [email protected] 1          0AC5: [email protected] [email protected]      end  endend

 

THIS

 

// This file was decompiled using sascm.ini published by http://gtag.gtagaming.com/opcode-database on 24.4.2011{$VERSION 3.1.1000}{$CLEO .cs}//-------------MAIN---------------0AC1: [email protected] = load_audiostream_with_3d_support "CLEO/MUSIC.MP3" //IF and SET :NONAME_21wait 0 if and  Player.Defined(0)0AB0: else_jump @NONAME_76 if   Actor.Driving($PLAYER_ACTOR)else_jump @NONAME_76 0811: [email protected] = actor $PLAYER_ACTOR car_nosave 0AAD: 0AC5: link_3d_audiostream [email protected] to_vehicle [email protected] :NONAME_76jump @NONAME_21 

 

Edited by Jbenz1

Share this post


Link to post
Share on other sites
Silent

Hmm, try to replace / to \ in path tounge.gif

 

First one is high-level construct, which is a Sanny syntax. Sanny replaces it to regular opcodes while compiling, and decompiles it using only opcodes (low-level).

Share this post


Link to post
Share on other sites
Strengthcamp

Nope, still crash after load bar.

 

Thank you for explanation of why it changes, I thought it broke or something. sigh.gif

 

Maybe you can try on your machine, and see if it crash too.

Share this post


Link to post
Share on other sites
DK22Pac

Here is code with my own mp3, it works 100%

 

{$CLEO .cs}0AC1: [email protected] "audio\radiosurf\track1.mp3"while true   wait 250    if and       player.Defined(0)       0AB0: key_pressed 87   then       if           actor.Driving($player_actor)       then           0811: [email protected] = actor $player_actor car_nosave           0AAD: [email protected] 1           0AC5: [email protected] [email protected]       end   endend

 

Share this post


Link to post
Share on other sites
Strengthcamp

sad.gif CLEO don't like me. Maybe it crash because my game don't have radios?

__________________________________________________________EDIT

I even install on vanilla SA, and still same outcome. I never had CLEO 4 problem before.

Edited by Jbenz1

Share this post


Link to post
Share on other sites
Silent

Or maybe you don't have CLEO4? : D

Share this post


Link to post
Share on other sites
Strengthcamp

Thanks for all your help guys. I'll keep trying and will post here if I get it work. smile.gif

 

edit:: okay when installing CLEO 4 build, I get error "Failed to open and write C:\Program Files\Sanny Builder 3\data\sa\classes.db". I think this is problem.

Edited by Jbenz1

Share this post


Link to post
Share on other sites
DSMTuner
Thanks for all your help guys. I'll keep trying and will post here if I get it work. smile.gif

 

edit:: okay when installing CLEO 4 build, I get error "Failed to open and write C:\Program Files\Sanny Builder 3\data\sa\classes.db". I think this is problem.

I've always had that problem, I never really thought much of it as I only needed to click 'abort'.

Share this post


Link to post
Share on other sites
Node

I used to have problems installing CLEO 4 with the installer, What i did is ran in administrator and compatability mode it worked perfect! smile.gif

Share this post


Link to post
Share on other sites
Strengthcamp

I got it to install thanks to The_Sorrow suggestion. It still crash after load bar, it's so frustrate.

 

edit:: I found out Cleo 4 don't crash if I uninstall sannybuilder. Until I figure what file cause conflict can someone compile for me on mediafire?

Edited by Jbenz1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.