Jump to content

Help running GTA IV properly on my Notebook


darkfailure

Recommended Posts

darkfailure

Hello guys!

 

I came to this place since GTA Vice City was released but sadly, I waited until today to register here.

I have a few problems with my Notebook. First of all, I only get about 15-19 fps with the recommended settings. And second, the water is invisible -.-

I know it sounds weird, but although I only get little fps, I still installed ENB Series to get better graphics.

 

And by looking at the video by this guy:

I should actually get more fps than I do right now. After all, my specs appear to be better than his. I don't really get why this game does not seem to work properly.

 

And in fact, I get the same amount of fps then I do when running the game without ENB. When I shoot or cause an explosion, I only get 6 fps, btw.

 

 

Help would be appreciated!

 

My specs are:

 

Intel i7 2630QM (2.0-2,9GHZ)

Amd Radeon HD 6650M (2GB VRam)

6GB DDR3 RAM

 

I am using the 1.0.4.0 version of GTA IV.

 

I hope this is not the wrong place to post this thread.

Edited by darkfailure
Link to comment
Share on other sites

darkfailure

Thanks for the fast response!

 

I only use two command lines:

-percentvidmem

-availablevidmem

But I have to admit that I don't know how to use/configure them properly

It would be nice, if someone can help me solving this problem (and the water problem)

Link to comment
Share on other sites

Make a new text file with notepad, call it 'commandline.txt' (without the quotation marks) and put it in the Grand Theft Auto IV directory (where GTAIV.exe and that stuff also is)

Next, put the commandlines in the file and save.

Just how you make it and get it to work in case you did something wrong wink.gif

 

The command which helped me a LOT was '-noprecache'. It turns pre cache off.

You can also use '-novblank' which removes V-sync.

Try '-disableimposters', it disables imposter rendering for vehicles although I don't really know if it helps in performance.

 

Tell me if this helps you.

Edited by Exxon
Link to comment
Share on other sites

darkfailure

I edited the command line file and inserted the lines you wanted me to add. Sadly, the game looks incredibly bad now because all settings have been automatically set to the lowest. And as soon as I shoot, the fps drop to 10, too sad.gif

Link to comment
Share on other sites

Uhh ... right mercie_blink.gif

 

Try to only use the commandlines which you already had and '-noprecache'.

You say everything has been lowered to lowest automaticly, only '-safemode' does that wow.gif

Edited by Exxon
Link to comment
Share on other sites

darkfailure

Okay...So I will only use "-noprecache" now and tell you how it runs wink.gif

I have no clue why it was all on low...

 

edit: When I throw a molotov/grenade, I only get 5 fps...When I shoot, I get something around 10-15

When I simply walk around without doing anything, I get 25 fps. That means it is better but still not good smile.gif

And I still have invisible water o.O

 

Btw, thanks for helping me (in advance)

Edited by darkfailure
Link to comment
Share on other sites

I see YankeesPwnMets is just reading this topic, let's wait and see what he's going to say wink.gif

Link to comment
Share on other sites

Hmms, he didn't post anything ... too bad whatsthat.gif

I'm sorry, but besides commandline, I don't know something else.

Oh, try Contig.exe, I'm going to use it now also. Many say Contig.exe helps.

Just search on YouTube or Google (or here).

Link to comment
Share on other sites

darkfailure

Okay, I will try it.

Thanks for your help!

I hope other people can help me out with my problem.

 

edit: The contig.exe did not help me at all sad.gif

Edited by darkfailure
Link to comment
Share on other sites

Your GPU is the bottleneck. I recommend patching your game to 1.0.04, not 1.040. I have the same CPU on my laptop with a better GPU so I that must be the problem.

Link to comment
Share on other sites

darkfailure

I know that my GPU is not really that good tounge.gif

I just thought there was a way to get solid 30 fps with the recommended settings. I was not able to fix the water problem, btw. Not even with the texture mod from these forums (and yes, I reinstalled the game several times).

Link to comment
Share on other sites

I know that my GPU is not really that good tounge.gif

I just thought there was a way to get solid 30 fps with the recommended settings. I was not able to fix the water problem, btw. Not even with the texture mod from these forums (and yes, I reinstalled the game several times).

I found a big difference in performance when I was at patch to 1.0.04 Vs 1.040 and using Realizm IV 6.2 on that gave me about 10 extra fps. I would try patch 1.0.04 without any mods first though.

Link to comment
Share on other sites

Holy, forgot to ask about patches blush.gif

I have 1.0.4.0, and many say thats the best one performance wise.

Edited by Exxon
Link to comment
Share on other sites

darkfailure

Do I have to reinstall the game or can I "downgrade" the patch? ( I guess not tounge.gif)

I am running it at 1600x900. Running it at 1280x720 gives me bad graphics but about 2-3 fps more (until there is an explosion smile.gif)

And that ATI tool gave me an error after the installation saying that it has not found compatible hardware.

Edited by darkfailure
Link to comment
Share on other sites

If I remember correctly, you have to uninstall the game and then patch to the patch you want

Link to comment
Share on other sites

darkfailure

Reinstalling the game and the patch did not solve my problem. Reality IV did not grant me any extra fps or fps drops.

Link to comment
Share on other sites

Then I gues your system is too weak then, sorry whatsthat.gif

There is nothing more that I can do confused.gif

Link to comment
Share on other sites

darkfailure

That's a shame. Especially when I look at that YouTube vid again...The game runs on a notebook which is weaker than mine sad.gif

 

You problem with the settings comes most probably from the amount of VRAM, that 2GB is probably the total amount of memory, with shared system ram.

 

Sadly I can not upgrade the laptop

 

I would love to change to the graphics card to a 560 or 580M GTX (I know they are pretty expensive)

Edited by darkfailure
Link to comment
Share on other sites

It could also be the VRAM, particularly if that is DDR3 and using a 128 Bit Bus.

 

If you are ever looking for a more cost effective new system in the future, that will still perform really well then you should consider the HD6970M. That mobile GPU has 2GB of GDDR5 VRAM and a 256 Bit Bus. It performs very closely to the GTX 485M but is almost 50% cheaper. I noticed with a custom built laptop, the GTX 485M costs an extra £292 but the 6970M only costs an extra +43.

 

Along with a mobile i7 2630QM, you will have no problems with GTA IV.

 

Often Youtube videos give a better impression than actual gameplay too.

Edited by Lodis
Link to comment
Share on other sites

darkfailure

Wow, that sounds great! But like I said, I have no idea if I am able to upgrade my notebook (because a google search does not give me any helpful info on that)..

Link to comment
Share on other sites

Wow, that sounds great! But like I said, I have no idea if I am able to upgrade my notebook (because a google search does not give me any helpful info on that)..

It is unlikely you can upgrade your notebook because only ones that use the MXM format are upgradeable. Even taking that into consideration, only recently do we have CPU's and GPU's that can fully handle GTA IV. Sure you could play it on a GTX 285M / ATI 5870 with a mobile quad i7 820qm but that is nothing compared to the Sandybridge techs performance.

 

 

Also your current notebook does not have the power requirements to deal with the higher wattage of those newer GPU's. When I said 'upgrade' I meant completely replace or sell in the future.

Link to comment
Share on other sites

darkfailure

I just got the laptop which means I will have to keep playing GTA on console without mods sad.gif

But I still thank you all for your help and replies on this thread!

Link to comment
Share on other sites

darkfailure

Okay, I have to admit that I feel incredibly stupid now...

I changed the settings in the Catalyst Control Center to default after playing around with it. And now, the game runs a lot better (on high settings) and I can even see the water smile.gif

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.