Jump to content

GTA IV runs at 9fps, only uses 33% of CPU...


JohnnyTheJew

Recommended Posts

JohnnyTheJew

I ran a benchmark on GTA IV and it runs at 9fps and only uses 33% of the CPU.

 

Average FPS: 9.04

Duration: 37.52 sec

CPU Usage: 33%

System memory usage: 64%

Video memory usage: 67%

 

Hardware

Microsoft Windows 7 Home Premium 64-bit

Service Pack 1

Video Adapter: AMD RADEON HD 6450 (1GB)

Video Driver version: 8.17.10.1047

Audio Adapter: Speakers (Realtek High Definition Audio)

Intel® Core i3 CPU 550 @ 3.20GHz

4GB RAM

 

 

How can I fix this problem so that it can use more of the CPU?

 

Also, I took the System Requirements test and these are the results.

 

user posted image

 

Obviously, I should be able to run it better. Please help!

Link to comment
Share on other sites

kgrogfefji82

user posted image

 

This is what I'm getting, and I get 47-49 FPS from doing the benchmark, game runs smoother than on consoles on my rig.

 

I have no idea why it's so low for me, below, could it be that the CPU being below recommended that's what's bringing me down that much.

Link to comment
Share on other sites

I don't know what's the CPU usage issue there, but 6450 is not a gaming card, it's on par with Intel integrated graphics which means it's not made for gaming.

 

Can you verify that all four cores are being used? You can try using Prime benchmark for this, have you maybe made any changes to OS or BIOS settings?

 

Laufas, yeah, that processor sucks. The benchmark tool is broken and its results should be ignored.

Link to comment
Share on other sites

kgrogfefji82
Laufas, yeah, that processor sucks. The benchmark tool is broken and its results should be ignored.

Ahaha, yeah. My CPU depresses me, I really want a new one but I ain't got ze cash. Getting a phenom when I do get cash, probably a six core.. Maybe the quad.. I'll have to read into it, what differences there are, etc..

Link to comment
Share on other sites

Go to control panel and make sure your computers power settings set to high performance. Second, your CPU only has 2 cores and 2 logical cores, GTA only uses 2 non logical cores.

Don't expect any good performance from that PC.

Link to comment
Share on other sites

@JigglyAss: physical cores also count as logical cores, so this CPU has 2 physical cores and 4 logical cores. Also GTA4 uses 3 cores (doesn't matter if they are physical or logical).

74cXSsx.png

Link to comment
Share on other sites

@JigglyAss: physical cores also count as logical cores, so this CPU has 2 physical cores and 4 logical cores. Also GTA4 uses 3 cores (doesn't matter if they are physical or logical).

GTA 4 does not support hyper threading.

It only supports physical cores, that CPU has 2 physical cores, whilst with HP active, it will only show as 50% usage.

Link to comment
Share on other sites

Nope, from what I know (and I tested it some time ago as well) it doesn't matter whether cores are physical or logical - any of these can be used by applications, they don't have to be specifically written to support HT. Application cannot determine if the core is logical or physical.

74cXSsx.png

Link to comment
Share on other sites

Nope, from what I know (and I tested it some time ago as well) it doesn't matter whether cores are physical or logical - any of these can be used by applications, they don't have to be specifically written to support HT. Application cannot determine if the core is logical or physical.

"they don't have to be specifically written to support HT"

To use it, no, but to stay stable on logical core, yes they have to have some revisions.

You have a xeon that supports HT and i assume its a quad. Disable 2 physical core in the BIOS and leave 2 physical enabled and keep HT enabled.

Run GTA benchmark. The CPU usage will be at 50%, not 66/67%

Link to comment
Share on other sites

Ok, here are the results. X3440 2C/4T @ 3126MHz, GTX470 stock, GTAIV maxed out @ 1680x1050, no mods installed.

 

Statistics

Average FPS: 56.92

Duration: 37.46 sec

CPU Usage: 76%

System memory usage: 64%

Video memory usage: 100%

74cXSsx.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.