Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (85,529 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Dutchy3010

Bug reports V6.0

Recommended Posts

Dutchy3010

In this topic you can report crashes and other bugs you encounter while using DYOM.

 

There are three mayor types of crashes:

  1. Crashes that occur as soon as you start SA/DYOM.
  2. Crashes that occur during designing a mission.
  3. Crashes that occur during playing a mission.
I'll try to describe shortly what is the best way to handle them:

 

Crashes that occur as soon as you start SA/DYOM

These are almost always related to incorrect CLEO3 installation.

- CLEO3 is not installled at all.

- CLEO3 is improperly installed.

- The .exe you have is not compatible with CLEO3 ( see here for a link to a compatible version).

 

Crashes that occur during designing a mission.

- Do you have other mods installed, that might conflict with DYOM?

- Try to disable CLEO scripts that are active.

- Report the problem in this thread, with as much detail about the moment the crash occurs. What was the state of your mission, and at exactly what moment did it crash? Be as detailed as possible, so instead of reporting that it crashes while adding an actor, it is even better to report that the crash occured right after you pressed <space> while selecting a RPG as the weapon for an actor.

- if possible include scmlog.txt in your report, if you have the scmlog CLEO plug-in installed. (recommended)

 

Crashes that occur during playing a mission

- Report the problem in this thread, provide a link to the mission-file that you played, and try to describe as accurate as possible the circumstances of the crash.

- if possible include scmlog.txt in your report, if you have the scmlog CLEO plugin installed. (recommended)

 

We want DYOM to be crash free, and will always try to fix any problems. But we can only fix problems if we can reproduce the problem or if the description of the problem is good enough. This will enable us to get a clue about the location of the bug in our code and we don't have to search in all the 20.000+ lines of scm-code that we have written sofar for this mod.

Share this post


Link to post
Share on other sites
Chimpso

Does the parachute bug still plauge us? I'm sure the solution is simple. Parachuting is an external script, so does not work properly in DYOM. Is it possible to add it?

 

As well as that, there is the "Crash after finishing mission" bug. Where the game crashes after the player completes a mission that had lots of actors/cars/objects in it. But I'm guessing that's unfixable.

Share this post


Link to post
Share on other sites
PatrickW

We are able to reproduce the parachutebug, but it has not yet ben solved. Normally parachute-handling is an external script, but since MPACK don't support external scripts, we've included th parachute-function in the SYOM scm file. At this point we'r unsure what causes the problem, but we continue to look into it.

 

The "Crash after finishing mission" has not happened to yet (as we usually test functionality with short simple missions). If you know a mission that crashes reproducable at passing the mission, we can look into solving that one.

Share this post


Link to post
Share on other sites
Nahiyan

 

The "Crash after finishing mission" has not happened to yet (as we usually test functionality with short simple missions). If you know a mission that crashes reproducable at passing the mission, we can look into solving that one.

I figured out what might cause the crash after finishing a mission. It happened to me a couple of times.

 

It crashes when the mission ends with the player and/or a actor(s) in a car. Maybe there's no mission cleanup.. or its done in the wrong order.

 

Note, I was using DYOM V5.

Edited by Nahiyan

Share this post


Link to post
Share on other sites
twannie1997

The game crashed after a certain time while creating a mission.

I had PlaceManager and CrazyTrainer on, it might be PlaceManager, because i had the trainer on without crashes.

Share this post


Link to post
Share on other sites
guib

Yeah, i have the Crazy trainer on the whole time so it cant be that,

 

it must be the PlaceManager

Share this post


Link to post
Share on other sites
Futuristyc

The "Crash after finishing mission" is happened to me on DYOM v5 i think...

 

on this version 6 beta i don't have any major bugs like above, but

bug that i got is when i put on marker, it will shows only arrows on top of it.

but the red marker is disappear. confused.gif

Share this post


Link to post
Share on other sites
Doublepulse

I was playing Secronom's Example storyline (Awesome), It sometimes crashes when I start a new mission. I sometimes get crashing after mission is complete.. But in the storyline case.. It crashes after I enter the checkpoint to start one of the missions

 

I would advise saving often to prevent crashes and losing the progress on storyline.

Overall though, Dyom v6 has worked very well for me, and it lasts alot longer before crashing.

 

 

I love all the new features especially:

-Ctrl+P actors

-storyline

- Not having to rewrite text on objectives.

 

LOL I think that is all of them.

 

 

 

Share this post


Link to post
Share on other sites
twannie1997

well i guess i have to spawn a JUMPJET and fly to chinatown

Share this post


Link to post
Share on other sites
Dutchy3010

@Doublepulse: yeah, I had some crashes while playing that storyline too... However, I can't find any "pattern" in it. So it's very difficult to find the sollution for this problem. It is "random at mission starts", as far as I know now. So if you know a bit more about these crashes, please report.

 

Until then, a simple sollution is indeed saving after every mission. biggrin.gif

Share this post


Link to post
Share on other sites
serialmondi

What does it do? Storyline on the menu ?

Share this post


Link to post
Share on other sites
Rewas

If you doing a mission in San Fierro or Las Venturas, when you die you always appear in Los Santos. You need to FIX this.

Share this post


Link to post
Share on other sites
PatrickW
If you doing a mission in San Fierro or Las Venturas, when you die you always appear in Los Santos. You need to FIX this.

Gotcha...... We will fix this in the next release.

Thanks for the report cookie.gifcookie.gif

Share this post


Link to post
Share on other sites
Jisseikatsu
If you doing a mission in San Fierro or Las Venturas, when you die you always appear in Los Santos. You need to FIX this.

Gotcha...... We will fix this in the next release.

Thanks for the report cookie.gifcookie.gif

While you're at it, could you fix the game so that we don't die when editing a mission?

Share this post


Link to post
Share on other sites
12jango

1. If you edit the mission trigger the map will be disappeared.

 

2. Also if you select the "new mission" in an interior, the map will be disappeared.

 

I can't select the icon for the missiontrigger, because it doesn't appeared!

 

3. No Cars/Peds feature doesn't work in storyline feature.

 

4. Riot mode isn't working 100%, in some places like countys side, and some areas in cities, there are no riots!

 

Please fix them for the better future! dontgetit.gif

Thanks! icon14.gif

 

 

Share this post


Link to post
Share on other sites
KENY1RAY2

Appears limited time for no reason

I was playing on a mission and soon to move the lens 9 to 10 receive a limited time for no reason and my mission fails because time is short listed.

 

The mission link:

http://dyom.gtagames.nl/?act=show&id=10415

 

It is a mistake a little annoying.

 

Password: dyom6dyom6dyom6

 

The mission is in Spanish because I am Peruvian.

Share this post


Link to post
Share on other sites
PatrickW

@Secronom President: We'll have a look, but I can't guarantee that it makes the next release :$

 

@12jango:

1) I put them on our todo list to check.

2) That is indeed not very handy.. I guess we have to temporary enable the radar to be able to select an icon.

Although I'm not sure if making a missiontrigger in an interior is such a good idea in general, as most interiors are

locatted high up in the air, at a different location from the outside world location. So the icon might not appear on

the location you intended. This is not something we can easily fix.

3) Good point, we will try to find a fix for that is the next release

4) Riot mode indeed only works in certain areas, but that is something in the engine. It might be possible to get riotmode also somewhere else,

with a cheat, but it's not trivial to trigger cheats from SCM.

 

@keny1ray2:

I had a look and checkpoint 9 indeed starts a 60 second timelimit.

Are you the author of this mission, in that case you should either not enable the timelimit at checkpoint 9, or give the player more time.

If you're not the author, that you should contact the author to propose a change.

Note: Checkpoint 16 and 21 (the last one), both extend the current timelimit with another 60 seconds.

Either way, it is not a bug in DYOM, but the timelimit is designed like that by the mission author.

Share this post


Link to post
Share on other sites
12jango

I've found one bug in storyline feature, wanted level is not working (while not in a mission)... dontgetit.gif

Share this post


Link to post
Share on other sites
Jisseikatsu

 

I've found one bug in storyline feature, wanted level is not working (while not in a mission)... dontgetit.gif

This bug, if it is one, found itself usefull in the storyline I made an example storyline for DYOM V6 for Dutchy3010.

 

I think that to fix it you need to play a mission with wanted level enabled.

Share this post


Link to post
Share on other sites
KENY1RAY2

Yes, the mission was created by me. But he had discovered the error just after climbing the mission. Thanks PatrickW.

Share this post


Link to post
Share on other sites
Kalvin'

Bug, If CJ is in a interior, or somewhere far away from where a cutscene is played, theres LOD, in the next version, v6.2 or something, please make the player teleport where the cutscenes are placed so there a no LODS, because it is REALLY distracting. Hope you can fix smile.gif

Share this post


Link to post
Share on other sites
KENY1RAY2

I have a bug, do not think it's a problem dyom, but I'll say it: When I do the story of my mission, to make 4 missions automatically closes the game. I think it's my graphics card but I want clarification. sad.gif

Share this post


Link to post
Share on other sites
szymcio

I've didin't found solution. When i try to add some text it is writing 0123456789 etc., and i can't delete it! Please help!

Share this post


Link to post
Share on other sites
JOJOXX
I've didin't found solution. When i try to add some text it is writing 0123456789 etc., and i can't delete it! Please help!

You can solve this problem by visit this topic. smile.gif

Share this post


Link to post
Share on other sites
szymcio

 

- Do you have other mods installed, that might conflict with DYOM?

I've already deleted them.

 

- Try to disable CLEO scripts that are active.

I haven't any running cleo scripts.

 

- Report the problem in this thread, with as much detail about the moment the crash occurs. What was the state of your mission, and at exactly what moment did it crash? Be as detailed as possible, so instead of reporting that it crashes while adding an actor, it is even better to report that the crash occured right after you pressed <space> while selecting a RPG as the weapon for an actor.

I simply can't edit any field w/o getting 0123456789

 

- if possible include scmlog.txt in your report, if you have the scmlog CLEO plug-in installed. (recommended)

I don't know what's this. Sorry, I'm a newbie.

 

On my previous windows installation, with the same GTA everything worked fine.

Share this post


Link to post
Share on other sites
JOJOXX

Use that and the problem now will be solved.

That's problem solved by GTA!!!

 

,,Delete everything thats present in CLEO folder (In your main game directory). Then text problem should be solved. "

Share this post


Link to post
Share on other sites
szymcio

It doesn't work...

 

If it will help:

I am using SA v1.01, CLEO3 and DYOM6

Edited by szymcio

Share this post


Link to post
Share on other sites
JOJOXX

 

It doesn't work...

 

If it will help:

I am using SA v1.01, CLEO3 and DYOM6

Hm... It's difficult.Can you post a screenshot?

 

Are you installed CLEO3 correct?

Share this post


Link to post
Share on other sites
Jisseikatsu
It doesn't work...

 

If it will help:

I am using SA v1.01, CLEO3 and DYOM6

Hm... It's difficult.Can you post a screenshot?

 

Are you installed CLEO3 correct?

I think it has something to do with the fact you have V1.1. Correct me if I'm wrong but, mods do not function properly (or not at all) unless we have V1.

Share this post


Link to post
Share on other sites
szymcio

user posted image

 

On CLEO site I have read that cleo works wirh 1.0 an 1.01 (not 2.0). However, how can I downgrade?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.