Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (85,243 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Deji

[CLEO 3/4]Stream Ini Extender

Recommended Posts

Asdf92

 

"framedelay" only applies after I enter a vehicle since Cleo 4.3.

 

Tryed on different computers, currently on a netbook with a very crappy graphics card where this behavior is extremely noticable.

From ~6 FPS before entering a vehicle to ~20 FPS after entering.

framedelay    0nocloudsnograss

Same thing happen to me here.

Share this post


Link to post
Share on other sites
Deji

"framedelay" only applies after I enter a vehicle since Cleo 4.3.

 

Tryed on different computers, currently on a netbook with a very crappy graphics card where this behavior is extremely noticable.

From ~6 FPS before entering a vehicle to ~20 FPS after entering.

 

 

framedelay    0nocloudsnograss

 

Well that's just technically impossible :p

 

But when you say it only applies when you enter a vehicle, does that mean is only applies while in that vehicle, or it applies after the first vehicle you enter? If so, the problem might make more sense in some way. Perhaps it's not entering the vehicle itself, but pressing the 'Enter' key, which would still be pretty weird.

 

Anyway, the memory address for what 'framedelay' changes is 0x53E94C - if you can, view it in Cheat Engine to see when it's actually applied... no doubt it will be at the start of the game, which is when this script should run. Perhaps you have another mod interfering with it.

Share this post


Link to post
Share on other sites
uokka

Strange indeed. "nograss" works. "noclouds" too, I think.

 

After I entered the first vehicle, the frame delay stayes as hacked by SIE.

I'll try the enter (-vehicle) key.. O_o

I'll try to trace it via CheatEngine.

I'll try to disable dozens of other scripts, too (damn q: ).

Share this post


Link to post
Share on other sites
eugene89

could you add an option to disable the smoke that comes out of cars exhaust? I really dont want to disable all the particle effects

Share this post


Link to post
Share on other sites
Danikov

could you add an option to disable the smoke that comes out of cars exhaust? I really dont want to disable all the particle effects

Or you could disable all exhausts in the handling.cfg .

Share this post


Link to post
Share on other sites
eugene89

 

could you add an option to disable the smoke that comes out of cars exhaust? I really dont want to disable all the particle effects

Or you could disable all exhausts in the handling.cfg .

 

too much work

Share this post


Link to post
Share on other sites
Reyks

Since this topic has already been bumped, i have a suggestion for some new commands if this ever gets a new version.

 

- nowatermist = disables that weird white mist above the water caused by some foggy weathers.

- nojetpackheat = disables the heat wave effect of the jetpack's flames.

 

Not sure if any of these are possible, but still there's no mod out there that removes this stuff, so it might be worth a look.

Share this post


Link to post
Share on other sites
eugene89

Since this topic has already been bumped, i have a suggestion for some new commands if this ever gets a new version.

 

- nowatermist = disables that weird white mist above the water caused by some foggy weathers.

- nojetpackheat = disables the heat wave effect of the jetpack's flames.

 

Not sure if any of these are possible, but still there's no mod out there that removes this stuff, so it might be worth a look.

never thought of these but it would help fps, nice! :lol:

Share this post


Link to post
Share on other sites
nyolc8

is this work in SAMP? Because atleast "noclouds" have no effect.

Share this post


Link to post
Share on other sites
uokka

[...] Perhaps you have another mod interfering with it.

It must be another mod. I was too lazy to investigate it deeply but SilenPatch produces the same behavior but a clean game (with only SIE or SP) works allright.

 

--

 

[...]

- nojetpackheat = disables the heat wave effect of the jetpack's flames.

 

Not sure if any of these are possible, but still there's no mod out there that removes this stuff, so it might be worth a look.

Heat haze can be disabled.

Either via CLEO:

 

{$CLEO .cs}0000: NOP0A8C: write_memory 0x72C1B7 size 1 value 0xEB virtual_protect 10A93: end_custom_thread
Or via UltraThing.

Share this post


Link to post
Share on other sites
Reyks
Heat haze can be disabled.

Either via CLEO:

 

{$CLEO .cs}0000: NOP0A8C: write_memory 0x72C1B7 size 1 value 0xEB virtual_protect 10A93: end_custom_thread
Or via UltraThing.

I know but that's not what im talking about. There's another heat effect that appears around the jetpack's flames, this one can't be disabled by using that CLEO script, i would take a pic but meh too lazy atm.

Share this post


Link to post
Share on other sites
uokka

Oh, you're right. Same for nitro I suppose.

Share this post


Link to post
Share on other sites
Inadequate

Well finally this runs on my game after a thousand of crashes. If anybody have the same issue only rename the extension of the file from '.cs' to '.cs3'.
It's how I get worked this on my game.

Share this post


Link to post
Share on other sites
Reyser

Well finally this runs on my game after a thousand of crashes. If anybody have the same issue only rename the extension of the file from '.cs' to '.cs3'.

It's how I get worked this on my game.

 

Thank you man for this info, I had the same problem but i solved with ".cs3" and my game again works fast ;)

Share this post


Link to post
Share on other sites
El Dorado

For some reason this cleo are simply don't working anymore on my game. Tried a reinstall, a clean game with only this cleo, renamed to cs3, and still getting a crash right after the loading screen. I used only the -noblur and -noclouds.

Share this post


Link to post
Share on other sites
nyolc8

No need for the "-" at the front of them. So "noclouds" instead of "-noclouds".

Share this post


Link to post
Share on other sites
JesusV37

Greetings

 

I have been using this mod since a while and i'm glad to know someone like you worries about the people who have computers of wood.

 

I am one who have a wood's PC.

 

And i'm thinking to add more features to your StreamIniExtender :)

If you can and if possible to add them i'll be more than just glad. :D

 

So i got here some suggestions to make this .asi file more helpful :D

 

*Disable fire torch.

f4o0ms.jpg

Disable fire while shooting

Disable smoke effect while shooting

Disable fire torchs

s33236.png

Disable water effect in screen while swimming

2mhilxv.png

Disable spread of water while driving a boat.

1zzn7t2.png

Disable road marks.

1oksg0.png

Disable Cascade effect.

Disable water dropping.

30mv4sg.png

Disable Nitro/fire effect from cars

2qao9k4.png

If is possible to make vegetation invisible except the stems. to avoid interrumped screen on servers where admins are insane and they leave like 1 million of plants there just lagging the game :S.

2886wko.png

Disable Tear GAS/smoke effect (this lags a lot)

a48w42.png

Disable particles standing at streets after destroy lamp posts.

11uul2e.png

This light you see in the middle has a high graphic lag. (most important to disable)

Disable fire lights after an strong explosion

f2pqp0.png

Disable Fire extinguisher effect

otj94z.png

Disable spray effect while spraying tags

19qfyo.png

Disable lights animations turning on/off automatically in Las Venturas.

jhtzsk.png

 

 

Add a option to set the Draw Distance of the timecyc. 0-900 metters.

(far draw distance gives you like 10+ fps more 100% tested.)

You can leave it able to modify in the stream.ini file :)

Draw_Distance=200.0

 

[bug found in SA:MP]

If ''nosound'' is enabled still i can hear the /radio and /radio took a considerable amount of fps.

If possible add a script to block any address/acces to internet radios in samp :)

 

I hope you can understand this, and i wanna thank you for the work and you've done with the old versions, keep it up please!

 

Still exist people who likes to play gta not matter if the graphics are f*cked up, as long as the fps becomes high it would be enough :)

 

Thanks for reading and consider this.

Edited by JesusV37

Share this post


Link to post
Share on other sites
Silent

Deji doesn't seem to be interested in GTA modding anymore.

 

But for starters, maybe you should try this? Disables post effects (that includes night/thermal vision and underwater camera effect) which are pretty slow if you have a sh*tty PC:

 

 

{$CLEO}0A8C: write_memory 0x53E227 size 1 value 0xC3 virtual_protect 10A93: end_custom_thread
https://dl.dropboxusercontent.com/u/46581994/nopostfx.cs

Share this post


Link to post
Share on other sites
Deji

Assumptions are dangerous ;)

Share this post


Link to post
Share on other sites
Blackbird88

Assumptions are dangerous ;)

But you only posted :p

Share this post


Link to post
Share on other sites
IG_

I'm not sure if this is an issue on my end but I think this script is now broken with CLEO 4.3.18.
The .cs file crashes my game everytime with CLEO 4.3... but if I use CLEO 4.1 instead everything works perfectly.

Share this post


Link to post
Share on other sites
TJGM

I'm not sure if this is an issue on my end but I think this script is now broken with CLEO 4.3.18.

The .cs file crashes my game everytime with CLEO 4.3... but if I use CLEO 4.1 instead everything works perfectly.

Stream ini extender needs to be a .cs3 file extension instead of .cs, just rename it.

Share this post


Link to post
Share on other sites
IG_

 

I'm not sure if this is an issue on my end but I think this script is now broken with CLEO 4.3.18.

The .cs file crashes my game everytime with CLEO 4.3... but if I use CLEO 4.1 instead everything works perfectly.

Stream ini extender needs to be a .cs3 file extension instead of .cs, just rename it.

 

I tried that fix as well, didn't work for me.

Instead of actually crashing, the game would simply never stop loading for me.

Share this post


Link to post
Share on other sites
Reyks

I tried that fix as well, didn't work for me.

Instead of actually crashing, the game would simply never stop loading for me.

Try using Mix Sets it has everything this mod has plus a ton more stuff, and it actually works with Cleo 4 without any problems.

Share this post


Link to post
Share on other sites
muh linucs

Can you confirm that the mod doesn't affect save files?

Share this post


Link to post
Share on other sites
REW01WER

Download link is dead

Share this post


Link to post
Share on other sites
zd62tbhdj82

Thanks a lot for this mod, I love it. It fixed the black roads bug and annoying motion blur for me.

 

Regarding compatibility, I found that it doesn't work with CLEO 4.3.22, it crashes the game when loading a save file "GTA.exe has stopped working". If I delete StreamIniExtender.cs, it works. However, it works fine with CLEO 4.1.1.30 (listed under "Older versions" on CLEO download site). Installing CLEO 4.1 will downgrade ASI loader to an older version, but you can just reinstall Silent's ASI loader afterwards to get it back.

Edited by zd62tbhdj82

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.