Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (91,537 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Deji

[CLEO 3/4]Stream Ini Extender

Recommended Posts

Deji

Not yet.. It's a matter of tracking down the function and finding the best way to stop completely. One of my main focuses was the ability to disable car reflections, which would give me much smoother gameplay when riding around on my NRG-500 tounge.gif So far I've disabled flashes (the ones that brighten up the enviroment after gunfire, et cetera).

 

The frame limit should be 60 with that value... 25 when the framelimit value is 30.

 

EDIT (pre-post edit.. I do that): Implemented that heat haze disabling thing smile.gif

 

EDIT (a real one, this time)

 

Found some more accepted values for the FPS Limiter.. odd how they aren't as you'd expect:

38 = 30fps

76 = 50fps

Edited by Deji

Share this post


Link to post
Share on other sites
Dev1ant

Cool mod! Gives much smoother gameplay but won't work with project oblivion 2010. Anychance of a fix? Probably something to do with the custom gta.exe. Got loads of other cleos running with it

Edited by Dev1ant

Share this post


Link to post
Share on other sites
Deji

What is project oblivion 2010?

Share this post


Link to post
Share on other sites
Deji

If it's due to a different .exe, a fix isn't going to happen.

Share this post


Link to post
Share on other sites
Dev1ant

Oh well thanks anyway

Share this post


Link to post
Share on other sites
Guns*R-Us

The shadow is too dark man, if you can make it more soft and darker a littler bit than original shadow, just like ENB series, it would be cool smile.gif

Share this post


Link to post
Share on other sites
Deji
The shadow is too dark man, if you can make it more soft and darker a littler bit than original shadow, just like ENB series, it would be cool smile.gif

Eh?

Share this post


Link to post
Share on other sites
Gramps
http://world-gta.info/load/57-1-0-197 Basically a map mod to add improved vegetation.

I got it to work with the COMPACT exe that Deji posted in this thread somewhere; you can use that .. But you cannot use all the data files that came with P.O 2010 sad.gif I think it errors out when you copy the Maps folder from P.O 2010 into the game (and maybe the gta.dat).

 

Butttt.... if you use the dff/txd files from P.O 2010, and then use the grass txd files from Tony Resta's Plant Mod, and use ALL of his data files that came with it, it will work ..

 

Butttt.... I cannot do any missions sad.gif Errors out on me .. I've basically started a new game, and can't do mission 'Ryder' .. It just goes to a black screen, has 'Ryder' in the bottom right hand corner, and just sits there sad.gif

 

I haven't troubleshooted it any further though, thats as far as I have gotten so far ..

 

@Deji;

 

I reccommend you install P.O 2010 from the link provided above; it is well worth it smile.gif And then download 'Vurts Better Colors for P.O 2010' from GTAGarage smile.gif San Andreas has never looked better smile.gif

Share this post


Link to post
Share on other sites
Deji

And my computer will have never run slower! I get all nostalgic about GTASA's wonderfully simple default textures and hate having to change many files when modding...

 

Does the problem with that mod occur when there are no changes to your stream.ini file from the SA default? Because Stream Ini Extender simply only runs for between the first 2-3 milleseconds of your game, so it is hard to believe it can freeze a mission, unless this mod accesses something that SIE (getting bored of typing the long name) changes through added commands to the stream.ini file.

 

 

Stream Ini Extender Update!

Version: 0.3b

 

I've added 2 new options and some compatibility fixes for other .exe versions that I believe should work well. This is mainly a compatibility fix.

 

 

Actually, I've just noticed the error info methodunderg posted showing "Exception Offset: 000049d9" is exactly the same error I was getting after making a few compatibility changes, which I've managed to fix... so this probably fixes those problems smile.gif

Edited by Deji

Share this post


Link to post
Share on other sites
Gramps

WoW ! OMFGGGG ....

 

Well done Deji smile.gif Great update smile.gif

 

Works with my 'complete' San Andreas no problems smile.gif So there should be no difficulties with P.O 2010 now smile.gif

Working perfect, and this game has gone smoooottthhhh smile.gifcookie.gifcookie.gifcookie.gifinlove.gifinlove.gifinlove.gif

 

Much respect to you smile.gif

 

Any other 'settings' in the works dude ?

 

**EDIT**

Only ones I can thnk of from the top of my head which I'd like to see if possible are : objects/peds/vehicles spawning/rendering from further away (I'm pretty sure its not possible; but only thru LOD's) .. And altering the cloud height smile.gif I used to have a program that did it for me, and I lowered the clouds to make the 'atmosphere' better from the ground; but since i reformatted and upgraded to Win7, i forgot to backup that app, and i dont know what its called smile.gif (its not SALA) So if that is possible, that would be awesome smile.gif

 

Cheers for everything buddy;

 

Top job !

Edited by methodunderg

Share this post


Link to post
Share on other sites
Dev1ant

Great update icon14.gif many thanks cookie.gif

Share this post


Link to post
Share on other sites
Deji

Another update. 0.4b brings 4 new options.

 

  • Disable Clouds
  • Disable Target Blip
  • Disable Specular Vehicle Lighting
  • Disable Vehicle Lighting

Share this post


Link to post
Share on other sites
TheD199434

Hey Deji,

It's an awesome mod i see, but sadly, my game crashes after i load game, right after the loading screen. sad.gif

 

Thats how my Stream.ini looks like, it worked perfectly before this mod.

 

 

memory 13500

devkit_memory 13500

vehicles 12

pe_lightchangerate 0.5

pe_lightingbasecap 0.5

pe_lightingbasemult 0.5

pe_leftx 200

pe_topy 200

pe_rightx 200

pe_bottomy 200

framedelay 15

framelimit 105

stencilshadowopacity 8

noblackroads

dontbuildpaths

 

 

Did i something wrong at the order or what :S? Did i missunderstood something? What did i wrong turn.gif ?

 

Oh btw, i use a 1.00 US gta_sa.exe:

14.383.616 (Size)

14.385.152 ("Second" size - dunno the name :S i got german PC)

 

Of course i got a modded game, which worked very stable before i added this mod. I'm sure, i added the .cs file into CLEO folder.

 

I got Cleo 4 installed and using.

I got GTA4HUD Plugin, which doesnt make problems.

And i use StreamMemoryFix

Oh and i use Enb Series 0.075 if it could be the thing

 

I think i didn't forgot anything. oh Yeah!

 

I got:

 

Win XP Home SP3 32bit

ATi Radeon x800pro

1GB RAM

Ah dunno tounge.gif

 

What could be the problem biggrin.gif? Plz tell me and sorry for such long post sad.gif i want it working so badly on my GTASA

 

( BTW: If you would find a "Disable Rain Effect+Rain Sounds" i would luv this mod so much lol and i will respect you much more than now (if possible biggrin.gif) happy.gif )

 

-Thx

Share this post


Link to post
Share on other sites
Gramps
Hey Deji,

It's an awesome mod i see, but sadly, my game crashes after i load game, right after the loading screen. sad.gif

 

Thats how my Stream.ini looks like, it worked perfectly before this mod.

 

 

memory 13500

devkit_memory 13500

vehicles 12

pe_lightchangerate 0.5

pe_lightingbasecap 0.5

pe_lightingbasemult 0.5

pe_leftx 200

pe_topy 200

pe_rightx 200

pe_bottomy 200

framedelay 15

framelimit 105

stencilshadowopacity 8

noblackroads

dontbuildpaths

 

 

Did i something wrong at the order or what :S? Did i missunderstood something? What did i wrong turn.gif ?

 

Oh btw, i use a 1.00 US gta_sa.exe:

14.383.616 (Size)

14.385.152 ("Second" size - dunno the name :S i got german PC)

 

Of course i got a modded game, which worked very stable before i added this mod. I'm sure, i added the .cs file into CLEO folder.

 

I got Cleo 4 installed and using.

I got GTA4HUD Plugin, which doesnt make problems.

And i use StreamMemoryFix

Oh and i use Enb Series 0.075 if it could be the thing

 

I think i didn't forgot anything. oh Yeah!

 

I got:

 

Win XP Home SP3 32bit

ATi Radeon x800pro

1GB RAM

Ah dunno tounge.gif

 

What could be the problem biggrin.gif? Plz tell me and sorry for such long post sad.gif i want it working so badly on my GTASA

 

( BTW: If you would find a "Disable Rain Effect+Rain Sounds" i would luv this mod so much lol and i will respect you much more than now (if possible biggrin.gif) happy.gif )

 

-Thx

Maybe you should quote the error code that appears when GTA:SA crashes .. Also try using original Stream.ini and see if that works as well.

Share this post


Link to post
Share on other sites
TheD199434

@methodunderg

Ok i try smile.gif

thx for tip

 

Edit:

Still Crashing, even with Orginal stream.ini

Here's the errordump generated by San Andreas Limit Adjuster:

(Don't worry, Limit Adjuster works perfect for me, i tested after this to be sure;))

 

 

GTA:SA Crashed, Debug Info Follows:

 

GTA Info:

 

Version: US 1.0

Last File Loaded: AUDIO\STREAMS\AMBIENCE

Last Library Loaded: user32.dll

Error: Unknown

 

Assembly Info:

 

Exception At Address: 0x7C92B21A

Exception Code: 0xc0000005 (EXCEPTION_ACCESS_VIOLATION)

 

Registers:

EAX: 0x00000000 EBX: 0x00000000

ECX: 0x0000042C EDX: 0x021119E0

ESI: 0x021119D0 EDI: 0x00000000

EBP: 0x0022FCDC ESP: 0x0022FC68

Edited by TheD199434

Share this post


Link to post
Share on other sites
Deji

14,385,152 is just the size that is used by the file on your hard drive (the extra data contains information about the file which is not part of the file itself, I think).

 

Anyway, the error report shows nothing I can trace to Stream Ini Extender. Does the crash still occur when no additional stream.ini lines are added?

Share this post


Link to post
Share on other sites
TheD199434

 

14,385,152 is just the size that is used by the file on your hard drive (the extra data contains information about the file which is not part of the file itself, I think).

 

Anyway, the error report shows nothing I can trace to Stream Ini Extender. Does the crash still occur when no additional stream.ini lines are added?

Yes, it does crash, i tried it with orginal stream.ini.

 

It's something up with cleo?

I use CLEO4 by the way.

Oh and some mods (GTA4 Features, like aim angle's and gta4 crosshair mod, etc) 5 cleo mods together (without StreamIniExdenter)

Maybe because this? But i wanna keep my cleo's in my game cry.gif

My cleo folder has some .cleo files named:

FileSystemOperations.cleo

InOperations.cleo

IniFiles.cleo

(only these i use and my game runs perfect and smooth without problems biggrin.gif )

 

AH, maybe because i patched my gta_sa.exe with "AllCarRadio&Repair" i downloaded on official cleo website or something?

Share this post


Link to post
Share on other sites
Gramps

If you remove Deji's cleo file from the CLEO folder, and use the original Stream.ini file, does the game work without crashes ?

Share this post


Link to post
Share on other sites
Adler
If you remove Deji's cleo file from the CLEO folder, and use the original Stream.ini file, does the game work without crashes ?

Well that's probably a given lol.

 

Try Deji's mod without any other CLEO mods and see if it works. If it still doesn't then the problem should be in Deji's script or the exe.

Share this post


Link to post
Share on other sites
Gramps
If you remove Deji's cleo file from the CLEO folder, and use the original Stream.ini file, does the game work without crashes ?

Well that's probably a given lol.

 

Try Deji's mod without any other CLEO mods and see if it works. If it still doesn't then the problem should be in Deji's script or the exe.

Yes, it should be a given .. but sometimes hand-holding is needed smile.gif

 

This is definately one of those must-have mods smile.gif Even for just the 'framedelay' smile.gif Makes the game smoooooth smile.gif

Share this post


Link to post
Share on other sites
TheD199434

@methodunderg

As i said once smile.gif

It works perfectly without the StreamIniExdenter very smooth and stable, although i modded my game very extremly tounge.gif

 

@Adler, I will try it smile.gif If it's crashing i gotta try on unpatched .exe too. Maybe the patch (i told in previous posts) is the problem, but luv this patch lol. Pay'nSpray with rhino and such^^

 

 

Edit:

 

Still crashing with even the orginal strem.ini and NO other mods in my cleo folder, only some backup folders, with a "#" before the backup folder name for safety that they wont get readed too by cleo.asi.

 

In tried with patched .exe and one unpatched .exe both same version of same copy.

Man, i want at least framelimiter and framedelay working nervous.gifsad.gif

Edited by TheD199434

Share this post


Link to post
Share on other sites
Deji

Well, I made a mod which allows Pay'n'Spray with any car, without .exe patching here.

 

I forgot something though... even with no lines in the stream.ini file, if that file is found, Stream Ini Extender will write the default values to all the memory locations in case you've restarted the game without closing it fully... Allowing you to remove an option and have it applied with only a game load, etc.

 

So you're best off renaming the stream.ini file (the game will work fine without it) and seeing if there's still a crash. I would bet not, but lets see...

Share this post


Link to post
Share on other sites
TheD199434

@Deji, Still crashes, Now right after i click on a savegame, which works, to load. I did renamed the stream.ini (to "#stream.ini") I tried it 2 times sad.gif Something's wrong with my GTA? Or did i do something wrong?

Share this post


Link to post
Share on other sites
Deji

Hmm.. try re-downloading CLEO 4 and re-installing it... it's the only thing I can think may be a problem here, since without the stream.ini file, this script just ends itself.

Share this post


Link to post
Share on other sites
TheD199434
Hmm.. try re-downloading CLEO 4 and re-installing it... it's the only thing I can think may be a problem here, since without the stream.ini file, this script just ends itself.

Ok, if this doesnt work, i reinstall GTASA full and install CLEO4 (which i downloaded new) biggrin.gif but later maybe, After i did, i post results here, how it went colgate.gif

Share this post


Link to post
Share on other sites
Jur1zz

Hi this is cool icon14.gif

 

Can yopu add one thing?

 

    USAGE

 

To use the settings, simply insert the lines in your stream.ini file, located in the main GTA San Andreas installation directory. Once you start the game, all settings will be applied immediately. Lines with # at the start will be ignored.

 

To undo a setting, remove or comment out the line in the stream.ini file and start a new game or load an existing game.

 

Reload stream.ini by pressing a key, so no need to start a new game or load an existing game

Share this post


Link to post
Share on other sites
TheD199434

Ok, After my Try on Orginal not modded GTA San Andreas, with a fresh installed and full installed CLEO4, the results are:

Still crashing like before. It's something up with the script. But i don't understand why for some here it works confused.gif

Share this post


Link to post
Share on other sites
Deji

Must be something that's up with CLEO 4 on your system or perhaps to do with file access.. don't really know. You could try CLEO 3, but I doubt there will be much difference there. Is there any change in the error report since the fresh install?

Share this post


Link to post
Share on other sites
TheD199434

 

Is there any change in the error report since the fresh install?

Nope there is'nt any change.

I gotta try it on CLEO3 as you said - But let's see later results^^

 

Edit:

 

Works very good on CLEO3! My game runs smoother! But it isn't CLEO4 Compatible. Please, fix it nervous.gif I use some cleo mods that i luv which requires CLEO4 (at least) cry.gif

Edited by TheD199434

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.