Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (92,093 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

  • 0
Rockstar Toronto

GTA IV Patch 7/EFLC Patch 2

Question

Rockstar Toronto

A new update is now available for both GTA IV and EFLC through GFWL. Downloadable versions will be made available on the Rockstar Games Support site.

 

GTA IV

 

v. 1.0.7.0 / 1.0.6.1 (Russian) / 1.0.5.2 (Japanese)

 

- fix a bug causing tree leaves to look transparent

- fix a bug that prevented uploading of rendered videos to Social Club when attaching certain music tracks

- fix for clip capture "OFF" slowdowns occuring when near waters edge

- expose "detonate" in custom key mapping options menu for Grand Theft Auto IV, Lost and Damned so users can remap "down" arrow key

 

EFLC

 

v. 1.1.2.0

 

- fix a bug causing tree leaves to look transparent

- fix a bug that prevented uploading of rendered videos to Social Club when attaching music tracks from the Ballad of Gay Tony

- fix for clip capture "OFF" slowdowns occuring when near waters edge

- fix for slowdown occuring when getting in a boat during "Sexy Time" mission in The Ballad of Gay Tony

- expose "detonate" in custom key mapping options menu for Lost and Damned so users can remap "down" arrow key

- EFLC now has it's own settings file called "SETTINGS_EFLC.CFG" to avoid possible conflicts with GTA IV installations

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
Rockstar Toronto
Since you ignored me in the last atch thread, Rockstar, I will ask this here, before I try/waste time of this new patch.

 

 

Rockstar Toronto, is there anyway of turning the static noise filter off, if one is using stock GTAIV, no mods, and patch 6 ?

Or this is only available to TLAD and EFLC owners ?

 

So, is this now possible with patch 7 ? A simple yes or no will suffice. I didn't see it anywhere in patch 6, so I won't hold my breath.

There is only an added noise filter on TLAD which is why there is an option to disable it only while playing TLAD.

 

If you are talking about the blur filter, that is called "Definition" in the settings menu.

Share this post


Link to post
Share on other sites
  • 0
Jigglyass
R*, can you give us the ability to save the episodes (DLC's) in the games directory? I have an SSD and id rather use it for photoshop than to have (Well be forced) to have DLCs saved on it. I have GTA installed on another HHD.

4xxx and 5xxx still not getting water ripples, what are the status on that fix. This problem has been around since like last year....

Thanks.

You can manually set the Downloads Directory in the "Settings" tab of the Games for Windows Live client.

 

As for the water ripples, that is something that needs to be solved in a driver update.

Would you please contact ATi about it? You're a developer, were small time. You get my point, hopefully....

We have sent bug reports out to the driver teams, not much else we can do.

Alright, thanks. Say, any plans to port RAGE to DX11?

I'd quite like to see that too, although I doubt it'd happen any time soon. The only engine I know of ported to DX11 was the Avalanche engine, and that was pretty much an entire re-write.

Il happen when consoles refresh, which is not until sometime Q4 2012.

 

Share this post


Link to post
Share on other sites
  • 0
Rockstar Toronto
If you are getting Texture Popping then you have exceeded the amount of available video memory.

 

Ahhhhhhhhh I see so it is our "own fault" is it, I shall make sure I never exceed the available video memory in future ............ oh wait I never have exceeded the video ram but I still got texture pop in. I run GTA 4 on the Auto settings that YOU guys recommend (in fact I have to turn them down a bit because the frame rate is still crap). Any way at least we know where we stand with the texture pop in problem, you aren't going to fix it you are just going to blame us sarcasm.gif

Sorry I did not mean "YOU" as in the end user, I meant the combination of the video driver, OS, game, etc. Again, if you are seeing issues with texture pop in then please see the thread I quoted above.

 

"auto configure" is not an exact science, it is our best guess based on what is reported from our queries to the OS.

 

For example, if you have a 9400 card with 1 Gig of VRAM, auto configure settings will be too high because the 9400 GPU cannot keep up with the load from using 1 Gig of Video Ram.

 

Also it is a requirement that by default we set the games resolution to the resolution set by the desktop, which can overwhelm a GPU in some cases.

 

 

Share this post


Link to post
Share on other sites
  • 0
DKT70

 

There is only an added noise filter on TLAD which is why there is an option to disable it only while playing TLAD.

 

Then why is it showing up on patch 6 in GTA IV, no TLAD installed ?

 

I can prove it with pics, if you like.

Share this post


Link to post
Share on other sites
  • 0
Fathat

 

R*, can you give us the ability to save the episodes (DLC's) in the games directory? I have an SSD and id rather use it for photoshop than to have (Well be forced) to have DLCs saved on it. I have GTA installed on another HHD.

4xxx and 5xxx still not getting water ripples, what are the status on that fix. This problem has been around since like last year....

Thanks.

You can manually set the Downloads Directory in the "Settings" tab of the Games for Windows Live client.

 

As for the water ripples, that is something that needs to be solved in a driver update.

Unfortunately the Downloads directory is only used as a temporary directory.

 

After the download is complete the DLC is automatically installed in this directory (WinXP):

 

C:\Documents and Settings\"User"\Local Settings\Application Data\Microsoft\XLive\*

Edited by Fathat

Share this post


Link to post
Share on other sites
  • 0
cuvip

what about pop-in texture prob, has it fixed yet?

Share this post


Link to post
Share on other sites
  • 0
sjaak327

 

The only annoyance on my part doesn't seem to be fixed (judging from the OP). New vehicle models in EFLC having problems with lights. Has this been overlooked, or deemded not important enough to be fixed ?

Not sure, but I might had an FPS increase.

 

Anyway that's the only problem I have with TBoGT vehicle models too. Only the light sprites will show up, but the lights themselves doesn't light up. If you haven't noticed it, check out a civilian using his blinkers in a new car (serrano for example).

 

Not sure if any1 mentioned this, but I think R* should prevent vehicles.img modifications online, since if you go online with a modded car (new car model, for example: Lamborghini Murcielago instead of Infernus), others will crash with either SMPA60 or SMPA50.

I didn't update my game yet, will do so once an updated scripthook is released.

 

So I cannot verify if this has been fixed, in any case, the problem only occurs in TBOGT (TLAD=fine) and ONLY with the new vehicles that came with TBOGT. (example, the Tampa in TLAD is correct, the one in TBOGT isn't )

 

A glaring ommission on the part of Rockstar's QA department. The fact that the bloke from Rockstar is ignoring three people on this account, gives me the impression that it isn't fixed.

 

Edit to add, and it's a model problem, I exported TLAD's Slamvan + tampa into TBOGT and the problem was fixed for those two cars.

 

 

Edited by sjaak327

Share this post


Link to post
Share on other sites
  • 0
monster875

do we need to update the game??

Share this post


Link to post
Share on other sites
  • 0
Astrixone
If you are getting Texture Popping then you have exceeded the amount of available video memory.

 

Ahhhhhhhhh I see so it is our "own fault" is it, I shall make sure I never exceed the available video memory in future ............ oh wait I never have exceeded the video ram but I still got texture pop in. I run GTA 4 on the Auto settings that YOU guys recommend (in fact I have to turn them down a bit because the frame rate is still crap). Any way at least we know where we stand with the texture pop in problem, you aren't going to fix it you are just going to blame us sarcasm.gif

Sorry I did not mean "YOU" as in the end user, I meant the combination of the video driver, OS, game, etc. Again, if you are seeing issues with texture pop in then please see the thread I quoted above.

 

"auto configure" is not an exact science, it is our best guess based on what is reported from our queries to the OS.

 

For example, if you have a 9400 card with 1 Gig of VRAM, auto configure settings will be too high because the 9400 GPU cannot keep up with the load from using 1 Gig of Video Ram.

 

Also it is a requirement that by default we set the games resolution to the resolution set by the desktop, which can overwhelm a GPU in some cases.

Well, my card is way better than 9400. you can see it in my signature.

I know this thread very well, word by word. i tried every possible thing in there and still there is no solution. according to my specs i cant see why my game cant load the textures like in patch 1.0.0.4. I am not sure that my problems have something to do with video memory and RAM anymore...

Share this post


Link to post
Share on other sites
  • 0
_CP_

 

What is the shadow map resolution?

What about pixelated reflections and bigger draw distance of them? Please, reply.

I am too missed, can You reply at this questions? I am interested to talk with You about a game, if You are interested, write to my PM. 3>

Share this post


Link to post
Share on other sites
  • 0
Rob.Zombie

 

The only annoyance on my part doesn't seem to be fixed (judging from the OP). New vehicle models in EFLC having problems with lights. Has this been overlooked, or deemded not important enough to be fixed ?

Not sure, but I might had an FPS increase.

 

Anyway that's the only problem I have with TBoGT vehicle models too. Only the light sprites will show up, but the lights themselves doesn't light up. If you haven't noticed it, check out a civilian using his blinkers in a new car (serrano for example).

 

Not sure if any1 mentioned this, but I think R* should prevent vehicles.img modifications online, since if you go online with a modded car (new car model, for example: Lamborghini Murcielago instead of Infernus), others will crash with either SMPA60 or SMPA50.

Please Rockstar Toronto can we get an answer to the vehicle lights problem, and can you do something about preventing car mods online (cuz it's really irritating knowing why we crash, but nobody does anything about it) confused.gif

 

Anyway it looks like I only had fps increase because graphics reverted back to automatic settings lol

 

EDIT:

@ City_Poke912

About the pixelated reflections... well that's how they did it. You can't fix it. However, if boris will update his ENB Series you'll get smooth HQ reflections even by only installing ENB Series (so you don't even have to turn it on)

Share this post


Link to post
Share on other sites
  • 0
sjaak327

 

The only annoyance on my part doesn't seem to be fixed (judging from the OP). New vehicle models in EFLC having problems with lights. Has this been overlooked, or deemded not important enough to be fixed ?

Not sure, but I might had an FPS increase.

 

Anyway that's the only problem I have with TBoGT vehicle models too. Only the light sprites will show up, but the lights themselves doesn't light up. If you haven't noticed it, check out a civilian using his blinkers in a new car (serrano for example).

 

Not sure if any1 mentioned this, but I think R* should prevent vehicles.img modifications online, since if you go online with a modded car (new car model, for example: Lamborghini Murcielago instead of Infernus), others will crash with either SMPA60 or SMPA50.

Please Rockstar Toronto can we get an answer to the vehicle lights problem, and can you do something about preventing car mods online (cuz it's really irritating knowing why we crash, but nobody does anything about it) confused.gif

 

Anyway it looks like I only had fps increase because graphics reverted back to automatic settings lol

Thanks for answering my question smile.gif

 

So if I get this straight, the transparant leaves are fixed (never noticed it, but hey I though GTA was all about cars), and fixing a few vehicle models is too much to ask.

 

LOL !

Share this post


Link to post
Share on other sites
  • 0
Jigglyass

Just installed it on a fresh, clean install of GTA 4. Performance is worse than on the 6th patch. I cant get constant 30 FPS anymore anywhere like i used to on maxed out settings.

The bushes in the game draw weird shadows too and the drawing of bushes in the distance is delayed....

Share this post


Link to post
Share on other sites
  • 0
SWEETSAPRIK

The game is still completely unplayable for me at any settings due to the constant slowdowns. It'd be great if you could put everything back the way it was before either of the last two patches.

 

I was playing the game at 2048x1152 with all the settings maxed out, now I can't play at any settings without encountering slowdown, and the slowdown kicks me from MP when it inevitably happens. Basically, the game is now unplayable for more than five minutes in either single player or multiplayer.

 

The only thing I haven't tried yet is completely uninstalling IV, and EFLC, then refusing to update when prompted. I'd still be unable to play MP, but at least the game won't be completely useless.

 

Share this post


Link to post
Share on other sites
  • 0
Cursed

Do the shadows implemented in Patch 6 still mean AA is not possible? It would be a really nice addition to the game. At the moment it's the one graphical letdown really.

Share this post


Link to post
Share on other sites
  • 0
Blissco

If you dont mind me asking, whats AA?

I thought it was Alco's Anonymous :S

Share this post


Link to post
Share on other sites
  • 0
mkey82

 

Do the shadows implemented in Patch 6 still mean AA is not possible? It would be a really nice addition to the game. At the moment it's the one graphical letdown really.

Really, do forget about AA. It's not going to happen (past what Boris is doing).

 

AA = Anti aliasing.

Share this post


Link to post
Share on other sites
  • 0
Cr!minal

Anti-aliasing, and no - AA isn't possible under DX9 because RAGE uses deferred lighting.

Share this post


Link to post
Share on other sites
  • 0
Anasterian

First of all: thanks for the patch that fixed some issues that bothered me a lot, especially that now i can turn off Clip Capture, i dont have to worry about slowdowns near water AND i gain back those frames that Clip Capture would steal overall, and that Sexy Time can be played properly now .

But i have a few questions, R* Torronto.

Is someone looking into issues with car head lights, tail lights, reverse lights and turn indicators textures in TBoGT?

Could the slowdown while using chat on multiplayer on Happiness Island somehow be related to other slow downs near that area/near water that occured on EFLC before the latest patch?

And last one, are you still looking into the texture pop in issue?

What i exactly mean, is that objects like trash bins, or even just the litter that is on the ground everywhere, appears about 5 meters in front of me as i move. Every other texture in the game is affected by this in one way or another, just that bigger textures, like textures of roads or bridges usually load a bit faster. Its just quite annoying that i turn around and see parts of various things load up, and then i turn back and its loading again.

Share this post


Link to post
Share on other sites
  • 0
DELETEDUSER

I cant login to soical club, WTF!

Share this post


Link to post
Share on other sites
  • 0
Smiler-Online
are you still looking into the texture pop in issue?

What i exactly mean, is that objects like trash bins, or even just the litter that is on the ground everywhere, appears about 5 meters in front of me as i move. Every other texture in the game is affected by this in one way or another, just that bigger textures, like textures of roads or bridges usually load a bit faster. Its just quite annoying that i turn around and see parts of various things load up, and then i turn back and its loading again.

You mean this bug right?

 

 

Share this post


Link to post
Share on other sites
  • 0
Kmeto 2
I cant login to soical club, WTF!

Me too confused.gif

Share this post


Link to post
Share on other sites
  • 0
Anasterian
are you still looking into the texture pop in issue?

What i exactly mean, is that objects like trash bins, or even just the litter that is on the ground everywhere, appears about 5 meters in front of me as i move. Every other texture in the game is affected by this in one way or another, just that bigger textures, like textures of roads or bridges usually load a bit faster. Its just quite annoying that i turn around and see parts of various things load up, and then i turn back and its loading again.

You mean this bug right?

 

 

Exactly that bug.

 

I think if they fix this bug, and lights on TBoGT cars, AND not add any bugs on the way the game will be fixed up eh?

 

Share this post


Link to post
Share on other sites
  • 0
Joker64
I cant login to soical club, WTF!

Me too confused.gif

Me too..

Share this post


Link to post
Share on other sites
  • 0
ivangtaiv

 

I cant login to soical club, WTF!

Me neither, Social Club fails to often lately. I guess it's because of RDR...

 

EDIT: It works now. wink.gif

Edited by ivangtaiv

Share this post


Link to post
Share on other sites
  • 0
FireItUp

Thank you R*. Now get working on that RDR port for PC please.

Share this post


Link to post
Share on other sites
  • 0
wrecker99

wut is rockstar games doing on moding site? wtf?

Share this post


Link to post
Share on other sites
  • 0
Peppah

Finally I can login in to Social Club, but update wont install. Just keeps repeating the installation process every time I try to login to GFWL. I blame Microsoft as usual.. They cant do anything right, it's always a hassle with products from Microsoft..

panic.gif

Share this post


Link to post
Share on other sites
  • 0
Rob.Zombie

lol great a new bug appeared online (this was the first time and hopefully the last 1), I drove around gta started stuttering in like every 2nd second and after it stopped I realised myself driving on nothing, but air. The whole city just f*cking disappeared, no lod textures, no hq textures, no nothing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.