Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (85,244 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

P1ch3

[GTAEFLC|REL|BETA] graphic modification

Recommended Posts

H1Vltg3

 

Ok so I had some time to get stuff working right today, this is what it looks like.

 

The look is alot better now then it was, but the refections on the cars are low quality (pixelated objects) no matter what setting I have reflections set to, never had this problem with any enb before. Thanks for the new shaders but please for the love of god remove the blur, add some DOF tho, thanks so much P1ch3 and Boris for the hard work!

In your commandline.txt (I assume you have one?) add:

 

-reflectionquality 4-reflectionresolution 2048

 

 

If you don't have the commandline, make one.

 

In the ENBseries.ini change:

 

ReflectionsForceHighPrecision=falseReflectionsExtremePrecision=false

 

to the following:

 

ReflectionsForceHighPrecision=trueReflectionsExtremePrecision=true

 

 

Then in the game's menu put reflections on "Very High"

 

All that will impact performance a little on some machines, but will make all of your clean cars practically mirrors.

 

That's exactly what I'm doing and it looks like the following:

user posted image

 

Uploaded with ImageShack.us

user posted image

 

Uploaded with ImageShack.us

 

Is that the kind of effect you're looking for?

Thanks but its somethin to do with the new shaders bro. I've been moddin GTA for 2 years now, never had reflections with ENB like this. Even without it, they are sh*t. The commands in ENB for HighReflection and Extreme do nothing with the new shaders. Also, the bloom, and lightsprites no longer work.

 

user posted image

 

user posted image

 

Look closely, you will see lines and blocks on the buildings in the reflection. Neverent, looks like you are running the shaders from the mega pack since you dont have shadows. My reflections looked as good as yours then too, but not with the new shaders folder P1ch3 posted.

Edited by H1Vltg3

Share this post


Link to post
Share on other sites
Atr9976

Hey guys, I've installed this and the EFLC launcher won't start the game now. Should I retry with a fresh install?

 

EDIT: I reinstalled it correctly and got it working. Is there anyway to fix the over-shinyness of cars?

Edited by Atr9976

Share this post


Link to post
Share on other sites
P1ch3

 

Look closely, you will see lines and blocks on the buildings in the reflection. Neverent, looks like you are running the shaders from the mega pack since you dont have shadows. My reflections looked as good as yours then too, but not with the new shaders folder P1ch3 posted.

Same Issue on my PC.

 

If I use deferred_lighting.fxc from 1.0.4.0 I Lost Shadow.

If I use the Original deferred_lighting.fxc from EFLC I Got Shadows But all Grainy Reflection.

 

Still Trying to find a Way to Fix This But I think We Will have to Wait for new EnbSeries for EFLC by BorisVorontsov.

 

BTW New Shaders without motion Blur Uploaded For Shadows Version but Relfection is Still Grainy

http://www.mediafire.com/?qawktjdnu3g

 

 

Comment Post By Boris:

 

Date:   2010-04-20 18:01:03, GMT +4

Name:   BorisVorontsov

Web:   http://enbdev.com

 

To all:

Version for EFLC may be released sometime, but i have tech problems right know, sorry.

Âåðñèÿ äëÿ EFLC âîçìîæíî ïîÿâèòñÿ, íî ñåé÷àñ ÿ êðóòî ïîïàë ñ àïãðåéäîì ïðîöà íà íîâûé äîõëûé, ïîêà ÷òî çàáóäüòå î enbseries, ÿ íå â íàñòðîåíèè.

 

Edited by P1ch3

Share this post


Link to post
Share on other sites
H1Vltg3

 

Look closely, you will see lines and blocks on the buildings in the reflection. Neverent, looks like you are running the shaders from the mega pack since you dont have shadows. My reflections looked as good as yours then too, but not with the new shaders folder P1ch3 posted.

Same Issue on my PC.

 

If I use deferred_lighting.fxc from 1.0.4.0 I Lost Shadow.

If I use the Original deferred_lighting.fxc from EFLC I Got Shadows But all Grainy Reflection.

 

Still Trying to find a Way to Fix This But I think We Will have to Wait for new EnbSeries for EFLC by BorisVorontsov.

 

BTW New Shaders without motion Blur Uploaded For Shadows Version but Relfection is Still Grainy

http://www.mediafire.com/?qawktjdnu3g

 

 

Comment Post By Boris:

 

Date:   2010-04-20 18:01:03, GMT +4

Name:   BorisVorontsov

Web:   http://enbdev.com

 

To all:

Version for EFLC may be released sometime, but i have tech problems right know, sorry.

Âåðñèÿ äëÿ EFLC âîçìîæíî ïîÿâèòñÿ, íî ñåé÷àñ ÿ êðóòî ïîïàë ñ àïãðåéäîì ïðîöà íà íîâûé äîõëûé, ïîêà ÷òî çàáóäüòå î enbseries, ÿ íå â íàñòðîåíèè.

 

Yeah I didn't see any screens of yours with the new shaders so I really wasnt aware. I sure hope you didnt remove the motion blur but instead the full screen blur on the new update.

 

Thats great news from Boris though!

Edited by H1Vltg3

Share this post


Link to post
Share on other sites
Neverent
Look closely, you will see lines and blocks on the buildings in the reflection. Neverent, looks like you are running the shaders from the mega pack since you dont have shadows. My reflections looked as good as yours then too, but not with the new shaders folder P1ch3 posted.

Same Issue on my PC.

 

If I use deferred_lighting.fxc from 1.0.4.0 I Lost Shadow.

If I use the Original deferred_lighting.fxc from EFLC I Got Shadows But all Grainy Reflection.

 

Still Trying to find a Way to Fix This But I think We Will have to Wait for new EnbSeries for EFLC by BorisVorontsov.

 

BTW New Shaders without motion Blur Uploaded For Shadows Version but Relfection is Still Grainy

http://www.mediafire.com/?qawktjdnu3g

 

 

Comment Post By Boris:

 

Date:   2010-04-20 18:01:03, GMT +4

Name:   BorisVorontsov

Web:   http://enbdev.com

 

To all:

Version for EFLC may be released sometime, but i have tech problems right know, sorry.

Âåðñèÿ äëÿ EFLC âîçìîæíî ïîÿâèòñÿ, íî ñåé÷àñ ÿ êðóòî ïîïàë ñ àïãðåéäîì ïðîöà íà íîâûé äîõëûé, ïîêà ÷òî çàáóäüòå î enbseries, ÿ íå â íàñòðîåíèè.

 

Yeah I didn't see any screens of yours with the new shaders so I really wasnt aware. I sure hope you didnt remove the motion blur but instead the full screen blur on the new update.

 

Thats great news from Boris though!

Same, because that's what I really want. Motion blur = good, full screen grainy blur = garbage that they put it to make consoles look "better".

Share this post


Link to post
Share on other sites
Bose321
As soon I put 'd3d9.dll' in my folder, and launch EFLC, the game shuts down 2 seconds after I see the white text (the first part, before the R* logo's).

 

When I remove it, it all runs fine.

try update your directx again worked for a time ago.

Nope, not working.

Share this post


Link to post
Share on other sites
steve30x

I had the same problem of the game failing to get to the rockstar logos. I replaced the shaders in the common folder with P1CH3's shaders and the game starts but the game crashes as soon as I leave a building with ENB enabled. I wish there was some way to get it working for me.

Share this post


Link to post
Share on other sites
Bose321

Already did that, doesn't work. whatsthat.gif

Share this post


Link to post
Share on other sites
Patrib1103

Hey P1ch3. Do you have a ENB Mega pack just for GTA IV? I know that you got ENB to work on GTA IV because of the Shaders and got EFLC to work with ENB 0.077b with modded shaders but do you have a mega enb pack for GTA IV maybe?

Share this post


Link to post
Share on other sites
..GhosT

I dont get it, put the Shader folder into the EFLC folder and have fun, or install the normal ENB + This?

 

Oh and please upload that corona texture ;D

Share this post


Link to post
Share on other sites
LoneMC

Shadows aside, this is running great. I can see ahead of me, and the game's looking greater than ever.

 

However, when I look at a certain angle range east and west, the 'new and improved' sky reverts back to the default:

user posted image

user posted image

 

user posted image

user posted image

 

What's up with this? Did I do something wrong or is it a side effect?

 

Else, it's just awesome now that it works for EFLC.

Share this post


Link to post
Share on other sites
H1Vltg3

@LoneMC: You must be using the new version of ENB. Download and use P1ch3's Mega Pack in post 1, and get the shaders update below that. That version is the old version 0.077b, which is the most stable at this point. Then you will have shadows and no new sky or nice bloom, but it looks better then the buggy one for time being until Boris gets over his technical issues and develops a EFLC ENBSeries.

 

Here's some new pics:

user posted image

 

user posted image

 

user posted image

 

user posted image

 

also, just view that whole album, there are tons of pics of enb, new ones added daily and are gonna be my current setup.

Edited by H1Vltg3

Share this post


Link to post
Share on other sites
XXLpeanuts

Other than ENB working with IV, why would anyone wanna play it again after Liberty City Stories anyway?!

New weapons, new story lines, better charactors i think.............. More stuff to do, f*ck IV

Share this post


Link to post
Share on other sites
P1ch3

user posted image

user posted image

user posted image

Edited by P1ch3

Share this post


Link to post
Share on other sites
Bose321

Tell me more about your avatar... happy.gif

 

 

I still can't get it to work.

Share this post


Link to post
Share on other sites
Monty717

I've tried installing this and it works, but there is no radar or mobile phone in game. This seems to happen when i enable anti aliasing in the enb settings.

Share this post


Link to post
Share on other sites
LoneMC

Thanks for the help H1Vltg3. Used a mix-and-match with all the posts floating around everywhere and chose the wrong versions.

 

@Monty717 As for the AA thing, I read that GTA4's method of antialiasing forces the game to be rendered at an epic resolution, which is then resized back to whatever resolution you use and slightly blurred for the "best effect". I think the game forgets to move the HUD back after that process. That's what I think is going on, since that happened to me too.

Share this post


Link to post
Share on other sites
Moshi

user posted image

 

How do I fix this? (Sorry if already asked)

 

And why do I get this cracking sound every few seconds in the sound in game when I install this mod? confused.gif

 

OK nvm. Fixed sound with basic acceleration.

Edited by Moshi

Share this post


Link to post
Share on other sites
Monty717

 

@Monty717 As for the AA thing, I read that GTA4's method of antialiasing forces the game to be rendered at an epic resolution, which is then resized back to whatever resolution you use and slightly blurred for the "best effect". I think the game forgets to move the HUD back after that process. That's what I think is going on, since that happened to me too.

 

This is probably what's going on, but has only been happening since the new patch. Before EFLC and the new patch the AA worked fine, and the hud was in place.

 

I know I could just leave the AA off, but the game looks so pixelated and jaggy without it and kind of ruins the experience.

Share this post


Link to post
Share on other sites
morphhh

Uhm... I use the 0.077b but still, there's no shadows..

Help?

 

Edit: Nevermind.

Edited by morphhh

Share this post


Link to post
Share on other sites
vans123

P1ch3: Man can you put the full package used for those screens and how you get so sharp edges when AA doesnt work? Can you share your secret?

Share this post


Link to post
Share on other sites
residentgta

Thanks P1ch3 man biggrin.gif Both games works with your files on my crap rig, with 30-35FPS, so thanks man tounge2.gif

And please ^^ post this setts the game looks awesome on those screens smile.gif

 

user posted imageuser posted imageuser posted imageuser posted image

Edited by residentgta

Share this post


Link to post
Share on other sites
amd74

PLZ HELP ME PLZZZZZZZZZZZZZ

I DON"T LIKE THIS WHAT SHOULD I DO?

user posted image

 

cryani.gif

 

i can't get anything else i am getting the Moshi's problem

is there any kind of solve for it?

------------------------------

forget it i don't wnat enb anymore now i have 1 problem

can anyone send me normal unmoded shader files? plzz?

 

the problem must be from windows

Edited by amd74

Share this post


Link to post
Share on other sites
P1ch3

@amd74 and @Moshi

 

Try this

ForceNVidiaCard=true

 

@vans123

 

I Don't Have Any Secret.

I Set my Desktop Resolution to 1280*720.

In GTA EFCL Option I Set Resolution to 1920*1080

This Give Me Free AA without using the One from EnbSeries.

 

The Only Thing New I Use now is VisualIV 1.6.1

Share this post


Link to post
Share on other sites
TyphoonCC

hi i have a hugh performance problem..i replaced the shaders with the shaders that you uploaded a few days ago and after that i have to turn off the shadows to get the normal fps that i used to have somewhere in between 35-45 fps. Well at night i can have the shadows at high without any problems what so ever but at mid day i get absolutly ridiculous fps it's crawling down to 10!!! Any ide what the problem is? i have change back to the original shaders now but still the game looks so much better with ENB and the other visual mods....

 

 

 

Share this post


Link to post
Share on other sites
residentgta
PLZ HELP ME PLZZZZZZZZZZZZZ

I DON"T LIKE THIS WHAT SHOULD I DO?

user posted image

 

cryani.gif

 

i can't get anything else i am getting the Moshi's problem

is there any kind of solve for it?

------------------------------

forget it i don't wnat enb anymore now i have 1 problem

can anyone send me normal unmoded shader files? plzz?

 

the problem must be from windows

Reinstall the game smile.gif

Share this post


Link to post
Share on other sites
Yakunchik

 

@vans123

 

I Don't Have Any Secret.

I Set my Desktop Resolution to 1280*720.

In GTA EFCL Option I Set Resolution to 1920*1080

This Give Me Free AA without using the One from EnbSeries.

 

The Only Thing New I Use now is VisualIV 1.6.1

 

What? Are you crazy? Your native resolution of the monitor is 1920*1080. Why on the desktop you use less?

Share this post


Link to post
Share on other sites
Erdo4

Why it gave me always error..? I deleted settings folder, tried shadow off.. I always get error.

Share this post


Link to post
Share on other sites
Darkauron

i have a question. if i install VisualIV 1.6.1 will i lost the shadow again ?

Share this post


Link to post
Share on other sites
H1Vltg3
i have a question. if i install VisualIV 1.6.1 will i lost the shadow again ?

Not if you install it over the shader patch that P1ch3 came up with. You will have to do some reconfiguring.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.