Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
      4. Frontier Pursuits
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Diamond Casino & Resort
      2. DLC
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA 6

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA IV Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA SA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA VC Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA III Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

rinuextreme

GTA EFLC PC Lags like HELL!

Recommended Posts

Jay_Capone

haha, i knew i needed a processor, it runs quite smooth just im a real FPS Person and smoothness, also i dont suppose you could Reccomend a processor that will be compatible with my Motherboard? the Model is : MCP73VT-PM, Thanks in advance

Share this post


Link to post
Share on other sites
spaceeinstein

 

You just have to admit, GTA IV and EFLC are just laggy games in themselves, even with top cards and processors. The engine incorporated into GTA IV and EFLC has to load up too many dynamic behaviours, animations, world environments plus textures. Sometimes they run fine, other times they don't.

Yes, I agree with that. The problem is GTA3, VC, and SA also have this problem. But back then people don't blame R* for slowdowns, they usually blame their machines and attempt to fix the problems themselves. When bugs appear, modders will readily search for a fix. These days people instead blame R* for slowdowns and bugs and will complain for a "patch that fix all" instead of fixing the problems themselves. There seem to be a switch in general behaviors among gamers sometime between 2005 and 2008. I'm not a hardcore PC gamer so I'm not sure what happened but people appear to be very needy these days. This change in behavior is what irritates me.

Share this post


Link to post
Share on other sites
Jay_Capone

just think in 2020 we'll all have new games no one will have heard of Grand theft auto: san andreas and gta 4 will run on any PC like gta sa does now lol

 

 

 

 

Share this post


Link to post
Share on other sites
Cpl.Dunn

Eh, for me it runs on better FPS than GTA IV.

Share this post


Link to post
Share on other sites
Jay_Capone

do you think this processor would be alright?

 

AMD Athlon II X2 250 / 3 GHz - Socket AM3 - L2 2 MB ( 2 x 1 MB )

 

i think it should be because its 3.0ghz and its dual core but im not too sure confused.gif

Share this post


Link to post
Share on other sites
TheTomster

To all people with higher end systems, but with crappy framerates (I had sh*tty framerates), lower you detail distance from 100 to something along the lines of 40. It helped me gain on average 10fps. Also, if you can run it, check in the Mod Showroom for the ENB series mod my P1C3H or whatever his name is. I had it and my FPS went from 25 avg, to 40 avg just like my regular IV which runs at 40 avg with ENB. Downsides are: Sun turns into a gray square, and the sky looks like a bit of sh*t, but everything else will look better, and run better.

Share this post


Link to post
Share on other sites
Jay_Capone

Well ive been doing a bit of tweaking and messing around and Those who said it shouldnt run at all i dont think its doing too badly, heres my OLD/NEW Benchmarks...

 

 

 

 

 

OLD

 

 

 

Statistics

Average FPS: 11.99

Duration: 32.78 sec

CPU Usage: 91%

System memory usage: 84%

Video memory usage: 32%

 

Graphics Settings

Video Mode: 800 x 600 (60 Hz)

Texture Quality: Medium

Shadow Quality: Medium

Reflection Resolution: High

Water Quality: High

Texture Filter Quality: Anisotropic x16

Night Shadows: Off

View Distance: 22

Detail Distance: 11

 

Hardware

Microsoft Windows XP Professional

Service Pack 3

Video Adapter: ATI Radeon HD 5450 1GB DDR3

Video Driver version: 6.14.10.7149

Audio Adapter: Realtek HD Audio output

Intel® Celeron® CPU E1500 @ 2.20GHz

 

File ID: TBoGT-Benchmark.cli

 

---------------------------------------------------------------

Statistics

Average FPS: 15.41

Duration: 36.46 sec

CPU Usage: 88%

System memory usage: 69%

Video memory usage: 29%

 

Graphics Settings

Video Mode: 800 x 600 (60 Hz)

Texture Quality: Medium

Shadow Quality: Medium

Reflection Resolution: High

Water Quality: High

Texture Filter Quality: Anisotropic x16

Night Shadows: Off

View Distance: 22

Detail Distance: 11

 

Hardware

Microsoft Windows XP Professional

Service Pack 3

Video Adapter: ATI Radeon HD 5450 1GB DDR3

Video Driver version: 6.14.10.7149

Audio Adapter: Realtek HD Audio output

Intel® Celeron® CPU E1500 @ 2.20GHz

 

File ID: TLAD-Benchmark.cli

 

 

 

 

------------------NEW BENCHMARKS:----------------

 

 

 

 

Statistics

Average FPS: 19.35

Duration: 32.71 sec

CPU Usage: 92%

System memory usage: 74%

Video memory usage: 25%

 

Graphics Settings

Video Mode: 800 x 600 (60 Hz)

Texture Quality: Low

Shadow Quality: Off

Reflection Resolution: Off

Water Quality: Low

Texture Filter Quality: Tri-Linear

Night Shadows: Off

View Distance: 1

Detail Distance: 1

 

Hardware

Microsoft Windows XP Professional

Service Pack 3

Video Adapter: ATI Radeon HD 5450

Video Driver version: 6.14.10.7149

Audio Adapter: Realtek HD Audio output

Intel® Celeron® CPU E1500 @ 2.20GHz

 

File ID: TBoGT-Benchmark.cli

 

 

 

-----------------------------------------

 

 

 

Statistics

Average FPS: 22.95

Duration: 36.21 sec

CPU Usage: 92%

System memory usage: 83%

Video memory usage: 25%

 

Graphics Settings

Video Mode: 800 x 600 (60 Hz)

Texture Quality: Low

Shadow Quality: Off

Reflection Resolution: Off

Water Quality: Low

Texture Filter Quality: Tri-Linear

Night Shadows: Off

View Distance: 1

Detail Distance: 1

 

Hardware

Microsoft Windows XP Professional

Service Pack 3

Video Adapter: ATI Radeon HD 5450

Video Driver version: 6.14.10.7149

Audio Adapter: Realtek HD Audio output

Intel® Celeron® CPU E1500 @ 2.20GHz

 

File ID: TLAD-Benchmark.cli

 

 

 

 

I Dont Think Its Too Bad, Definatly Playable untill i get my new AMD Athlon II X2 250 / 3 GHz Processor.

 

Thanks For everyones help anyway, icon14.gif

 

Share this post


Link to post
Share on other sites
kudoboi

lol im on nvidia 9500GT n i can play the game with settings maxed out

Share this post


Link to post
Share on other sites
Jay_Capone

 

lol im on nvidia 9500GT n i can play the game with settings maxed out

 

 

I could play it maxed out too my Card has 1gb, i could max everything out just my processor lets me down, with a good processor this game would play awesome on my system, and its Not a high end system at all.

Share this post


Link to post
Share on other sites
gp4f2008

GUYS!!! I found how to get out of this lag!!! First of all, this is only for Nvidia, and i am very sorry about that. Try this:

 

•Go to The nVidia Control Panel and go to Manage 3d settings

•Then turn Anisotrophic Filtering OFF and set Antialiasing Transparency to Multi Sampling

•Antialiasing Setting to 2x.

•Texture Filtering Quality to High Performance.

•Texture Filtering -Trilinear Optimisation to ON.

•Texture Filtering -Negative LOD bias to ALLOW.

•Threaded Optimisation ON.

•Vertical Sync and Triple Buffering ON .

 

This helps me a lot. Now, in-game i get like 20-30 fps, maybe higher when Luis is on specific places. These are my in-game settings:

 

user posted image

 

I had to turn off the shadows and reflections to get this framerate, but i am happy that i can put a higher resolution. Hope this helps! tounge.gif

Share this post


Link to post
Share on other sites
Jay_Capone
Intel® Celeron® CPU E1500 @ 2.20GHz

 

There's your problem-you are lucky the game even runs at all-the game REQUIRES at least a AMD Athlon Dual Core @ 2.4GHZ or higher OR an Intel Core 2 Duo 1.8 GHZ or Higher as per the box the game came in AND the PINNED can I run it.... thread. Long story short, your processor does not meet minimum, as it (Celeron) are Single core processors...

I Think i must be doing something right then, what do you think?

 

 

 

Yeah everythings on low but if im lucky its even running it cant be that bad smile.gif

 

 

 

Statistics

Average FPS: 24.27

Duration: 36.22 sec

CPU Usage: 94%

System memory usage: 82%

Video memory usage: 49%

 

Graphics Settings

Video Mode: 800 x 600 (60 Hz)

Texture Quality: Low

Shadow Quality: Off

Reflection Resolution: Off

Water Quality: Low

Texture Filter Quality: Tri-Linear

Night Shadows: Off

View Distance: 1

Detail Distance: 1

 

Hardware

Microsoft Windows XP Professional

Service Pack 3

Video Adapter: ATI Radeon HD 3600 Series

Video Driver version: 6.14.10.7149

Audio Adapter: Realtek HD Audio output

Intel® Celeron® CPU E1500 @ 2.20GHz

 

File ID: TLAD-Benchmark.cli

Share this post


Link to post
Share on other sites
Jay_Capone

got a AMD Athlon 64 x2 Dual Core Processor 4000+ 2.11GHZ With 3.0GB Ram With Same GFX Card and it run worse..... i give up, more ram and a better CPU Means i lose FPS omfg does this game just run how it fealsl ike or summat?

Share this post


Link to post
Share on other sites
killah09

My sys : Intel C2D E7600 , GT 9600 , 2GB of Ram and i have 37 FPS in GTA IV with all on medium and view distance 34 and detail distance 100 shadow density 0 some times lags some times not smile.gif Want screens ?

Share this post


Link to post
Share on other sites
The Lolwut Pear

I have low shadows and verything else on Medium settings and it runs at about 15-24 FPS in sunny weather and nighttime.

 

Lags like hell when it rain's, though.

Share this post


Link to post
Share on other sites
OGIamLoco

turn off the texture filter, you won't see hardly any difference anyways.

Share this post


Link to post
Share on other sites
hugh750

 

I've tried to reduce the graphic settings all to low and I'm using 200MB out of a graphic card with 1GB!

 

I have 3.3GB RAM Memory and GTA IV Original runs smooth at High Textures and with 800MB of resource usage. But after the 6th patch, both GTA IV Original (6th patch) and EFLC LAG LIKE HELL!!!!!

 

I'd like to know what can I do to fix this! I love the new features of the 6th patch and I'd love to complete the Episodes calmly and nicely.

 

Please give any support if possible.

 

Thank you!

 

 

My PC SPECS:

 

Windows XP SP3

ATI Powercolor 4670HD 1GB

3.3GB RAM

Intel Core2Duo 2.13GHz

 

 

I too get lag in gta 4 eflc (but i play tbogt multiplayer and i keep getting dropped by gfwl. angry.gif

to let you know my specs are:

Cpu intel core 2 quad 2.5 gig q8300

memory 3 gigs

os windows vista 32 bit

mobo intel dp43tf with latest drivers and latest bios update

video card radeon 4670 1 gig with latest drivers from ati

realtek hd audio

(but when i play tbogt multiplayer i use my headset. plus the settings i use in graphics is on medium except water and shadow quality is on high

Share this post


Link to post
Share on other sites
OverTheBelow

You're going to get some lag on medium-high settings with a 4670. Only solution is to turn them down or get a new card. Or live with it.

Share this post


Link to post
Share on other sites
nightwalker83
I had to turn off the shadows and reflections to get this framerate, but i am happy that i can put a higher resolution. Hope this helps! tounge.gif

I was going to suggest for the people who have fraps if changing the frame rate makes a difference?

Share this post


Link to post
Share on other sites
hugh750

 

You're going to get some lag on medium-high settings with a 4670. Only solution is to turn them down or get a new card. Or live with it.

I get good performance with my listed graphics settings, its just i get randomly dropped by gfwl. cry.gif

 

Microsoft needs to fix games for windows live, i've looked my problem on google and it goes back a year. angry.gifangry.gif

Edited by hugh750

Share this post


Link to post
Share on other sites
hugh750

Well i put in a cisco/linksys ae1000 usb wireless with latest drivers (i previously had a railink wireless card)

Now i don't get dropped by gfwl. colgate.gif

Share this post


Link to post
Share on other sites
westforge

so what's the best patch to install for EFLC? i mean performance wise..

Share this post


Link to post
Share on other sites
unc13bud

it depends on your computer

Share this post


Link to post
Share on other sites
gta player13

It's simple.Just make sure you have enough card space,and close all other applications before running the game.

Don't worry about the quality.As long as you have Definition:On,it still has good graphics.

The most important here is low settings even on the most powerful systems.Make sure the number on the bottom is green and far away

from the max MB capacity.Example I play both IV and EFLC with 202/538MB which is just perfect to play the game without lag.

If you reaaally want high settings,use a game-boosting software.But all they do is close other applications,nothing more.

Hope it works...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 2 Users Currently Viewing
    0 members, 0 Anonymous, 2 Guests

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.