Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Online

      1. Gameplay
      2. Find Lobbies & Outlaws
      3. Help & Support
      4. Frontier Pursuits
    1. Crews & Posses

      1. Recruitment
    2. Events

    1. GTA Online

      1. Diamond Casino & Resort
      2. DLC
      3. Find Lobbies & Players
      4. Guides & Strategies
      5. Vehicles
      6. Content Creator
      7. Help & Support
    2. Grand Theft Auto Series

    3. GTA 6

    4. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    5. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA IV Mods
    6. GTA Chinatown Wars

    7. GTA Vice City Stories

    8. GTA Liberty City Stories

    9. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA SA Mods
    10. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA VC Mods
    11. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA III Mods
    12. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    13. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. News

    2. Forum Support

    3. Site Suggestions

rinuextreme

GTA EFLC PC Lags like HELL!

Recommended Posts

f5544

i have a same sort of system and i have about 60 fps and not all on maxed. pff strange.

Share this post


Link to post
Share on other sites
TTKRickJames
anyone having trouble in the water around happiness island? Thats where I lag the most. Especially on the mission "sexy time"

I'm having the same problem too. As far as I know, "majority" or everybody here has the same problem. It's a big disappointment from Rockstar Games again. How come they release the game like that? Do they have testers to test the game? If they have, they should fire them all! icon13.gif

In most cases, game testers are hired by 3rd party game testing firms, I wouldn't be surprised if R* hires them too.

Share this post


Link to post
Share on other sites
pilot1889

Hello,finnally got hold of eflc,but the game lag a lot cannot even move a car,gta 4 was working fine with high settings.

my spec

Inter® core2 duo cpu E7300 @ 2.66 GHz

2.00GB RAM

NVIDIA Geforce 9500 GT.

Do i need to upgrade something.

Share this post


Link to post
Share on other sites
TiRANB

 

Hello,finnally got hold of eflc,but the game lag a lot cannot even move a car,gta 4 was working fine with high settings.

my spec

Inter® core2 duo cpu E7300 @ 2.66 GHz

2.00GB RAM

NVIDIA Geforce 9500 GT.

Do i need to upgrade something.

It's your Graphics Card. nVidia Geforce 9500 GT is not enough for the game. Also, Episodes From Liberty City have some lag issues that "majority" of the players here are experiencing. I suggest that you wait for a patch.

Edited by TiRANB

Share this post


Link to post
Share on other sites
pilot1889

Nvidia 9500 GT,is a 1GB card.

are u sure its still not enough for eplc as i had no problem with gta 4.

Share this post


Link to post
Share on other sites
Vladornot

naw dude its k ur graphics card should handle it, but maybe not on max setting, but EFLC is having issues due to poor optimization, probably because it was tested on NASA hardware. You need a REALLY good card (like the ATI 5990 with 4gb of mem) if that sh*t doesn't cut it, no sh*t will.

Share this post


Link to post
Share on other sites
TTKRickJames
I just built a new system yesterday:

 

Intel i7 930

6Gb ddr3 12800

Radeon HD 5870

Intel X25 SSD

Asus  P6T

 

All settings at very high,1920x1080  view distance at 64,  detail at 75 im getting 50-100 FPS

 

On my last system i was getting 15-30 Fps with most settings in high and the distances at like 20

 

 

we'll see what i get in EFLC in about 5 hours when its done downloading...

 

Would post my benchmark but the game crashes every time i try... Lets hope EFLC's benchmark works for me...

How much have you spent in that new system?

$1632 CAD

Share this post


Link to post
Share on other sites
TTKRickJames
i have a same sort of system and i have about 60 fps and not all on maxed. pff strange.

Um, close but theres one big difference, you have a 4870, I have a 5870.....

Share this post


Link to post
Share on other sites
ppehrson
Hello,finnally got hold of eflc,but the game lag a lot cannot even move a car,gta 4 was working fine with high settings.

my spec

Inter® core2 duo cpu E7300 @ 2.66 GHz

2.00GB RAM

NVIDIA Geforce 9500 GT.

Do i need to upgrade something.

It's your Graphics Card. nVidia Geforce 9500 GT is not enough for the game. Also, Episodes From Liberty City have some lag issues that "majority" of the players here are experiencing. I suggest that you wait for a patch.

Bullcrap. I played it fine on a 8600 GT Silent.

Share this post


Link to post
Share on other sites
ppehrson

 

I just built a new system yesterday:

 

Intel i7 930

6Gb ddr3 12800

Radeon HD 5870

Intel X25 SSD

Asus  P6T

 

All settings at very high,1920x1080  view distance at 64,  detail at 75 im getting 50-100 FPS

 

On my last system i was getting 15-30 Fps with most settings in high and the distances at like 20

 

 

we'll see what i get in EFLC in about 5 hours when its done downloading...

 

Would post my benchmark but the game crashes every time i try... Lets hope EFLC's benchmark works for me...

How much have you spent in that new system?

$1632 CAD

So, you spent a lot of bucks on a really nice system and then you go and destroy it by installing a card from an inferior developer. (Yes, ATI cards may SEEM faster, in reality they just produce too much heat making your OVERALL system slower due to heat). I would have chosen a high end ASUS nVidia that matches your mainboard. Not many games are optimized for ATI anymore.

Share this post


Link to post
Share on other sites
f5544
i have a same sort of system and i have about 60 fps and not all on maxed. pff strange.

Um, close but theres one big difference, you have a 4870, I have a 5870.....

yes but i forgot to mention i have the X2 version.

Share this post


Link to post
Share on other sites
Neaera

Hey that trick with turning that clip capture thing on didnt work for me!

still game runs smoothly and after an random amount of minutes games fps start drop as hell!

 

Help?

Share this post


Link to post
Share on other sites
rinuextreme
Hey that trick with turning that clip capture thing on didnt work for me!

still game runs smoothly and after an random amount of minutes games fps start drop as hell!

 

Help?

Close any background programs running before starting the game. Example:

 

- Messenger

- Rockstar Games Social Club

- Any Adobe program that consums a lot of RAM memory

- Firefox/Google Chrome/Internet Explorer or any web browser you have

- And anything you may close like folders and things like that except the Anti-virus

 

 

Run the game and in the menu, go to Options and:

 

 

- Disable Night Shadows (latest patch only)

- Set Shadows to Low or Medium

- Set Clip Capture to OFF

- Set VSYNC to OFF

- Set Definition to OFF

- Set Reflections and Water Quality to High or less

- Textures to Medium or if your PC is good enough turn it to High

- View Distance to 15 or 30

- Detail Distance at 50 or less

- Vehicle Density to 50 or less

 

 

 

If possible, use a trainer to set the day time to Sunny/Extra Sunny or to Rainy/Drizzle. Afternoon and Night makes the game lag even more.

Share this post


Link to post
Share on other sites
Neaera

Dude, thanks for the help.

But I believe the problem has nothing to do with graphics configurations.

Like i said, game runs smoothly and after 5 mins it becomes laggy. i do not understand it. everything was fine at gta 4.

 

You see, it doesn't matter if i change something. game still runs like an old lady.

Share this post


Link to post
Share on other sites
classact68

Hi. I don't mean to poke fun at anyone. BUT!! I running this game on:

 

P4 3.0 HT

2 gig ram

nvidia APG 7600GT

Xp sp3

 

Now i have a duel boot, and the 2nd OS is stripped down. Removed alot of MS crap, no firewall, no anti virus and used msconfig to remove any background running programs i don't need. I think what you having running in the background , has alot to do with it.

 

Lost and the Damned : ran ok, some lag and frame rate drops and a weird black screen of death, here and there.

Ballad of Gay Tony : runs great, just like GTAIV did.

 

Settings are low, running at 800x600 60hrtz. all setting to MED, and the rest a 1.

 

Im not bragging here, i just showing, you can run this game, under the system req. I plan on building a new PC here shortly.

 

I5, 4 gig ram, nvidia 270. All i can say, if it runs worse on that PC, rockstar is full of crap and cant port a game to save their lives.

 

Once last rant, what pisses me off the most, Us PC users put them on the map, from GTA to San Andreas, and leave us so far behind on releasing the game, and a very poor job at porting this game. GTAIV ran so bad out of the box.

 

Classy

Share this post


Link to post
Share on other sites
Cinnober

Same here... GTA IV just fine about 50 fps....TLAD/TBOTG runs like sh*t on a Intel E8400 with a Geforce 260GTX 896mb and 4GB PC2-6400 ram. sad.gif

Share this post


Link to post
Share on other sites
rinuextreme
Same here... GTA IV just fine about 50 fps....TLAD/TBOTG runs like sh*t on a Intel E8400 with a Geforce 260GTX 896mb and 4GB PC2-6400 ram. sad.gif

Well, guys, let's just wait for the 6th patch for EFLC. Period.

Share this post


Link to post
Share on other sites
Brown Sugar

I just bought eflc but hasn't arrived yet because I bought it on play and after readign this im sure it will lag like hell

 

can anyone tell me if these specs will be enough to run it without lag (I don't mind having it on low settings.):

 

AMD Phenom x3 II 710 2.60 ghz

4gb ram

ATI raedon hd 4350

Share this post


Link to post
Share on other sites
Marabunta Grande

 

Hey that trick with turning that clip capture thing on didnt work for me!

still game runs smoothly and after an random amount of minutes games fps start drop as hell!

 

Help?

Close any background programs running before starting the game. Example:

 

- Messenger

- Rockstar Games Social Club

- Any Adobe program that consums a lot of RAM memory

- Firefox/Google Chrome/Internet Explorer or any web browser you have

- And anything you may close like folders and things like that except the Anti-virus

 

 

Run the game and in the menu, go to Options and:

 

 

- Disable Night Shadows (latest patch only)

- Set Shadows to Low or Medium

- Set Clip Capture to OFF

- Set VSYNC to OFF

- Set Definition to OFF

- Set Reflections and Water Quality to High or less

- Textures to Medium or if your PC is good enough turn it to High

- View Distance to 15 or 30

- Detail Distance at 50 or less

- Vehicle Density to 50 or less

 

 

 

If possible, use a trainer to set the day time to Sunny/Extra Sunny or to Rainy/Drizzle. Afternoon and Night makes the game lag even more.

Are you sure? I don't want to argue, but on my opinion, the foggy and rainy weather makes my game lagg. Turen Clip Capture ON so the game gets rid of the lags.

Edited by DODI3OG

Share this post


Link to post
Share on other sites
f5544

the game runs smoother when everything is maxed out for me. strange

Share this post


Link to post
Share on other sites
reo11

 

 

Player Hater

 

Group: Members

Joined: May 11, 2010

 

 

Member Log

 

 

i played gta4 eflc and i have :

pentium D 2.8 ghr - 3gb ram - nvidia geforce 9500gt 1gb/ddr2 in windows 7

when i start the test performance it give me this result :

 

Statistiques

Moyenne images/sec. : 16.18

Durée: 32.66 sec

Utilisation processeur : 96%

Utilisation mémoire système : 71%

Utilisation mémoire vidéo : 50%

 

Paramètres graphiques

Mode d'affichage: 1280 x 1024 (60 Hz)

Qualité textures: Elevé

Qualité ombres: Faible

Résolution réflexions: Elevé

Qualité eau: Faible

Qualité Filtre Textures: Anisotropique x16

Ombres nocturnes: Sans

Profondeur de champ: 13

Distance détails: 11

 

the strange thing that i see many people they show they test performance and they always have on "mémoire vidéo : 80%-90%" but mee it seems that my gpu is traying to not surpassing the 50% !!!!!!! what can i do to solve this problem ???? please help

Share this post


Link to post
Share on other sites
Iwillforget

I have the same problem. On yesterday I benchmarked it with very low settings and I got ~30 FPS. Today I benchmarked it with high settings and got ~13 FPS and the video was like 1 FPS at some times of the benchmark. (My friend has the same GTS 250 GPU but with 512 MB of memory and I have 1 GB of memory. He got ~21 FPS at medium settings.) After changing settings and benchmarking I started to get 9 FPS then 6 FPS and now it is always 6 FPS.

Share this post


Link to post
Share on other sites
nnyymm
What's with turnin that on? It fixes what?

 

 

This Clip Capture thing is only going to help on machines that were seeing slowdowns when near the waters edge. It has nothing to do with optimizations and such it is a bug in the code that only occurs when clip capture is set to OFF.

 

Source :-

 

http://www.gtaforums.com/index.php?act=ST&...st&p=1059888228

Thanks, mate.

I'm going to try that later!

 

I'm lagging too running at

 

Q9550 @3.63ghz

6GB ram

HD4870X2 2gb

(running at recommended graphic setting pre determined by the game)

 

I lag alot especially when i am in alderney city area..

 

Share this post


Link to post
Share on other sites
Vladornot

ok i got a system that is able to run this game decent, and the new patch fixes the lag at sexytime

 

intel i7 975 over clocked to 4.1ghz

 

6gb ddr3 2000mhz

 

gtx480

 

x58 ftw3

 

I get 35 fps in the benchmark with all setting maxed including view distance.

Share this post


Link to post
Share on other sites
markjaysongalang

Just Buy a better PC, XBOX 360 or a PS3 if you want to play the IV series SMOOTHLY at PERFECT FRAME RATE 60 FPS. It's even better on HDMI 1.3 using PS3 or 360.

Share this post


Link to post
Share on other sites
kuipertje

hello guys

 

i allso have the lagg problem i just got a new laptop specs : i7 740qm 4gb ram ati radeon hd5730 1 gb .

i got the game right out the game shop happy with it and finnaly got a laptop thats fast enouch .

but when i started to play it first the f+cking problems with the windows live en social club sh+t .

i did set all the settings on hich becouse heey man got a new machine !!

 

started playing all seems nice en good bust with driving it seems like someone is hitting the brakes every 2 a 3 seconds .

its realy F+cked up thougt i got it all good original game and good laptop but it doesnt run like i want it to

the settings now are all near low or off it runs good but still a bit lagg i hoped the patch worked for me.

but heey the fu+cking game got an error now ( fatal error w10 ) or someting like that .

 

now in reinstalling it and go and play it on low settings hope that rockstar comes with a good patch .

or maybe you guys know someting i dont smile.gif .

i allso got problems with san andreas hanging and restarting computer ( my old computer )

that was allso a original game and good pc back then .

 

i have to say that rockstar isnt a good company in my eyes if you look around on the net and see how mutch problems there are with games they released .

again a f+cked game by rockstar waiting to be fixed ...... rampage_ani.gif

 

a other game i just played maffia 2 runs very well all settings hich colgate.gif no comments on that and a real nice game

hope gta 4 will be just as good in a short time

 

if you guys have some tips than let me know biggrin.gif

 

( im dutch so my english writing can be wrong some times sorry for that tounge.gif hahaha )

 

 

Share this post


Link to post
Share on other sites
spaceeinstein

You bought a laptop and expect it to play on high settings, but instead blame R* for not making the game run smoothly on your laptop? That's a very narrow-minded way to think, blaming someone else without putting some blame on yourself. Why do you want to compare the performance on high settings between this game and Mafia II? There's no standard on how high settings is suppose to perform.

Edited by spaceeinstein

Share this post


Link to post
Share on other sites
Motorizer

You just have to admit, GTA IV and EFLC are just laggy games in themselves, even with top cards and processors. The engine incorporated into GTA IV and EFLC has to load up too many dynamic behaviours, animations, world environments plus textures. Sometimes they run fine, other times they don't.

Share this post


Link to post
Share on other sites
Jay_Capone

could anybody help me out GTA EFLC Runs so slow on my P.C i know a CPU Upgrade wouldnt go a miss but i mean just for now untill i can get one. Any help would be great and apprecieated, Thanks.

 

 

 

 

 

 

 

All Patched up to patch 2, every Driver Updated to the newest versions.

 

 

 

Statistics

Average FPS: 11.99

Duration: 32.78 sec

CPU Usage: 91%

System memory usage: 84%

Video memory usage: 32%

 

Graphics Settings

Video Mode: 800 x 600 (60 Hz)

Texture Quality: Medium

Shadow Quality: Medium

Reflection Resolution: High

Water Quality: High

Texture Filter Quality: Anisotropic x16

Night Shadows: Off

View Distance: 22

Detail Distance: 11

 

Hardware

Microsoft Windows XP Professional

Service Pack 3

Video Adapter: ATI Radeon HD 5450 1GB DDR3

Video Driver version: 6.14.10.7149

Audio Adapter: Realtek HD Audio output

Intel® Celeron® CPU E1500 @ 2.20GHz

 

File ID: TBoGT-Benchmark.cli

 

---------------------------------------------------------------

Statistics

Average FPS: 15.41

Duration: 36.46 sec

CPU Usage: 88%

System memory usage: 69%

Video memory usage: 29%

 

Graphics Settings

Video Mode: 800 x 600 (60 Hz)

Texture Quality: Medium

Shadow Quality: Medium

Reflection Resolution: High

Water Quality: High

Texture Filter Quality: Anisotropic x16

Night Shadows: Off

View Distance: 22

Detail Distance: 11

 

Hardware

Microsoft Windows XP Professional

Service Pack 3

Video Adapter: ATI Radeon HD 5450 1GB DDR3

Video Driver version: 6.14.10.7149

Audio Adapter: Realtek HD Audio output

Intel® Celeron® CPU E1500 @ 2.20GHz

 

File ID: TLAD-Benchmark.cli

Share this post


Link to post
Share on other sites
radioman

 

Intel® Celeron® CPU E1500 @ 2.20GHz

 

There's your problem-you are lucky the game even runs at all-the game REQUIRES at least a AMD Athlon Dual Core @ 2.4GHZ or higher OR an Intel Core 2 Duo 1.8 GHZ or Higher as per the box the game came in AND the PINNED can I run it.... thread. Long story short, your processor does not meet minimum, as it (Celeron) are Single core processors...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.