Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    1. GTA Online

      1. The Diamond Casino Heist
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Red Dead Online

      1. Frontier Pursuits
      2. Find Lobbies & Outlaws
      3. Help & Support
    3. Crews

      1. Events
    1. Red Dead Redemption 2

      1. PC
      2. Gameplay
      3. Missions
      4. Help & Support
    2. Red Dead Redemption

    1. Grand Theft Auto Series

    2. GTA 6

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. The Lost and Damned
      2. The Ballad of Gay Tony
      3. Guides & Strategies
      4. Help & Support
      5. GTA IV Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA SA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA VC Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA III Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    1. GTA Mods

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Red Dead Mods

    3. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    4. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Rockstar Games

    2. Rockstar Collectors

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    3. Gangs

    1. News

    2. Forum Support

    3. Site Suggestions

Owenwilson1

[WIP] Model testing gallery

Recommended Posts

Owenwilson1
Sorry for the confusion... I was simply asking if putting in a higher polygon mesh would help make the quality better... etc

its okay rich i knew what ya ment mate. yeh high poly's do look good but again. its trying to texture a new model car anything because you cant make ya own wtd yet. so ya stuck with what ya got in the default cars in gtaIV

Share this post


Link to post
Share on other sites
Rich246

Ok, so what about comet to Porsche 911? or a civilian buffalo? *no fib stuff in the back etc...*

Share this post


Link to post
Share on other sites
FunGt

We just need a editor to create new wdt files. If I'm not wrong, no tool do it yet.

Share this post


Link to post
Share on other sites
Fabio206
We just need a editor to create new wdt files. If I'm not wrong, no tool do it yet.

mm G-Texture? biggrin.gif

*wtd

Share this post


Link to post
Share on other sites
DexX

 

How new is this?

 

 

Edit: The *.dcl files have been changed with R* patches (1.0.2.0 for sure, 1.0.1.0 is untested) and no longer contain full vertex declarations mad.gif

Anyone using that data needs to grab the files from a 1.0.0.0 install.

That particular edit was made, i believe, in March. The actual description seemed to be useful only to humans, it looks like the number at the beginning of the file is what the game actually reads and is a combination of all the vertex flags. I did some work guessing at the values, you can read my notes here.

 

 

Does this have to do with the vertex bugs? If so, does that mean modding is presumably a 1.0 affair now? How does this affect people with Steam copies of the game who will always only be able to download the latest version? Perhaps 1.0.1.0 patches will be an option to down-patch copies of the game? Since steam copies run from anywhere w/ or w/o steam as long as social club is running? Gold pressing consumers are screwed?

I don't think it affects anyone (in terms of exporting models that is). You'll note that in the patches, R* never changed any of the models. We're still playing with the models that shipped with the 1.0.0.0 game, despite 4 patches.

 

 

You said in your response about padding, also, I see now with the lighting thing. To be clear though, IV buildings/statics, they don't have light data in the vertex anymore, it's all done on the last pass dynamically, right? Maps have the potential of looking great with flat/unlit meshes, thanks to Rage? Or not as dynamic as I think, and requires more than basic prelighting on the assets? I'm way behind, I need to be up to speed  blush.gif

They might have some kind of prelight data; even the weapons have a vertex color that is probably used for something, although what exactly i don't know. Every 3d object in the game is dynamically lit. So every vertex should have at the minimum, a position and a normal. Normal maps are used too, depending on the shader used for a particular material, but it still requires a vertex normal, and to make the normal map work correctly, a vertex tangent.

 

About the padding, that seems to be a more common issue in general. REspawn had problems with it, prince-link is with his wdr tool, i doubt Oleg is unaffected.

Share this post


Link to post
Share on other sites
Owenwilson1

 

We just need a editor to create new wdt files. If I'm not wrong, no tool do it yet.

mm G-Texture? biggrin.gif

*wtd

i'll correct myself on that i think ive acheived it. making new wtd's

Edited by Owenwilson1

Share this post


Link to post
Share on other sites
chasez
We just need a editor to create new wdt files. If I'm not wrong, no tool do it yet.

mm G-Texture? biggrin.gif

*wtd

i'll correct myself on that i think ive acheived it. making new wtd's

Omg when you people will understand that G-texture doesn't work to create wtd

Share this post


Link to post
Share on other sites
crashsilumator234
look at this cutie ... i need to know how to add decals and carcolor secondary. ..

 

Blubb Comet Police

thats awesome

 

Maybe i could help to put the decals?

Share this post


Link to post
Share on other sites
DexX

 

Omg when you people will understand that G-texture doesn't work to create wtd

It does infact create new Wtd files, with as many textures as you need to use. Are you having trouble getting the wtd program to work, or are you having problems getting the wtd file to work in the game?

Edited by DexX

Share this post


Link to post
Share on other sites
Owenwilson1
Omg when you people will understand that G-texture doesn't work to create wtd

It does infact create new Wtd files, with as many textures as you need to use. Are you having trouble getting the program to work, or are you having problems getting the wtd to work in IV?

well i managed to get my new wtds ingame its getting the windows transparent thats bothering me

Share this post


Link to post
Share on other sites
JKM

tried the exporter today too.

Just wanna show some damage screens (i know the car is still buggy^^).

It seems that the damage is not as strong as for the original schafter (yeah i replaced schafter and didnt change any other data file wink.gif )

 

user posted image user posted image user posted image

 

Edit: yes im using the carcol-line

Edited by JKM

Share this post


Link to post
Share on other sites
Fabio206

This is my very first attempt to 3d modeling and zmodeler..little thing added to a turismo biggrin.gif

there is a problem with tires and windowscreens textures in vehshare.wtd lol

user posted image

Share this post


Link to post
Share on other sites
chasez

 

This is my very first attempt to 3d modeling and zmodeler..little thing added to a turismo  biggrin.gif

there is a problem with tires and windowscreens textures in vehshare.wtd lol

user posted image

nope there is no problem. remember this is not San Andreas, texturing is different now.

 

Oh and did you add the vehshare textures to zmodeler texture path?

Share this post


Link to post
Share on other sites
chasez

 

Omg when you people will understand that G-texture doesn't work to create wtd

It does infact create new Wtd files, with as many textures as you need to use. Are you having trouble getting the program to work, or are you having problems getting the wtd to work in IV?

Have you tried it yourself? well you can add the pictures to the wtd or create new wtd file but it won't work in the game and even in the sparkIV. Just try to add one picture to the wtd and then try to see it in SparkIV, after you've done that come back to the forum and tell everyone else what did you experienced.

 

All that we can do for now is just replace the textures but not to create new ones.

Share this post


Link to post
Share on other sites
JKM

well its working in sparkIV... but youre right its not working ingame wink.gif

user posted image

Edited by JKM

Share this post


Link to post
Share on other sites
Owenwilson1
well its working in sparkIV... but youre right its not working ingame wink.gif

user posted image

i could have told ya that.

Share this post


Link to post
Share on other sites
JKM

Lol its working ingame too. So its not true chasez. G-Texture is working fine

 

Proof (and no i didnt change old textures i made my own wtd) btw its my own scratch made model:

user posted image user posted image

Share this post


Link to post
Share on other sites
FunGt

My first GTAIV 3d modification, the spoiler. :D

user posted image

click to enlarge

Share this post


Link to post
Share on other sites
Owenwilson1
Lol its working ingame too. So its not true chasez. G-Texture is working fine

 

Proof (and no i didnt change old textures i made my own wtd) btw its my own scratch made model:

user posted image user posted image

i just tried it again it realy is lol

Share this post


Link to post
Share on other sites
chasez
Lol its working ingame too. So its not true chasez. G-Texture is working fine

 

Proof (and no i didnt change old textures i made my own wtd) btw its my own scratch made model:

user posted image user posted image

I see that your textures are in DXT5 but when I tried to add in new wtd file it showed me unknown and the saved version crashed the SparkIV. Make a tutorial so I can see what did you do.

Share this post


Link to post
Share on other sites
Neos7

ehm i have a problem with my supra : In Zmod when i export my edited .wft file with new textures

i got this error to clipboard

 

Object "banshee.wft" was not found. Whole scene will be exported. Missing shader configuration for shader "gta_vehicle_MOMO_Corse_gm" in material "MOMO_Corse_gm". Defaulting to "gta_default". Missing shader configuration for shader "gta_vehicle_conti" in material "conti". Defaulting to "gta_default". Missing shader configuration for shader "gta_vehicle_conti-sc2" in material "conti-sc2". Defaulting to "gta_default". Missing shader configuration for shader "gta_vehicle_brake" in material "brake". Defaulting to "gta_default".

 

 

and the added parts are untextured u know how to fix it?

Share this post


Link to post
Share on other sites
chasez

Well ok if everyone else is showing what they have done than I will show you how far I am now smile.gif

user posted image

user posted image

Share this post


Link to post
Share on other sites
lpgunit

Well, as Niko once said, "We're making some progress then," - I guess we're only a few steps away from making custom 3D content for IV, but I have another question: Do vehicle and weapon meshes require dummy cubes like what the Renderware-based games use for defining positions like passenger/driver seats, headlights, etc? Or is it stored somewhere else?

Share this post


Link to post
Share on other sites
JKM

 

ehm i have a problem with my supra : In Zmod when i export my edited .wft file with new textures

i got this error to clipboard

 

Object "banshee.wft" was not found. Whole scene will be exported. Missing shader configuration for shader "gta_vehicle_MOMO_Corse_gm" in material "MOMO_Corse_gm". Defaulting to "gta_default". Missing shader configuration for shader "gta_vehicle_conti" in material "conti". Defaulting to "gta_default". Missing shader configuration for shader "gta_vehicle_conti-sc2" in material "conti-sc2". Defaulting to "gta_default". Missing shader configuration for shader "gta_vehicle_brake" in material "brake". Defaulting to "gta_default".

 

 

and the added parts are untextured u know how to fix it?

I am having this trouble too.

But ingame the textures show up. Dont know why ZModeler gives such a report.

 

I am using Paint.net and converted my textures to dxt5 .dds ones.

Thats all^^ Open G-Texture create new wtd and add your images (dont forget to generate mipmaps)!

Ah and dont change any material from imported model.... didnt try it yet I only used original materials with my new textures in the texture slot wink.gif

Edited by JKM

Share this post


Link to post
Share on other sites
OverTheBelow

Great job on the progress guys, keep the screens comin'. tounge.gif

Share this post


Link to post
Share on other sites
Neos7

so u use custom materials but without delete the default ones from gta4 geometry even if they are on no geomtry part?

anyway how to add mipmaps?i convert my textures from tga to dds with dds converter 2.2.1

 

EDIT:my settings from dds converter are them ok?

user posted image

Edited by Neos7

Share this post


Link to post
Share on other sites
AzuShin
I wonder what a Lamborghini Murci looks like in gta4.. *hint hint*  blush.gif

here ya go

user posted image

I wonder how a perfectly made 300C looks like in game tounge.gifbiggrin.gifsarcasm.gif

Nice job guys. Owen try to make a car perfect, so like the Murci have transparent glasses, textures working etc.

LOL that looks like sh*t. But hey, it's in beta. Good luck with the testing and thanks. tounge.gif

The PMP600 is the 300C. God I hate the 300C. It's everywhere.

Share this post


Link to post
Share on other sites
Starion
What's the car damage like on that Crown Victoria chasez? Does it work, does it deform as it all should do?

Share this post


Link to post
Share on other sites
JKM

nope... im only using the materials given by imported models... not my own ones.

But I can delete some Shader infos and its working ingame too. So I can define if i wanna use Specular or Reflectionmaps.

Try to check the Box in ZM in the material editor (user defined options) before exporting any model.

 

Made some leather in the interior without specular and without reflections (its only the interior light)

user posted image user posted image

 

@Neos7: I dont know. I used just the standard options in paint.net.... but i am generating mipmaps with g-texture

Edited by JKM

Share this post


Link to post
Share on other sites
Neos7

nice user posted image

 

these are my dds convering settings i hope they are ok

 

btw u have msn,skype,yahoo or something we can use to speak quickly?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×
×
  • Create New...

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.