Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!   (91,417 visits to this link)

    2. News

    1. GTA Online

      1. Find Lobbies & Players
      2. Guides & Strategies
      3. Vehicles
      4. Content Creator
      5. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption 2

    2. Red Dead Redemption

    3. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

  • 0
Rockstar Toronto

Maintenance Update 1.0.4.0

How has this update affected your game? (poll added by mods)  

1,092 members have voted

  1. 1. How has this update affected your game? (poll added by mods)

    • Performance boost.
      189
    • No change.
      229
    • Performance decrease.
      112
    • Haven't installed it / not going to install it.
      124


Question

Rockstar Toronto

Today we released a Maintenance Update for the PC version of Grand Theft Auto IV. This update ensures all copies of the game are properly aligned for the next gold master build pressing. We have also improved the resource management numbers to detect and adjust accordingly to different operating systems.

 

Like all previous updates, this contains all the fixes from past title updates, so there is no need to re-install previous patches if you have to re-install the game for any reason. A direct link to download Maintenance Update 1.0.4.0 can be found here. For more details and download links for other languages, check out the Grand Theft Auto IV PC support page.

Edited by Rockstar Toronto

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
[CTD]LaBan

 

Hmm this update didn't do any good to my game. In fact, it make it run worse.  sad.gif

Maybe it's because benchmark tool in the game isn't accurate? rolleyes.gif

Share this post


Link to post
Share on other sites
  • 0
Nillus

In my opinion the #1 thing R* should do now is: write a decent multiplayer server system, P2P isn't the way to go for this, it's laggy and there's no central point handling security etc.

The multiplayer on the PC version is one of the things that make it stand out, make it useable then. bored.gif

 

If this thing is still in dev, consider adding a function for enabling/disabling gun recoil, no recoil AT ALL now: it's like you are playing lasergame lol and some people don't like that

Console versions have gun recoil and ingame texts on both consoles and PC talk about recoil and to aim more accurately etc. Aiming from cover isn't any less accurate while the consoles and the ingame texts state this.

Aka, add a switch for 'Realistic gun handling on/off' as this is clearly a bug. smile.gif

 

 

PS: Since mods don't work now, that means cheaters are not online anymore? biggrin.gif

I've been on multiplayer today and there's less cheaters but there are still skiddies around: I once saw like 50+ Annihilators falling down from the sky crashing everyone's game. cry.gif

Edited by Nillus

Share this post


Link to post
Share on other sites
  • 0
Intosia
Ow, does Gold Patch mean, last patch that gonne be made?

it means they make the early full price buyers test and suffer for the late cheap buyers...

Yeah indeed, thats what i thought. Well i dont expect a game to be 100% on release, but still crappy after 1.4, meh... thats where bad software design kicks in...

Share this post


Link to post
Share on other sites
  • 0
zerosaber

The game runs better for me now!!! I have obtained a 5-6 FPS boost. Thanks R*!!!!!

Share this post


Link to post
Share on other sites
  • 0
Hydro_PT
LaBan' date='Jun 19 2009, 20:00']
Hmm this update didn't do any good to my game. In fact, it make it run worse.  sad.gif

Maybe it's because benchmark tool in the game isn't accurate? rolleyes.gif

Read the rest of my post lol. As I said, a 3 FPS loss in the benchmark is nothing to worry about, but ingame things are much worse. I lost 5 and sometimes even more FPS. And it stutters a bit more.

Share this post


Link to post
Share on other sites
  • 0
FunGt

We have to wait the big update, this is nothing imho.

Share this post


Link to post
Share on other sites
  • 0
anus

 

LaBan,Jun 19 2009, 20:00]
Hmm this update didn't do any good to my game. In fact, it make it run worse.  sad.gif

Maybe it's because benchmark tool in the game isn't accurate? rolleyes.gif

Read the rest of my post lol. As I said, a 3 FPS loss in the benchmark is nothing to worry about, but ingame things are much worse. I lost 5 and sometimes even more FPS. And it stutters a bit more.

Mistakened you for Spider-Vice. Sorry tounge.gif.

Edited by Warlord.

Share this post


Link to post
Share on other sites
  • 0
Ruscris2

Benchmark is a sh*t ! My benchmark say that I lose 3 fps but Fraps indicate i got more ! And the game runs more good ! So download Fraps or buy it and see !!!

Share this post


Link to post
Share on other sites
  • 0
Cornflake

 

In my opinion the #1 thing R* should do now is: write a decent multiplayer server system, P2P isn't the way to go for this, it's laggy and there's no central point handling security etc.

The multiplayer on the PC version is one of the things that make it stand out, make it useable then. bored.gif

Well, all the consoles are doing it! So it's the thing, whatever they do on the Xbox 360 goes for PC, too! Didn't you get the memo?

 

On a serious note, it really does suck when a game runs on P2P multiplayer system. Not only becaused of lag and lack of security... but you loose any consistency and customizations. You don't have server names, can't keep track of good places to play, no chance of server-side mods or tweaks, etc. You only ever get the very basic vanialla gaming experience. You just see a player name and colored bars. What does green mean? under 100ms? What's orange? Does red mean they are in China? How the hell am I supposed to tell? I also agree with what you said about the weapon recoil smile.gif

 

I'm not just ranting, I speak from experience. I had run a Garry's Mod server (A very popular and quite addicting Half-Life 2 mod) for over 2 years now and let me tell you... the server / client setup is the only way to go. Yeah it might take time to find a server, and you're relying on the host but it's a much more organized and rewarding gaming experience. And at the very least you can let the people WITH A FAST CONNECTION NOT OVERSEAS host the game.

 

 

I lost 5 fps in benchmark,Now I have pops up of texture going on,and it more lagy.

At least you can run the benchmark! Ever since updating to 1.0.3.0 the benchmark option is missing for me anywhere in the menu; My textures are locked at Low and view distance at 1 no matter what drivers / OS i use; and terrible pop in (like I'm over my memory limit) even If I leave the settings at default. Worst of all after searching the web and the forums not one other person has mentioned this problem with 1.0.3.0. I've tried in Vista, XP, 10 different driver versions, etc. Nothing.

 

And I should congradulate them on this patch because... not a thing was solved!

Edited by Cornflake

Share this post


Link to post
Share on other sites
  • 0
jimnms

 

I WANT TO BE ABLE TO REMAP THE RMB TO MOVE FORWARD!!! FIX THIS ROCKSTAR.

SAME HERE! I won't be able to try this patch until tonight, but I had a small bit of hope that they might have finally fixed this. ARE YOU EVEN LISTENING ROCKSTAR???

 

I had to use a hacked version of the Logitech mouse driver for my mouse to play the game. After I finished the story missions I uninstalled the driver because it causes problems with other programs. I want to play the game again, but I don't want to have to use hacked drivers just to play a damn game.

 

Every GTA from GTA: III to GTA: SA allowed rebinding of any key and mouse button to any function. Why can't we do the same in GTA: IV? Also remove the hard coded binding that hangs up the phone on right mouse button even if re-bound to something else.

Share this post


Link to post
Share on other sites
  • 0
knee

Ok guys, I'm going to need some help here because this new patch is giving me some serious problems. Take a look at these benchmark stats:

 

Before:

 

Statistics

Average FPS: 32.43

Duration: 37.10 sec

CPU Usage: 98%

System memory usage: 58%

Video memory usage: 93%

 

After:

 

Statistics

Average FPS: 7.27

Duration: 38.12 sec

CPU Usage: 99%

System memory usage: 69%

Video memory usage: 97%

 

Settings:

 

Graphics Settings

Video Mode: 800 x 600 (60 Hz)

Texture Quality: Low

Texture Filter Quality: Low

View Distance: 1

Detail Distance: 1

 

Hardware

Microsoft® Windows Vista" Home Premium

Service Pack 2

Video Adapter: NVIDIA GeForce 8600M GT

Video Driver version: 185.63

Audio Adapter: Speakers / Headphones (SigmaTel High Definition Audio CODEC)

Intel® Core2 Duo CPU T8300 @ 2.40GHz

 

 

So it went from 32 to 7 fps and needless to say I won't be doing any racing tonight.

 

Anyone have any ideas? Clip capture is off, I've got the settings turned as low as they go. I've tried it with and without the recommended command line for the 1.03 patch. I've checked to see if I have the correct power settings on my laptop. Everything is the same, except for the patch. I'm going to try and download from outside live and reinstall after I have posted this...

Share this post


Link to post
Share on other sites
  • 0
knee

Ok when I tried to reinstall the patch it reported errors with copying binkw32.dll and GTAIV.exe. I reeeeaaaaally don't want to go through a game reinstall...

Share this post


Link to post
Share on other sites
  • 0
Zemmeh

 

to detect and adjust accordingly to different operating systems.

 

Yea thats why i lost 10 fps again with what your patch put in graphics settings. AND my my aspect ratio was so bad that the mini map looked like a football ball instead of a circle.

 

suicidal.gif

 

Edit: @knee: Even on low graphics everywhere, i burned my gfx(same as yours) with GTA4 So be carefull my friend. And each patch mess up with many users' fps, best of luck to you with this mess.

Edited by Zemmeh

Share this post


Link to post
Share on other sites
  • 0
Spider-Vice

 

I WANT TO BE ABLE TO REMAP THE RMB TO MOVE FORWARD!!! FIX THIS ROCKSTAR.

SAME HERE! I won't be able to try this patch until tonight, but I had a small bit of hope that they might have finally fixed this. ARE YOU EVEN LISTENING ROCKSTAR???

 

I had to use a hacked version of the Logitech mouse driver for my mouse to play the game. After I finished the story missions I uninstalled the driver because it causes problems with other programs. I want to play the game again, but I don't want to have to use hacked drivers just to play a damn game.

 

Every GTA from GTA: III to GTA: SA allowed rebinding of any key and mouse button to any function. Why can't we do the same in GTA: IV? Also remove the hard coded binding that hangs up the phone on right mouse button even if re-bound to something else.

There's always an anonymous user logged on opinion threads and sh*t, haven't you noticed? It may be R*.

Share this post


Link to post
Share on other sites
  • 0
MitchyK

Well i'm all patched up and i'm quite happy, i'm running at higher settings, and by default the game actually seems to get the auto settings not far off now. Before it was a joke. I'm getting about 3-5fps more in the benchmark, but in game it's running like silk. At night i'm getting between 40 and 60fps before it was 30-50, and it's usually towards the higher end of the scale, and it also runs much smoother.

So whatever they patched, seemed to work for me.

 

MitchyK

 

Share this post


Link to post
Share on other sites
  • 0
knee

Ok sorry for the spam but my issue is now resolved. The patch downloaded from outside live worked. The binkw32.dll and GTAIV.exe copying errors were due to my exe still running in the processes. I'm now back to 31 fps. Hope this helps anyone who might experience the same issues.

Share this post


Link to post
Share on other sites
  • 0
Sp4wNers
Where is changelog ?

There's no changelog, as he said "This update ensures all copies of the game are properly aligned for the next gold master build pressing". We must wait for this BIG update

Share this post


Link to post
Share on other sites
  • 0
Gta Guy 108
Ok thanks Rockstar, but I'm going to give up..

 

I just spent 6 whole weeks nonstop tweaking, reinstalling.. finetuning and spent $600 on gpu's.. own 3 copies of the game... Finally I have got it running straight and smooth for 2 whole days and then you release a patch that made me loose 15fps in-game..!!!!!????

 

I really needed to step out and scream for a moment...

 

And why do you always answer my mails with a counter question, and when I answer that I never hear of you people again?

Hey you are not the only one, your computer must be really good after you spent 600 on gpu, but really it is not the computer that is making this game messing up, it has to be the game.

 

This game will go number 1 on my list of worst ports in history. All said and done, it seems like you need a computer from Nasa just to run the damn thing, but then again, it seems like they could not even run Crysis, but that is a whole 'nother topic. Rockstar really did mess up with this one. I think they really should have released two versions of the same game, one is to play on multiplayer, and has all that security crap on it, and the other to mod and do what you please. I would have bought the one that you could mod with. I could care less about online with this game, I have heard alot of stuff with modders shooting frags out of their M4's and pistols that shoot rockets, and it is sad that they spent 200k on a faulty game security check to make sure that players won't find another virtual sex mini-game. Instead, we get a game we can hardly even work.

Share this post


Link to post
Share on other sites
  • 0
Boris_Chavez

For me this update caused a lot more trouble than it was worth. First of all it completely wrecked single player - fine till you get outside the safehouse, then frame rate immediately tumbles to nothing, crash to desktop, same when trying to run the benchmark, but MP free mode seemed OK-ish but crashed out after about 15 minutes. Installed the latest NVidia drivers (for 9800GT 1GB) which I didn't particularly want to do as the game was running very nicely before. Now the game works again, but looks like cr*p and is much jerkier even on recommended settings. And that was after turning clip capture off again. The effects of known causes of lag (e.g. not turning off traffic and peds in helicopter races) also seem much worse. What we need is a new, properly coded engine/executable, not a buggy one with layers of patches that drain performance.

Share this post


Link to post
Share on other sites
  • 0
Intosia

I decided to install the patch. I was still at 1.0.2 because of the .net hook. And im very pleasantly supprised!! The game runs much smoother (and less resources in use in the benchmark). Even played with Shadow Detail on max, didnt make a difference? Ok, maybe i missed some things of the 1.0.3 patch, that could be it tounge.gif

 

Fps range form 23-60. Admit im running om 1280x720, with medium settings, on a Q6600 with a 8800GTX. I dont see the difference between Medium and High anyway :S

 

Ow and thats with 181.xx Nvidia drivers, lol. I need to update, ahah

Edited by Intosia

Share this post


Link to post
Share on other sites
  • 0
gamerzworld

 

Ok when I tried to reinstall the patch it reported errors with copying binkw32.dll and GTAIV.exe. I reeeeaaaaally don't want to go through a game reinstall...

Make sure GTAIV and Social Club are not running. Also, make sure the patch is running with admin if you are using Vista.

Share this post


Link to post
Share on other sites
  • 0
FullMetal

Shamefully the patch isn't helping me at all. In fact I have a fps drop of 15 even up to 20 FPS sometimes. sad.gif Buying a new flatscreen monitor soon so I hope it'll run better on higher resolutions (because alot of people keep saying it runs better in higher resolutions than lower ones).

Share this post


Link to post
Share on other sites
  • 0
YoungGun

54MBs.. biggest patch yet?

 

 

Share this post


Link to post
Share on other sites
  • 0
Zemmeh

thats YOUR SUPER DUPER RECOMMENDED SETTINGS FROM THE PATCH:

 

Statistics

Average FPS: 25.66

Duration: 37.61 sec

CPU Usage: 93%

System memory usage: 72%

Video memory usage: 76%

 

Graphics Settings

Video Mode: 1280 x 1024 (70 Hz)

Texture Quality: High

Texture Filter Quality: High

View Distance: 26

Detail Distance: 51

 

Hardware

Microsoft® Windows Vista" Ultimate

Service Pack 1

Video Adapter: ATI Radeon HD 4850 Series

Video Driver version: 7.14.10.612

Audio Adapter: Speakers (High Definition Audio Device)

Intel® Core2 CPU 6600 @ 2.40GHz

 

Thats the settings i put on myself:

 

Statistics

Average FPS: 30.94

Duration: 37.58 sec

CPU Usage: 95%

System memory usage: 67%

Video memory usage: 46%

 

Graphics Settings

Video Mode: 1024 x 768 (70 Hz)

Texture Quality: Medium

Texture Filter Quality: High

View Distance: 26

Detail Distance: 51

 

Hardware

Microsoft® Windows Vista" Ultimate

Service Pack 1

Video Adapter: ATI Radeon HD 4850 Series

Video Driver version: 7.14.10.612

Audio Adapter: Speakers (High Definition Audio Device)

Intel® Core2 CPU 6600 @ 2.40GHz

 

Your patch failed at optimizing my comp i guess, + aspect ratio was ugly had to change it. By the way, your benchmark doesnt even show shadow quality which influance rly much performances.

Share this post


Link to post
Share on other sites
  • 0
Nietzsche's God

I don't notice the difference on mine. Still the same to me. Good thing we got a break from the fa**ot cheaters for the time being.

Share this post


Link to post
Share on other sites
  • 0
Th3 ProphetMan
54MBs.. biggest patch yet?

The file contains all previous fixes plus the new changes, so every patch should be bigger tounge.gif

 

 

About performance, i do notice it a bit better smile.gificon14.gif

Share this post


Link to post
Share on other sites
  • 0
reznor

Ahahah biggrin.gif new Patch --> New problems biggrin.gif

Share this post


Link to post
Share on other sites
  • 0
ForgedReality

 

woot! it made my IV run alot better and look better! the damage looks great now and the graphics just look better in general.

 

i'm running 10-30fps (10 with a damaged car in a police chase...) averages around 20 yay!

 

i'm running:

800x600

High Textures (i'm using -availablevidmem 3.5 and -memrestrict 629145600 and i get no popup!)

No Reflections/Low (I switch to low reflections in certain cars that look bad without reflections)

Low Water

No Shadows

 

100 traffic desenty with the 100 peds and 3x traffic and peds mod

 

specs:

AMD X2 64bit 5200+

5GB Ram

Vista Home Premium 64bit

ATi Radeon X1300 256mb

 

 

yay!

 

..but wtf? i get 4.98 fps on the benchmark!?

Wow. That's f*ckin sh*tty. I get 78fps on the benchmark, and I run max EVERYTHING at 1920x1200.

 

Time to upgrade, mate. tounge2.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.