Quantcast
Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
    1. Welcome to GTAForums!

    2. News

    1. Red Dead Redemption 2

      1. Gameplay
      2. Missions
      3. Help & Support
    2. Red Dead Online

      1. Gameplay
    1. GTA Online

      1. After Hours
      2. Find Lobbies & Players
      3. Guides & Strategies
      4. Vehicles
      5. Content Creator
      6. Help & Support
    2. Crews

      1. Events
      2. Recruitment
    1. Grand Theft Auto Series

    2. GTA Next

    3. GTA V

      1. PC
      2. Guides & Strategies
      3. Help & Support
    4. GTA IV

      1. Episodes from Liberty City
      2. Multiplayer
      3. Guides & Strategies
      4. Help & Support
      5. GTA Mods
    5. GTA Chinatown Wars

    6. GTA Vice City Stories

    7. GTA Liberty City Stories

    8. GTA San Andreas

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    9. GTA Vice City

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    10. GTA III

      1. Guides & Strategies
      2. Help & Support
      3. GTA Mods
    11. Top Down Games

      1. GTA Advance
      2. GTA 2
      3. GTA
    12. Wiki

      1. Merchandising
    1. GTA Modding

      1. GTA V
      2. GTA IV
      3. GTA III, VC & SA
      4. Tutorials
    2. Mod Showroom

      1. Scripts & Plugins
      2. Maps
      3. Total Conversions
      4. Vehicles
      5. Textures
      6. Characters
      7. Tools
      8. Other
      9. Workshop
    3. Featured Mods

      1. DYOM
      2. OpenIV
      3. GTA: Underground
      4. GTA: Liberty City
      5. GTA: State of Liberty
    1. Red Dead Redemption

    2. Rockstar Games

    1. Off-Topic

      1. General Chat
      2. Gaming
      3. Technology
      4. Programming
      5. Movies & TV
      6. Music
      7. Sports
      8. Vehicles
    2. Expression

      1. Graphics / Visual Arts
      2. GFX Requests & Tutorials
      3. Writers' Discussion
      4. Debates & Discussion
    1. Forum Support

    2. Site Suggestions

Alexander Blade

[GTAIV|REL] MP File Check Fix

Recommended Posts

UncleCrank

Yep it doesn't

And Alex somehow disappeared...

Share this post


Link to post
Share on other sites
Coldkilla

Win7x64 here. Same error as MetalLord, also same SRT10 error.

 

ARG!!!

Share this post


Link to post
Share on other sites
sjaak327

Maybe you guys can benefit from an alternative method I am using on my machine, it does involve filecheckfix, but doesn't use dsound.dll as asi loader, nor does it have any asi mod in the gtaiv directory, also no scripthook.dll:

 

The problem is that Rockstar added a check to see if scripthook.dll is in the GTAIV directory, also any .asi (like trainer.asi) are in the gtaiv directory, also dsound.dll. All of these files are in that directory, so filecheckfix must surpress this, as the connection lost message comes up when you try and create a match. The crash to desktop happens if you try to join a match. We have rockstar to thank for this problem...

 

To get around the issue perform the following:

 

-move dsound.dll out of the GTAIV directory. (delete it, or move it to desktop for instance).

-create plugins directory as subdirectory of the main GTAIV directory

-move any .asi (like trainer.asi) into plugins (except filecheckfix.asi, leave that in the GTAIV directory).

-leave any .ini (like trainer.ini) into the GTAIV directory.

-download thisand put d3d9.dll and devloader.config into the GTAIV directory (this is another asi loader, that let's you load asi's from the plugins directory, another great piece of software by Aru)

-move scripthook.dll to: c:\windows\system32 if you are running 32 bits windows (x86) or c:\windows\syswow64 if you are running 64 bits windows.

-delete scripthook.log from GTAIV directory.

 

So now you should have:

-no dsound.dll, trainer.asi, scripthook.dll in the GTAIV directory (they should NOT be there)

-d3d9.dll, devloader.config trainer.ini and filecheckfix.asi should be in the GTAIV directory. All other non original files should NOT be there.

-trainer.asi (and other .asi you happen to use) should now be in \plugins.

 

Now start the game, and you will be able to access MP each and every time. The only thing is that you might get an access violation error message when exiting the game, but that beats having the connection error problem IMHO.

 

Maybe it works for you guys, it does work 100% for me, but for others it apparently doesn't work.

 

Edit: you also need to run Windows update, and set it to receive updates to other Microsoft programs, on my new PC this workaround didn't work until I ran windows update and installed the following two updates (not sure which one did the trick): update for C++ redistributable (KB 973923) and Update to Games for Windows Live 3.2.

Edited by sjaak327

Share this post


Link to post
Share on other sites
Latetzki

So there isn't solution for that error with ASI loader and Filecheckfix? Or which one it's the problem?

Share this post


Link to post
Share on other sites
UncleCrank

Thx sjaak but unfortunately the game doesn't start at all if i try this. It just loads into taskmanager and then immediatley exits.

Share this post


Link to post
Share on other sites
sjaak327
Thx sjaak but unfortunately the game doesn't start at all if i try this. It just loads into taskmanager and then immediatley exits.

Yes, more people have the same issue, I don't know why though, it works fully on my Vista install, and to be honest, I tried to troubleshoot this for someone (although remotely) and indeed their game does not even start, no error message in event log, just nothing.

 

Maybe I have a special GTAIV smile.gif

 

 

Share this post


Link to post
Share on other sites
UncleCrank

I just tried renaming it to d3d10.dll for directx 10.

I can start the game now but im unable to start your trainer in the plugins folder. So no effect if you rename it.

Share this post


Link to post
Share on other sites
sjaak327

 

I just tried renaming it to d3d10.dll for directx 10.

I can start the game now but im unable to start your trainer in the plugins folder. So no effect if you rename it.

Renaming won't work, I will try this approach on Windows 7 tonight, see if it works there are well, (I share the same installation between Vista and Windows 7, but haven't ran the game in Win7 for a week or so).

 

This might be a wild goose chase but maybe try and change the devloader.config file and change the first path, so that it doesn't try to load anything in the GTAIV directory, and see if that works, then move filecheckfix to plugins as well and see if that works.

 

 

<Plugins>

<Path1></Path1>

<Path2>.\plugins</Path2>

<Path3></Path3>

</Plugins>

 

(remove the . that is in path1 now, maybe you also need to set path1 to .\plugins and have path 2 empty). Wild goose chase but hey if you don't try..

 

Edit: works fine on Windows 7 X64 for me as well.

Edited by sjaak327

Share this post


Link to post
Share on other sites
UncleCrank

I tried every possibility so far. Change the name of the path, set no path, set path 1 to 3, 1 to 2, remove the . etc

The game loads, and nothing happens.

Why did Alex leave us anyway?

Edited by TheMetalLord

Share this post


Link to post
Share on other sites
sjaak327
I tried every possibility so far. Change the name of the path, set no path, set path 1 to 3, 1 to 2, remove the . etc

The game loads, and nothing happens.

Why did Alex leave us anyway?

Wait, the game loads ?

 

If that's the case, try setting the debug logger.

 

<ConsoleLogger>

<Enabled>1</Enabled>

</ConsoleLogger>

 

There should appear a dos box like window, maybe it'll tell us more.

 

 

Share this post


Link to post
Share on other sites
GTAIVmbb
Mode note: No no no, standard FileCheckFix only, not a cracked version

Share this post


Link to post
Share on other sites
UncleCrank

Nope it doesn't load sry for the misunderstanding.

I can see the LaunchGTAIV.exe in the taskmanager for a few seconds but thats all.

 

Share this post


Link to post
Share on other sites
sjaak327

I have no idea to be honest, I actually copied the files from the link back to my game (maybe I made a mistake in uploading them) but it works fully for me.

 

 

Share this post


Link to post
Share on other sites
GTAIVmbb

sjaak waar kommie vandaan

Share this post


Link to post
Share on other sites
Coldkilla

Thanks Sjaak!!! Your method works perfectly! (x64 Windows 7).

 

 

Share this post


Link to post
Share on other sites
Ziggy yardie

 

2pigs18 : r u drunked ?

i'd wrote in readme that u CAN'T CHANGE SUSPICIOUS FILES

 

2wachumanango : i can but there is one big trouble - original xlive.dll checks the memory , so if i'll modify some code and this code should be modifed all time - live check will give a game crash (like it was in first version of car spawner etc)

hey alex i got this strange error the title is [GTAIV] FILE CHECK FIX ERRO!"sorry,but this version of gtaiv is not supported.supported versions : 1.0.1 us,1.0.2us,1.0.3us"

i dont know whats this about,was this from ur filecheck? i have a few graphics mods & vehicles. any idea what might cause this?

Share this post


Link to post
Share on other sites
FTS
I tried every possibility so far. Change the name of the path, set no path, set path 1 to 3,  1 to 2, remove the . etc

The game loads, and nothing happens.

Why did Alex leave us anyway?

Wait, the game loads ?

 

If that's the case, try setting the debug logger.

 

<ConsoleLogger>

<Enabled>1</Enabled>

</ConsoleLogger>

 

There should appear a dos box like window, maybe it'll tell us more.

Wait how do you mean this? How do i open debug logger and where should i type

 

"<ConsoleLogger>

<Enabled>1</Enabled>

</ConsoleLogger>" in?

Share this post


Link to post
Share on other sites
FelipeVinhao

'Sup guys? Long time no see ya!

 

Hope you can help me with the following:

I am using Windows Vista 32 bits, and installed the latest patch to GTA4.

 

I had (well, still have) several mods and ASis like Ultimate Graphics Tweak, Environmental Mod, Busses on Traffic, Sjaak's Simple Trainer... So I got the latest DLLs to make them work, including FileCheckFix.

 

The problem is that FileCheckFix isn't working very friendly with the Graphics Tweak: without FileCheckFix, Busses on Traffic doesn't load; with it, game crashes after finishing loading a saved game - if I remove Graphics Tweak and keep FileCheckFix, Busses on Traffic works normally.

 

Do you have any suggestions?

 

PS: Don't worry, I don't wanna go online with these mods! I wanna play single player. tounge.gif

Share this post


Link to post
Share on other sites
dsi1

 

'Sup guys? Long time no see ya!

 

Hope you can help me with the following:

I am using Windows Vista 32 bits, and installed the latest patch to GTA4.

 

I had (well, still have) several mods and ASis like Ultimate Graphics Tweak, Environmental Mod, Busses on Traffic, Sjaak's Simple Trainer... So I got the latest DLLs to make them work, including FileCheckFix.

 

The problem is that FileCheckFix isn't working very friendly with the Graphics Tweak: without FileCheckFix, Busses on Traffic doesn't load; with it, game crashes after finishing loading a saved game - if I remove Graphics Tweak and keep FileCheckFix, Busses on Traffic works normally.

 

Do you have any suggestions?

 

PS: Don't worry, I don't wanna go online with these mods! I wanna play single player. tounge.gif

Hrm, I have the Graphics Tweak installed here as well, could there be a compatability problem?

 

Going to try and get rid of Graphics Tweak and see if it works.

 

EDIT: YES, it does work now, no idea how it interferes, but disabling Graphics Tweak should fix it up.

Edited by dsi1

Share this post


Link to post
Share on other sites
FelipeVinhao

Yes, that is the problem. But I didn't have the intention to get rid of UGT... confused.gif

Share this post


Link to post
Share on other sites
fatcowxlive

Hi, So I am using GTA IV Multiplayer with patch five. I have some VISUAL car mods (Like turismo to ferrari in vehicles.img), and the Vice City Style HUD but i could not enter multiplayer because i have modded files. I instaled the latest ASI loader and File Check Fix to work with 1.0.0.4 but when i launch multiplayer it gives me The connection to GFWL has been Dissconnected returning to single player. Please Help me i am doing no cheating just the vehicles look different

Share this post


Link to post
Share on other sites
jhde7

i cheat you can hear it i cheat but i dont use it to kill other dudes i help them getting cars and things nothing else and it doesnt work mad.gifmad.gifangry.gifangry.gifangry.gifangry.gif

Share this post


Link to post
Share on other sites
Alexander Blade

STR10 error fixed .

Share this post


Link to post
Share on other sites
BigBoss154
STR10 error fixed .

You absolute legend. icon14.gifcookie.gif

Share this post


Link to post
Share on other sites
FelipeVinhao

Hmm...

 

No effect for me tho. I still can't play with FCF and UGT together. confused.gif

Share this post


Link to post
Share on other sites
UncleCrank
Hmm...

 

No effect for me tho. I still can't play with FCF and UGT together. confused.gif

Same here...

Share this post


Link to post
Share on other sites
tarkins

i actully chould join a game with mods (native trainer) but only by joining a friend on GFWL friend list, just joined session and i was in.

 

i think enabling Support for using mods online would be a smart idea (host can now kick players without votes biggrin.gif)

 

 

Hosts can now immediately Kick users from their games in Lobby and in game via Cell phone without having to rely on peer voting

 

and thats how you now can T-Bag a cheater in the face smile.gif

 

http://www.rockstargames.com/support/IV/PC/patch/index.html

Edited by tarkins

Share this post


Link to post
Share on other sites
TwwIX

Download link seems to be down. I Am unable to download it. Could you upload to one of the numerous free hosts out there please.

Share this post


Link to post
Share on other sites
NTAuthority
-download thisand put d3d9.dll and devloader.config into the GTAIV directory (this is another asi loader, that let's you load asi's from the plugins directory, another great piece of software by Aru)

 

One thing to note is that DevLoader requires this weird security update to run.

Share this post


Link to post
Share on other sites
Coldkilla

post deleted.

Edited by Coldkilla

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • 1 User Currently Viewing
    0 Members, 0 Anonymous, 1 Guest

×

Important Information

By using GTAForums.com, you agree to our Terms of Use and Privacy Policy.